]> git.pld-linux.org Git - packages/cogl.git/blob - cogl.spec
- added Provides for gles1/gles2/wayland featured base/-devel/-static packages
[packages/cogl.git] / cogl.spec
1 #
2 # Conditional build
3 %bcond_without  static_libs     # static libraries
4 %bcond_without  gdkpixbuf       # gdk-pixbuf for image loading [instead of stb_image]
5 %bcond_without  gles1           # OpenGL-ES 1.1 support
6 %bcond_without  gles2           # OpenGL-ES 2.0 support
7 %bcond_without  gstreamer       # GStreamer support
8 %bcond_without  wayland         # Wayland EGL support
9 #
10 Summary:        A library for using 3D graphics hardware to draw pretty pictures
11 Summary(pl.UTF-8):      Biblioteka do rysowania ładnych obrazków przy użyciu sprzętowej grafiki 3D
12 Name:           cogl
13 Version:        1.16.0
14 Release:        2
15 License:        LGPL v2+
16 Group:          Libraries
17 Source0:        http://ftp.gnome.org/pub/GNOME/sources/cogl/1.16/%{name}-%{version}.tar.xz
18 # Source0-md5:  611a61bed04354cbfffa3dc27feb6d4f
19 Patch0:         %{name}-link.patch
20 URL:            http://www.clutter-project.org/
21 %{?with_wayland:BuildRequires:  EGL-devel}
22 %{?with_wayland:BuildRequires:  Mesa-libwayland-egl-devel >= 1.0.0}
23 %{?with_gles1:BuildRequires:    OpenGLESv1-devel >= 1.1}
24 BuildRequires:  OpenGL-GLX-devel
25 BuildRequires:  autoconf >= 2.59
26 BuildRequires:  automake >= 1:1.11
27 BuildRequires:  cairo-devel >= 1.10
28 %{?with_gdkpixbuf:BuildRequires:        gdk-pixbuf2-devel >= 2.0}
29 BuildRequires:  gettext-devel >= 0.18.1
30 BuildRequires:  glib2-devel >= 1:2.32.0
31 BuildRequires:  gobject-introspection-devel >= 0.9.5
32 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 1.0}
33 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-base-devel >= 1.0}
34 BuildRequires:  gtk-doc >= 1.13
35 BuildRequires:  libdrm-devel
36 BuildRequires:  libtool >= 2:2.2.6
37 BuildRequires:  pango-devel >= 1:1.20
38 BuildRequires:  pkgconfig
39 BuildRequires:  tar >= 1:1.22
40 # wayland-client >= 1.0.0, wayland-server >= 1.1.90
41 %{?with_wayland:BuildRequires:  wayland-devel >= 1.2.0}
42 BuildRequires:  xorg-lib-libX11-devel
43 BuildRequires:  xorg-lib-libXcomposite-devel >= 0.4
44 BuildRequires:  xorg-lib-libXdamage-devel
45 BuildRequires:  xorg-lib-libXext-devel
46 BuildRequires:  xorg-lib-libXfixes-devel >= 3
47 BuildRequires:  xorg-lib-libXrandr-devel >= 1.2
48 BuildRequires:  xz
49 Requires:       cairo >= 1.10
50 Requires:       glib2 >= 1:2.32.0
51 Requires:       pango >= 1:1.20
52 %{?with_wayland:Requires:       wayland >= 1.2.0}
53 Requires:       xorg-lib-libXcomposite >= 0.4
54 Requires:       xorg-lib-libXfixes >= 3
55 Requires:       xorg-lib-libXrandr >= 1.2
56 Suggests:       OpenGL
57 %{?with_gles1:Provides: cogl(gles1) = %{version}-%{release}}
58 %{?with_gles2:Provides: cogl(gles2) = %{version}-%{release}}
59 %{?with_wayland:Provides:       cogl(wayland) = %{version}-%{release}}
60 Conflicts:      clutter < 1.8.0
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 Cogl is a small open source library for using 3D graphics hardware to
65 draw pretty pictures. The API departs from the flat state machine
66 style of OpenGL and is designed to make it easy to write orthogonal
67 components that can render without stepping on each others toes.
68
69 %description -l pl.UTF-8
70 Cogl to mała biblioteka o otwartych źródłach, pozwalająca na rysowanie
71 ładnych rysunków przy użyciu sprzętu graficznego 3D. API wywodzi się z
72 automatu skończonego w stylu OpenGL i zostało tak zaprojektowane, aby
73 ułatwić pisanie ortogonalnych komponentów, potrafiących renderować bez
74 przeszkadzania sobie nawzajem.
75
76 %package devel
77 Summary:        Header files for cogl library
78 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cogl
79 Group:          Development/Libraries
80 Requires:       %{name} = %{version}-%{release}
81 %{?with_wayland:Requires:       EGL-devel}
82 %{?with_wayland:Requires:       Mesa-libwayland-egl-devel >= 1.0.0}
83 Requires:       cairo-devel >= 1.10
84 %{?with_gdkpixbuf:Requires:     gdk-pixbuf2-devel >= 2.0}
85 Requires:       glib2-devel >= 1:2.32.0
86 Requires:       gobject-introspection-devel >= 0.9.5
87 Requires:       libdrm-devel
88 Requires:       pango-devel >= 1:1.20
89 %{?with_wayland:Requires:       wayland-devel >= 1.2.0}
90 Requires:       xorg-lib-libXcomposite-devel >= 0.4
91 Requires:       xorg-lib-libXdamage-devel
92 Requires:       xorg-lib-libXext-devel
93 Requires:       xorg-lib-libXfixes-devel >= 3
94 Requires:       xorg-lib-libXrandr-devel >= 1.2
95 %{?with_gles1:Provides: cogl-devel(gles1) = %{version}-%{release}}
96 %{?with_gles2:Provides: cogl-devel(gles2) = %{version}-%{release}}
97 %{?with_wayland:Provides:       cogl-devel(wayland) = %{version}-%{release}}
98 Conflicts:      clutter-devel < 1.8.0
99
100 %description devel
101 Header files for building and developing applications with cogl.
102
103 %description devel -l pl.UTF-8
104 Pliki nagłówkowe do tworzenia aplikacji z użyciem biblioteki cogl.
105
106 %package static
107 Summary:        Static cogl libraries
108 Summary(pl.UTF-8):      Statyczne biblioteki cogl
109 Group:          Development/Libraries
110 Requires:       %{name}-devel = %{version}-%{release}
111 %{?with_gles1:Provides: cogl-static(gles1) = %{version}-%{release}}
112 %{?with_gles2:Provides: cogl-static(gles2) = %{version}-%{release}}
113 %{?with_wayland:Provides:       cogl-static(wayland) = %{version}-%{release}}
114 Conflicts:      clutter-static < 1.8.0
115
116 %description static
117 Static cogl libraries.
118
119 %description static -l pl.UTF-8
120 Statyczne biblioteki cogl.
121
122 %package doc
123 Summary:        API documentation for cogl
124 Summary(pl.UTF-8):      Dokumentacja API cogl
125 Group:          Documentation
126
127 %description doc
128 This package contains API documentation for cogl.
129
130 %description doc -l pl.UTF-8
131 Ten pakiet zawiera dokumentację API cogl.
132
133 %package gles2
134 Summary:        Cogl frontend library for OpenGL-ES 2.0
135 Summary(pl.UTF-8):      Biblioteka frontendowa Cogl dla OpenGL-ES 2.0
136 Group:          Libraries
137 Requires:       %{name}(gles2) = %{version}-%{release}
138
139 %description gles2
140 Cogl frontend library for OpenGL-ES 2.0.
141
142 %description gles2 -l pl.UTF-8
143 Biblioteka frontendowa Cogl dla OpenGL-ES 2.0.
144
145 %package gles2-devel
146 Summary:        Header files for cogl-gles2 library
147 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cogl-gles2
148 Group:          Development/Libraries
149 Requires:       %{name}-devel(gles2) = %{version}-%{release}
150 Requires:       %{name}-gles2 = %{version}-%{release}
151
152 %description gles2-devel
153 Header files for cogl-gles2 library.
154
155 %description gles2-devel -l pl.UTF-8
156 Pliki nagłówkowe biblioteki cogl-gles2.
157
158 %package gles2-static
159 Summary:        Static cogl-gles2 library
160 Summary(pl.UTF-8):      Statyczna biblioteka cogl-gles2
161 Group:          Development/Libraries
162 Requires:       %{name}-gles2-devel = %{version}-%{release}
163
164 %description gles2-static
165 Static cogl-gles2 library.
166
167 %description gles2-static -l pl.UTF-8
168 Statyczna biblioteka cogl-gles2.
169
170 %package gst
171 Summary:        GStreamer integration library for Cogl
172 Summary(pl.UTF-8):      Biblioteka integrująca GStreamera z Cogl
173 Group:          Libraries
174 Requires:       %{name} = %{version}-%{release}
175
176 %description gst
177 GStreamer integration library for Cogl.
178
179 %description gst -l pl.UTF-8
180 Biblioteka integrująca GStreamera z Cogl.
181
182 %package gst-devel
183 Summary:        Header files for cogl-gst library
184 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cogl-gst
185 Group:          Development/Libraries
186 Requires:       %{name}-devel = %{version}-%{release}
187 Requires:       %{name}-gst = %{version}-%{release}
188 Requires:       gstreamer-devel >= 1.0
189 Requires:       gstreamer-plugins-base-devel >= 1.0
190
191 %description gst-devel
192 Header files for cogl-gst library.
193
194 %description gst-devel -l pl.UTF-8
195 Pliki nagłówkowe biblioteki cogl-gst.
196
197 %package gst-static
198 Summary:        Static cogl-gst library
199 Summary(pl.UTF-8):      Statyczna biblioteka cogl-gst
200 Group:          Development/Libraries
201 Requires:       %{name}-gst-devel = %{version}-%{release}
202
203 %description gst-static
204 Static cogl-gst library.
205
206 %description gst-static -l pl.UTF-8
207 Statyczna biblioteka cogl-gst.
208
209 %package gst-apidocs
210 Summary:        API documentation for cogl-gst library
211 Summary(pl.UTF-8):      Dokumentacja API biblioteki cogl-gst
212 Group:          Documentation
213
214 %description gst-apidocs
215 API documentation for cogl-gst library.
216
217 %description gst-apidocs -l pl.UTF-8
218 Dokumentacja API biblioteki cogl-gst.
219
220 %prep
221 %setup -q
222 %patch0 -p1
223
224 %build
225 %{__gettextize}
226 %{__libtoolize}
227 %{__aclocal} -I build/autotools
228 %{__autoconf}
229 %{__autoheader}
230 %{__automake}
231 %configure \
232         %{!?with_gdkpixbuf:--disable-gdk-pixbuf} \
233         --disable-silent-rules \
234         --enable-cairo \
235         %{?with_gstreamer:--enable-cogl-gst} \
236         --enable-cogl-pango \
237         %{?with_gles1:--enable-gles1 --with-gles1-libname=libGLESv1_CM.so.1} \
238         %{?with_gles2:--enable-gles2 --with-gles2-libname=libGLESv2.so.2} \
239         --enable-glx \
240         --enable-gtk-doc \
241         --enable-introspection \
242         %{?with_static_libs:--enable-static} \
243         %{?with_wayland:--enable-wayland-egl-platform} \
244         %{?with_wayland:--enable-wayland-egl-server} \
245         --with-html-dir=%{_gtkdocdir}
246 %{__make}
247
248 %install
249 rm -rf $RPM_BUILD_ROOT
250
251 %{__make} install \
252         DESTDIR=$RPM_BUILD_ROOT
253
254 %if %{with gstreamer}
255 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/libgstcogl.la
256 %if %{with static_libs}
257 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/libgstcogl.a
258 %endif
259 %endif
260 # obsoleted by pkg-config
261 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcogl*.la
262
263 %find_lang %{name}
264
265 %clean
266 rm -rf $RPM_BUILD_ROOT
267
268 %post   -p /sbin/ldconfig
269 %postun -p /sbin/ldconfig
270
271 %post   gles2 -p /sbin/ldconfig
272 %postun gles2 -p /sbin/ldconfig
273
274 %post   gst -p /sbin/ldconfig
275 %postun gst -p /sbin/ldconfig
276
277 %files -f %{name}.lang
278 %defattr(644,root,root,755)
279 %doc ChangeLog NEWS README
280 %attr(755,root,root) %{_libdir}/libcogl.so.*.*.*
281 %attr(755,root,root) %ghost %{_libdir}/libcogl.so.15
282 %attr(755,root,root) %{_libdir}/libcogl-pango.so.*.*.*
283 %attr(755,root,root) %ghost %{_libdir}/libcogl-pango.so.15
284 %{_libdir}/girepository-1.0/Cogl-1.0.typelib
285 %{_libdir}/girepository-1.0/CoglPango-1.0.typelib
286
287 %files devel
288 %defattr(644,root,root,755)
289 %attr(755,root,root) %{_libdir}/libcogl.so
290 %attr(755,root,root) %{_libdir}/libcogl-pango.so
291 %dir %{_includedir}/cogl
292 %{_includedir}/cogl/cogl
293 %{_includedir}/cogl/cogl-pango
294 %{_includedir}/cogl/cogl-path
295 %{_pkgconfigdir}/cogl-1.0.pc
296 %{_pkgconfigdir}/cogl-2.0-experimental.pc
297 %{_pkgconfigdir}/cogl-gl-1.0.pc
298 %{_pkgconfigdir}/cogl-pango-1.0.pc
299 %{_pkgconfigdir}/cogl-pango-2.0-experimental.pc
300 %{_datadir}/gir-1.0/Cogl-1.0.gir
301 %{_datadir}/gir-1.0/CoglPango-1.0.gir
302
303 %if %{with static_libs}
304 %files static
305 %defattr(644,root,root,755)
306 %{_libdir}/libcogl.a
307 %{_libdir}/libcogl-pango.a
308 %endif
309
310 %files doc
311 %defattr(644,root,root,755)
312 %{_gtkdocdir}/cogl
313 %{_gtkdocdir}/cogl-2.0-experimental
314
315 %if %{with gles2}
316 %files gles2
317 %defattr(644,root,root,755)
318 %attr(755,root,root) %{_libdir}/libcogl-gles2.so.*.*.*
319 %attr(755,root,root) %ghost %{_libdir}/libcogl-gles2.so.15
320
321 %files gles2-devel
322 %defattr(644,root,root,755)
323 %attr(755,root,root) %{_libdir}/libcogl-gles2.so
324 %{_includedir}/cogl/cogl-gles2
325 %{_pkgconfigdir}/cogl-gles2-experimental.pc
326
327 %if %{with static_libs}
328 %files gles2-static
329 %defattr(644,root,root,755)
330 %{_libdir}/libcogl-gles2.a
331 %endif
332 %endif
333
334 %if %{with gstreamer}
335 %files gst
336 %defattr(644,root,root,755)
337 %attr(755,root,root) %{_libdir}/libcogl-gst.so.*.*.*
338 %attr(755,root,root) %ghost %{_libdir}/libcogl-gst.so.15
339 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libgstcogl.so
340
341 %files gst-devel
342 %defattr(644,root,root,755)
343 %attr(755,root,root) %{_libdir}/libcogl-gst.so
344 %{_includedir}/cogl/cogl-gst
345 %{_pkgconfigdir}/cogl-gst.pc
346
347 %if %{with static_libs}
348 %files gst-static
349 %defattr(644,root,root,755)
350 %{_libdir}/libcogl-gst.a
351 %endif
352
353 %files gst-apidocs
354 %defattr(644,root,root,755)
355 %{_gtkdocdir}/cogl-gst
356 %endif
This page took 0.053285 seconds and 4 git commands to generate.