]> git.pld-linux.org Git - packages/cogl.git/blob - cogl.spec
- updated to 1.8.2
[packages/cogl.git] / cogl.spec
1 #
2 # Conditional build
3 %bcond_without  static_libs     # static libraries
4 #
5 Summary:        A library for using 3D graphics hardware to draw pretty pictures
6 Summary(pl.UTF-8):      Biblioteka do rysowania ładnych obrazków przy użyciu sprzętowej grafiki 3D
7 Name:           cogl
8 Version:        1.8.2
9 Release:        1
10 License:        LGPL v2+
11 Group:          Libraries
12 Source0:        http://source.clutter-project.org/sources/cogl/1.8/%{name}-%{version}.tar.xz
13 # Source0-md5:  2c527075b7205ce98d320945496b0b58
14 URL:            http://www.clutter-project.org/
15 BuildRequires:  OpenGL-GLX-devel
16 BuildRequires:  autoconf >= 2.59
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  cairo-devel >= 1.10
19 BuildRequires:  gettext-devel >= 0.18.1
20 BuildRequires:  glib2-devel >= 1:2.26.0
21 BuildRequires:  gobject-introspection-devel >= 0.9.5
22 BuildRequires:  gtk-doc >= 1.13
23 BuildRequires:  libdrm-devel
24 BuildRequires:  libtool >= 2:2.2.6
25 BuildRequires:  pango-devel >= 1:1.20
26 BuildRequires:  pkgconfig
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xorg-lib-libX11-devel
29 BuildRequires:  xorg-lib-libXcomposite-devel >= 0.4
30 BuildRequires:  xorg-lib-libXdamage-devel
31 BuildRequires:  xorg-lib-libXext-devel
32 BuildRequires:  xorg-lib-libXfixes-devel >= 3
33 BuildRequires:  xz
34 Requires:       cairo >= 1.10
35 Requires:       glib2 >= 1:2.26.0
36 Requires:       pango >= 1:1.20
37 Requires:       xorg-lib-libXcomposite >= 0.4
38 Requires:       xorg-lib-libXfixes >= 3
39 Suggests:       OpenGL
40 Conflicts:      clutter < 1.8.0
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Cogl is a small open source library for using 3D graphics hardware to
45 draw pretty pictures. The API departs from the flat state machine
46 style of OpenGL and is designed to make it easy to write orthogonal
47 components that can render without stepping on each others toes.
48
49 %description -l pl.UTF-8
50 Cogl to mała biblioteka o otwartych źródłach, pozwalająca na rysowanie
51 ładnych rysunków przy użyciu sprzętu graficznego 3D. API wywodzi się z
52 automatu skończonego w stylu OpenGL i zostało tak zaprojektowane, aby
53 ułatwić pisanie ortogonalnych komponentów, potrafiących renderować bez
54 przeszkadzania sobie nawzajem.
55
56 %package devel
57 Summary:        Header files for cogl library
58 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cogl
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       cairo-devel >= 1.10
62 Requires:       glib2-devel >= 1:2.26.0
63 Requires:       gobject-introspection-devel >= 0.9.5
64 Requires:       libdrm-devel
65 Requires:       pango-devel >= 1:1.20
66 Requires:       xorg-lib-libXcomposite-devel >= 0.4
67 Requires:       xorg-lib-libXdamage-devel
68 Requires:       xorg-lib-libXext-devel
69 Requires:       xorg-lib-libXfixes-devel >= 3
70 Conflicts:      clutter-devel < 1.8.0
71
72 %description devel
73 Header files for building and developing applications with cogl.
74
75 %description devel -l pl.UTF-8
76 Pliki nagłówkowe do tworzenia aplikacji z użyciem biblioteki cogl.
77
78 %package static
79 Summary:        Static cogl libraries
80 Summary(pl.UTF-8):      Statyczne biblioteki cogl
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{version}-%{release}
83 Conflicts:      clutter-static < 1.8.0
84
85 %description static
86 Static cogl libraries.
87
88 %description static -l pl.UTF-8
89 Statyczne biblioteki cogl.
90
91 %package doc
92 Summary:        API documentation for cogl
93 Summary(pl.UTF-8):      Dokumentacja API cogl
94 Group:          Documentation
95
96 %description doc
97 This package contains API documentation for cogl.
98
99 %description doc -l pl.UTF-8
100 Ten pakiet zawiera dokumentację API cogl.
101
102 %prep
103 %setup -q
104
105 %build
106 %{__gettextize}
107 %{__libtoolize}
108 %{__aclocal} -I build/autotools
109 %{__autoconf}
110 %{__autoheader}
111 %{__automake}
112 %configure \
113         --disable-gdk-pixbuf \
114         --disable-silent-rules \
115         --enable-cairo \
116         --enable-cogl-pango \
117         --enable-glx \
118         --enable-gtk-doc \
119         --enable-introspection \
120         %{?with_static_libs:--enable-static} \
121         --with-html-dir=%{_gtkdocdir}
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 # obsoleted by pkg-config
131 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcogl.la
132 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcogl-pango.la
133
134 %find_lang %{name}
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %files -f %{name}.lang
143 %defattr(644,root,root,755)
144 %doc ChangeLog NEWS README
145 %attr(755,root,root) %{_libdir}/libcogl.so.*.*.*
146 %attr(755,root,root) %ghost %{_libdir}/libcogl.so.5
147 %attr(755,root,root) %{_libdir}/libcogl-pango.so.*.*.*
148 %attr(755,root,root) %ghost %{_libdir}/libcogl-pango.so.0
149 %{_libdir}/girepository-1.0/Cogl-1.0.typelib
150 %{_libdir}/girepository-1.0/CoglPango-1.0.typelib
151
152 %files devel
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/libcogl.so
155 %attr(755,root,root) %{_libdir}/libcogl-pango.so
156 %{_includedir}/cogl
157 %{_pkgconfigdir}/cogl-1.0.pc
158 %{_pkgconfigdir}/cogl-2.0-experimental.pc
159 %{_pkgconfigdir}/cogl-gl-1.0.pc
160 %{_pkgconfigdir}/cogl-pango-1.0.pc
161 %{_pkgconfigdir}/cogl-pango-2.0-experimental.pc
162 %{_datadir}/gir-1.0/Cogl-1.0.gir
163 %{_datadir}/gir-1.0/CoglPango-1.0.gir
164
165 %if %{with static_libs}
166 %files static
167 %defattr(644,root,root,755)
168 %{_libdir}/libcogl.a
169 %{_libdir}/libcogl-pango.a
170 %endif
171
172 %files doc
173 %defattr(644,root,root,755)
174 %{_gtkdocdir}/cogl
175 %{_gtkdocdir}/cogl-2.0-experimental
This page took 0.044985 seconds and 4 git commands to generate.