]> git.pld-linux.org Git - packages/clucene-core.git/blob - clucene-core.spec
- removed boost headers and their references, see
[packages/clucene-core.git] / clucene-core.spec
1 Summary:        An indexing and searching API
2 Summary(pl.UTF-8):      API do indeksowania i wyszukiwania
3 Name:           clucene-core
4 Version:        2.3.3.4
5 Release:        2
6 License:        LGPL or Apache v2.0
7 Group:          Libraries
8 Source0:        http://downloads.sourceforge.net/clucene/%{name}-%{version}.tar.gz
9 # Source0-md5:  48d647fbd8ef8889e5a7f422c1bfda94
10 Patch0:         %{name}-2.3.3.4-install_contribs_lib.patch
11 Patch1:         remove-boost-headers.patch
12 URL:            http://clucene.sourceforge.net/
13 BuildRequires:  cmake
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  libtool >= 2:1.5
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 CLucene is a C++ port of Lucene. It is a high-performance,
20 full-featured text search engine written in C++.
21
22 %description -l pl.UTF-8
23 CLucene jest portem Lucene na C++. Jest to wysokowydajny silnik do
24 wyszukiwania tekstu napisany w C++.
25
26 %package devel
27 Summary:        Header files for CLucene library
28 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CLucene
29 Group:          Development/Libraries
30 Requires:       %{name} = %{version}-%{release}
31 Requires:       libstdc++-devel
32
33 %description devel
34 Header files for CLucene library.
35
36 %description devel -l pl.UTF-8
37 Pliki nagłówkowe biblioteki CLucene.
38
39 %package static
40 Summary:        Static CLucene library
41 Summary(pl.UTF-8):      Statyczna biblioteka CLucene
42 Group:          Development/Libraries
43 Requires:       %{name}-devel = %{version}-%{release}
44
45 %description static
46 Static CLucene library.
47
48 %description static -l pl.UTF-8
49 Statyczna biblioteka CLucene.
50
51 %prep
52 %setup -q
53 %patch0 -p1
54 %patch1 -p1
55
56 %build
57 install -d build
58 cd build
59 %cmake \
60         -DBUILD_STATIC_LIBRARIES=ON \
61         -DBUILD_CONTRIBS=ON \
62         -DBUILD_CONTRIBS_LIB=ON \
63         ..
64
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} -C build install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 # remove boost headers, they are not needed nor used here
74 %{__rm} -r %{_includedir}/CLucene/ext
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post   -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files
83 %defattr(644,root,root,755)
84 %doc AUTHORS COPYING ChangeLog NEWS README
85 %attr(755,root,root) %{_libdir}/libclucene-contribs-lib.so.*.*.*
86 %attr(755,root,root) %ghost %{_libdir}/libclucene-contribs-lib.so.1
87 %attr(755,root,root) %{_libdir}/libclucene-core.so.*.*.*
88 %attr(755,root,root) %ghost %{_libdir}/libclucene-core.so.1
89 %attr(755,root,root) %{_libdir}/libclucene-shared.so.*.*.*
90 %attr(755,root,root) %ghost %{_libdir}/libclucene-shared.so.1
91
92 %files devel
93 %defattr(644,root,root,755)
94 %attr(755,root,root) %{_libdir}/libclucene-contribs-lib.so
95 %attr(755,root,root) %{_libdir}/libclucene-core.so
96 %attr(755,root,root) %{_libdir}/libclucene-shared.so
97 %{_includedir}/CLucene.h
98 %{_includedir}/CLucene
99 %{_libdir}/CLuceneConfig.cmake
100 %{_pkgconfigdir}/libclucene-core.pc
101
102 %files static
103 %defattr(644,root,root,755)
104 %{_libdir}/libclucene-core-static.a
105 %{_libdir}/libclucene-shared-static.a
This page took 0.087495 seconds and 3 git commands to generate.