]> git.pld-linux.org Git - packages/clisp.git/blob - clisp.spec
- Initial version.
[packages/clisp.git] / clisp.spec
1 Summary:        Common Lisp (ANSI CL) implementation
2 Name:           clisp
3 Version:        2.27
4 Release:        1
5 Icon:           clisp.gif
6 License:        GPL
7 Group:          Development/Languages
8 Group(de):      Entwicklung/Sprachen
9 Group(pl):      Programowanie/Jêzyki
10 Source0:        ftp://cvs2.cons.org/pub/lisp/clisp/source/latest/%{name}-%{version}.tar.bz2
11 #Alternatively http://prdownloads.sourceforge.net/clisp/clisp-2.27.tar.bz2
12 Patch0:         %{name}-shell.patch
13 URL:            http://clisp.cons.org/
14 BuildRequires:  readline-devel
15 BuildRequires:  gettext-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Common Lisp is a high-level, all-purpose programming language. CLISP
20 is a Common Lisp implementation by Bruno Haible of Karlsruhe
21 University and Michael Stoll of Munich University, both in Germany. It
22 mostly supports Common Lisp as described in the ANSI CL standard. It
23 runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
24 500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
25 Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
26 needs only 2 MB of RAM.
27
28 It is free software and may be distributed under the terms of GNU GPL,
29 while it is possible to distribute commercial applications compiled
30 with CLISP.
31
32 The user interface comes in German, English, French and Spanish. CLISP
33 includes an interpreter, a compiler, a large subset of CLOS, a foreign
34 language interface and a socket interface. An X11 interface is
35 available through CLX and Garnet.
36
37 %prep
38 %setup -q
39 %patch0 -p1
40
41 %build
42 ./configure --prefix=%{_prefix}
43 cd src
44 ./makemake \
45         --prefix=%{_prefix} \
46         --with-readline \
47         --with-gettext \
48         --with-dynamic-ffi \
49         --with-module=wildcard \
50         --with-module=regexp \
51         --with-module=bindings/linuxlibc6 \
52         >Makefile
53 %{__make} config.lisp
54 %{__make}
55 #make check
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 cd src
60 install -d $RPM_BUILD_ROOT{%{_bindir},%{_docdir},%{_libdir},%{_mandir}}
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT \
63         lispdocdir=%{_docdir}/%{name}-%{version} \
64         mandir=%{_mandir}
65 cd ..
66 mkdir $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
67 cp modules/*/*.dvi $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %attr(755,root,root) %{_bindir}/clisp
75 %doc %{_docdir}/%{name}-%{version}
76 %dir %{_libdir}/clisp
77 %dir %{_libdir}/clisp/base
78 %{_libdir}/clisp/base/*.[aho]
79 %{_libdir}/clisp/base/lispinit.mem
80 %attr(755,root,root) %{_libdir}/clisp/base/lisp.run
81 %{_libdir}/clisp/base/makevars
82 %{_libdir}/clisp/clisp-link
83 %{_libdir}/clisp/data
84 %{_libdir}/clisp/full/*.[aho]
85 %{_libdir}/clisp/full/lispinit.mem
86 %attr(755,root,root) %{_libdir}/clisp/full/lisp.run
87 %{_libdir}/clisp/full/makevars
88 %{_libdir}/clisp/linkkit
89 %lang(de) %{_datadir}/locale/de/LC_MESSAGES/*
90 %lang(en) %{_datadir}/locale/en/LC_MESSAGES/*
91 %lang(es) %{_datadir}/locale/es/LC_MESSAGES/*
92 %lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/*
93 %lang(nl) %{_datadir}/locale/nl/LC_MESSAGES/*
94 %{_mandir}/man[13]/*
This page took 0.040984 seconds and 4 git commands to generate.