]> git.pld-linux.org Git - packages/cjs.git/blob - cjs.spec
new, version 2.4.1
[packages/cjs.git] / cjs.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 Summary:        Javascript Bindings for Cinnamon
6 Name:           cjs
7 Version:        2.4.1
8 Release:        1
9 Group:          Libraries
10 # The following files contain code from Mozilla which
11 # is triple licensed under MPL1.1/LGPLv2+/GPLv2+:
12 # The console module (modules/console.c)
13 # Stack printer (gjs/stack.c)
14 License:        MIT and (MPLv1.1 or GPLv2+ or LGPLv2+)
15 Source0:        https://github.com/linuxmint/cjs/archive/%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  846940e9cf97b15a5b3940cf5c7b2591
17 URL:            http://cinnamon.linuxmint.com/
18 BuildRequires:  cairo-gobject-devel
19 BuildRequires:  dbus-glib-devel
20 BuildRequires:  gobject-introspection-devel >= 1.38.0
21 BuildRequires:  gtk+3-devel
22 BuildRequires:  intltool
23 BuildRequires:  mozjs24-devel
24 BuildRequires:  readline-devel
25 BuildRequires:  sed >= 4.0
26 # Require for checks
27 BuildRequires:  dbus-x11
28 # Bootstrap requirements
29 BuildRequires:  gnome-common
30 BuildRequires:  gtk-doc
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Cjs allows using Cinnamon libraries from Javascript. It's based on the
35 Spidermonkey Javascript engine from Mozilla and the GObject
36 introspection framework.
37
38 %package devel
39 Summary:        Development package for %{name}
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 Files for development with %{name}.
45
46 %package tests
47 Summary:        Tests for the cjs package
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description tests
52 The cjs-tests package contains tests that can be used to verify the
53 functionality of the installed cjs package.
54
55 %prep
56 %setup -q
57 sed -i -e 's@{ACLOCAL_FLAGS}@{ACLOCAL_FLAGS} -I m4@g' Makefile.am
58 echo "AC_CONFIG_MACRO_DIR([m4])" >> configure.ac
59
60 %build
61 NOCONFIGURE=1 ./autogen.sh
62 %configure \
63         --disable-silent-rules \
64         --disable-static \
65         --enable-installed-tests \
66
67 %{__make}
68
69 %if %{with tests}
70 %{__make} check
71 %endif
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcjs.la
79 %{__rm} $RPM_BUILD_ROOT%{_libdir}/cjs/lib*.la
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(644,root,root,755)
89 %doc COPYING COPYING.LGPL NEWS README
90 %attr(755,root,root) %{_bindir}/cjs
91 %attr(755,root,root) %{_bindir}/cjs-console
92 %attr(755,root,root) %{_libdir}/libcjs.so.*.*.*
93 %ghost %{_libdir}/libcjs.so.0
94 %dir %{_libdir}/cjs
95 %dir %{_libdir}/cjs/girepository-1.0
96 %{_libdir}/cjs/girepository-1.0/CjsPrivate-1.0.typelib
97
98 %files devel
99 %defattr(644,root,root,755)
100 %doc examples/*
101 %{_includedir}/cjs-1.0
102 %{_libdir}/libcjs.so
103 %{_pkgconfigdir}/cjs-1.0.pc
104 %{_pkgconfigdir}/cjs-internals-1.0.pc
105 %attr(755,root,root) %{_libdir}/cjs/libgimarshallingtests.so
106 %attr(755,root,root) %{_libdir}/cjs/libregress.so
107 %attr(755,root,root) %{_libdir}/cjs/libwarnlib.so
108
109 %files tests
110 %defattr(644,root,root,755)
111 %{_libdir}/cjs/installed-tests
112 %{_datadir}/installed-tests
This page took 0.389799 seconds and 4 git commands to generate.