]> git.pld-linux.org Git - packages/cinnamon-menus.git/blob - cinnamon-menus.spec
cleanup BR
[packages/cinnamon-menus.git] / cinnamon-menus.spec
1 #
2 # Conditional build:
3 %bcond_with     debug           # enable debugging
4
5 Summary:        A menu system for the Cinnamon project
6 Name:           cinnamon-menus
7 Version:        2.4.1
8 Release:        1
9 License:        LGPL v2+
10 Group:          Libraries
11 Source0:        https://github.com/linuxmint/cinnamon-menus/archive/%{version}/%{name}-%{version}.tar.gz
12 # Source0-md5:  e61dbeb08e55a0ad0ee518d7e980fb50
13 URL:            http://cinnamon.linuxmint.com/
14 BuildRequires:  glib2-devel
15 BuildRequires:  gobject-introspection-devel
16 BuildRequires:  pkgconfig
17 BuildRequires:  python-devel
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 cinnamon-menus is an implementation of the draft "Desktop Menu
22 Specification" from freedesktop.org. This package also contains the
23 Cinnamon menu layout configuration files, .directory files and
24 assorted menu related utility programs, Python bindings, and a simple
25 menu editor.
26
27 %package devel
28 Summary:        Libraries and include files for the Cinnamon menu system
29 Group:          Development/Libraries
30 Requires:       %{name} = %{version}-%{release}
31
32 %description devel
33 This package provides the necessary development libraries for writing
34 applications that use the Cinnamon menu system.
35
36 %prep
37 %setup -q
38
39 %build
40 %configure \
41         --disable-silent-rules \
42         --disable-static \
43         --enable-introspection \
44         --enable-debug=%{!?with_debug:no}%{?with_debug:yes}
45
46 %{__make}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcinnamon-menu-3.la
54
55 %post   -p /sbin/ldconfig
56 %postun -p /sbin/ldconfig
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc AUTHORS NEWS COPYING.LIB
64 %{_libdir}/libcinnamon-menu-3.so.*.*.*
65 %ghost %{_libdir}/libcinnamon-menu-3.so.0
66 %{_libdir}/girepository-1.0/CMenu-3.0.typelib
67
68 %files devel
69 %defattr(644,root,root,755)
70 %{_libdir}/libcinnamon-menu-3.so
71 %{_pkgconfigdir}/libcinnamon-menu-3.0.pc
72 %{_includedir}/cinnamon-menus-3.0
73 %{_datadir}/gir-1.0/CMenu-3.0.gir
This page took 0.029723 seconds and 4 git commands to generate.