]> git.pld-linux.org Git - packages/chrony.git/blob - chrony.spec
- no -pie on gcc 3.3.6 (ac), assume gcc 3.4 has it
[packages/chrony.git] / chrony.spec
1 Summary:        An NTP client/server
2 Name:           chrony
3 Version:        1.26
4 Release:        5
5 License:        GPL v2
6 Group:          Daemons
7 URL:            http://chrony.tuxfamily.org/
8 Source0:        http://download.tuxfamily.org/chrony/%{name}-%{version}.tar.gz
9 # Source0-md5:  ad6dd619ff1986e4ff780363c64e2246
10 Source1:        %{name}.conf
11 Source2:        %{name}.keys
12 Source3:        %{name}d.sysconfig
13 Source4:        %{name}d.init
14 Source5:        %{name}.logrotate
15 Source6:        %{name}d.upstart
16 BuildRequires:  bison
17 BuildRequires:  libcap-devel
18 BuildRequires:  readline-devel
19 BuildRequires:  rpmbuild(macros) >= 1.453
20 BuildRequires:  texinfo
21 Requires(postun):       /usr/sbin/groupdel
22 Requires(postun):       /usr/sbin/userdel
23 Requires(pre):  /bin/id
24 Requires(pre):  /usr/bin/getgid
25 Requires(pre):  /usr/sbin/groupadd
26 Requires(pre):  /usr/sbin/useradd
27 Provides:       group(ntp)
28 Provides:       ntpdaemon
29 Provides:       user(ntp)
30 Obsoletes:      ntpdaemon
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _sysconfdir     /etc/ntp
34
35 # assume gcc 3.4 has it
36 %if "%{cc_version}" >= "3.4"
37 %define         specflags       -pie -fpie
38 %endif
39
40 %description
41 A client/server for the Network Time Protocol, this program keeps your
42 computer's clock accurate. It was specially designed to support
43 systems with dial-up Internet connections, and also supports computers
44 in permanently connected environments.
45
46 %prep
47 %setup -q
48
49 %{__sed} -i -e 's,/usr/local,%{_prefix},g' *.texi
50
51 %build
52 # NOTE: It is not autoconf generated configre
53 CC="%{__cc}" \
54 CFLAGS="%{rpmcflags} -Wmissing-prototypes -Wall" \
55 CPPFLAGS="%{rpmcppflags}" \
56 ./configure \
57         --prefix=%{_prefix} \
58         --sysconfdir=%{_sysconfdir} \
59         --docdir=%{_docdir} \
60         --without-editline \
61
62 %{__make} getdate all docs
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT/etc/{sysconfig,logrotate.d,rc.d/init.d,init} \
67         $RPM_BUILD_ROOT{%{_sysconfdir},/var/{lib/ntp,log/chrony}}
68
69 %{__make} install install-docs \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 rm -rf $RPM_BUILD_ROOT%{_docdir}
73
74 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/chrony.conf
75 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/keys
76 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/chronyd
77 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/logrotate.d/chrony
78 install -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/chronyd
79 cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/init/chronyd.conf
80
81 touch $RPM_BUILD_ROOT%{_localstatedir}/lib/ntp/{drift,rtc}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %pre
87 %groupadd -g 246 ntp
88 %useradd -u 246 -d %{_localstatedir}/lib/ntp -g ntp -c "NTP Daemon" ntp
89
90 %post
91 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
92 /sbin/chkconfig --add chronyd
93 %service chronyd restart
94
95 %preun
96 if [ "$1" = "0" ]; then
97         %service chronyd stop
98         /sbin/chkconfig --del chronyd
99 fi
100
101 %postun
102 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
103 if [ "$1" = "0" ]; then
104         %userremove ntp
105         %groupremove ntp
106 fi
107
108 %files
109 %defattr(644,root,root,755)
110 %doc NEWS README chrony.txt faq.txt examples/*
111 %dir %{_sysconfdir}
112 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chrony.conf
113 %attr(640,root,ntp) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/keys
114 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/chronyd
115 %config(noreplace) %verify(not md5 mtime size) /etc/init/chronyd.conf
116 %config(noreplace) /etc/logrotate.d/chrony
117 %attr(754,root,root) /etc/rc.d/init.d/chronyd
118 %attr(755,root,root) %{_bindir}/chronyc
119 %attr(755,root,root) %{_sbindir}/chronyd
120 %{_mandir}/man1/chrony.1*
121 %{_mandir}/man1/chronyc.1*
122 %{_mandir}/man5/chrony.conf.5*
123 %{_mandir}/man8/chronyd.8*
124 %{_infodir}/chrony.info*
125
126 %dir %attr(770,root,ntp) /var/lib/ntp
127 %attr(640,ntp,ntp) %ghost /var/lib/ntp/drift
128 %attr(640,ntp,ntp) %ghost /var/lib/ntp/rtc
129
130 %dir %attr(770,ntp,ntp) /var/log/chrony
This page took 0.071161 seconds and 4 git commands to generate.