]> git.pld-linux.org Git - packages/chrony.git/blob - chrony.spec
- --with-readline is not valid opt
[packages/chrony.git] / chrony.spec
1 Summary:        An NTP client/server
2 Name:           chrony
3 Version:        1.26
4 Release:        5
5 License:        GPL v2
6 Group:          Daemons
7 URL:            http://chrony.tuxfamily.org/
8 Source0:        http://download.tuxfamily.org/chrony/%{name}-%{version}.tar.gz
9 # Source0-md5:  ad6dd619ff1986e4ff780363c64e2246
10 Source1:        %{name}.conf
11 Source2:        %{name}.keys
12 Source3:        %{name}d.sysconfig
13 Source4:        %{name}d.init
14 Source5:        %{name}.logrotate
15 Source6:        %{name}d.upstart
16 BuildRequires:  bison
17 BuildRequires:  libcap-devel
18 BuildRequires:  readline-devel
19 BuildRequires:  rpmbuild(macros) >= 1.202
20 BuildRequires:  texinfo
21 Requires(postun):       /usr/sbin/groupdel
22 Requires(postun):       /usr/sbin/userdel
23 Requires(pre):  /bin/id
24 Requires(pre):  /usr/bin/getgid
25 Requires(pre):  /usr/sbin/groupadd
26 Requires(pre):  /usr/sbin/useradd
27 Provides:       group(ntp)
28 Provides:       ntpdaemon
29 Provides:       user(ntp)
30 Obsoletes:      ntpdaemon
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _sysconfdir     /etc/ntp
34
35 %description
36 A client/server for the Network Time Protocol, this program keeps your
37 computer's clock accurate. It was specially designed to support
38 systems with dial-up Internet connections, and also supports computers
39 in permanently connected environments.
40
41 %prep
42 %setup -q
43
44 %{__sed} -i -e 's,/usr/local,%{_prefix},g' *.texi
45
46 %build
47 # NOTE: It is not autoconf generated configre
48 CC="%{__cc}" \
49 CFLAGS="%{rpmcflags} -pie -fpie -Wmissing-prototypes -Wall" \
50 CPPFLAGS="%{rpmcppflags}" \
51 ./configure \
52         --prefix=%{_prefix} \
53         --sysconfdir=%{_sysconfdir} \
54         --docdir=%{_docdir} \
55         --without-editline \
56
57 %{__make} getdate all docs
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT/etc/{sysconfig,logrotate.d,rc.d/init.d,init} \
62         $RPM_BUILD_ROOT{%{_sysconfdir},/var/{lib/ntp,log/chrony}}
63
64 %{__make} install install-docs \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 rm -rf $RPM_BUILD_ROOT%{_docdir}
68
69 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/chrony.conf
70 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/keys
71 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/chronyd
72 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/logrotate.d/chrony
73 install -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/chronyd
74 cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/init/chronyd.conf
75
76 touch $RPM_BUILD_ROOT%{_localstatedir}/lib/ntp/{drift,rtc}
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %pre
82 %groupadd -g 246 ntp
83 %useradd -u 246 -d %{_localstatedir}/lib/ntp -g ntp -c "NTP Daemon" ntp
84
85 %post
86 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
87 /sbin/chkconfig --add chronyd
88 %service chronyd restart
89
90 %preun
91 if [ "$1" = "0" ]; then
92         %service chronyd stop
93         /sbin/chkconfig --del chronyd
94 fi
95
96 %postun
97 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
98 if [ "$1" = "0" ]; then
99         %userremove ntp
100         %groupremove ntp
101 fi
102
103 %files
104 %defattr(644,root,root,755)
105 %doc NEWS README chrony.txt faq.txt examples/*
106 %dir %{_sysconfdir}
107 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chrony.conf
108 %attr(640,root,ntp) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/keys
109 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/chronyd
110 %config(noreplace) %verify(not md5 mtime size) /etc/init/chronyd.conf
111 %config(noreplace) /etc/logrotate.d/chrony
112 %attr(754,root,root) /etc/rc.d/init.d/chronyd
113 %attr(755,root,root) %{_bindir}/chronyc
114 %attr(755,root,root) %{_sbindir}/chronyd
115 %{_mandir}/man1/chrony.1*
116 %{_mandir}/man1/chronyc.1*
117 %{_mandir}/man5/chrony.conf.5*
118 %{_mandir}/man8/chronyd.8*
119 %{_infodir}/chrony.info*
120
121 %dir %attr(770,root,ntp) /var/lib/ntp
122 %attr(640,ntp,ntp) %ghost /var/lib/ntp/drift
123 %attr(640,ntp,ntp) %ghost /var/lib/ntp/rtc
124
125 %dir %attr(770,ntp,ntp) /var/log/chrony
This page took 0.037476 seconds and 4 git commands to generate.