]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
fix chrome sandbox path
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
9 %bcond_without  libjpegturbo    # use libjpeg-turbo features
10 %bcond_with     nacl                    # build Native Client support, disabled: http://crbug.com/269560
11 %bcond_without  pulseaudio              # with pulseaudio
12 %bcond_without  sandboxing              # with sandboxing
13 %bcond_with             selinux                 # with SELinux (need policy first)
14 %bcond_with             shared_libs             # with shared libs
15 %bcond_with             sse2                    # use SSE2 instructions
16 %bcond_without  system_flac             # system flac
17 %bcond_without  system_ffmpeg   # system ffmpeg instead of ffmpegsumo
18 %bcond_without  system_harfbuzz # system harfbuzz
19 %bcond_without  system_jsoncpp  # system jsoncpp
20 %bcond_without  system_libexif  # system libexif
21 %bcond_without  system_libmtp   # system libmtp
22 %bcond_with     system_libusb   # system libusb-1, disabled: http://crbug.com/266149
23 %bcond_without  system_libwebp  # system libwebp
24 %bcond_without  system_libxnvctrl       # system libxnvctrl
25 %bcond_with     system_mesa             # system Mesa
26 %bcond_without  system_minizip  # system minizip
27 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
28 %bcond_without  system_protobuf # system protobuf
29 %bcond_without  system_re2              # system re2
30 %bcond_without  system_snappy   # system snappy
31 %bcond_without  system_speex    # system speex
32 %bcond_with     system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
33 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
34 %bcond_with             system_v8               # system v8
35 %bcond_without  system_libvpx   # system libvpx
36 %bcond_without  system_yasm             # system yasm
37 %bcond_without  system_zlib             # system zlib
38 %bcond_without  tcmalloc                # use tcmalloc
39 %bcond_without  verbose                 # verbose build (V=1)
40
41 %ifarch %{ix86}
42 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
43 %undefine       with_system_mesa
44 %endif
45
46 # TODO
47 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
48 # - use_system_skia
49 # - use_system_ssl (use_openssl: http://crbug.com/62803)
50 # - use_system_stlport (android specific)
51 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
52
53 # NOTES:
54 # - mute BEEP mixer if you do not want to hear horrible system bell when
55 #   pressing home/end in url bar or more ^F search results on page.
56 # - space considerations:
57 #   - unpacked sources: ~490MiB
58 #   - built code: ~1.4GiB (x86_64/i686)
59 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
60 # - to look for new tarball, use update-source.sh script
61
62 %define         branch          30.0.1599
63 %define         basever         66
64 %define         patchver        114
65 %define         gyp_rev 1014
66 Summary:        A WebKit powered web browser
67 Name:           chromium-browser
68 %if "%{?patchver}" != ""
69 Version:        %{branch}.%{patchver}
70 %else
71 Version:        %{branch}.%{basever}
72 %endif
73 Release:        3
74 License:        BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
75 Group:          X11/Applications/Networking
76 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
77 # Source0-md5:  065e908d4b4a7ca44026a8234b336cf1
78 %if "%{?patchver}" != ""
79 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
80 # Patch0-md5:   ccc99af9e31d866c174d824eeed5aab2
81 %endif
82 Source1:        %{name}.default
83 Source2:        %{name}.sh
84 Source3:        %{name}.desktop
85 Source5:        find-lang.sh
86 Source6:        update-source.sh
87 Source7:        clean-source.sh
88 Source8:        get-source.sh
89 Source9:        master_preferences.json
90 Patch1:         plugin-searchdirs.patch
91 Patch4:         path-libpdf.patch
92 Patch7:         dlopen_sonamed_gl.patch
93 Patch8:         chromium_useragent.patch.in
94 Patch10:        system-libxnvctrl.patch
95 # https://bugs.gentoo.org/show_bug.cgi?id=393471
96 # libjpeg-turbo >= 1.1.90 supports that feature
97 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
98 Patch12:        system-ffmpeg.patch
99 Patch15:        nacl-build-irt.patch
100 Patch16:        nacl-linkingfix.patch
101 Patch18:        nacl-no-untar.patch
102 Patch24:        nacl-verbose.patch
103 Patch25:        gnome3-volume-control.patch
104 Patch26:        master-prefs-path.patch
105 Patch28:        system-mesa.patch
106 Patch29:        system-icu.patch
107 Patch30:        system-ply.patch
108 URL:            http://www.chromium.org/Home
109 %{?with_gconf:BuildRequires:    GConf2-devel}
110 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
111 BuildRequires:  Mesa-libGLES-devel >= 9.1
112 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
113 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
114 BuildRequires:  alsa-lib-devel
115 BuildRequires:  atk-devel
116 BuildRequires:  bison
117 BuildRequires:  bzip2-devel
118 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
119 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
120 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
121 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
122 %{?with_cups:BuildRequires:     cups-devel}
123 BuildRequires:  elfutils-devel
124 BuildRequires:  expat-devel
125 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
126 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
127 BuildRequires:  fontconfig-devel
128 BuildRequires:  glib2-devel
129 BuildRequires:  gperf
130 %{?with_gps:BuildRequires:      gpsd-devel}
131 BuildRequires:  gtest-devel
132 BuildRequires:  gtk+2-devel
133 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
134 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-icu-devel}
135 %{?with_kerberos:BuildRequires: heimdal-devel}
136 BuildRequires:  hicolor-icon-theme
137 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
138 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
139 BuildRequires:  libevent-devel
140 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
141 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
142 BuildRequires:  libicu-devel >= 4.6
143 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
144 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
145 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
146 BuildRequires:  libpng-devel
147 %{?with_selinux:BuildRequires:  libselinux-devel}
148 BuildRequires:  libstdc++-devel
149 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
150 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
151 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
152 BuildRequires:  libxml2-devel
153 BuildRequires:  libxslt-devel
154 BuildRequires:  man-db
155 %{?with_system_minizip:BuildRequires:   minizip-devel}
156 BuildRequires:  nspr-devel
157 BuildRequires:  nss-devel >= 1:3.12.3
158 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
159 BuildRequires:  pam-devel
160 BuildRequires:  pango-devel
161 BuildRequires:  pciutils-devel
162 BuildRequires:  perl-JSON
163 BuildRequires:  perl-modules
164 BuildRequires:  pkgconfig
165 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
166 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
167 BuildRequires:  python
168 #BuildRequires: python-gyp >= 1-%{gyp_rev}
169 BuildRequires:  python-jinja2
170 BuildRequires:  python-modules
171 BuildRequires:  python-ply >= 3.4
172 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
173 BuildRequires:  rpm >= 4.4.9-56
174 BuildRequires:  rpmbuild(macros) >= 1.453
175 %{?with_system_snappy:BuildRequires:    snappy-devel}
176 BuildRequires:  speech-dispatcher-devel >= 0.8
177 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
178 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
179 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
180 BuildRequires:  tar >= 1:1.22
181 BuildRequires:  udev-devel
182 BuildRequires:  usbutils
183 BuildRequires:  util-linux
184 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
185 BuildRequires:  which
186 BuildRequires:  xorg-lib-libXScrnSaver-devel
187 BuildRequires:  xorg-lib-libXtst-devel
188 BuildRequires:  xz
189 %{?with_system_yasm:BuildRequires:      yasm}
190 %{?with_system_zlib:BuildRequires:      zlib-devel}
191 Requires:       browser-plugins >= 2.0
192 Requires:       desktop-file-utils
193 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
194 # crashes if no fontconfig font present
195 Requires:       fonts-Type1-urw
196 Requires:       hicolor-icon-theme
197 Requires:       libevent >= 2.0.21
198 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
199 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
200 Requires:       lsb-release
201 %{?with_system_re2:Requires:    re2 >= 20130115-2}
202 Requires:       shared-mime-info
203 %{?with_system_sqlite:Requires: sqlite3(icu)}
204 Requires:       xdg-utils >= 1.0.2-4
205 Requires:       xorg-lib-libX11 >= 1.4.99.1
206 Provides:       wwwbrowser
207 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
208 Obsoletes:      chromium-browser-inspector < 15.0.863.0
209 ExclusiveArch:  %{ix86} %{x8664} arm
210 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
211
212 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
213 # Note: these are for PLD Linux use ONLY.
214 # For your own distribution, please get your own set of keys.
215 %define         google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
216 %define         google_default_client_id 724288223830.apps.googleusercontent.com
217 %define         google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
218
219 %define         find_lang       sh find-lang.sh %{buildroot}
220
221 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
222 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
223
224 %if %{without debuginfo}
225 %define         _enable_debug_packages  0
226 %endif
227
228 %description
229 Chromium is an open-source browser project that aims to build a safer,
230 faster, and more stable way for all Internet users to experience the
231 web.
232
233 Chromium serves as a base for Google Chrome, which is Chromium
234 rebranded (name and logo) with very few additions such as usage
235 tracking and an auto-updater system.
236
237 %package l10n
238 Summary:        chromium-browser language packages
239 Group:          I18n
240 Requires:       %{name} = %{version}-%{release}
241 %if "%{_rpmversion}" >= "5"
242 BuildArch:      noarch
243 %endif
244
245 %description l10n
246 Chromium is an open-source browser project that aims to build a safer,
247 faster, and more stable way for all Internet users to experience the
248 web.
249
250 This package contains language packages for 50 languages:
251
252 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
253 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
254 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
255 zh-TW
256
257 %prep
258 %setup -qc
259 %if "%{?patchver}" != ""
260 cd %{name}-%{branch}.%{basever}
261 %patch0 -p1
262 cd ..
263 %endif
264 mv %{name}-%{branch}.%{basever}/* .
265
266 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
267 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
268 . ./chrome/VERSION
269 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
270 test "$chrome" = %{version}
271
272 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
273 test "$gyp_rev" = %{gyp_rev} || :
274
275 . ./v8.sh
276 v8=$MAJOR_VERSION.$MINOR_VERSION.$BUILD_NUMBER.$PATCH_LEVEL
277
278 # add chromium and pld to useragent
279 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
280 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
281         -e 's/@BUILD_DIST_NAME@/PLD/g' \
282         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
283         < %{PATCH8} | %{__patch} -p1
284
285 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
286 ln -s %{SOURCE7} .
287
288 %patch1 -p1
289 %patch4 -p3
290 %patch7 -p1
291 %patch10 -p1
292 %patch15 -p2
293 %{!?with_libjpegturbo:%patch11 -p0}
294 %patch12 -p1
295 %patch16 -p1
296 %patch28 -p1
297 %patch25 -p2
298 %{?with_nacl:%patch18 -p1}
299 %patch24 -p2
300 %patch26 -p2
301 %patch29 -p0
302 %patch30 -p0
303
304 sh -x clean-source.sh \
305         %{!?with_nacl:nacl=0} \
306         %{!?with_system_libvpx:libvpx=0} \
307         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
308         %{!?with_system_mesa:mesa=0} \
309         %{!?with_system_protobuf:protobuf=0} \
310         %{!?with_system_re2:re2=0} \
311         %{!?with_system_snappy:snappy=0} \
312         %{!?with_system_sqlite:sqlite=0} \
313         %{!?with_system_v8:v8=0} \
314         %{!?with_system_zlib:zlib=0} \
315         %{nil}
316
317 %build
318 %if %{with nacl}
319 rm -rf native_client/toolchain/linux_x86_newlib
320 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
321 # Make symlinks for NaCL
322 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
323
324 cd native_client/toolchain/linux_x86_newlib
325 ln -s x86_64-nacl/bin bin
326 cd x86_64-nacl/bin
327 __cc='%{__cc}'
328 if [ "${__cc#ccache}" != "$__cc" ]; then
329         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
330         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
331         %{__sed} -i -e '1i#!/bin/sh' gcc g++
332         chmod +x gcc g++
333 else
334         ln -s %{_bindir}/x86_64-nacl-gcc gcc
335         ln -s %{_bindir}/x86_64-nacl-g++ g++
336 fi
337 ln -s gcc x86_64-nacl-gcc
338 ln -s g++ x86_64-nacl-g++
339 ln -s %{_bindir}/x86_64-nacl-ar .
340 ln -s %{_bindir}/x86_64-nacl-ar ar
341 ln -s %{_bindir}/x86_64-nacl-as as
342 ln -s %{_bindir}/x86_64-nacl-ranlib .
343 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
344 ln -s %{_bindir}/x86_64-nacl-strip .
345 ln -s %{_bindir}/x86_64-nacl-strip strip
346 ln -s %{_bindir}/x86_64-nacl-objcopy .
347 ln -s %{_prefix}/x86_64-nacl/lib ../lib
348 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
349 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
350 cd ../../../../..
351 fi
352 %endif
353
354 flags="
355 %ifarch %{ix86}
356         -Dtarget_arch=ia32 \
357 %endif
358 %ifarch %{x8664}
359         -Dtarget_arch=x64 \
360 %endif
361 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
362         -Dno_strict_aliasing=1 -Dgcc_version=44 \
363 %endif
364         %{!?debug:-Dwerror=} \
365         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
366         %{?with_shared_libs:-Dlibrary=shared_library} \
367         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
368         -Dinclude_tests=0 \
369 %if %{with nacl}
370         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
371         -Ddisable_glibc_untar=1 \
372         -Ddisable_newlib_untar=1 \
373         -Ddisable_glibc=1 \
374         -Ddisable_pnacl=1 \
375         -Dbuild_pnacl_newlib=0 \
376 %else
377         -Ddisable_pnacl_untar=1 \
378         -Ddisable_nacl=1 \
379 %endif
380         %{!?with_sse2:-Ddisable_sse2=1} \
381         %{?with_selinux:-Dselinux=1} \
382         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
383         -Dlinux_link_libpci=1 \
384         -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
385         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
386         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
387         -Dlinux_use_gold_binary=0 \
388         -Dlinux_use_gold_flags=0 \
389         -Dlogging_like_official_build=1 \
390         -Dgoogle_api_key=%{google_api_key} \
391         -Dgoogle_default_client_id=%{google_default_client_id} \
392         -Dgoogle_default_client_secret=%{google_default_client_secret} \
393         %{gyp_with cups} \
394         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
395         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
396         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
397         %{gyp_with pulseaudio} \
398         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
399         %{gyp_with system_flac} \
400         %{gyp_with system_harfbuzz} \
401         %{gyp_with system_jsoncpp} \
402         %{gyp_with system_libexif} \
403         %{gyp_with system_libmtp} \
404         %{gyp_with system_libsrtp} \
405         %{gyp_with system_libusb} \
406         %{gyp_with system_libvpx} -Dmedia_use_libvpx=0 \
407         %{gyp_with system_libwebp} \
408         %{gyp_with system_libxnvctrl} \
409         %{gyp_with system_mesa} \
410         %{gyp_with system_minizip} \
411         %{gyp_with system_opus} \
412         %{gyp_with system_protobuf} \
413         %{gyp_with system_re2} \
414         %{gyp_with system_snappy} \
415         %{gyp_with system_speex} \
416         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
417         %{gyp_with system_v8} \
418         %{gyp_with system_yasm} \
419         %{gyp_with system_zlib} \
420         -Duse_system_bzip2=1 \
421         -Duse_system_expat=1 \
422         -Duse_system_icu=1 \
423         -Duse_system_libevent=1 \
424         -Duse_system_libjpeg=1 \
425         -Duse_system_libpng=1 \
426         -Duse_system_libxml=1 \
427         -Duse_system_libxslt=1 \
428         -Duse_system_nspr=1 \
429         -Duse_system_xdg_utils=1 \
430 "
431
432 build/linux/unbundle/replace_gyp_files.py $flags
433
434 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
435 test -e Makefile || \
436         CC="%{__cc}" \
437         CXX="%{__cxx}" \
438         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
439         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
440         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
441         CC_host="%{__cc}" \
442         CXX_host="%{__cxx}" \
443         LD_host="%{__cxx}" \
444 %{__python} build/gyp_chromium \
445         --format=make \
446         --depth=. \
447         build/all.gyp \
448         $flags
449
450 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
451 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
452         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
453         %{?with_verbose:V=1} \
454         CC.host="%{__cc}" \
455         CXX.host="%{__cxx}" \
456         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
457
458 cd out/%{!?debug:Release}%{?debug:Debug}
459 MANWIDTH=80 man ./chrome.1 > man.out
460 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
461
462 %install
463 rm -rf $RPM_BUILD_ROOT
464 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
465         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
466         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
467
468 cd out/%{!?debug:Release}%{?debug:Debug}
469 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
470 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
471 %{__sed} -i -e '
472         s,@libdir@,%{_libdir}/%{name},
473
474         /@OPTIONS@/ {
475                 r options.txt
476                 d
477         }
478 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
479 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
480 cp -a *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
481 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
482 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
483 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
484 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
485 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
486 %if %{without system_ffmpeg}
487 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
488 %endif
489 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
490 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
491
492 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
493
494 %if %{with nacl}
495 # Install Native Client files on platforms that support it.
496 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
497 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
498 %ifarch %{x8664}
499 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
500 %endif
501 %ifarch %{ix86}
502 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
503 %endif
504 %endif
505
506 cd -
507
508 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
509         size=${icon##*/product_logo_}
510         size=${size%.png}
511
512         # this will skip non-numeric (22_mono_invert, 22_mono)
513         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
514         test -d "$dir" || continue
515
516         install -d $RPM_BUILD_ROOT$dir
517         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
518 done
519
520 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
521 # http://code.google.com/p/chromium/issues/detail?id=24507
522 gecko-mediaplayer*.so
523 EOF
524
525 # find locales
526 %find_lang %{name}.lang
527 # always package en-US
528 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
529
530 %clean
531 rm -rf $RPM_BUILD_ROOT
532
533 %pretrans
534 for d in locales resources; do
535         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
536                 install -d %{_datadir}/%{name}
537                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
538         fi
539 done
540 exit 0
541
542 %post
543 %update_icon_cache hicolor
544 %update_desktop_database
545 %update_browser_plugins
546
547 %postun
548 if [ "$1" = 0 ]; then
549         %update_icon_cache hicolor
550         %update_browser_plugins
551 fi
552
553 %files
554 %defattr(644,root,root,755)
555 %doc AUTHORS LICENSE
556 %{_browserpluginsconfdir}/browsers.d/%{name}.*
557 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
558 %dir %{_sysconfdir}/%{name}
559 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
560 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
561 %attr(755,root,root) %{_bindir}/%{name}
562 %{_mandir}/man1/%{name}.1*
563 %{_desktopdir}/*.desktop
564 %{_iconsdir}/hicolor/*/apps/%{name}.png
565 %dir %{_libdir}/%{name}
566 %{_libdir}/%{name}/chrome*.pak
567 %{_libdir}/%{name}/content_resources.pak
568 %{_libdir}/%{name}/resources.pak
569 %{_libdir}/%{name}/locales
570 %{_libdir}/%{name}/resources
571
572 %dir %{_datadir}/%{name}
573 %dir %{_datadir}/%{name}/locales
574 %{_datadir}/%{name}/locales/en-US.pak
575 %dir %{_datadir}/%{name}/resources
576 %{_datadir}/%{name}/resources/inspector
577
578 %dir %{_libdir}/%{name}/plugins
579 %attr(755,root,root) %{_libdir}/%{name}/%{name}
580 # These unique permissions are intentional and necessary for the sandboxing
581 %attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
582
583 # ffmpeg libs
584 %if %{without system_ffmpeg}
585 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
586 %endif
587
588 %if %{with nacl}
589 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
590 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
591 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
592 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
593 %endif
594
595 %files l10n -f %{name}.lang
596 %defattr(644,root,root,755)
This page took 0.064692 seconds and 4 git commands to generate.