]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
up to 26.0.1410.63
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
9 %bcond_without  libjpegturbo    # use libjpeg-turbo features
10 %bcond_without  nacl                    # build Native Client support
11 %bcond_without  pulseaudio              # with pulseaudio
12 %bcond_without  sandboxing              # with sandboxing
13 %bcond_with             selinux                 # with SELinux (need policy first)
14 %bcond_with             shared_libs             # with shared libs
15 %bcond_with             sse2                    # use SSE2 instructions
16 %bcond_without  system_flac             # system flac
17 %bcond_without  system_ffmpeg   # system ffmpeg instead of ffmpegsumo
18 %bcond_without  system_harfbuzz # system harfbuzz
19 %bcond_without  system_jsoncpp  # system jsoncpp
20 %bcond_without  system_libexif  # system libexif
21 %bcond_without  system_libmtp   # system libmtp
22 %bcond_without  system_libusb   # system libusb-1
23 %bcond_without  system_libwebp  # system libwebp
24 %bcond_without  system_libxnvctrl       # system libxnvctrl
25 %bcond_without  system_mesa             # system Mesa
26 %bcond_without  system_minizip  # system minizip
27 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
28 %bcond_without  system_protobuf # system protobuf
29 %bcond_without  system_re2              # system re2
30 %bcond_without  system_speex    # system speex
31 %bcond_with             system_sqlite   # system sqlite
32 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
33 %bcond_with             system_v8               # system v8
34 %bcond_without  system_libvpx   # system libvpx
35 %bcond_without  system_yasm             # system yasm
36 %bcond_without  system_zlib             # system zlib
37 %bcond_without  tcmalloc                # use tcmalloc
38 %bcond_without  verbose                 # verbose build (V=1)
39
40 %ifarch %{ix86}
41 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
42 %undefine       with_system_mesa
43 %endif
44
45 # TODO
46 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
47 # - use_system_skia
48 # - use_system_ssl (use_openssl: http://crbug.com/62803)
49 # - use_system_stlport (android specific)
50 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
51
52 # NOTES:
53 # - mute BEEP mixer if you do not want to hear horrible system bell when
54 #   pressing home/end in url bar or more ^F search results on page.
55 # - space considerations:
56 #   - unpacked sources: ~490MiB
57 #   - built code: ~1.4GiB (x86_64/i686)
58 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
59 # - to look for new tarball, use update-source.sh script
60
61 # NOTE TO USERS:
62 # To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
63 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
64 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
65
66 %define         branch          26.0.1410
67 %define         basever         43
68 %define         patchver        63
69 %define         gyp_rev 1014
70 Summary:        A WebKit powered web browser
71 Name:           chromium-browser
72 %if "%{?patchver}" != ""
73 Version:        %{branch}.%{patchver}
74 %else
75 Version:        %{branch}.%{basever}
76 %endif
77 Release:        1
78 License:        BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
79 Group:          X11/Applications/Networking
80 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
81 # Source0-md5:  eafd6a919faadc8a7446cd673f460c4c
82 %if "%{?patchver}" != ""
83 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
84 # Patch0-md5:   8eaaa7eb2866d1b3b5536074853de998
85 %endif
86 Source1:        %{name}.default
87 Source2:        %{name}.sh
88 Source3:        %{name}.desktop
89 Source5:        find-lang.sh
90 Source6:        update-source.sh
91 Source7:        clean-source.sh
92 Source8:        get-source.sh
93 Source9:        master_preferences.json
94 Patch1:         plugin-searchdirs.patch
95 #Patch2:                system-nspr.patch
96 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
97 Patch4:         path-libpdf.patch
98 Patch6:         get-webkit_revision.patch
99 Patch7:         dlopen_sonamed_gl.patch
100 Patch8:         chromium_useragent.patch.in
101 Patch9:         chromium-ppapi.patch
102 Patch10:        system-libxnvctrl.patch
103 # https://bugs.gentoo.org/show_bug.cgi?id=393471
104 # libjpeg-turbo >= 1.1.90 supports that feature
105 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
106 Patch12:        system-ffmpeg.patch
107 Patch15:        nacl-build-irt.patch
108 Patch16:        nacl-linkingfix.patch
109 Patch18:        nacl-no-untar.patch
110 Patch19:        system-jsoncpp.patch
111 Patch24:        nacl-verbose.patch
112 Patch25:        gnome3-volume-control.patch
113 Patch26:        master-prefs-path.patch
114 Patch27:        tcmalloc-glibc2.16.patch
115 Patch28:        system-mesa.patch
116 Patch29:        speechd-0.8.patch
117 Patch30:        harfbuzz-0.13.patch
118 Patch31:        %{name}-whitelist-gpu.patch
119 URL:            http://www.chromium.org/Home
120 %{?with_gconf:BuildRequires:    GConf2-devel}
121 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
122 %{?with_system_mesa:BuildRequires:      Mesa-libGLES-devel >= 9.1}
123 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
124 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
125 BuildRequires:  alsa-lib-devel
126 BuildRequires:  atk-devel
127 BuildRequires:  bison
128 BuildRequires:  bzip2-devel
129 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
130 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
131 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
132 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
133 %{?with_cups:BuildRequires:     cups-devel}
134 BuildRequires:  elfutils-devel
135 BuildRequires:  expat-devel
136 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
137 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
138 BuildRequires:  fontconfig-devel
139 BuildRequires:  glib2-devel
140 BuildRequires:  gperf
141 %{?with_gps:BuildRequires:      gpsd-devel}
142 BuildRequires:  gtest-devel
143 BuildRequires:  gtk+2-devel
144 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
145 %{?with_kerberos:BuildRequires: heimdal-devel}
146 BuildRequires:  hicolor-icon-theme
147 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
148 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
149 BuildRequires:  libevent-devel
150 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
151 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
152 BuildRequires:  libicu-devel >= 4.6
153 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
154 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
155 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
156 BuildRequires:  libpng-devel
157 %{?with_selinux:BuildRequires:  libselinux-devel}
158 BuildRequires:  libstdc++-devel
159 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
160 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
161 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
162 BuildRequires:  libxml2-devel
163 BuildRequires:  libxslt-devel
164 BuildRequires:  man-db
165 %{?with_system_minizip:BuildRequires:   minizip-devel}
166 BuildRequires:  nspr-devel
167 BuildRequires:  nss-devel >= 1:3.12.3
168 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
169 BuildRequires:  pam-devel
170 BuildRequires:  pango-devel
171 BuildRequires:  pciutils-devel
172 BuildRequires:  perl-modules
173 BuildRequires:  pkgconfig
174 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
175 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
176 BuildRequires:  python
177 #BuildRequires: python-gyp >= 1-%{gyp_rev}
178 BuildRequires:  python-modules
179 BuildRequires:  python-ply
180 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
181 BuildRequires:  rpm >= 4.4.9-56
182 BuildRequires:  rpmbuild(macros) >= 1.453
183 BuildRequires:  speech-dispatcher-devel >= 0.8
184 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
185 BuildRequires:  sqlite3-devel >= 3.6.1
186 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
187 BuildRequires:  subversion
188 BuildRequires:  tar >= 1:1.22
189 BuildRequires:  udev-devel
190 BuildRequires:  usbutils
191 BuildRequires:  util-linux
192 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
193 BuildRequires:  which
194 BuildRequires:  xorg-lib-libXScrnSaver-devel
195 BuildRequires:  xz
196 %{?with_system_yasm:BuildRequires:      yasm}
197 %{?with_system_zlib:BuildRequires:      zlib-devel}
198 Requires:       browser-plugins >= 2.0
199 Requires:       desktop-file-utils
200 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
201 # crashes if no fontconfig font present
202 Requires:       fonts-Type1-urw
203 Requires:       hicolor-icon-theme
204 Requires:       libevent >= 2.0.21
205 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
206 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
207 Requires:       lsb-release
208 %{?with_system_re2:Requires:    re2 >= 20130115-2}
209 Requires:       shared-mime-info
210 Requires:       xdg-utils >= 1.0.2-4
211 Requires:       xorg-lib-libX11 >= 1.4.99.1
212 Provides:       wwwbrowser
213 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
214 Obsoletes:      chromium-browser-inspector < 15.0.863.0
215 ExclusiveArch:  %{ix86} %{x8664} arm
216 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
217
218 %define         find_lang       sh find-lang.sh %{buildroot}
219
220 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
221 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
222
223 %if %{without debuginfo}
224 %define         _enable_debug_packages  0
225 %endif
226
227 %description
228 Chromium is an open-source browser project that aims to build a safer,
229 faster, and more stable way for all Internet users to experience the
230 web.
231
232 Chromium serves as a base for Google Chrome, which is Chromium
233 rebranded (name and logo) with very few additions such as usage
234 tracking and an auto-updater system.
235
236 %package l10n
237 Summary:        chromium-browser language packages
238 Group:          I18n
239 Requires:       %{name} = %{version}-%{release}
240
241 %description l10n
242 Chromium is an open-source browser project that aims to build a safer,
243 faster, and more stable way for all Internet users to experience the
244 web.
245
246 This package contains language packages for 50 languages:
247
248 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
249 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
250 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
251 zh-TW
252
253 %prep
254 %setup -qc
255 %if "%{?patchver}" != ""
256 cd %{name}-%{branch}.%{basever}
257 %patch0 -p1
258 cd ..
259 %endif
260 mv %{name}-%{branch}.%{basever}/* .
261
262 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
263 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
264 . ./chrome/VERSION
265 ver=$MAJOR.$MINOR.$BUILD.$PATCH
266 test "$ver" = %{version}
267
268 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
269 test "$gyp_rev" = %{gyp_rev} || :
270
271 v8_ver=$(awk 'NR=1 {print $NF; exit}' v8/ChangeLog || :)
272
273 # add chromium and pld to useragent
274 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
275 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
276         -e 's/@BUILD_DIST_NAME@/PLD/g' \
277         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
278         < %{PATCH8} | %{__patch} -p2
279
280 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
281 ln -s %{SOURCE7} .
282
283 %patch1 -p2
284 %patch3 -p2
285 %patch4 -p3
286 %patch6 -p2
287 %patch7 -p2
288 %patch10 -p2
289 %patch15 -p2
290 %patch9 -p0
291 #%patch2 -p1
292 %{!?with_libjpegturbo:%patch11 -p0}
293 %patch12 -p1
294 %patch16 -p1
295 %patch19 -p2
296 %patch27 -p1
297 %patch28 -p1
298 %patch25 -p2
299 %patch18 -p2
300 %patch24 -p2
301 %patch26 -p2
302 %patch29 -p2
303 cd third_party/WebKit
304 %patch30 -p1
305 cd -
306 %patch31 -p1
307
308 sh -x clean-source.sh \
309         %{!?with_nacl:nacl=0} \
310         %{!?with_system_libvpx:libvpx=0} \
311         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
312         %{!?with_system_mesa:mesa=0} \
313         %{!?with_system_protobuf:protobuf=0} \
314         %{!?with_system_re2:re2=0} \
315         %{!?with_system_v8:v8=0} \
316         %{!?with_system_zlib:zlib=0} \
317         %{nil}
318
319 %build
320 %if %{with nacl}
321 rm -rf native_client/toolchain/linux_x86_newlib
322 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
323 # Make symlinks for NaCL
324 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
325
326 cd native_client/toolchain/linux_x86_newlib
327 ln -s x86_64-nacl/bin bin
328 cd x86_64-nacl/bin
329 __cc='%{__cc}'
330 if [ "${__cc#ccache}" != "$__cc" ]; then
331         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
332         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
333         %{__sed} -i -e '1i#!/bin/sh' gcc g++
334         chmod +x gcc g++
335 else
336         ln -s %{_bindir}/x86_64-nacl-gcc gcc
337         ln -s %{_bindir}/x86_64-nacl-g++ g++
338 fi
339 ln -s gcc x86_64-nacl-gcc
340 ln -s g++ x86_64-nacl-g++
341 ln -s %{_bindir}/x86_64-nacl-ar .
342 ln -s %{_bindir}/x86_64-nacl-ar ar
343 ln -s %{_bindir}/x86_64-nacl-as as
344 ln -s %{_bindir}/x86_64-nacl-ranlib .
345 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
346 ln -s %{_bindir}/x86_64-nacl-strip .
347 ln -s %{_bindir}/x86_64-nacl-strip strip
348 ln -s %{_prefix}/x86_64-nacl/lib ../lib
349 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
350 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
351 cd ../../../../..
352 fi
353 %endif
354
355 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
356 test -e Makefile || \
357         CC="%{__cc}" \
358         CXX="%{__cxx}" \
359         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
360         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
361         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
362 %{__python} build/gyp_chromium \
363         --format=make \
364         --depth=. \
365         build/all.gyp \
366 %ifarch %{ix86}
367         -Dtarget_arch=ia32 \
368 %endif
369 %ifarch %{x8664}
370         -Dtarget_arch=x64 \
371 %endif
372 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
373         -Dno_strict_aliasing=1 -Dgcc_version=44 \
374 %endif
375 %if %{with sandboxing}
376         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
377         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
378 %endif
379         %{!?debug:-Dwerror=} \
380         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
381         %{?with_shared_libs:-Dlibrary=shared_library} \
382         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
383         -Dinclude_tests=0 \
384 %if %{with nacl}
385         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
386         -Ddisable_glibc_untar=1 \
387         -Ddisable_newlib_untar=1 \
388         -Ddisable_glibc=1 \
389         -Ddisable_pnacl=1 \
390         -Dbuild_pnacl_newlib=0 \
391 %else
392         -Ddisable_pnacl_untar=1 \
393         -Ddisable_nacl=1 \
394 %endif
395         %{!?with_sse2:-Ddisable_sse2=1} \
396         %{?with_selinux:-Dselinux=1} \
397         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
398         -Dlinux_link_libpci=1 \
399         -Dlinux_link_libspeechd=1 \
400         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
401         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
402         -Dlinux_use_gold_binary=0 \
403         -Dlinux_use_gold_flags=0 \
404         %{gyp_with cups} \
405         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
406         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
407         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
408         %{gyp_with pulseaudio} \
409         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
410         %{gyp_with system_flac} \
411         %{gyp_with system_harfbuzz} \
412         %{gyp_with system_jsoncpp} \
413         %{gyp_with system_libexif} \
414         %{gyp_with system_libmtp} \
415         %{gyp_with system_libsrtp} \
416         %{gyp_with system_libusb} \
417         %{gyp_with system_libvpx} -Dmedia_use_libvpx=0 \
418         %{gyp_with system_libwebp} \
419         %{gyp_with system_libxnvctrl} \
420         %{gyp_with system_mesa} \
421         %{gyp_with system_minizip} \
422         %{gyp_with system_opus} \
423         %{gyp_with system_protobuf} \
424         %{gyp_with system_re2} \
425         %{gyp_with system_speex} \
426         %{gyp_with system_sqlite} \
427         %{gyp_with system_v8} \
428         %{gyp_with system_yasm} \
429         %{gyp_with system_zlib} \
430         -Duse_system_bzip2=1 \
431         -Duse_system_expat=1 \
432         -Duse_system_icu=1 \
433         -Duse_system_libevent=1 \
434         -Duse_system_libjpeg=1 \
435         -Duse_system_libpng=1 \
436         -Duse_system_libxml=1 \
437         -Duse_system_libxslt=1 \
438         -Duse_system_nspr=1 \
439         -Duse_system_xdg_utils=1 \
440
441 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
442 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
443         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
444         %{?with_verbose:V=1} \
445         CC.host="%{__cc}" \
446         CXX.host="%{__cxx}" \
447         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
448
449 cd out/%{!?debug:Release}%{?debug:Debug}
450 MANWIDTH=80 man ./chrome.1 > man.out
451 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
452
453 %install
454 rm -rf $RPM_BUILD_ROOT
455 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
456         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
457
458 cd out/%{!?debug:Release}%{?debug:Debug}
459 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
460 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
461 %{__sed} -i -e '
462         s,@libdir@,%{_libdir}/%{name},
463
464         /@OPTIONS@/ {
465                 r options.txt
466                 d
467         }
468 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
469 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
470 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
471 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
472 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
473 %if %{without system_ffmpeg}
474 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
475 %endif
476 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
477 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
478
479 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
480
481 %if %{with nacl}
482 # Install Native Client files on platforms that support it.
483 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
484 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
485 %ifarch %{x8664}
486 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
487 %endif
488 %ifarch %{ix86}
489 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
490 %endif
491 %endif
492
493 cd -
494
495 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
496         size=${icon##*/product_logo_}
497         size=${size%.png}
498
499         # this will skip non-numeric (22_mono_invert, 22_mono)
500         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
501         test -d "$dir" || continue
502
503         install -d $RPM_BUILD_ROOT$dir
504         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
505 done
506
507 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
508 # http://code.google.com/p/chromium/issues/detail?id=24507
509 gecko-mediaplayer*.so
510 EOF
511
512 # find locales
513 %find_lang %{name}.lang
514 # always package en-US
515 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
516
517 %clean
518 rm -rf $RPM_BUILD_ROOT
519
520 %post
521 %update_icon_cache hicolor
522 %update_desktop_database
523 %update_browser_plugins
524
525 %postun
526 if [ "$1" = 0 ]; then
527         %update_icon_cache hicolor
528         %update_browser_plugins
529 fi
530
531 %files
532 %defattr(644,root,root,755)
533 %doc AUTHORS LICENSE
534 %{_browserpluginsconfdir}/browsers.d/%{name}.*
535 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
536 %dir %{_sysconfdir}/%{name}
537 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
538 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
539 %attr(755,root,root) %{_bindir}/%{name}
540 %{_mandir}/man1/%{name}.1*
541 %{_desktopdir}/*.desktop
542 %{_iconsdir}/hicolor/*/apps/%{name}.png
543 %dir %{_libdir}/%{name}
544 %{_libdir}/%{name}/chrome*.pak
545 %{_libdir}/%{name}/content_resources.pak
546 %{_libdir}/%{name}/resources.pak
547 %dir %{_libdir}/%{name}/locales
548 %{_libdir}/%{name}/locales/en-US.pak
549 %dir %{_libdir}/%{name}/resources
550 %{_libdir}/%{name}/resources/inspector
551 %dir %{_libdir}/%{name}/themes
552 %dir %{_libdir}/%{name}/extensions
553 %dir %{_libdir}/%{name}/plugins
554 %attr(755,root,root) %{_libdir}/%{name}/%{name}
555 # These unique permissions are intentional and necessary for the sandboxing
556 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
557
558 # ffmpeg libs
559 %if %{without system_ffmpeg}
560 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
561 %endif
562
563 %if %{with nacl}
564 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
565 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
566 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
567 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
568 %endif
569
570 %files l10n -f %{name}.lang
571 %defattr(644,root,root,755)
This page took 0.086812 seconds and 4 git commands to generate.