]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
- rediffed nacl-linkingfix,gnome3-volume-control patches, build patch obsolete
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_with     dev                     # with dev optimizations (skip clean source)
6 %bcond_without  gconf                   # with GConf
7 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
8 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
9 %bcond_with     gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
10 %bcond_without  libjpegturbo            # use libjpeg-turbo features
11 %bcond_with     nacl                    # build Native Client support, disabled: http://crbug.com/269560
12 %bcond_without  ninja                   # use Ninja instead of make to build
13 %bcond_without  pulseaudio              # with pulseaudio
14 %bcond_without  sandboxing              # with sandboxing
15 %bcond_with     selinux                 # with SELinux (need policy first)
16 %bcond_with     shared_libs             # with shared libs
17 %bcond_with     sse2                    # use SSE2 instructions
18 %bcond_without  system_flac             # system flac
19 %bcond_without  system_ffmpeg           # system ffmpeg
20 %bcond_without  system_harfbuzz         # system harfbuzz
21 # http://bugs.gentoo.org/576370
22 %bcond_with     system_icu              # system icu
23 %bcond_without  system_jsoncpp          # system jsoncpp
24 %bcond_without  system_libexif          # system libexif
25 %bcond_without  system_libmtp           # system libmtp
26 %bcond_with     system_libusb           # system libusb-1, disabled: http://crbug.com/266149
27 %bcond_without  system_libwebp          # system libwebp
28 %bcond_without  system_libxnvctrl       # system libxnvctrl
29 %bcond_with     system_mesa             # system Mesa
30 %bcond_without  system_minizip          # system minizip
31 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
32 # protobuf broken: https://bugs.gentoo.org/show_bug.cgi?id=525560
33 %bcond_with     system_protobuf         # system protobuf
34 %bcond_with     system_re2              # system re2
35 %bcond_without  system_snappy           # system snappy
36 %bcond_without  system_speex            # system speex
37 %bcond_with     system_sqlite           # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
38 %bcond_without  system_libsrtp          # system srtp (can be used if using bundled libjingle), http://bugs.gentoo.org/459932
39 %bcond_with     system_v8               # system v8
40 %bcond_with     system_libvpx           # system libvpx, http://crbug.com/494939
41 %bcond_without  system_yasm             # system yasm
42 %bcond_without  system_zlib             # system zlib
43 %bcond_with     tcmalloc                # use tcmalloc
44 %bcond_without  verbose                 # verbose build (V=1)
45
46 %ifarch %{ix86}
47 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
48 %undefine       with_system_mesa
49
50 # unable build with debuginfo on 32bit build systems
51 # /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
52 %undefine       with_debuginfo
53 %endif
54
55 %ifarch %{x8664}
56 # x86_64 systems fail with debugedit crashing
57 # /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
58 %undefine       with_debuginfo
59 %endif
60
61 # TODO
62 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
63 # - use_system_skia
64 # - use_system_ssl (use_openssl: http://crbug.com/62803)
65 # - use_system_stlport (android specific)
66
67 # NOTES:
68 # - mute BEEP mixer if you do not want to hear horrible system bell when
69 #   pressing home/end in url bar or more ^F search results on page.
70 # - space considerations:
71 #   - unpacked sources: ~490MiB
72 #   - built code: ~1.1GiB (x86_64/i686)
73 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
74 # - to look for new tarball, use update-source.sh script
75
76 %define         branch          50.0.2661
77 %define         basever         75
78 %define         patchver        102
79 %define         gyp_rev 1014
80 Summary:        A WebKit powered web browser
81 Name:           chromium-browser
82 %if "%{?patchver}" != ""
83 Version:        %{branch}.%{patchver}
84 %else
85 Version:        %{branch}.%{basever}
86 %endif
87 Release:        3
88 License:        BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
89 Group:          X11/Applications/Networking
90 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
91 # Source0-md5:  f6ae41191ec560a0d1cd238ac2a618cf
92 #Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{branch}.%{basever}.tar.gz
93 %if "%{?patchver}" != ""
94 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
95 # Patch0-md5:   a8bd6c3c0f6befac88c81632a9360761
96 %endif
97 Source1:        %{name}.default
98 Source2:        %{name}.sh
99 Source3:        %{name}.desktop
100 Source5:        find-lang.sh
101 Source6:        update-source.sh
102 Source7:        clean-source.sh
103 Source8:        get-source.sh
104 Source9:        master_preferences.json
105 # https://github.com/Kelvin-Ng/Kelvin-Gentoo-Overlay/tree/master/www-client/chromium/files
106 Patch2:         enable-video-decode-accel.patch
107 Patch7:         dlopen_sonamed_gl.patch
108 Patch8:         chromium_useragent.patch.in
109 # https://bugs.gentoo.org/show_bug.cgi?id=393471
110 # libjpeg-turbo >= 1.1.90 supports that feature
111 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
112 Patch15:        nacl-build-irt.patch
113 Patch16:        nacl-linkingfix.patch
114 Patch18:        nacl-no-untar.patch
115 Patch24:        nacl-verbose.patch
116 Patch25:        gnome3-volume-control.patch
117 Patch26:        master-prefs-path.patch
118 Patch28:        system-mesa.patch
119 Patch31:        system-jinja.patch
120 Patch32:        remove_bundled_libraries-stale.patch
121 Patch35:        etc-dir.patch
122 Patch36:        angle.patch
123 Patch38:        vaapi_include.patch
124 Patch39:        libsecret.patch
125 Patch40:        ffmpeg-generate-errors.patch
126 Patch41:        ffmpeg-generate.patch
127 Patch42:        system-ffmpeg.patch
128 Patch43:        cups22.patch
129 URL:            http://www.chromium.org/Home
130 %{?with_gconf:BuildRequires:    GConf2-devel}
131 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
132 BuildRequires:  Mesa-libGLES-devel >= 9.1
133 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
134 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
135 BuildRequires:  alsa-lib-devel
136 BuildRequires:  atk-devel
137 BuildRequires:  bison
138 BuildRequires:  bzip2-devel
139 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
140 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
141 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
142 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
143 %{?with_cups:BuildRequires:     cups-devel}
144 BuildRequires:  elfutils-devel
145 BuildRequires:  expat-devel
146 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 2.7.2}
147 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
148 BuildRequires:  fontconfig-devel
149 BuildRequires:  glib2-devel
150 BuildRequires:  gperf
151 %{?with_gps:BuildRequires:      gpsd-devel}
152 BuildRequires:  gtest-devel
153 BuildRequires:  gtk+2-devel
154 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
155 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-icu-devel}
156 %{?with_kerberos:BuildRequires: heimdal-devel}
157 BuildRequires:  hicolor-icon-theme
158 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
159 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
160 BuildRequires:  libevent-devel
161 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
162 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
163 %{?with_system_icu:BuildRequires:       libicu-devel >= 4.6}
164 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
165 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
166 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
167 BuildRequires:  libpng-devel
168 BuildRequires:  libsecret-devel
169 %{?with_selinux:BuildRequires:  libselinux-devel}
170 BuildRequires:  libstdc++-devel
171 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
172 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 1.5.0}
173 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.4.0}
174 BuildRequires:  libxml2-devel
175 BuildRequires:  libxslt-devel
176 BuildRequires:  man-db
177 %{?with_system_minizip:BuildRequires:   minizip-devel}
178 %{?with_ninja:BuildRequires:    ninja >= 1.3.0}
179 BuildRequires:  nspr-devel
180 BuildRequires:  nss-devel >= 1:3.12.3
181 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
182 BuildRequires:  pam-devel
183 BuildRequires:  pango-devel
184 BuildRequires:  pciutils-devel
185 BuildRequires:  perl-JSON
186 BuildRequires:  perl-modules
187 BuildRequires:  pkgconfig
188 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
189 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
190 BuildRequires:  python
191 BuildRequires:  python-BeautifulSoup
192 #BuildRequires: python-gyp >= 1-%{gyp_rev}
193 BuildRequires:  python-html5lib
194 BuildRequires:  python-jinja2 >= 2.7
195 BuildRequires:  python-modules
196 BuildRequires:  python-ply >= 3.4
197 %{?with_system_re2:BuildRequires:       re2-devel >= 20151101}
198 BuildRequires:  rpm >= 4.4.9-56
199 BuildRequires:  rpmbuild(macros) >= 1.453
200 %{?with_system_snappy:BuildRequires:    snappy-devel}
201 BuildRequires:  speech-dispatcher-devel >= 0.8
202 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
203 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
204 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
205 BuildRequires:  tar >= 1:1.22
206 BuildRequires:  udev-devel
207 BuildRequires:  usbutils
208 BuildRequires:  util-linux
209 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
210 BuildRequires:  which
211 BuildRequires:  xorg-lib-libXScrnSaver-devel
212 BuildRequires:  xorg-lib-libXtst-devel
213 BuildRequires:  xz
214 %{?with_system_yasm:BuildRequires:      yasm}
215 %{?with_system_zlib:BuildRequires:      zlib-devel}
216 Requires:       browser-plugins >= 2.0
217 Requires:       desktop-file-utils
218 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
219 # crashes if no fontconfig font present
220 Requires:       fonts-Type1-urw
221 Requires:       hicolor-icon-theme
222 Requires:       libevent >= 2.0.21
223 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
224 %{?with_system_libvpx:Requires: libvpx >= 1.4.0}
225 Requires:       lsb-release
226 %{?with_system_re2:Requires:    re2 >= 20151101}
227 %{?with_system_protobuf:Requires:       protobuf-libs >= 2.5.0-2}
228 Requires:       shared-mime-info
229 %{?with_system_sqlite:Requires: sqlite3(icu)}
230 Requires:       uname(release) >= 3.17
231 Requires:       xdg-utils >= 1.0.2-4
232 Requires:       xorg-lib-libX11 >= 1.4.99.1
233 Provides:       wwwbrowser
234 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
235 Obsoletes:      chromium-browser-inspector < 15.0.863.0
236 ExclusiveArch:  %{ix86} %{x8664} arm
237 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
238
239 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
240 # Note: these are for PLD Linux use ONLY.
241 # For your own distribution, please get your own set of keys.
242 %define         google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
243 %define         google_default_client_id 724288223830.apps.googleusercontent.com
244 %define         google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
245
246 %define         find_lang       sh find-lang.sh %{buildroot}
247
248 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
249 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
250
251 %ifarch %{ix86}
252 %define         target_arch ia32
253 %endif
254 %ifarch %{x8664}
255 %define         target_arch x64
256 %endif
257
258 %define         buildtype       %{?debug:Debug}%{!?debug:Release}
259 %define         builddir        out/%{buildtype}
260
261 %if %{without debuginfo}
262 %define         _enable_debug_packages  0
263 %endif
264
265 %description
266 Chromium is an open-source browser project that aims to build a safer,
267 faster, and more stable way for all Internet users to experience the
268 web.
269
270 Chromium serves as a base for Google Chrome, which is Chromium
271 rebranded (name and logo) with very few additions such as usage
272 tracking and an auto-updater system.
273
274 %package l10n
275 Summary:        chromium-browser language packages
276 Group:          I18n
277 Requires:       %{name} = %{version}-%{release}
278 BuildArch:      noarch
279
280 %description l10n
281 Chromium is an open-source browser project that aims to build a safer,
282 faster, and more stable way for all Internet users to experience the
283 web.
284
285 This package contains language packages for 50 languages:
286
287 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
288 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
289 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
290 zh-TW
291
292 %prep
293 %setup -qc
294 %if "%{?patchver}" != ""
295 cd chromium*-%{branch}.%{basever}
296 %patch0 -p1
297 cd ..
298 %endif
299 mv chromium*-%{branch}.%{basever}/* .
300
301 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
302 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
303 . ./chrome/VERSION
304 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
305 test "$chrome" = %{version}
306
307 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
308 test "$gyp_rev" = %{gyp_rev} || :
309
310 # add chromium and pld to useragent
311 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
312 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
313         -e 's/@BUILD_DIST_NAME@/PLD/g' \
314         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
315         < %{PATCH8} | %{__patch} -p1
316
317 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
318 ln -s %{SOURCE7} .
319
320 #%patch2 -p1 CHECK
321 %patch7 -p1
322 %patch15 -p2
323 %{!?with_libjpegturbo:%patch11 -p0}
324 %patch16 -p1
325 %patch28 -p1
326 %patch25 -p1
327 %{?with_nacl:%patch18 -p1}
328 %patch24 -p1
329 %patch26 -p2
330 %patch31 -p0
331 %patch32 -p1
332 %patch35 -p1
333 %patch36 -p1
334 #%patch38 -p1 CHECK
335 %patch39 -p1
336 #%patch40 -p1 UPDATE
337 #%patch41 -p1 CHECK
338 %patch42 -p1
339 %patch43 -p1
340
341 # https://groups.google.com/a/chromium.org/forum/#!topic/chromium-packagers/9JX1N2nf4PU
342 install -d chrome/test/data/webui
343 touch chrome/test/data/webui/i18n_process_css_test.html
344
345 %{?with_dev:exit 0}
346
347 sh -x clean-source.sh \
348         %{!?with_nacl:nacl=0} \
349         %{!?with_system_libvpx:libvpx=0} \
350         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
351         %{!?with_system_mesa:mesa=0} \
352         %{!?with_system_protobuf:protobuf=0} \
353         %{!?with_system_re2:re2=0} \
354         %{!?with_system_snappy:snappy=0} \
355         %{!?with_system_sqlite:sqlite=0} \
356         %{!?with_system_v8:v8=0} \
357         %{!?with_system_libwebp:libwebp=0} \
358         %{!?with_system_zlib:zlib=0} \
359         %{!?with_system_ffmpeg:ffmpeg=0} \
360         %{nil}
361
362 %build
363 %if %{with nacl}
364 rm -rf native_client/toolchain/linux_x86_newlib
365 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
366 # Make symlinks for NaCL
367 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
368
369 cd native_client/toolchain/linux_x86_newlib
370 ln -s x86_64-nacl/bin bin
371 cd x86_64-nacl/bin
372 __cc='%{__cc}'
373 if [ "${__cc#ccache}" != "$__cc" ]; then
374         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
375         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
376         %{__sed} -i -e '1i#!/bin/sh' gcc g++
377         chmod +x gcc g++
378 else
379         ln -s %{_bindir}/x86_64-nacl-gcc gcc
380         ln -s %{_bindir}/x86_64-nacl-g++ g++
381 fi
382 ln -s gcc x86_64-nacl-gcc
383 ln -s g++ x86_64-nacl-g++
384 ln -s %{_bindir}/x86_64-nacl-ar .
385 ln -s %{_bindir}/x86_64-nacl-ar ar
386 ln -s %{_bindir}/x86_64-nacl-as as
387 ln -s %{_bindir}/x86_64-nacl-ranlib .
388 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
389 ln -s %{_bindir}/x86_64-nacl-strip .
390 ln -s %{_bindir}/x86_64-nacl-strip strip
391 ln -s %{_bindir}/x86_64-nacl-objcopy .
392 ln -s %{_prefix}/x86_64-nacl/lib ../lib
393 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
394 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
395 cd ../../../../..
396 fi
397 %endif
398
399 %if %{without system_ffmpeg}
400 if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
401         # Re-configure bundled ffmpeg
402         cd third_party/ffmpeg
403         chromium/scripts/build_ffmpeg.py linux %{target_arch} \
404                 --branding Chromium
405         chromium/scripts/copy_config.sh
406         chromium/scripts/generate_gyp.py
407         cd -
408 fi
409 %endif
410
411 third_party/libaddressinput/chromium/tools/update-strings.py
412
413 flags="
414         -Dtarget_arch=%{target_arch} \
415         -Dpython_arch=%{target_arch} \
416         -Dproprietary_codecs=1 \
417         -Dffmpeg_branding=Chromium \
418         -Dsystem_libdir=%{_lib} \
419         -Dpython_ver=%{py_ver} \
420 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
421         -Dno_strict_aliasing=1 -Dgcc_version=44 \
422 %endif
423         %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
424         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
425         %{?with_shared_libs:-Dlibrary=shared_library} \
426         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} \
427         -Dinclude_tests__=0 \
428 %if %{with nacl}
429         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
430         -Ddisable_glibc_untar=1 \
431         -Ddisable_newlib_untar=1 \
432         -Ddisable_glibc=1 \
433         -Ddisable_pnacl=1 \
434         -Dbuild_pnacl_newlib=0 \
435 %else
436         -Ddisable_pnacl_untar=1 \
437         -Ddisable_nacl=1 \
438 %endif
439         %{!?with_sse2:-Ddisable_sse2=1} \
440         %{?with_selinux:-Dselinux=1} \
441         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
442         -Dlinux_link_libpci=1 \
443         -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
444         -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
445         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
446         -Dclang=0 \
447         -Dhost_clang=0 \
448         -Dsysroot= \
449         -Dlinux_use_bundled_binutils=0 \
450         -Dlinux_use_bundled_gold=0 \
451         -Dlinux_use_gold_flags=0 \
452         -Dlogging_like_official_build=1 \
453         -Dgoogle_api_key=%{google_api_key} \
454         -Dgoogle_default_client_id=%{google_default_client_id} \
455         -Dgoogle_default_client_secret=%{google_default_client_secret} \
456         %{gyp_with cups} \
457         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
458         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
459         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
460         %{gyp_with pulseaudio} \
461         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
462         %{gyp_with system_flac} \
463         %{gyp_with system_harfbuzz} \
464         %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
465         %{gyp_with system_jsoncpp} \
466         %{gyp_with system_libexif} \
467         %{gyp_with system_libmtp} \
468         %{gyp_with system_libsrtp} \
469         %{gyp_with system_libusb} \
470         %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
471         %{gyp_with system_libwebp} \
472         %{gyp_with system_libxnvctrl} \
473         %{gyp_with system_mesa} \
474         %{gyp_with system_minizip} \
475         %{gyp_with system_opus} \
476         %{gyp_with system_protobuf} \
477         %{gyp_with system_re2} \
478         %{gyp_with system_snappy} \
479         %{gyp_with system_speex} \
480         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
481         %{gyp_with system_v8} \
482         %{gyp_with system_yasm} \
483         %{gyp_with system_zlib} \
484         -Duse_system_bzip2=1 \
485         -Duse_system_expat=1 \
486         -Duse_system_libevent=1 \
487         -Duse_system_libjpeg=1 \
488         -Duse_system_libpng=1 \
489         -Duse_system_libxml=1 \
490         -Duse_system_libxslt=1 \
491         -Duse_system_nspr=1 \
492         -Duse_system_xdg_utils=1 \
493 "
494
495 build/linux/unbundle/replace_gyp_files.py $flags
496
497 %if %{with ninja}
498 chkfile=%{builddir}/build.ninja
499 %else
500 chkfile=Makefile
501 %endif
502 test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
503 test -e $chkfile || \
504         CC="%{__cc}" \
505         CXX="%{__cxx}" \
506         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
507         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
508         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
509         CC_host="%{__cc}" \
510         CXX_host="%{__cxx}" \
511         LD_host="%{__cxx}" \
512 %{__python} build/gyp_chromium \
513         --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
514         --depth=. \
515         build/all.gyp \
516         $flags
517
518 %if %{with ninja}
519 ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
520 %else
521 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
522 %{__make} -r \
523         BUILDTYPE=%{buildtype} \
524         %{?with_verbose:V=1} \
525         CC.host="%{__cc}" \
526         CXX.host="%{__cxx}" \
527         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
528 %endif
529         chrome %{?with_sandboxing:chrome_sandbox} \
530         %{nil}
531
532 cd %{builddir}
533 MANWIDTH=80 man ./chrome.1 > man.out
534 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
535
536 %install
537 rm -rf $RPM_BUILD_ROOT
538 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
539         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
540         $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
541         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
542
543 %if %{without system_icu}
544 cp -p third_party/icu/source/data/in/icudtl.dat $RPM_BUILD_ROOT%{_libdir}/%{name}
545 %endif
546
547 cd %{builddir}
548 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
549 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
550 %{__sed} -i -e '
551         s,@libdir@,%{_libdir}/%{name},
552
553         /@OPTIONS@/ {
554                 r options.txt
555                 d
556         }
557 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
558 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
559 cp -p *.pak *.bin $RPM_BUILD_ROOT%{_libdir}/%{name}
560 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
561 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
562 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
563 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
564 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
565 %if %{without system_ffmpeg} && 0
566 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
567 %endif
568 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
569 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
570
571 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
572
573 %if %{with nacl}
574 # Install Native Client files on platforms that support it.
575 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
576 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
577 %ifarch %{x8664}
578 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
579 %endif
580 %ifarch %{ix86}
581 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
582 %endif
583 %endif
584
585 cd -
586
587 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
588         size=${icon##*/product_logo_}
589         size=${size%.png}
590
591         # this will skip non-numeric (22_mono_invert, 22_mono)
592         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
593         test -d "$dir" || continue
594
595         install -d $RPM_BUILD_ROOT$dir
596         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
597 done
598
599 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
600 # http://code.google.com/p/chromium/issues/detail?id=24507
601 gecko-mediaplayer*.so
602 EOF
603
604 # find locales
605 %find_lang %{name}.lang
606 # always package en-US
607 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
608
609 %clean
610 rm -rf $RPM_BUILD_ROOT
611
612 %pretrans
613 for d in locales resources; do
614         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
615                 install -d %{_datadir}/%{name}
616                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
617         fi
618 done
619 exit 0
620
621 %post
622 %update_icon_cache hicolor
623 %update_desktop_database
624 %update_browser_plugins
625
626 %postun
627 if [ "$1" = 0 ]; then
628         %update_icon_cache hicolor
629         %update_desktop_database
630         %update_browser_plugins
631 fi
632
633 %files
634 %defattr(644,root,root,755)
635 %doc AUTHORS LICENSE
636 %{_browserpluginsconfdir}/browsers.d/%{name}.*
637 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
638 %dir %{_sysconfdir}/%{name}
639 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
640 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
641 %dir %{_sysconfdir}/%{name}/native-messaging-hosts
642 %dir %{_sysconfdir}/%{name}/policies
643 %dir %{_sysconfdir}/%{name}/policies/managed
644 %attr(755,root,root) %{_bindir}/%{name}
645 %{_mandir}/man1/%{name}.1*
646 %{_desktopdir}/*.desktop
647 %{_iconsdir}/hicolor/*/apps/%{name}.png
648 %dir %{_libdir}/%{name}
649 %{_libdir}/%{name}/chrome*.pak
650 %{!?with_system_icu:%{_libdir}/%{name}/icudtl.dat}
651 %{_libdir}/%{name}/content_resources.pak
652 %{_libdir}/%{name}/keyboard_resources.pak
653 %{_libdir}/%{name}/resources.pak
654 %{_libdir}/%{name}/natives_blob.bin
655 %{_libdir}/%{name}/snapshot_blob.bin
656 %{_libdir}/%{name}/locales
657 %{_libdir}/%{name}/resources
658
659 %dir %{_datadir}/%{name}
660 %dir %{_datadir}/%{name}/locales
661 %{_datadir}/%{name}/locales/en-US.pak
662 %dir %{_datadir}/%{name}/resources
663 %{_datadir}/%{name}/resources/inspector
664
665 %dir %{_libdir}/%{name}/plugins
666 %attr(755,root,root) %{_libdir}/%{name}/%{name}
667 # These unique permissions are intentional and necessary for the sandboxing
668 %attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
669
670 # ffmpeg libs
671 %if %{without system_ffmpeg} && 0
672 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
673 %endif
674
675 %if %{with nacl}
676 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
677 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
678 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
679 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
680 %endif
681
682 %files l10n -f %{name}.lang
683 %defattr(644,root,root,755)
This page took 0.09346 seconds and 4 git commands to generate.