]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
workaround bad python path detection
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
9 %bcond_without  libjpegturbo    # use libjpeg-turbo features
10 %bcond_with     nacl                    # build Native Client support, disabled: http://crbug.com/269560
11 %bcond_without  pulseaudio              # with pulseaudio
12 %bcond_without  sandboxing              # with sandboxing
13 %bcond_with             selinux                 # with SELinux (need policy first)
14 %bcond_with             shared_libs             # with shared libs
15 %bcond_with             sse2                    # use SSE2 instructions
16 %bcond_without  system_flac             # system flac
17 %bcond_without  system_ffmpeg   # system ffmpeg instead of ffmpegsumo
18 %bcond_without  system_harfbuzz # system harfbuzz
19 %bcond_without  system_jsoncpp  # system jsoncpp
20 %bcond_without  system_libexif  # system libexif
21 %bcond_without  system_libmtp   # system libmtp
22 %bcond_with     system_libusb   # system libusb-1, disabled: http://crbug.com/266149
23 %bcond_with     system_libwebp  # system libwebp, disabled: http://crbug.com/288019
24 %bcond_without  system_libxnvctrl       # system libxnvctrl
25 %bcond_with     system_mesa             # system Mesa
26 %bcond_without  system_minizip  # system minizip
27 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
28 %bcond_without  system_protobuf # system protobuf
29 %bcond_without  system_re2              # system re2
30 %bcond_without  system_snappy   # system snappy
31 %bcond_without  system_speex    # system speex
32 %bcond_with     system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
33 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
34 %bcond_with             system_v8               # system v8
35 %bcond_without  system_libvpx   # system libvpx
36 %bcond_without  system_yasm             # system yasm
37 %bcond_without  system_zlib             # system zlib
38 %bcond_without  tcmalloc                # use tcmalloc
39 %bcond_without  verbose                 # verbose build (V=1)
40
41 %ifarch %{ix86}
42 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
43 %undefine       with_system_mesa
44 %endif
45
46 # TODO
47 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
48 # - use_system_skia
49 # - use_system_ssl (use_openssl: http://crbug.com/62803)
50 # - use_system_stlport (android specific)
51 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
52
53 # NOTES:
54 # - mute BEEP mixer if you do not want to hear horrible system bell when
55 #   pressing home/end in url bar or more ^F search results on page.
56 # - space considerations:
57 #   - unpacked sources: ~490MiB
58 #   - built code: ~1.4GiB (x86_64/i686)
59 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
60 # - to look for new tarball, use update-source.sh script
61
62 %define         branch          31.0.1650
63 %define         basever         57
64 %define         patchver        63
65 %define         gyp_rev 1014
66 Summary:        A WebKit powered web browser
67 Name:           chromium-browser
68 %if "%{?patchver}" != ""
69 Version:        %{branch}.%{patchver}
70 %else
71 Version:        %{branch}.%{basever}
72 %endif
73 Release:        2
74 License:        BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
75 Group:          X11/Applications/Networking
76 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
77 # Source0-md5:  8fcdee6bdefad83dedaecc7ca2a1cf5f
78 %if "%{?patchver}" != ""
79 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
80 # Patch0-md5:   f17f75a65414167cf822c6aaf409a537
81 %endif
82 Source1:        %{name}.default
83 Source2:        %{name}.sh
84 Source3:        %{name}.desktop
85 Source5:        find-lang.sh
86 Source6:        update-source.sh
87 Source7:        clean-source.sh
88 Source8:        get-source.sh
89 Source9:        master_preferences.json
90 Patch1:         plugin-searchdirs.patch
91 Patch4:         path-libpdf.patch
92 Patch7:         dlopen_sonamed_gl.patch
93 Patch8:         chromium_useragent.patch.in
94 Patch10:        system-libxnvctrl.patch
95 # https://bugs.gentoo.org/show_bug.cgi?id=393471
96 # libjpeg-turbo >= 1.1.90 supports that feature
97 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
98 Patch12:        system-ffmpeg.patch
99 Patch15:        nacl-build-irt.patch
100 Patch16:        nacl-linkingfix.patch
101 Patch18:        nacl-no-untar.patch
102 Patch24:        nacl-verbose.patch
103 Patch25:        gnome3-volume-control.patch
104 Patch26:        master-prefs-path.patch
105 Patch28:        system-mesa.patch
106 Patch29:        system-icu.patch
107 Patch30:        system-ply.patch
108 Patch31:        system-jinja.patch
109 Patch32:        remove_bundled_libraries-stale.patch
110 URL:            http://www.chromium.org/Home
111 %{?with_gconf:BuildRequires:    GConf2-devel}
112 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
113 BuildRequires:  Mesa-libGLES-devel >= 9.1
114 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
115 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
116 BuildRequires:  alsa-lib-devel
117 BuildRequires:  atk-devel
118 BuildRequires:  bison
119 BuildRequires:  bzip2-devel
120 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
121 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
122 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
123 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
124 %{?with_cups:BuildRequires:     cups-devel}
125 BuildRequires:  elfutils-devel
126 BuildRequires:  expat-devel
127 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
128 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
129 BuildRequires:  fontconfig-devel
130 BuildRequires:  glib2-devel
131 BuildRequires:  gperf
132 %{?with_gps:BuildRequires:      gpsd-devel}
133 BuildRequires:  gtest-devel
134 BuildRequires:  gtk+2-devel
135 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
136 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-icu-devel}
137 %{?with_kerberos:BuildRequires: heimdal-devel}
138 BuildRequires:  hicolor-icon-theme
139 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
140 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
141 BuildRequires:  libevent-devel
142 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
143 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
144 BuildRequires:  libicu-devel >= 4.6
145 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
146 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
147 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
148 BuildRequires:  libpng-devel
149 %{?with_selinux:BuildRequires:  libselinux-devel}
150 BuildRequires:  libstdc++-devel
151 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
152 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
153 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
154 BuildRequires:  libxml2-devel
155 BuildRequires:  libxslt-devel
156 BuildRequires:  man-db
157 %{?with_system_minizip:BuildRequires:   minizip-devel}
158 BuildRequires:  nspr-devel
159 BuildRequires:  nss-devel >= 1:3.12.3
160 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
161 BuildRequires:  pam-devel
162 BuildRequires:  pango-devel
163 BuildRequires:  pciutils-devel
164 BuildRequires:  perl-JSON
165 BuildRequires:  perl-modules
166 BuildRequires:  pkgconfig
167 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
168 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
169 BuildRequires:  python
170 #BuildRequires: python-gyp >= 1-%{gyp_rev}
171 BuildRequires:  python-jinja2 >= 2.7
172 BuildRequires:  python-modules
173 BuildRequires:  python-ply >= 3.4
174 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
175 BuildRequires:  rpm >= 4.4.9-56
176 BuildRequires:  rpmbuild(macros) >= 1.453
177 %{?with_system_snappy:BuildRequires:    snappy-devel}
178 BuildRequires:  speech-dispatcher-devel >= 0.8
179 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
180 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
181 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
182 BuildRequires:  tar >= 1:1.22
183 BuildRequires:  udev-devel
184 BuildRequires:  usbutils
185 BuildRequires:  util-linux
186 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
187 BuildRequires:  which
188 BuildRequires:  xorg-lib-libXScrnSaver-devel
189 BuildRequires:  xorg-lib-libXtst-devel
190 BuildRequires:  xz
191 %{?with_system_yasm:BuildRequires:      yasm}
192 %{?with_system_zlib:BuildRequires:      zlib-devel}
193 Requires:       browser-plugins >= 2.0
194 Requires:       desktop-file-utils
195 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
196 # crashes if no fontconfig font present
197 Requires:       fonts-Type1-urw
198 Requires:       hicolor-icon-theme
199 Requires:       libevent >= 2.0.21
200 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
201 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
202 Requires:       lsb-release
203 %{?with_system_re2:Requires:    re2 >= 20130115-2}
204 Requires:       shared-mime-info
205 %{?with_system_sqlite:Requires: sqlite3(icu)}
206 Requires:       xdg-utils >= 1.0.2-4
207 Requires:       xorg-lib-libX11 >= 1.4.99.1
208 Provides:       wwwbrowser
209 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
210 Obsoletes:      chromium-browser-inspector < 15.0.863.0
211 ExclusiveArch:  %{ix86} %{x8664} arm
212 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
213
214 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
215 # Note: these are for PLD Linux use ONLY.
216 # For your own distribution, please get your own set of keys.
217 %define         google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
218 %define         google_default_client_id 724288223830.apps.googleusercontent.com
219 %define         google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
220
221 %define         find_lang       sh find-lang.sh %{buildroot}
222
223 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
224 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
225
226 %if %{without debuginfo}
227 %define         _enable_debug_packages  0
228 %endif
229
230 %description
231 Chromium is an open-source browser project that aims to build a safer,
232 faster, and more stable way for all Internet users to experience the
233 web.
234
235 Chromium serves as a base for Google Chrome, which is Chromium
236 rebranded (name and logo) with very few additions such as usage
237 tracking and an auto-updater system.
238
239 %package l10n
240 Summary:        chromium-browser language packages
241 Group:          I18n
242 Requires:       %{name} = %{version}-%{release}
243 %if "%{_rpmversion}" >= "5"
244 BuildArch:      noarch
245 %endif
246
247 %description l10n
248 Chromium is an open-source browser project that aims to build a safer,
249 faster, and more stable way for all Internet users to experience the
250 web.
251
252 This package contains language packages for 50 languages:
253
254 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
255 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
256 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
257 zh-TW
258
259 %prep
260 %setup -qc
261 %if "%{?patchver}" != ""
262 cd %{name}-%{branch}.%{basever}
263 %patch0 -p1
264 cd ..
265 %endif
266 mv %{name}-%{branch}.%{basever}/* .
267
268 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
269 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
270 . ./chrome/VERSION
271 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
272 test "$chrome" = %{version}
273
274 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
275 test "$gyp_rev" = %{gyp_rev} || :
276
277 . ./v8.sh
278 v8=$MAJOR_VERSION.$MINOR_VERSION.$BUILD_NUMBER.$PATCH_LEVEL
279
280 # add chromium and pld to useragent
281 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
282 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
283         -e 's/@BUILD_DIST_NAME@/PLD/g' \
284         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
285         < %{PATCH8} | %{__patch} -p1
286
287 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
288 ln -s %{SOURCE7} .
289
290 %patch1 -p1
291 %patch4 -p3
292 %patch7 -p1
293 %patch10 -p1
294 %patch15 -p2
295 %{!?with_libjpegturbo:%patch11 -p0}
296 %patch12 -p1
297 %patch16 -p1
298 %patch28 -p1
299 %patch25 -p2
300 %{?with_nacl:%patch18 -p1}
301 %patch24 -p2
302 %patch26 -p2
303 %patch29 -p0
304 %patch30 -p1
305 %patch31 -p0
306 %patch32 -p1
307
308 sh -x clean-source.sh \
309         %{!?with_nacl:nacl=0} \
310         %{!?with_system_libvpx:libvpx=0} \
311         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
312         %{!?with_system_mesa:mesa=0} \
313         %{!?with_system_protobuf:protobuf=0} \
314         %{!?with_system_re2:re2=0} \
315         %{!?with_system_snappy:snappy=0} \
316         %{!?with_system_sqlite:sqlite=0} \
317         %{!?with_system_v8:v8=0} \
318         %{!?with_system_libwebp:libwebp=0} \
319         %{!?with_system_zlib:zlib=0} \
320         %{nil}
321
322 %build
323 %if %{with nacl}
324 rm -rf native_client/toolchain/linux_x86_newlib
325 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
326 # Make symlinks for NaCL
327 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
328
329 cd native_client/toolchain/linux_x86_newlib
330 ln -s x86_64-nacl/bin bin
331 cd x86_64-nacl/bin
332 __cc='%{__cc}'
333 if [ "${__cc#ccache}" != "$__cc" ]; then
334         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
335         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
336         %{__sed} -i -e '1i#!/bin/sh' gcc g++
337         chmod +x gcc g++
338 else
339         ln -s %{_bindir}/x86_64-nacl-gcc gcc
340         ln -s %{_bindir}/x86_64-nacl-g++ g++
341 fi
342 ln -s gcc x86_64-nacl-gcc
343 ln -s g++ x86_64-nacl-g++
344 ln -s %{_bindir}/x86_64-nacl-ar .
345 ln -s %{_bindir}/x86_64-nacl-ar ar
346 ln -s %{_bindir}/x86_64-nacl-as as
347 ln -s %{_bindir}/x86_64-nacl-ranlib .
348 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
349 ln -s %{_bindir}/x86_64-nacl-strip .
350 ln -s %{_bindir}/x86_64-nacl-strip strip
351 ln -s %{_bindir}/x86_64-nacl-objcopy .
352 ln -s %{_prefix}/x86_64-nacl/lib ../lib
353 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
354 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
355 cd ../../../../..
356 fi
357 %endif
358
359 flags="
360 %ifarch %{ix86}
361         -Dtarget_arch=ia32 \
362         -Dpython_arch=ia32 \
363 %endif
364 %ifarch %{x8664}
365         -Dtarget_arch=x64 \
366         -Dpython_arch=x64 \
367 %endif
368         -Dsystem_libdir=%{_lib} \
369         -Dpython_ver=2.7 \
370 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
371         -Dno_strict_aliasing=1 -Dgcc_version=44 \
372 %endif
373         %{!?debug:-Dwerror=} \
374         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
375         %{?with_shared_libs:-Dlibrary=shared_library} \
376         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
377         -Dinclude_tests=0 \
378 %if %{with nacl}
379         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
380         -Ddisable_glibc_untar=1 \
381         -Ddisable_newlib_untar=1 \
382         -Ddisable_glibc=1 \
383         -Ddisable_pnacl=1 \
384         -Dbuild_pnacl_newlib=0 \
385 %else
386         -Ddisable_pnacl_untar=1 \
387         -Ddisable_nacl=1 \
388 %endif
389         %{!?with_sse2:-Ddisable_sse2=1} \
390         %{?with_selinux:-Dselinux=1} \
391         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
392         -Dlinux_link_libpci=1 \
393         -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
394         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
395         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
396         -Dlinux_use_gold_binary=0 \
397         -Dlinux_use_gold_flags=0 \
398         -Dlogging_like_official_build=1 \
399         -Dgoogle_api_key=%{google_api_key} \
400         -Dgoogle_default_client_id=%{google_default_client_id} \
401         -Dgoogle_default_client_secret=%{google_default_client_secret} \
402         %{gyp_with cups} \
403         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
404         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
405         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
406         %{gyp_with pulseaudio} \
407         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
408         %{gyp_with system_flac} \
409         %{gyp_with system_harfbuzz} \
410         %{gyp_with system_jsoncpp} \
411         %{gyp_with system_libexif} \
412         %{gyp_with system_libmtp} \
413         %{gyp_with system_libsrtp} \
414         %{gyp_with system_libusb} \
415         %{gyp_with system_libvpx} -Dmedia_use_libvpx=0 \
416         %{gyp_with system_libwebp} \
417         %{gyp_with system_libxnvctrl} \
418         %{gyp_with system_mesa} \
419         %{gyp_with system_minizip} \
420         %{gyp_with system_opus} \
421         %{gyp_with system_protobuf} \
422         %{gyp_with system_re2} \
423         %{gyp_with system_snappy} \
424         %{gyp_with system_speex} \
425         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
426         %{gyp_with system_v8} \
427         %{gyp_with system_yasm} \
428         %{gyp_with system_zlib} \
429         -Duse_system_bzip2=1 \
430         -Duse_system_expat=1 \
431         -Duse_system_icu=1 \
432         -Duse_system_libevent=1 \
433         -Duse_system_libjpeg=1 \
434         -Duse_system_libpng=1 \
435         -Duse_system_libxml=1 \
436         -Duse_system_libxslt=1 \
437         -Duse_system_nspr=1 \
438         -Duse_system_xdg_utils=1 \
439 "
440
441 build/linux/unbundle/replace_gyp_files.py $flags
442
443 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
444 test -e Makefile || \
445         CC="%{__cc}" \
446         CXX="%{__cxx}" \
447         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
448         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
449         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
450         CC_host="%{__cc}" \
451         CXX_host="%{__cxx}" \
452         LD_host="%{__cxx}" \
453 %{__python} build/gyp_chromium \
454         --format=make \
455         --depth=. \
456         build/all.gyp \
457         $flags
458
459 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
460 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
461         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
462         %{?with_verbose:V=1} \
463         CC.host="%{__cc}" \
464         CXX.host="%{__cxx}" \
465         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
466
467 cd out/%{!?debug:Release}%{?debug:Debug}
468 MANWIDTH=80 man ./chrome.1 > man.out
469 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
470
471 %install
472 rm -rf $RPM_BUILD_ROOT
473 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
474         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
475         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
476
477 cd out/%{!?debug:Release}%{?debug:Debug}
478 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
479 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
480 %{__sed} -i -e '
481         s,@libdir@,%{_libdir}/%{name},
482
483         /@OPTIONS@/ {
484                 r options.txt
485                 d
486         }
487 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
488 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
489 cp -a *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
490 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
491 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
492 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
493 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
494 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
495 %if %{without system_ffmpeg}
496 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
497 %endif
498 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
499 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
500
501 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
502
503 %if %{with nacl}
504 # Install Native Client files on platforms that support it.
505 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
506 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
507 %ifarch %{x8664}
508 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
509 %endif
510 %ifarch %{ix86}
511 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
512 %endif
513 %endif
514
515 cd -
516
517 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
518         size=${icon##*/product_logo_}
519         size=${size%.png}
520
521         # this will skip non-numeric (22_mono_invert, 22_mono)
522         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
523         test -d "$dir" || continue
524
525         install -d $RPM_BUILD_ROOT$dir
526         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
527 done
528
529 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
530 # http://code.google.com/p/chromium/issues/detail?id=24507
531 gecko-mediaplayer*.so
532 EOF
533
534 # find locales
535 %find_lang %{name}.lang
536 # always package en-US
537 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
538
539 %clean
540 rm -rf $RPM_BUILD_ROOT
541
542 %pretrans
543 for d in locales resources; do
544         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
545                 install -d %{_datadir}/%{name}
546                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
547         fi
548 done
549 exit 0
550
551 %post
552 %update_icon_cache hicolor
553 %update_desktop_database
554 %update_browser_plugins
555
556 %postun
557 if [ "$1" = 0 ]; then
558         %update_icon_cache hicolor
559         %update_browser_plugins
560 fi
561
562 %files
563 %defattr(644,root,root,755)
564 %doc AUTHORS LICENSE
565 %{_browserpluginsconfdir}/browsers.d/%{name}.*
566 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
567 %dir %{_sysconfdir}/%{name}
568 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
569 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
570 %attr(755,root,root) %{_bindir}/%{name}
571 %{_mandir}/man1/%{name}.1*
572 %{_desktopdir}/*.desktop
573 %{_iconsdir}/hicolor/*/apps/%{name}.png
574 %dir %{_libdir}/%{name}
575 %{_libdir}/%{name}/chrome*.pak
576 %{_libdir}/%{name}/content_resources.pak
577 %{_libdir}/%{name}/resources.pak
578 %{_libdir}/%{name}/locales
579 %{_libdir}/%{name}/resources
580
581 %dir %{_datadir}/%{name}
582 %dir %{_datadir}/%{name}/locales
583 %{_datadir}/%{name}/locales/en-US.pak
584 %dir %{_datadir}/%{name}/resources
585 %{_datadir}/%{name}/resources/inspector
586
587 %dir %{_libdir}/%{name}/plugins
588 %attr(755,root,root) %{_libdir}/%{name}/%{name}
589 # These unique permissions are intentional and necessary for the sandboxing
590 %attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
591
592 # ffmpeg libs
593 %if %{without system_ffmpeg}
594 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
595 %endif
596
597 %if %{with nacl}
598 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
599 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
600 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
601 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
602 %endif
603
604 %files l10n -f %{name}.lang
605 %defattr(644,root,root,755)
This page took 0.070201 seconds and 4 git commands to generate.