]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
R: lsb-release
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_without  libjpegturbo    # use libjpeg-turbo features
9 %bcond_without  nacl                    # build Native Client support
10 %bcond_without  pulseaudio              # with pulseaudio
11 %bcond_without  sandboxing              # with sandboxing
12 %bcond_with             selinux                 # with SELinux (need policy first)
13 %bcond_with             shared_libs             # with shared libs
14 %bcond_with             sse2                    # use SSE2 instructions
15 %bcond_without  system_flac             # system flac
16 %bcond_with             system_ffmpeg   # system ffmpeg instead of ffmpegsumo
17 %bcond_with             system_harfbuzz # system harfbuzz
18 %bcond_without  system_jsoncpp  # system jsoncpp
19 %bcond_without  system_libexif  # system libexif
20 %bcond_without  system_libmtp   # system libmtp
21 %bcond_without  system_libusb   # system libusb-1
22 %bcond_without  system_libwebp  # system libwebp
23 %bcond_without  system_libxnvctrl       # system libxnvctrl
24 %bcond_without  system_minizip  # system minizip
25 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
26 %bcond_with             system_protobuf # system protobuf
27 %bcond_without  system_speex    # system speex
28 %bcond_with             system_sqlite   # system sqlite
29 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
30 %bcond_with             system_v8               # system v8
31 %bcond_without  system_libvpx   # system libvpx
32 %bcond_without  system_yasm             # system yasm
33 %bcond_without  system_zlib             # system zlib
34 %bcond_without  tcmalloc                # use tcmalloc
35 %bcond_without  verbose                 # verbose build (V=1)
36
37 %if %{with nacl}
38 # temporary hack as seems this does not work: http://codereview.chromium.org/8890043
39 # nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
40 #14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
41 #14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
42 #14:51:06 @baggins> as-needed will take care of unneeded lib
43 #14:52:03 @baggins> -lssp comes with gcc
44 %define         _ssp_cflags     %{nil}
45 %endif
46
47 # TODO
48 # - check system sqlite linking problems
49 # - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
50 # - use_system_ssl (use_openssl: http://crbug.com/62803)
51 # - use_system_hunspell
52 # - use_system_stlport
53 # - other defaults: src/build/common.gypi
54
55 # NOTES:
56 # - mute BEEP mixer if you do not want to hear horrible system bell when
57 #   pressing home/end in url bar or more ^F search results on page.
58 # - space considerations:
59 #   - unpacked sources: ~574MiB
60 #   - built code: ~1.4GiB (x86_64/i686)
61 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
62 # - to look for new tarball, use update-source.sh script
63
64 # NOTE TO USERS:
65 # To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
66 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
67 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
68
69 %define         branch          24.0.1312
70 %define         basever         52
71 %define         patchver        69
72 %define         gyp_rev 1014
73 Summary:        A WebKit powered web browser
74 Name:           chromium-browser
75 %if "%{?patchver}" != ""
76 Version:        %{branch}.%{patchver}
77 %else
78 Version:        %{branch}.%{basever}
79 %endif
80 Release:        1
81 License:        BSD, LGPL v2+ (ffmpeg)
82 Group:          X11/Applications/Networking
83 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
84 # Source0-md5:  bcc3976e61b9ce715ba9c85d46df72f1
85 %if "%{?patchver}" != ""
86 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
87 # Patch0-md5:   130262d245d6833200cef43e61b641c2
88 %endif
89 Source1:        %{name}.default
90 Source2:        %{name}.sh
91 Source3:        %{name}.desktop
92 Source5:        find-lang.sh
93 Source6:        update-source.sh
94 Source7:        clean-source.sh
95 Source8:        get-source.sh
96 Source9:        master_preferences.json
97 Patch1:         plugin-searchdirs.patch
98 #Patch2:                system-nspr.patch
99 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
100 Patch4:         path-libpdf.patch
101 Patch6:         get-webkit_revision.patch
102 Patch7:         dlopen_sonamed_gl.patch
103 Patch8:         chromium_useragent.patch.in
104 Patch9:         chromium-ppapi.patch
105 Patch10:        system-libxnvctrl.patch
106 # https://bugs.gentoo.org/show_bug.cgi?id=393471
107 # libjpeg-turbo >= 1.1.90 supports that feature
108 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
109 Patch15:        nacl-build-irt.patch
110 Patch16:        nacl-linkingfix.patch
111 Patch18:        nacl-no-untar.patch
112 Patch19:        system-jsoncpp.patch
113 Patch22:        pulse_fix-157876.patch
114 Patch23:        no-pnacl.patch
115 Patch24:        nacl-verbose.patch
116 Patch25:        gnome3-volume-control.patch
117 Patch26:        master-prefs-path.patch
118 Patch27:        tcmalloc-glibc2.16.patch
119 URL:            http://www.chromium.org/Home
120 %{?with_gconf:BuildRequires:    GConf2-devel}
121 BuildRequires:  OpenGL-GLU-devel
122 BuildRequires:  alsa-lib-devel
123 BuildRequires:  atk-devel
124 BuildRequires:  bison
125 BuildRequires:  bzip2-devel
126 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
127 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
128 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
129 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
130 %{?with_cups:BuildRequires:     cups-devel}
131 BuildRequires:  dbus-glib-devel
132 BuildRequires:  elfutils-devel
133 BuildRequires:  expat-devel
134 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
135 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
136 BuildRequires:  flex
137 BuildRequires:  fontconfig-devel
138 BuildRequires:  glib2-devel
139 BuildRequires:  gperf
140 BuildRequires:  gtest-devel
141 BuildRequires:  gtk+2-devel
142 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
143 %{?with_kerberos:BuildRequires: heimdal-devel}
144 BuildRequires:  hicolor-icon-theme
145 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
146 %{?with_system_libxvnctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
147 BuildRequires:  libevent-devel
148 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
149 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
150 BuildRequires:  libicu-devel >= 4.6
151 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
152 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
153 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
154 BuildRequires:  libpng-devel
155 %{?with_selinux:BuildRequires:  libselinux-devel}
156 BuildRequires:  libstdc++-devel
157 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
158 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
159 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
160 BuildRequires:  libxml2-devel
161 BuildRequires:  libxslt-devel
162 BuildRequires:  lzma
163 %{?with_system_minizip:BuildRequires:   minizip-devel}
164 BuildRequires:  nspr-devel
165 BuildRequires:  nss-devel >= 1:3.12.3
166 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
167 BuildRequires:  pam-devel
168 BuildRequires:  pango-devel
169 BuildRequires:  perl-modules
170 BuildRequires:  pkgconfig
171 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
172 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
173 BuildRequires:  python
174 #BuildRequires: python-gyp >= 1-%{gyp_rev}
175 BuildRequires:  python-modules
176 BuildRequires:  python-ply
177 BuildRequires:  rpm >= 4.4.9-56
178 BuildRequires:  rpmbuild(macros) >= 1.453
179 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
180 BuildRequires:  sqlite3-devel >= 3.6.1
181 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
182 BuildRequires:  subversion
183 BuildRequires:  tar >= 1:1.22
184 BuildRequires:  udev-devel
185 BuildRequires:  util-linux
186 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
187 BuildRequires:  which
188 BuildRequires:  xorg-lib-libXScrnSaver-devel
189 BuildRequires:  xorg-lib-libXt-devel
190 BuildRequires:  xorg-lib-libXtst-devel
191 BuildRequires:  xz
192 %{?with_system_yasm:BuildRequires:      yasm}
193 %{?with_system_zlib:BuildRequires:      zlib-devel}
194 Requires:       browser-plugins >= 2.0
195 Requires:       desktop-file-utils
196 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
197 # requires any TTF font actually
198 Requires:       fonts-TTF-bitstream-vera
199 Requires:       hicolor-icon-theme
200 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
201 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
202 Requires:       lsb-release
203 Requires:       xdg-utils >= 1.0.2-4
204 Provides:       wwwbrowser
205 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
206 Obsoletes:      chromium-browser-inspector < 15.0.863.0
207 ExclusiveArch:  %{ix86} %{x8664} arm
208 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
209
210 %define         find_lang       sh find-lang.sh %{buildroot}
211
212 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
213 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
214
215 %if %{without debuginfo}
216 %define         _enable_debug_packages  0
217 %endif
218
219 %description
220 Chromium is an open-source browser project that aims to build a safer,
221 faster, and more stable way for all Internet users to experience the
222 web.
223
224 Chromium serves as a base for Google Chrome, which is Chromium
225 rebranded (name and logo) with very few additions such as usage
226 tracking and an auto-updater system.
227
228 %package l10n
229 Summary:        chromium-browser language packages
230 Group:          I18n
231 Requires:       %{name} = %{version}-%{release}
232
233 %description l10n
234 Chromium is an open-source browser project that aims to build a safer,
235 faster, and more stable way for all Internet users to experience the
236 web.
237
238 This package contains language packages for 50 languages:
239
240 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
241 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
242 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
243 zh-TW
244
245 %prep
246 %setup -qc
247 %if "%{?patchver}" != ""
248 cd %{name}-%{branch}.%{basever}
249 %patch0 -p1
250 cd ..
251 %endif
252 mv %{name}-%{branch}.%{basever}/src .
253
254 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
255 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
256 . ./src/chrome/VERSION
257 ver=$MAJOR.$MINOR.$BUILD.$PATCH
258 test "$ver" = %{version}
259
260 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
261 test "$gyp_rev" = %{gyp_rev} || :
262
263 v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
264
265 # add chromium and pld to useragent
266 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
267 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
268     -e 's/@BUILD_DIST_NAME@/PLD/g' \
269     -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
270     < %{PATCH8} | %{__patch} -p1
271
272 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
273 ln -s %{SOURCE7} src
274
275 %patch1 -p1
276 %patch3 -p1
277 %patch4 -p1
278 %patch6 -p1
279 %patch7 -p1
280 %patch15 -p1
281 cd src
282 %patch9 -p0
283 #%patch2 -p1
284 %{!?with_libjpegturbo:%patch11 -p0}
285 %patch16 -p1
286 %patch19 -p1
287 %patch22 -p1
288 %patch25 -p1
289 %patch27 -p1
290 cd ..
291 %patch18 -p1
292 %patch23 -p1
293 %patch24 -p1
294 %patch26 -p1
295
296 cd src
297
298 # Missing gyp files in tarball.
299 # https://code.google.com/p/chromium/issues/detail?id=144823
300 if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
301         echo "tarball fixed, please remove workaround"
302         exit 1
303 fi
304
305 install -d chrome/test/data/nacl
306 cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
307 {
308  'targets': [
309    {
310      'target_name': 'nacl_tests',
311      'type': 'none',
312    },
313  ],
314 }
315 EOF
316
317 sh -x clean-source.sh \
318         %{!?with_nacl:nacl=0} \
319         %{!?with_system_protobuf:protobuf=0} \
320         %{!?with_system_v8:v8=0} \
321         %{!?with_system_zlib:zlib=0} \
322         %{nil}
323
324 %build
325 cd src
326
327 %if %{with nacl}
328 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
329 # Make symlinks for NaCL
330 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,lib,lib32,nacl}
331
332 cd native_client/toolchain/linux_x86_newlib/x86_64-nacl/bin
333 __cc='%{__cc}'
334 if [ "${__cc#ccache}" != "$__cc" ]; then
335         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
336         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
337         %{__sed} -i -e '1i#!/bin/sh' gcc g++
338         chmod +x gcc g++
339 else
340         ln -s %{_bindir}/x86_64-nacl-gcc gcc
341         ln -s %{_bindir}/x86_64-nacl-g++ g++
342 fi
343 ln -s %{_bindir}/x86_64-nacl-ar ar
344 ln -s %{_bindir}/x86_64-nacl-as as
345 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
346 ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
347 ln -s %{_bindir}/x86_64-nacl-strip strip
348 ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib
349 ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32
350 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
351 cd ../../../../..
352 fi
353 %endif
354
355 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
356 test -e Makefile || %{__python} build/gyp_chromium \
357         --format=make \
358         -Goutput_dir=../out \
359         build/all.gyp \
360 %ifarch %{ix86}
361         -Dtarget_arch=ia32 \
362 %endif
363 %ifarch %{x8664}
364         -Dtarget_arch=x64 \
365 %endif
366 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
367         -Dno_strict_aliasing=1 -Dgcc_version=44 \
368 %endif
369 %if %{with sandboxing}
370         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
371         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
372 %endif
373         %{!?debug:-Dwerror=} \
374         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
375         %{?with_shared_libs:-Dlibrary=shared_library} \
376         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
377         -Dinclude_tests=0 \
378 %if %{with nacl}
379         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
380         -Ddisable_glibc_untar=1 \
381         -Ddisable_newlib_untar=1 \
382         -Ddisable_glibc=1 \
383         -Ddisable_pnacl=1 \
384         -Dbuild_pnacl_newlib=0 \
385 %else
386         -Ddisable_pnacl_untar=1 \
387         -Ddisable_nacl=1 \
388 %endif
389         %{!?with_sse2:-Ddisable_sse2=1} \
390         %{?with_selinux:-Dselinux=1} \
391         %{gyp_with cups} \
392         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
393         %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
394         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
395         %{gyp_with pulseaudio} \
396         %{gyp_with system_ffmpeg} \
397         %{gyp_with system_flac} \
398         %{gyp_with system_harfbuzz} \
399         %{gyp_with system_libexif} \
400         %{gyp_with system_libmtp} \
401         %{gyp_with system_libsrtp} \
402         %{gyp_with system_libusb} \
403         %{gyp_with system_libvpx} \
404         %{gyp_with system_libwebp} \
405         %{gyp_with system_libxnvctrl} \
406         %{gyp_with system_minizip} \
407         %{gyp_with system_opus} \
408         %{gyp_with system_protobuf} \
409         %{gyp_with system_speex} \
410         %{gyp_with system_sqlite} \
411         %{gyp_with system_v8} \
412         %{gyp_with system_yasm} \
413         %{gyp_with system_zlib} \
414         -Duse_system_bzip2=1 \
415         -Duse_system_expat=1 \
416         -Duse_system_icu=1 \
417         -Duse_system_libevent=1 \
418         -Duse_system_libjpeg=1 \
419         -Duse_system_libpng=1 \
420         -Duse_system_libxml=1 \
421         -Duse_system_libxslt=1 \
422         -Duse_system_xdg_utils=1 \
423         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
424         -Dlinux_use_gold_binary=0 \
425         -Dlinux_use_gold_flags=0
426
427 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
428         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
429         %{?with_verbose:V=1} \
430         CC="%{__cc}" \
431         CXX="%{__cxx}" \
432         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
433         CC.host="%{__cc}" \
434         CXX.host="%{__cxx}" \
435         LDFLAGS.host="%{rpmldflags}" \
436         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
437         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
438
439 %install
440 rm -rf $RPM_BUILD_ROOT
441 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
442         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
443
444 cd out/%{!?debug:Release}%{?debug:Debug}
445 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
446 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
447 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
448 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
449 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
450 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
451 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
452 %if %{without system_ffmpeg}
453 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
454 %endif
455 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
456 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
457
458 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
459
460 %if %{with nacl}
461 # Install Native Client files on platforms that support it.
462 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
463 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
464 %ifarch %{x8664}
465 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
466 %endif
467 %ifarch %{ix86}
468 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
469 %endif
470 %endif
471
472 cd -
473
474 for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
475         size=${icon##*/product_logo_}
476         size=${size%.png}
477
478         # this will skip non-numeric (22_mono_invert, 22_mono)
479         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
480         test -d "$dir" || continue
481
482         install -d $RPM_BUILD_ROOT$dir
483         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
484 done
485
486 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
487 # http://code.google.com/p/chromium/issues/detail?id=24507
488 gecko-mediaplayer*.so
489 EOF
490
491 # find locales
492 %find_lang %{name}.lang
493 # always package en-US
494 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
495
496 %clean
497 rm -rf $RPM_BUILD_ROOT
498
499 %post
500 %update_icon_cache hicolor
501 %update_desktop_database
502 %update_browser_plugins
503
504 %postun
505 if [ "$1" = 0 ]; then
506         %update_icon_cache hicolor
507         %update_browser_plugins
508 fi
509
510 %files
511 %defattr(644,root,root,755)
512 %doc src/{AUTHORS,LICENSE}
513 %{_browserpluginsconfdir}/browsers.d/%{name}.*
514 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
515 %dir %{_sysconfdir}/%{name}
516 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
517 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
518 %attr(755,root,root) %{_bindir}/%{name}
519 %{_mandir}/man1/%{name}.1*
520 %{_desktopdir}/*.desktop
521 %{_iconsdir}/hicolor/*/apps/%{name}.png
522 %dir %{_libdir}/%{name}
523 %{_libdir}/%{name}/chrome*.pak
524 %{_libdir}/%{name}/content_resources.pak
525 %{_libdir}/%{name}/resources.pak
526 %dir %{_libdir}/%{name}/locales
527 %{_libdir}/%{name}/locales/en-US.pak
528 %dir %{_libdir}/%{name}/resources
529 %{_libdir}/%{name}/resources/inspector
530 %dir %{_libdir}/%{name}/themes
531 %dir %{_libdir}/%{name}/extensions
532 %dir %{_libdir}/%{name}/plugins
533 %attr(755,root,root) %{_libdir}/%{name}/%{name}
534 # These unique permissions are intentional and necessary for the sandboxing
535 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
536
537 # ffmpeg libs
538 %if %{without system_ffmpeg}
539 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
540 %endif
541
542 %if %{with nacl}
543 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
544 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
545 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
546 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
547 %endif
548
549 %files l10n -f %{name}.lang
550 %defattr(644,root,root,755)
This page took 0.092355 seconds and 4 git commands to generate.