]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
up to 27.0.1453.15 beta
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
9 %bcond_without  libjpegturbo    # use libjpeg-turbo features
10 %bcond_without  nacl                    # build Native Client support
11 %bcond_without  pulseaudio              # with pulseaudio
12 %bcond_without  sandboxing              # with sandboxing
13 %bcond_with             selinux                 # with SELinux (need policy first)
14 %bcond_with             shared_libs             # with shared libs
15 %bcond_with             sse2                    # use SSE2 instructions
16 %bcond_without  system_flac             # system flac
17 %bcond_without  system_ffmpeg   # system ffmpeg instead of ffmpegsumo
18 %bcond_without  system_harfbuzz # system harfbuzz
19 %bcond_without  system_jsoncpp  # system jsoncpp
20 %bcond_without  system_libexif  # system libexif
21 %bcond_without  system_libmtp   # system libmtp
22 %bcond_without  system_libusb   # system libusb-1
23 %bcond_without  system_libwebp  # system libwebp
24 %bcond_without  system_libxnvctrl       # system libxnvctrl
25 %bcond_without  system_mesa             # system Mesa
26 %bcond_without  system_minizip  # system minizip
27 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
28 %bcond_without  system_protobuf # system protobuf
29 %bcond_without  system_re2              # system re2
30 %bcond_without  system_speex    # system speex
31 %bcond_without  system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
32 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
33 %bcond_with             system_v8               # system v8
34 %bcond_without  system_libvpx   # system libvpx
35 %bcond_without  system_yasm             # system yasm
36 %bcond_without  system_zlib             # system zlib
37 %bcond_without  tcmalloc                # use tcmalloc
38 %bcond_without  verbose                 # verbose build (V=1)
39
40 %ifarch %{ix86}
41 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
42 %undefine       with_system_mesa
43 %endif
44
45 # TODO
46 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
47 # - use_system_skia
48 # - use_system_ssl (use_openssl: http://crbug.com/62803)
49 # - use_system_stlport (android specific)
50 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
51
52 # NOTES:
53 # - mute BEEP mixer if you do not want to hear horrible system bell when
54 #   pressing home/end in url bar or more ^F search results on page.
55 # - space considerations:
56 #   - unpacked sources: ~490MiB
57 #   - built code: ~1.4GiB (x86_64/i686)
58 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
59 # - to look for new tarball, use update-source.sh script
60
61 %define         branch          27.0.1453
62 %define         basever         15
63 #define         patchver        70
64 %define         gyp_rev 1014
65 Summary:        A WebKit powered web browser
66 Name:           chromium-browser
67 %if "%{?patchver}" != ""
68 Version:        %{branch}.%{patchver}
69 %else
70 Version:        %{branch}.%{basever}
71 %endif
72 Release:        0.6
73 License:        BSD, LGPL v2+ (ffmpeg)
74 Group:          X11/Applications/Networking
75 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{branch}.%{basever}.tar.gz
76 # Source0-md5:  eafd6a919faadc8a7446cd673f460c4c
77 %if "%{?patchver}" != ""
78 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
79 # Patch0-md5:   7e2f26d76ca6241961276a328a9230cf
80 %endif
81 Source1:        %{name}.default
82 Source2:        %{name}.sh
83 Source3:        %{name}.desktop
84 Source5:        find-lang.sh
85 Source6:        update-source.sh
86 Source7:        clean-source.sh
87 Source8:        get-source.sh
88 Source9:        master_preferences.json
89 Patch1:         plugin-searchdirs.patch
90 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
91 Patch4:         path-libpdf.patch
92 Patch6:         get-webkit_revision.patch
93 Patch7:         dlopen_sonamed_gl.patch
94 Patch8:         chromium_useragent.patch.in
95 Patch10:        system-libxnvctrl.patch
96 # https://bugs.gentoo.org/show_bug.cgi?id=393471
97 # libjpeg-turbo >= 1.1.90 supports that feature
98 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
99 Patch12:        system-ffmpeg.patch
100 Patch15:        nacl-build-irt.patch
101 Patch16:        nacl-linkingfix.patch
102 Patch18:        nacl-no-untar.patch
103 Patch24:        nacl-verbose.patch
104 Patch25:        gnome3-volume-control.patch
105 Patch26:        master-prefs-path.patch
106 Patch28:        system-mesa.patch
107 Patch29:        speechd-0.8.patch
108 Patch30:        no-pnacl.patch
109 URL:            http://www.chromium.org/Home
110 %{?with_gconf:BuildRequires:    GConf2-devel}
111 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
112 %{?with_system_mesa:BuildRequires:      Mesa-libGLES-devel >= 9.1}
113 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
114 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
115 BuildRequires:  alsa-lib-devel
116 BuildRequires:  atk-devel
117 BuildRequires:  bison
118 BuildRequires:  bzip2-devel
119 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
120 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
121 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
122 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
123 %{?with_cups:BuildRequires:     cups-devel}
124 BuildRequires:  elfutils-devel
125 BuildRequires:  expat-devel
126 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
127 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
128 BuildRequires:  fontconfig-devel
129 BuildRequires:  glib2-devel
130 BuildRequires:  gperf
131 %{?with_gps:BuildRequires:      gpsd-devel}
132 BuildRequires:  gtest-devel
133 BuildRequires:  gtk+2-devel
134 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
135 %{?with_kerberos:BuildRequires: heimdal-devel}
136 BuildRequires:  hicolor-icon-theme
137 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
138 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
139 BuildRequires:  libevent-devel
140 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
141 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
142 BuildRequires:  libicu-devel >= 4.6
143 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
144 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
145 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
146 BuildRequires:  libpng-devel
147 %{?with_selinux:BuildRequires:  libselinux-devel}
148 BuildRequires:  libstdc++-devel
149 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
150 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
151 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
152 BuildRequires:  libxml2-devel
153 BuildRequires:  libxslt-devel
154 BuildRequires:  man-db
155 %{?with_system_minizip:BuildRequires:   minizip-devel}
156 BuildRequires:  nspr-devel
157 BuildRequires:  nss-devel >= 1:3.12.3
158 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
159 BuildRequires:  pam-devel
160 BuildRequires:  pango-devel
161 BuildRequires:  pciutils-devel
162 BuildRequires:  perl-modules
163 BuildRequires:  pkgconfig
164 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
165 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
166 BuildRequires:  python
167 #BuildRequires: python-gyp >= 1-%{gyp_rev}
168 BuildRequires:  python-modules
169 BuildRequires:  python-ply
170 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
171 BuildRequires:  rpm >= 4.4.9-56
172 BuildRequires:  rpmbuild(macros) >= 1.453
173 BuildRequires:  speech-dispatcher-devel >= 0.8
174 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
175 BuildRequires:  sqlite3-devel >= 3.6.1
176 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
177 BuildRequires:  subversion
178 BuildRequires:  tar >= 1:1.22
179 BuildRequires:  udev-devel
180 BuildRequires:  usbutils
181 BuildRequires:  util-linux
182 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
183 BuildRequires:  which
184 BuildRequires:  xorg-lib-libXScrnSaver-devel
185 BuildRequires:  xz
186 %{?with_system_yasm:BuildRequires:      yasm}
187 %{?with_system_zlib:BuildRequires:      zlib-devel}
188 Requires:       browser-plugins >= 2.0
189 Requires:       desktop-file-utils
190 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
191 # crashes if no fontconfig font present
192 Requires:       fonts-Type1-urw
193 Requires:       hicolor-icon-theme
194 Requires:       libevent >= 2.0.21
195 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
196 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
197 Requires:       lsb-release
198 %{?with_system_re2:Requires:    re2 >= 20130115-2}
199 Requires:       shared-mime-info
200 Requires:       xdg-utils >= 1.0.2-4
201 Requires:       xorg-lib-libX11 >= 1.4.99.1
202 Provides:       wwwbrowser
203 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
204 Obsoletes:      chromium-browser-inspector < 15.0.863.0
205 ExclusiveArch:  %{ix86} %{x8664} arm
206 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
207
208 %define         find_lang       sh find-lang.sh %{buildroot}
209
210 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
211 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
212
213 %if %{without debuginfo}
214 %define         _enable_debug_packages  0
215 %endif
216
217 %description
218 Chromium is an open-source browser project that aims to build a safer,
219 faster, and more stable way for all Internet users to experience the
220 web.
221
222 Chromium serves as a base for Google Chrome, which is Chromium
223 rebranded (name and logo) with very few additions such as usage
224 tracking and an auto-updater system.
225
226 %package l10n
227 Summary:        chromium-browser language packages
228 Group:          I18n
229 Requires:       %{name} = %{version}-%{release}
230
231 %description l10n
232 Chromium is an open-source browser project that aims to build a safer,
233 faster, and more stable way for all Internet users to experience the
234 web.
235
236 This package contains language packages for 50 languages:
237
238 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
239 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
240 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
241 zh-TW
242
243 %prep
244 %setup -qc
245 %if "%{?patchver}" != ""
246 cd %{name}-%{branch}.%{basever}
247 %patch0 -p1
248 cd ..
249 %endif
250 mv %{name}-%{branch}.%{basever}/* .
251
252 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
253 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
254 . ./chrome/VERSION
255 ver=$MAJOR.$MINOR.$BUILD.$PATCH
256 test "$ver" = %{version}
257
258 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
259 test "$gyp_rev" = %{gyp_rev} || :
260
261 v8_ver=$(awk 'NR=1 {print $NF; exit}' v8/ChangeLog || :)
262
263 # add chromium and pld to useragent
264 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
265 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
266         -e 's/@BUILD_DIST_NAME@/PLD/g' \
267         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
268         < %{PATCH8} | %{__patch} -p2
269
270 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
271 ln -s %{SOURCE7} .
272
273 %patch1 -p2
274 %patch3 -p2
275 %patch4 -p3
276 %patch6 -p2
277 %patch7 -p2
278 %patch10 -p2
279 %patch15 -p2
280 %{!?with_libjpegturbo:%patch11 -p0}
281 %patch12 -p1
282 %patch16 -p1
283 %patch28 -p1
284 %patch25 -p2
285 %patch18 -p2
286 %patch24 -p2
287 %patch26 -p2
288 %patch29 -p2
289 %patch30 -p0
290
291 sh -x clean-source.sh \
292         %{!?with_nacl:nacl=0} \
293         %{!?with_system_libvpx:libvpx=0} \
294         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
295         %{!?with_system_mesa:mesa=0} \
296         %{!?with_system_protobuf:protobuf=0} \
297         %{!?with_system_re2:re2=0} \
298         %{!?with_system_v8:v8=0} \
299         %{!?with_system_zlib:zlib=0} \
300         %{nil}
301
302 %build
303 %if %{with nacl}
304 rm -rf native_client/toolchain/linux_x86_newlib
305 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
306 # Make symlinks for NaCL
307 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
308
309 cd native_client/toolchain/linux_x86_newlib
310 ln -s x86_64-nacl/bin bin
311 cd x86_64-nacl/bin
312 __cc='%{__cc}'
313 if [ "${__cc#ccache}" != "$__cc" ]; then
314         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
315         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
316         %{__sed} -i -e '1i#!/bin/sh' gcc g++
317         chmod +x gcc g++
318 else
319         ln -s %{_bindir}/x86_64-nacl-gcc gcc
320         ln -s %{_bindir}/x86_64-nacl-g++ g++
321 fi
322 ln -s gcc x86_64-nacl-gcc
323 ln -s g++ x86_64-nacl-g++
324 ln -s %{_bindir}/x86_64-nacl-ar .
325 ln -s %{_bindir}/x86_64-nacl-ar ar
326 ln -s %{_bindir}/x86_64-nacl-as as
327 ln -s %{_bindir}/x86_64-nacl-ranlib .
328 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
329 ln -s %{_bindir}/x86_64-nacl-strip .
330 ln -s %{_bindir}/x86_64-nacl-strip strip
331 ln -s %{_prefix}/x86_64-nacl/lib ../lib
332 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
333 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
334 cd ../../../../..
335 fi
336 %endif
337
338 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
339 test -e Makefile || \
340         CC="%{__cc}" \
341         CXX="%{__cxx}" \
342         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
343         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
344         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
345 %{__python} build/gyp_chromium \
346         --format=make \
347         --depth=. \
348         build/all.gyp \
349 %ifarch %{ix86}
350         -Dtarget_arch=ia32 \
351 %endif
352 %ifarch %{x8664}
353         -Dtarget_arch=x64 \
354 %endif
355 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
356         -Dno_strict_aliasing=1 -Dgcc_version=44 \
357 %endif
358 %if %{with sandboxing}
359         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
360         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
361 %endif
362         %{!?debug:-Dwerror=} \
363         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
364         %{?with_shared_libs:-Dlibrary=shared_library} \
365         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
366         -Dinclude_tests=0 \
367 %if %{with nacl}
368         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
369         -Ddisable_glibc_untar=1 \
370         -Ddisable_newlib_untar=1 \
371         -Ddisable_glibc=1 \
372         -Ddisable_pnacl=1 \
373         -Dbuild_pnacl_newlib=0 \
374 %else
375         -Ddisable_pnacl_untar=1 \
376         -Ddisable_nacl=1 \
377 %endif
378         %{!?with_sse2:-Ddisable_sse2=1} \
379         %{?with_selinux:-Dselinux=1} \
380         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
381         -Dlinux_link_libpci=1 \
382         -Dlinux_link_libspeechd=1 \
383         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
384         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
385         -Dlinux_use_gold_binary=0 \
386         -Dlinux_use_gold_flags=0 \
387         %{gyp_with cups} \
388         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
389         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
390         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
391         %{gyp_with pulseaudio} \
392         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
393         %{gyp_with system_flac} \
394         %{gyp_with system_harfbuzz} \
395         %{gyp_with system_jsoncpp} \
396         %{gyp_with system_libexif} \
397         %{gyp_with system_libmtp} \
398         %{gyp_with system_libsrtp} \
399         %{gyp_with system_libusb} \
400         %{gyp_with system_libvpx} -Dmedia_use_libvpx=0 \
401         %{gyp_with system_libwebp} \
402         %{gyp_with system_libxnvctrl} \
403         %{gyp_with system_mesa} \
404         %{gyp_with system_minizip} \
405         %{gyp_with system_opus} \
406         %{gyp_with system_protobuf} \
407         %{gyp_with system_re2} \
408         %{gyp_with system_speex} \
409         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
410         %{gyp_with system_v8} \
411         %{gyp_with system_yasm} \
412         %{gyp_with system_zlib} \
413         -Duse_system_bzip2=1 \
414         -Duse_system_expat=1 \
415         -Duse_system_icu=1 \
416         -Duse_system_libevent=1 \
417         -Duse_system_libjpeg=1 \
418         -Duse_system_libpng=1 \
419         -Duse_system_libxml=1 \
420         -Duse_system_libxslt=1 \
421         -Duse_system_nspr=1 \
422         -Duse_system_xdg_utils=1 \
423
424 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
425 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
426         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
427         %{?with_verbose:V=1} \
428         CC.host="%{__cc}" \
429         CXX.host="%{__cxx}" \
430         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
431
432 cd out/%{!?debug:Release}%{?debug:Debug}
433 MANWIDTH=80 man ./chrome.1 > man.out
434 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
435
436 %install
437 rm -rf $RPM_BUILD_ROOT
438 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
439         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
440
441 cd out/%{!?debug:Release}%{?debug:Debug}
442 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
443 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
444 %{__sed} -i -e '
445         s,@libdir@,%{_libdir}/%{name},
446
447         /@OPTIONS@/ {
448                 r options.txt
449                 d
450         }
451 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
452 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
453 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
454 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
455 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
456 %if %{without system_ffmpeg}
457 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
458 %endif
459 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
460 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
461
462 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
463
464 %if %{with nacl}
465 # Install Native Client files on platforms that support it.
466 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
467 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
468 %ifarch %{x8664}
469 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
470 %endif
471 %ifarch %{ix86}
472 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
473 %endif
474 %endif
475
476 cd -
477
478 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
479         size=${icon##*/product_logo_}
480         size=${size%.png}
481
482         # this will skip non-numeric (22_mono_invert, 22_mono)
483         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
484         test -d "$dir" || continue
485
486         install -d $RPM_BUILD_ROOT$dir
487         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
488 done
489
490 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
491 # http://code.google.com/p/chromium/issues/detail?id=24507
492 gecko-mediaplayer*.so
493 EOF
494
495 # find locales
496 %find_lang %{name}.lang
497 # always package en-US
498 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
499
500 %clean
501 rm -rf $RPM_BUILD_ROOT
502
503 %post
504 %update_icon_cache hicolor
505 %update_desktop_database
506 %update_browser_plugins
507
508 %postun
509 if [ "$1" = 0 ]; then
510         %update_icon_cache hicolor
511         %update_browser_plugins
512 fi
513
514 %files
515 %defattr(644,root,root,755)
516 %doc AUTHORS LICENSE
517 %{_browserpluginsconfdir}/browsers.d/%{name}.*
518 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
519 %dir %{_sysconfdir}/%{name}
520 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
521 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
522 %attr(755,root,root) %{_bindir}/%{name}
523 %{_mandir}/man1/%{name}.1*
524 %{_desktopdir}/*.desktop
525 %{_iconsdir}/hicolor/*/apps/%{name}.png
526 %dir %{_libdir}/%{name}
527 %{_libdir}/%{name}/chrome*.pak
528 %{_libdir}/%{name}/content_resources.pak
529 %{_libdir}/%{name}/resources.pak
530 %dir %{_libdir}/%{name}/locales
531 %{_libdir}/%{name}/locales/en-US.pak
532 %dir %{_libdir}/%{name}/resources
533 %{_libdir}/%{name}/resources/inspector
534 %dir %{_libdir}/%{name}/themes
535 %dir %{_libdir}/%{name}/extensions
536 %dir %{_libdir}/%{name}/plugins
537 %attr(755,root,root) %{_libdir}/%{name}/%{name}
538 # These unique permissions are intentional and necessary for the sandboxing
539 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
540
541 # ffmpeg libs
542 %if %{without system_ffmpeg}
543 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
544 %endif
545
546 %if %{with nacl}
547 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
548 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
549 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
550 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
551 %endif
552
553 %files l10n -f %{name}.lang
554 %defattr(644,root,root,755)
This page took 0.083378 seconds and 4 git commands to generate.