]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
- pl
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_with     dev                     # with dev optimizations (skip clean source)
6 %bcond_without  gconf                   # with GConf
7 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
8 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
9 %bcond_with     gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
10 %bcond_without  libjpegturbo            # use libjpeg-turbo features
11 %bcond_with     nacl                    # build Native Client support, disabled: http://crbug.com/269560
12 %bcond_without  ninja                   # use Ninja instead of make to build
13 %bcond_without  pulseaudio              # with pulseaudio
14 %bcond_without  sandboxing              # with sandboxing
15 %bcond_with     selinux                 # with SELinux (need policy first)
16 %bcond_with     shared_libs             # with shared libs
17 %bcond_with     sse2                    # use SSE2 instructions
18 %bcond_without  system_flac             # system flac
19 %bcond_without  system_ffmpeg           # system ffmpeg
20 %bcond_without  system_harfbuzz         # system harfbuzz
21 # http://bugs.gentoo.org/576370
22 %bcond_with     system_icu              # system icu
23 %bcond_without  system_jsoncpp          # system jsoncpp
24 %bcond_without  system_libexif          # system libexif
25 %bcond_without  system_libmtp           # system libmtp
26 %bcond_with     system_libusb           # system libusb-1, disabled: http://crbug.com/266149
27 %bcond_without  system_libwebp          # system libwebp
28 %bcond_without  system_libxnvctrl       # system libxnvctrl
29 %bcond_with     system_mesa             # system Mesa
30 %bcond_without  system_minizip          # system minizip
31 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
32 # protobuf broken: https://bugs.gentoo.org/show_bug.cgi?id=525560
33 %bcond_with     system_protobuf         # system protobuf
34 %bcond_with     system_re2              # system re2
35 %bcond_without  system_snappy           # system snappy
36 %bcond_without  system_speex            # system speex
37 %bcond_with     system_sqlite           # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
38 %bcond_without  system_libsrtp          # system srtp (can be used if using bundled libjingle), http://bugs.gentoo.org/459932
39 %bcond_with     system_v8               # system v8
40 %bcond_with     system_libvpx           # system libvpx, http://crbug.com/494939
41 %bcond_without  system_yasm             # system yasm
42 %bcond_without  system_zlib             # system zlib
43 %bcond_with     tcmalloc                # use tcmalloc
44 %bcond_without  verbose                 # verbose build (V=1)
45
46 %ifarch %{ix86}
47 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
48 %undefine       with_system_mesa
49
50 # unable build with debuginfo on 32bit build systems
51 # /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
52 %undefine       with_debuginfo
53 %endif
54
55 %ifarch %{x8664}
56 # x86_64 systems fail with debugedit crashing
57 # /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
58 %undefine       with_debuginfo
59 %endif
60
61 # TODO
62 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
63 # - use_system_skia
64 # - use_system_ssl (use_openssl: http://crbug.com/62803)
65 # - use_system_stlport (android specific)
66
67 # NOTES:
68 # - mute BEEP mixer if you do not want to hear horrible system bell when
69 #   pressing home/end in url bar or more ^F search results on page.
70 # - space considerations:
71 #   - unpacked sources: ~490MiB
72 #   - built code: ~1.1GiB (x86_64/i686)
73 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
74 # - to look for new tarball, use update-source.sh script
75
76 %define         branch          50.0.2661
77 %define         basever         75
78 %define         patchver        102
79 %define         gyp_rev 1014
80 Summary:        A WebKit powered web browser
81 Summary(pl.UTF-8):      PrzeglÄ…darka WWW oparta na bibliotece WebKit
82 Name:           chromium-browser
83 %if "%{?patchver}" != ""
84 Version:        %{branch}.%{patchver}
85 %else
86 Version:        %{branch}.%{basever}
87 %endif
88 Release:        3
89 License:        BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
90 Group:          X11/Applications/Networking
91 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
92 # Source0-md5:  f6ae41191ec560a0d1cd238ac2a618cf
93 #Source0:       http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{branch}.%{basever}.tar.gz
94 %if "%{?patchver}" != ""
95 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
96 # Patch0-md5:   a8bd6c3c0f6befac88c81632a9360761
97 %endif
98 Source1:        %{name}.default
99 Source2:        %{name}.sh
100 Source3:        %{name}.desktop
101 Source5:        find-lang.sh
102 Source6:        update-source.sh
103 Source7:        clean-source.sh
104 Source8:        get-source.sh
105 Source9:        master_preferences.json
106 # https://github.com/Kelvin-Ng/Kelvin-Gentoo-Overlay/tree/master/www-client/chromium/files
107 Patch2:         enable-video-decode-accel.patch
108 Patch7:         dlopen_sonamed_gl.patch
109 Patch8:         chromium_useragent.patch.in
110 # https://bugs.gentoo.org/show_bug.cgi?id=393471
111 # libjpeg-turbo >= 1.1.90 supports that feature
112 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
113 Patch15:        nacl-build-irt.patch
114 Patch16:        nacl-linkingfix.patch
115 Patch18:        nacl-no-untar.patch
116 Patch24:        nacl-verbose.patch
117 Patch25:        gnome3-volume-control.patch
118 Patch26:        master-prefs-path.patch
119 Patch28:        system-mesa.patch
120 Patch31:        system-jinja.patch
121 Patch32:        remove_bundled_libraries-stale.patch
122 Patch35:        etc-dir.patch
123 Patch36:        angle.patch
124 Patch38:        vaapi_include.patch
125 Patch39:        libsecret.patch
126 Patch40:        ffmpeg-generate-errors.patch
127 Patch41:        ffmpeg-generate.patch
128 Patch42:        system-ffmpeg.patch
129 Patch43:        cups22.patch
130 URL:            http://www.chromium.org/Home
131 %{?with_gconf:BuildRequires:    GConf2-devel}
132 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
133 BuildRequires:  Mesa-libGLES-devel >= 9.1
134 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
135 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
136 BuildRequires:  alsa-lib-devel
137 BuildRequires:  atk-devel
138 BuildRequires:  bison
139 BuildRequires:  bzip2-devel
140 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
141 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
142 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
143 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
144 %{?with_cups:BuildRequires:     cups-devel}
145 BuildRequires:  elfutils-devel
146 BuildRequires:  expat-devel
147 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 2.7.2}
148 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
149 BuildRequires:  fontconfig-devel
150 BuildRequires:  glib2-devel
151 BuildRequires:  gperf
152 %{?with_gps:BuildRequires:      gpsd-devel}
153 BuildRequires:  gtest-devel
154 BuildRequires:  gtk+2-devel
155 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
156 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-icu-devel}
157 %{?with_kerberos:BuildRequires: heimdal-devel}
158 BuildRequires:  hicolor-icon-theme
159 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
160 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
161 BuildRequires:  libevent-devel
162 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
163 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
164 %{?with_system_icu:BuildRequires:       libicu-devel >= 4.6}
165 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
166 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
167 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
168 BuildRequires:  libpng-devel
169 BuildRequires:  libsecret-devel
170 %{?with_selinux:BuildRequires:  libselinux-devel}
171 BuildRequires:  libstdc++-devel
172 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
173 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 1.5.0}
174 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.4.0}
175 BuildRequires:  libxml2-devel
176 BuildRequires:  libxslt-devel
177 BuildRequires:  man-db
178 %{?with_system_minizip:BuildRequires:   minizip-devel}
179 %{?with_ninja:BuildRequires:    ninja >= 1.3.0}
180 BuildRequires:  nspr-devel
181 BuildRequires:  nss-devel >= 1:3.12.3
182 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
183 BuildRequires:  pam-devel
184 BuildRequires:  pango-devel
185 BuildRequires:  pciutils-devel
186 BuildRequires:  perl-JSON
187 BuildRequires:  perl-modules
188 BuildRequires:  pkgconfig
189 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
190 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
191 BuildRequires:  python
192 BuildRequires:  python-BeautifulSoup
193 #BuildRequires: python-gyp >= 1-%{gyp_rev}
194 BuildRequires:  python-html5lib
195 BuildRequires:  python-jinja2 >= 2.7
196 BuildRequires:  python-modules
197 BuildRequires:  python-ply >= 3.4
198 %{?with_system_re2:BuildRequires:       re2-devel >= 20151101}
199 BuildRequires:  rpm >= 4.4.9-56
200 BuildRequires:  rpm-build >= 4.6
201 BuildRequires:  rpmbuild(macros) >= 1.453
202 %{?with_system_snappy:BuildRequires:    snappy-devel}
203 BuildRequires:  speech-dispatcher-devel >= 0.8
204 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
205 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
206 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
207 BuildRequires:  tar >= 1:1.22
208 BuildRequires:  udev-devel
209 BuildRequires:  usbutils
210 BuildRequires:  util-linux
211 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
212 BuildRequires:  which
213 BuildRequires:  xorg-lib-libXScrnSaver-devel
214 BuildRequires:  xorg-lib-libXtst-devel
215 BuildRequires:  xz
216 %{?with_system_yasm:BuildRequires:      yasm}
217 %{?with_system_zlib:BuildRequires:      zlib-devel}
218 Requires:       browser-plugins >= 2.0
219 Requires:       desktop-file-utils
220 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
221 # crashes if no fontconfig font present
222 Requires:       fonts-Type1-urw
223 Requires:       hicolor-icon-theme
224 Requires:       libevent >= 2.0.21
225 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
226 %{?with_system_libvpx:Requires: libvpx >= 1.4.0}
227 Requires:       lsb-release
228 %{?with_system_re2:Requires:    re2 >= 20151101}
229 %{?with_system_protobuf:Requires:       protobuf-libs >= 2.5.0-2}
230 Requires:       shared-mime-info
231 %{?with_system_sqlite:Requires: sqlite3(icu)}
232 Requires:       uname(release) >= 3.17
233 Requires:       xdg-utils >= 1.0.2-4
234 Requires:       xorg-lib-libX11 >= 1.4.99.1
235 Provides:       wwwbrowser
236 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
237 Obsoletes:      chromium-browser-inspector < 15.0.863.0
238 ExclusiveArch:  %{ix86} %{x8664} arm
239 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
240
241 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
242 # Note: these are for PLD Linux use ONLY.
243 # For your own distribution, please get your own set of keys.
244 %define         google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
245 %define         google_default_client_id 724288223830.apps.googleusercontent.com
246 %define         google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
247
248 %define         find_lang       sh find-lang.sh %{buildroot}
249
250 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
251 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
252
253 %ifarch %{ix86}
254 %define         target_arch ia32
255 %endif
256 %ifarch %{x8664}
257 %define         target_arch x64
258 %endif
259
260 %define         buildtype       %{?debug:Debug}%{!?debug:Release}
261 %define         builddir        out/%{buildtype}
262
263 %if %{without debuginfo}
264 %define         _enable_debug_packages  0
265 %endif
266
267 %description
268 Chromium is an open-source browser project that aims to build a safer,
269 faster, and more stable way for all Internet users to experience the
270 web.
271
272 Chromium serves as a base for Google Chrome, which is Chromium
273 rebranded (name and logo) with very few additions such as usage
274 tracking and an auto-updater system.
275
276 %description -l pl.UTF-8
277 Chromium to majÄ…cy otwarte ÅºródÅ‚a projekt przeglÄ…darki WWW, którego
278 celem jest stworzenie bezpieczniejszego, szybszego, batdziej
279 stabilnego sposobu korzystania przez użytkowników z Internetu.
280
281 Chromium sÅ‚uży jako podstawa dla przeglÄ…darki Google Chrome, która
282 jest zrebrandowanym (z wÅ‚asnÄ… nazwÄ… i logo) Chromium z kilkoma
283 dodatkami, takimi jak Å›ledzenie sposobu korzystania czy system
284 automatycznych uaktualnieÅ„.
285
286 %package l10n
287 Summary:        chromium-browser language packages
288 Summary(pl.UTF-8):      Pakiety jÄ™zykowe do przeglÄ…darki Chromium
289 Group:          I18n
290 Requires:       %{name} = %{version}-%{release}
291 BuildArch:      noarch
292
293 %description l10n
294 Chromium is an open-source browser project that aims to build a safer,
295 faster, and more stable way for all Internet users to experience the
296 web.
297
298 This package contains language packages for 50 languages:
299
300 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
301 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
302 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
303 zh-TW
304
305 %description l10n -l pl.UTF-8
306 Chromium to majÄ…cy otwarte ÅºródÅ‚a projekt przeglÄ…darki WWW, którego
307 celem jest stworzenie bezpieczniejszego, szybszego, batdziej
308 stabilnego sposobu korzystania przez użytkowników z Internetu.
309
310 Ten pakiet zawiera zasoby jÄ™zykowa dla ponad 50 jÄ™zyków:
311
312 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
313 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
314 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
315 zh-TW
316
317 %prep
318 %setup -qc
319 %if "%{?patchver}" != ""
320 cd chromium*-%{branch}.%{basever}
321 %patch0 -p1
322 cd ..
323 %endif
324 mv chromium*-%{branch}.%{basever}/* .
325
326 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
327 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
328 . ./chrome/VERSION
329 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
330 test "$chrome" = %{version}
331
332 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
333 test "$gyp_rev" = %{gyp_rev} || :
334
335 # add chromium and pld to useragent
336 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
337 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
338         -e 's/@BUILD_DIST_NAME@/PLD/g' \
339         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
340         < %{PATCH8} | %{__patch} -p1
341
342 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
343 ln -s %{SOURCE7} .
344
345 #%patch2 -p1 CHECK
346 %patch7 -p1
347 %patch15 -p2
348 %{!?with_libjpegturbo:%patch11 -p0}
349 %patch16 -p1
350 %patch28 -p1
351 %patch25 -p1
352 %{?with_nacl:%patch18 -p1}
353 %patch24 -p1
354 %patch26 -p2
355 %patch31 -p0
356 %patch32 -p1
357 %patch35 -p1
358 %patch36 -p1
359 #%patch38 -p1 CHECK
360 %patch39 -p1
361 #%patch40 -p1 UPDATE
362 #%patch41 -p1 CHECK
363 %patch42 -p1
364 %patch43 -p1
365
366 # https://groups.google.com/a/chromium.org/forum/#!topic/chromium-packagers/9JX1N2nf4PU
367 install -d chrome/test/data/webui
368 touch chrome/test/data/webui/i18n_process_css_test.html
369
370 %{?with_dev:exit 0}
371
372 sh -x clean-source.sh \
373         %{!?with_nacl:nacl=0} \
374         %{!?with_system_libvpx:libvpx=0} \
375         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
376         %{!?with_system_mesa:mesa=0} \
377         %{!?with_system_protobuf:protobuf=0} \
378         %{!?with_system_re2:re2=0} \
379         %{!?with_system_snappy:snappy=0} \
380         %{!?with_system_sqlite:sqlite=0} \
381         %{!?with_system_v8:v8=0} \
382         %{!?with_system_libwebp:libwebp=0} \
383         %{!?with_system_zlib:zlib=0} \
384         %{!?with_system_ffmpeg:ffmpeg=0} \
385         %{nil}
386
387 %build
388 %if %{with nacl}
389 rm -rf native_client/toolchain/linux_x86_newlib
390 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
391 # Make symlinks for NaCL
392 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
393
394 cd native_client/toolchain/linux_x86_newlib
395 ln -s x86_64-nacl/bin bin
396 cd x86_64-nacl/bin
397 __cc='%{__cc}'
398 if [ "${__cc#ccache}" != "$__cc" ]; then
399         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
400         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
401         %{__sed} -i -e '1i#!/bin/sh' gcc g++
402         chmod +x gcc g++
403 else
404         ln -s %{_bindir}/x86_64-nacl-gcc gcc
405         ln -s %{_bindir}/x86_64-nacl-g++ g++
406 fi
407 ln -s gcc x86_64-nacl-gcc
408 ln -s g++ x86_64-nacl-g++
409 ln -s %{_bindir}/x86_64-nacl-ar .
410 ln -s %{_bindir}/x86_64-nacl-ar ar
411 ln -s %{_bindir}/x86_64-nacl-as as
412 ln -s %{_bindir}/x86_64-nacl-ranlib .
413 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
414 ln -s %{_bindir}/x86_64-nacl-strip .
415 ln -s %{_bindir}/x86_64-nacl-strip strip
416 ln -s %{_bindir}/x86_64-nacl-objcopy .
417 ln -s %{_prefix}/x86_64-nacl/lib ../lib
418 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
419 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
420 cd ../../../../..
421 fi
422 %endif
423
424 %if %{without system_ffmpeg}
425 if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
426         # Re-configure bundled ffmpeg
427         cd third_party/ffmpeg
428         chromium/scripts/build_ffmpeg.py linux %{target_arch} \
429                 --branding Chromium
430         chromium/scripts/copy_config.sh
431         chromium/scripts/generate_gyp.py
432         cd -
433 fi
434 %endif
435
436 third_party/libaddressinput/chromium/tools/update-strings.py
437
438 flags="
439         -Dtarget_arch=%{target_arch} \
440         -Dpython_arch=%{target_arch} \
441         -Dproprietary_codecs=1 \
442         -Dffmpeg_branding=Chromium \
443         -Dsystem_libdir=%{_lib} \
444         -Dpython_ver=%{py_ver} \
445 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
446         -Dno_strict_aliasing=1 -Dgcc_version=44 \
447 %endif
448         %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
449         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
450         %{?with_shared_libs:-Dlibrary=shared_library} \
451         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} \
452         -Dinclude_tests__=0 \
453 %if %{with nacl}
454         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
455         -Ddisable_glibc_untar=1 \
456         -Ddisable_newlib_untar=1 \
457         -Ddisable_glibc=1 \
458         -Ddisable_pnacl=1 \
459         -Dbuild_pnacl_newlib=0 \
460 %else
461         -Ddisable_pnacl_untar=1 \
462         -Ddisable_nacl=1 \
463 %endif
464         %{!?with_sse2:-Ddisable_sse2=1} \
465         %{?with_selinux:-Dselinux=1} \
466         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
467         -Dlinux_link_libpci=1 \
468         -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
469         -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
470         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
471         -Dclang=0 \
472         -Dhost_clang=0 \
473         -Dsysroot= \
474         -Dlinux_use_bundled_binutils=0 \
475         -Dlinux_use_bundled_gold=0 \
476         -Dlinux_use_gold_flags=0 \
477         -Dlogging_like_official_build=1 \
478         -Dgoogle_api_key=%{google_api_key} \
479         -Dgoogle_default_client_id=%{google_default_client_id} \
480         -Dgoogle_default_client_secret=%{google_default_client_secret} \
481         %{gyp_with cups} \
482         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
483         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
484         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
485         %{gyp_with pulseaudio} \
486         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
487         %{gyp_with system_flac} \
488         %{gyp_with system_harfbuzz} \
489         %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
490         %{gyp_with system_jsoncpp} \
491         %{gyp_with system_libexif} \
492         %{gyp_with system_libmtp} \
493         %{gyp_with system_libsrtp} \
494         %{gyp_with system_libusb} \
495         %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
496         %{gyp_with system_libwebp} \
497         %{gyp_with system_libxnvctrl} \
498         %{gyp_with system_mesa} \
499         %{gyp_with system_minizip} \
500         %{gyp_with system_opus} \
501         %{gyp_with system_protobuf} \
502         %{gyp_with system_re2} \
503         %{gyp_with system_snappy} \
504         %{gyp_with system_speex} \
505         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
506         %{gyp_with system_v8} \
507         %{gyp_with system_yasm} \
508         %{gyp_with system_zlib} \
509         -Duse_system_bzip2=1 \
510         -Duse_system_expat=1 \
511         -Duse_system_libevent=1 \
512         -Duse_system_libjpeg=1 \
513         -Duse_system_libpng=1 \
514         -Duse_system_libxml=1 \
515         -Duse_system_libxslt=1 \
516         -Duse_system_nspr=1 \
517         -Duse_system_xdg_utils=1 \
518 "
519
520 build/linux/unbundle/replace_gyp_files.py $flags
521
522 %if %{with ninja}
523 chkfile=%{builddir}/build.ninja
524 %else
525 chkfile=Makefile
526 %endif
527 test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
528 test -e $chkfile || \
529         CC="%{__cc}" \
530         CXX="%{__cxx}" \
531         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
532         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
533         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
534         CC_host="%{__cc}" \
535         CXX_host="%{__cxx}" \
536         LD_host="%{__cxx}" \
537 %{__python} build/gyp_chromium \
538         --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
539         --depth=. \
540         build/all.gyp \
541         $flags
542
543 %if %{with ninja}
544 ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
545 %else
546 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
547 %{__make} -r \
548         BUILDTYPE=%{buildtype} \
549         %{?with_verbose:V=1} \
550         CC.host="%{__cc}" \
551         CXX.host="%{__cxx}" \
552         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
553 %endif
554         chrome %{?with_sandboxing:chrome_sandbox} \
555         %{nil}
556
557 cd %{builddir}
558 MANWIDTH=80 man ./chrome.1 > man.out
559 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
560
561 %install
562 rm -rf $RPM_BUILD_ROOT
563 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
564         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
565         $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
566         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
567
568 %if %{without system_icu}
569 cp -p third_party/icu/source/data/in/icudtl.dat $RPM_BUILD_ROOT%{_libdir}/%{name}
570 %endif
571
572 cd %{builddir}
573 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
574 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
575 %{__sed} -i -e '
576         s,@libdir@,%{_libdir}/%{name},
577
578         /@OPTIONS@/ {
579                 r options.txt
580                 d
581         }
582 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
583 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
584 cp -p *.pak *.bin $RPM_BUILD_ROOT%{_libdir}/%{name}
585 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
586 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
587 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
588 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
589 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
590 %if %{without system_ffmpeg} && 0
591 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
592 %endif
593 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
594 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
595
596 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
597
598 %if %{with nacl}
599 # Install Native Client files on platforms that support it.
600 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
601 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
602 %ifarch %{x8664}
603 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
604 %endif
605 %ifarch %{ix86}
606 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
607 %endif
608 %endif
609
610 cd -
611
612 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
613         size=${icon##*/product_logo_}
614         size=${size%.png}
615
616         # this will skip non-numeric (22_mono_invert, 22_mono)
617         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
618         test -d "$dir" || continue
619
620         install -d $RPM_BUILD_ROOT$dir
621         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
622 done
623
624 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
625 # http://code.google.com/p/chromium/issues/detail?id=24507
626 gecko-mediaplayer*.so
627 EOF
628
629 # find locales
630 %find_lang %{name}.lang
631 # always package en-US
632 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
633
634 %clean
635 rm -rf $RPM_BUILD_ROOT
636
637 %pretrans
638 for d in locales resources; do
639         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
640                 install -d %{_datadir}/%{name}
641                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
642         fi
643 done
644 exit 0
645
646 %post
647 %update_icon_cache hicolor
648 %update_desktop_database
649 %update_browser_plugins
650
651 %postun
652 if [ "$1" = 0 ]; then
653         %update_icon_cache hicolor
654         %update_desktop_database
655         %update_browser_plugins
656 fi
657
658 %files
659 %defattr(644,root,root,755)
660 %doc AUTHORS LICENSE
661 %{_browserpluginsconfdir}/browsers.d/%{name}.*
662 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
663 %dir %{_sysconfdir}/%{name}
664 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
665 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
666 %dir %{_sysconfdir}/%{name}/native-messaging-hosts
667 %dir %{_sysconfdir}/%{name}/policies
668 %dir %{_sysconfdir}/%{name}/policies/managed
669 %attr(755,root,root) %{_bindir}/%{name}
670 %{_mandir}/man1/%{name}.1*
671 %{_desktopdir}/*.desktop
672 %{_iconsdir}/hicolor/*/apps/%{name}.png
673 %dir %{_libdir}/%{name}
674 %{_libdir}/%{name}/chrome*.pak
675 %{!?with_system_icu:%{_libdir}/%{name}/icudtl.dat}
676 %{_libdir}/%{name}/content_resources.pak
677 %{_libdir}/%{name}/keyboard_resources.pak
678 %{_libdir}/%{name}/resources.pak
679 %{_libdir}/%{name}/natives_blob.bin
680 %{_libdir}/%{name}/snapshot_blob.bin
681 %{_libdir}/%{name}/locales
682 %{_libdir}/%{name}/resources
683
684 %dir %{_datadir}/%{name}
685 %dir %{_datadir}/%{name}/locales
686 %{_datadir}/%{name}/locales/en-US.pak
687 %dir %{_datadir}/%{name}/resources
688 %{_datadir}/%{name}/resources/inspector
689
690 %dir %{_libdir}/%{name}/plugins
691 %attr(755,root,root) %{_libdir}/%{name}/%{name}
692 # These unique permissions are intentional and necessary for the sandboxing
693 %attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
694
695 # ffmpeg libs
696 %if %{without system_ffmpeg} && 0
697 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
698 %endif
699
700 %if %{with nacl}
701 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
702 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
703 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
704 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
705 %endif
706
707 %files l10n -f %{name}.lang
708 %defattr(644,root,root,755)
This page took 0.092177 seconds and 4 git commands to generate.