]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
merge update to stable 26.0.1410.43
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
9 %bcond_without  libjpegturbo    # use libjpeg-turbo features
10 %bcond_without  nacl                    # build Native Client support
11 %bcond_without  pulseaudio              # with pulseaudio
12 %bcond_without  sandboxing              # with sandboxing
13 %bcond_with             selinux                 # with SELinux (need policy first)
14 %bcond_with             shared_libs             # with shared libs
15 %bcond_with             sse2                    # use SSE2 instructions
16 %bcond_without  system_flac             # system flac
17 %bcond_without  system_ffmpeg   # system ffmpeg instead of ffmpegsumo
18 %bcond_without  system_harfbuzz # system harfbuzz
19 %bcond_without  system_jsoncpp  # system jsoncpp
20 %bcond_without  system_libexif  # system libexif
21 %bcond_without  system_libmtp   # system libmtp
22 %bcond_without  system_libusb   # system libusb-1
23 %bcond_without  system_libwebp  # system libwebp
24 %bcond_without  system_libxnvctrl       # system libxnvctrl
25 %bcond_without  system_mesa             # system Mesa
26 %bcond_without  system_minizip  # system minizip
27 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
28 %bcond_without  system_protobuf # system protobuf
29 %bcond_without  system_re2              # system re2
30 %bcond_without  system_speex    # system speex
31 %bcond_with             system_sqlite   # system sqlite
32 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
33 %bcond_with             system_v8               # system v8
34 %bcond_without  system_libvpx   # system libvpx
35 %bcond_without  system_yasm             # system yasm
36 %bcond_without  system_zlib             # system zlib
37 %bcond_without  tcmalloc                # use tcmalloc
38 %bcond_without  verbose                 # verbose build (V=1)
39
40 %ifarch %{ix86}
41 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
42 %undefine       with_system_mesa
43 %endif
44
45 # TODO
46 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
47 # - use_system_skia
48 # - use_system_ssl (use_openssl: http://crbug.com/62803)
49 # - use_system_stlport (android specific)
50 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
51
52 # NOTES:
53 # - mute BEEP mixer if you do not want to hear horrible system bell when
54 #   pressing home/end in url bar or more ^F search results on page.
55 # - space considerations:
56 #   - unpacked sources: ~490MiB
57 #   - built code: ~1.4GiB (x86_64/i686)
58 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
59 # - to look for new tarball, use update-source.sh script
60
61 # NOTE TO USERS:
62 # To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
63 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
64 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
65
66 %define         branch          26.0.1410
67 %define         basever         43
68 #define         patchver        70
69 %define         gyp_rev 1014
70 Summary:        A WebKit powered web browser
71 Name:           chromium-browser
72 %if "%{?patchver}" != ""
73 Version:        %{branch}.%{patchver}
74 %else
75 Version:        %{branch}.%{basever}
76 %endif
77 Release:        1
78 License:        BSD, LGPL v2+ (ffmpeg)
79 Group:          X11/Applications/Networking
80 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
81 # Source0-md5:  eafd6a919faadc8a7446cd673f460c4c
82 %if "%{?patchver}" != ""
83 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
84 # Patch0-md5:   7e2f26d76ca6241961276a328a9230cf
85 %endif
86 Source1:        %{name}.default
87 Source2:        %{name}.sh
88 Source3:        %{name}.desktop
89 Source5:        find-lang.sh
90 Source6:        update-source.sh
91 Source7:        clean-source.sh
92 Source8:        get-source.sh
93 Source9:        master_preferences.json
94 Patch1:         plugin-searchdirs.patch
95 #Patch2:                system-nspr.patch
96 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
97 Patch4:         path-libpdf.patch
98 Patch6:         get-webkit_revision.patch
99 Patch7:         dlopen_sonamed_gl.patch
100 Patch8:         chromium_useragent.patch.in
101 Patch9:         chromium-ppapi.patch
102 Patch10:        system-libxnvctrl.patch
103 # https://bugs.gentoo.org/show_bug.cgi?id=393471
104 # libjpeg-turbo >= 1.1.90 supports that feature
105 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
106 Patch12:        system-ffmpeg.patch
107 Patch15:        nacl-build-irt.patch
108 Patch16:        nacl-linkingfix.patch
109 Patch18:        nacl-no-untar.patch
110 Patch19:        system-jsoncpp.patch
111 Patch24:        nacl-verbose.patch
112 Patch25:        gnome3-volume-control.patch
113 Patch26:        master-prefs-path.patch
114 Patch27:        tcmalloc-glibc2.16.patch
115 Patch28:        system-mesa.patch
116 Patch29:        speechd-0.8.patch
117 URL:            http://www.chromium.org/Home
118 %{?with_gconf:BuildRequires:    GConf2-devel}
119 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
120 %{?with_system_mesa:BuildRequires:      Mesa-libGLES-devel >= 9.1}
121 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
122 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
123 BuildRequires:  alsa-lib-devel
124 BuildRequires:  atk-devel
125 BuildRequires:  bison
126 BuildRequires:  bzip2-devel
127 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
128 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
129 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
130 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
131 %{?with_cups:BuildRequires:     cups-devel}
132 BuildRequires:  elfutils-devel
133 BuildRequires:  expat-devel
134 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
135 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
136 BuildRequires:  fontconfig-devel
137 BuildRequires:  glib2-devel
138 BuildRequires:  gperf
139 %{?with_gps:BuildRequires:      gpsd-devel}
140 BuildRequires:  gtest-devel
141 BuildRequires:  gtk+2-devel
142 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
143 %{?with_kerberos:BuildRequires: heimdal-devel}
144 BuildRequires:  hicolor-icon-theme
145 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
146 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
147 BuildRequires:  libevent-devel
148 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
149 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
150 BuildRequires:  libicu-devel >= 4.6
151 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
152 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
153 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
154 BuildRequires:  libpng-devel
155 %{?with_selinux:BuildRequires:  libselinux-devel}
156 BuildRequires:  libstdc++-devel
157 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
158 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
159 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
160 BuildRequires:  libxml2-devel
161 BuildRequires:  libxslt-devel
162 BuildRequires:  man-db
163 %{?with_system_minizip:BuildRequires:   minizip-devel}
164 BuildRequires:  nspr-devel
165 BuildRequires:  nss-devel >= 1:3.12.3
166 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
167 BuildRequires:  pam-devel
168 BuildRequires:  pango-devel
169 BuildRequires:  pciutils-devel
170 BuildRequires:  perl-modules
171 BuildRequires:  pkgconfig
172 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
173 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
174 BuildRequires:  python
175 #BuildRequires: python-gyp >= 1-%{gyp_rev}
176 BuildRequires:  python-modules
177 BuildRequires:  python-ply
178 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
179 BuildRequires:  rpm >= 4.4.9-56
180 BuildRequires:  rpmbuild(macros) >= 1.453
181 BuildRequires:  speech-dispatcher-devel >= 0.8
182 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
183 BuildRequires:  sqlite3-devel >= 3.6.1
184 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
185 BuildRequires:  subversion
186 BuildRequires:  tar >= 1:1.22
187 BuildRequires:  udev-devel
188 BuildRequires:  usbutils
189 BuildRequires:  util-linux
190 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
191 BuildRequires:  which
192 BuildRequires:  xorg-lib-libXScrnSaver-devel
193 BuildRequires:  xz
194 %{?with_system_yasm:BuildRequires:      yasm}
195 %{?with_system_zlib:BuildRequires:      zlib-devel}
196 Requires:       browser-plugins >= 2.0
197 Requires:       desktop-file-utils
198 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
199 # crashes if no fontconfig font present
200 Requires:       fonts-Type1-urw
201 Requires:       hicolor-icon-theme
202 Requires:       libevent >= 2.0.21
203 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
204 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
205 Requires:       lsb-release
206 %{?with_system_re2:Requires:    re2 >= 20130115-2}
207 Requires:       shared-mime-info
208 Requires:       xdg-utils >= 1.0.2-4
209 Requires:       xorg-lib-libX11 >= 1.4.99.1
210 Provides:       wwwbrowser
211 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
212 Obsoletes:      chromium-browser-inspector < 15.0.863.0
213 ExclusiveArch:  %{ix86} %{x8664} arm
214 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
215
216 %define         find_lang       sh find-lang.sh %{buildroot}
217
218 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
219 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
220
221 %if %{without debuginfo}
222 %define         _enable_debug_packages  0
223 %endif
224
225 %description
226 Chromium is an open-source browser project that aims to build a safer,
227 faster, and more stable way for all Internet users to experience the
228 web.
229
230 Chromium serves as a base for Google Chrome, which is Chromium
231 rebranded (name and logo) with very few additions such as usage
232 tracking and an auto-updater system.
233
234 %package l10n
235 Summary:        chromium-browser language packages
236 Group:          I18n
237 Requires:       %{name} = %{version}-%{release}
238
239 %description l10n
240 Chromium is an open-source browser project that aims to build a safer,
241 faster, and more stable way for all Internet users to experience the
242 web.
243
244 This package contains language packages for 50 languages:
245
246 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
247 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
248 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
249 zh-TW
250
251 %prep
252 %setup -qc
253 %if "%{?patchver}" != ""
254 cd %{name}-%{branch}.%{basever}
255 %patch0 -p1
256 cd ..
257 %endif
258 mv %{name}-%{branch}.%{basever}/* .
259
260 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
261 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
262 . ./chrome/VERSION
263 ver=$MAJOR.$MINOR.$BUILD.$PATCH
264 test "$ver" = %{version}
265
266 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
267 test "$gyp_rev" = %{gyp_rev} || :
268
269 v8_ver=$(awk 'NR=1 {print $NF; exit}' v8/ChangeLog || :)
270
271 # add chromium and pld to useragent
272 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
273 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
274         -e 's/@BUILD_DIST_NAME@/PLD/g' \
275         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
276         < %{PATCH8} | %{__patch} -p2
277
278 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
279 ln -s %{SOURCE7} .
280
281 %patch1 -p2
282 %patch3 -p2
283 %patch4 -p3
284 %patch6 -p2
285 %patch7 -p2
286 %patch10 -p2
287 %patch15 -p2
288 %patch9 -p0
289 #%patch2 -p1
290 %{!?with_libjpegturbo:%patch11 -p0}
291 %patch12 -p1
292 %patch16 -p1
293 %patch19 -p2
294 %patch27 -p1
295 %patch28 -p1
296 %patch25 -p2
297 %patch18 -p2
298 %patch24 -p2
299 %patch26 -p2
300 %patch29 -p2
301
302 sh -x clean-source.sh \
303         %{!?with_nacl:nacl=0} \
304         %{!?with_system_libvpx:libvpx=0} \
305         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
306         %{!?with_system_mesa:mesa=0} \
307         %{!?with_system_protobuf:protobuf=0} \
308         %{!?with_system_re2:re2=0} \
309         %{!?with_system_v8:v8=0} \
310         %{!?with_system_zlib:zlib=0} \
311         %{nil}
312
313 %build
314 %if %{with nacl}
315 rm -rf native_client/toolchain/linux_x86_newlib
316 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
317 # Make symlinks for NaCL
318 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
319
320 cd native_client/toolchain/linux_x86_newlib
321 ln -s x86_64-nacl/bin bin
322 cd x86_64-nacl/bin
323 __cc='%{__cc}'
324 if [ "${__cc#ccache}" != "$__cc" ]; then
325         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
326         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
327         %{__sed} -i -e '1i#!/bin/sh' gcc g++
328         chmod +x gcc g++
329 else
330         ln -s %{_bindir}/x86_64-nacl-gcc gcc
331         ln -s %{_bindir}/x86_64-nacl-g++ g++
332 fi
333 ln -s gcc x86_64-nacl-gcc
334 ln -s g++ x86_64-nacl-g++
335 ln -s %{_bindir}/x86_64-nacl-ar .
336 ln -s %{_bindir}/x86_64-nacl-ar ar
337 ln -s %{_bindir}/x86_64-nacl-as as
338 ln -s %{_bindir}/x86_64-nacl-ranlib .
339 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
340 ln -s %{_bindir}/x86_64-nacl-strip .
341 ln -s %{_bindir}/x86_64-nacl-strip strip
342 ln -s %{_prefix}/x86_64-nacl/lib ../lib
343 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
344 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
345 cd ../../../../..
346 fi
347 %endif
348
349 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
350 test -e Makefile || \
351         CC="%{__cc}" \
352         CXX="%{__cxx}" \
353         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
354         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
355         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
356 %{__python} build/gyp_chromium \
357         --format=make \
358         --depth=. \
359         build/all.gyp \
360 %ifarch %{ix86}
361         -Dtarget_arch=ia32 \
362 %endif
363 %ifarch %{x8664}
364         -Dtarget_arch=x64 \
365 %endif
366 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
367         -Dno_strict_aliasing=1 -Dgcc_version=44 \
368 %endif
369 %if %{with sandboxing}
370         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
371         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
372 %endif
373         %{!?debug:-Dwerror=} \
374         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
375         %{?with_shared_libs:-Dlibrary=shared_library} \
376         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
377         -Dinclude_tests=0 \
378 %if %{with nacl}
379         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
380         -Ddisable_glibc_untar=1 \
381         -Ddisable_newlib_untar=1 \
382         -Ddisable_glibc=1 \
383         -Ddisable_pnacl=1 \
384         -Dbuild_pnacl_newlib=0 \
385 %else
386         -Ddisable_pnacl_untar=1 \
387         -Ddisable_nacl=1 \
388 %endif
389         %{!?with_sse2:-Ddisable_sse2=1} \
390         %{?with_selinux:-Dselinux=1} \
391         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
392         -Dlinux_link_libpci=1 \
393         -Dlinux_link_libspeechd=1 \
394         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
395         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
396         -Dlinux_use_gold_binary=0 \
397         -Dlinux_use_gold_flags=0 \
398         %{gyp_with cups} \
399         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
400         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
401         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
402         %{gyp_with pulseaudio} \
403         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
404         %{gyp_with system_flac} \
405         %{gyp_with system_harfbuzz} \
406         %{gyp_with system_jsoncpp} \
407         %{gyp_with system_libexif} \
408         %{gyp_with system_libmtp} \
409         %{gyp_with system_libsrtp} \
410         %{gyp_with system_libusb} \
411         %{gyp_with system_libvpx} -Dmedia_use_libvpx=0 \
412         %{gyp_with system_libwebp} \
413         %{gyp_with system_libxnvctrl} \
414         %{gyp_with system_mesa} \
415         %{gyp_with system_minizip} \
416         %{gyp_with system_opus} \
417         %{gyp_with system_protobuf} \
418         %{gyp_with system_re2} \
419         %{gyp_with system_speex} \
420         %{gyp_with system_sqlite} \
421         %{gyp_with system_v8} \
422         %{gyp_with system_yasm} \
423         %{gyp_with system_zlib} \
424         -Duse_system_bzip2=1 \
425         -Duse_system_expat=1 \
426         -Duse_system_icu=1 \
427         -Duse_system_libevent=1 \
428         -Duse_system_libjpeg=1 \
429         -Duse_system_libpng=1 \
430         -Duse_system_libxml=1 \
431         -Duse_system_libxslt=1 \
432         -Duse_system_nspr=1 \
433         -Duse_system_xdg_utils=1 \
434
435 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
436 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
437         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
438         %{?with_verbose:V=1} \
439         CC.host="%{__cc}" \
440         CXX.host="%{__cxx}" \
441         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
442
443 cd out/%{!?debug:Release}%{?debug:Debug}
444 MANWIDTH=80 man ./chrome.1 > man.out
445 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
446
447 %install
448 rm -rf $RPM_BUILD_ROOT
449 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
450         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
451
452 cd out/%{!?debug:Release}%{?debug:Debug}
453 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
454 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
455 %{__sed} -i -e '
456         s,@libdir@,%{_libdir}/%{name},
457
458         /@OPTIONS@/ {
459                 r options.txt
460                 d
461         }
462 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
463 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
464 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
465 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
466 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
467 %if %{without system_ffmpeg}
468 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
469 %endif
470 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
471 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
472
473 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
474
475 %if %{with nacl}
476 # Install Native Client files on platforms that support it.
477 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
478 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
479 %ifarch %{x8664}
480 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
481 %endif
482 %ifarch %{ix86}
483 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
484 %endif
485 %endif
486
487 cd -
488
489 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
490         size=${icon##*/product_logo_}
491         size=${size%.png}
492
493         # this will skip non-numeric (22_mono_invert, 22_mono)
494         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
495         test -d "$dir" || continue
496
497         install -d $RPM_BUILD_ROOT$dir
498         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
499 done
500
501 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
502 # http://code.google.com/p/chromium/issues/detail?id=24507
503 gecko-mediaplayer*.so
504 EOF
505
506 # find locales
507 %find_lang %{name}.lang
508 # always package en-US
509 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
510
511 %clean
512 rm -rf $RPM_BUILD_ROOT
513
514 %post
515 %update_icon_cache hicolor
516 %update_desktop_database
517 %update_browser_plugins
518
519 %postun
520 if [ "$1" = 0 ]; then
521         %update_icon_cache hicolor
522         %update_browser_plugins
523 fi
524
525 %files
526 %defattr(644,root,root,755)
527 %doc AUTHORS LICENSE
528 %{_browserpluginsconfdir}/browsers.d/%{name}.*
529 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
530 %dir %{_sysconfdir}/%{name}
531 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
532 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
533 %attr(755,root,root) %{_bindir}/%{name}
534 %{_mandir}/man1/%{name}.1*
535 %{_desktopdir}/*.desktop
536 %{_iconsdir}/hicolor/*/apps/%{name}.png
537 %dir %{_libdir}/%{name}
538 %{_libdir}/%{name}/chrome*.pak
539 %{_libdir}/%{name}/content_resources.pak
540 %{_libdir}/%{name}/resources.pak
541 %dir %{_libdir}/%{name}/locales
542 %{_libdir}/%{name}/locales/en-US.pak
543 %dir %{_libdir}/%{name}/resources
544 %{_libdir}/%{name}/resources/inspector
545 %dir %{_libdir}/%{name}/themes
546 %dir %{_libdir}/%{name}/extensions
547 %dir %{_libdir}/%{name}/plugins
548 %attr(755,root,root) %{_libdir}/%{name}/%{name}
549 # These unique permissions are intentional and necessary for the sandboxing
550 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
551
552 # ffmpeg libs
553 %if %{without system_ffmpeg}
554 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
555 %endif
556
557 %if %{with nacl}
558 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
559 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
560 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
561 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
562 %endif
563
564 %files l10n -f %{name}.lang
565 %defattr(644,root,root,755)
This page took 0.085921 seconds and 4 git commands to generate.