]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
up to 27.0.1453.73
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
9 %bcond_without  libjpegturbo    # use libjpeg-turbo features
10 %bcond_without  nacl                    # build Native Client support
11 %bcond_without  pulseaudio              # with pulseaudio
12 %bcond_without  sandboxing              # with sandboxing
13 %bcond_with             selinux                 # with SELinux (need policy first)
14 %bcond_with             shared_libs             # with shared libs
15 %bcond_with             sse2                    # use SSE2 instructions
16 %bcond_without  system_flac             # system flac
17 %bcond_without  system_ffmpeg   # system ffmpeg instead of ffmpegsumo
18 %bcond_without  system_harfbuzz # system harfbuzz
19 %bcond_without  system_jsoncpp  # system jsoncpp
20 %bcond_without  system_libexif  # system libexif
21 %bcond_without  system_libmtp   # system libmtp
22 %bcond_without  system_libusb   # system libusb-1
23 %bcond_without  system_libwebp  # system libwebp
24 %bcond_without  system_libxnvctrl       # system libxnvctrl
25 %bcond_without  system_mesa             # system Mesa
26 %bcond_without  system_minizip  # system minizip
27 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
28 %bcond_without  system_protobuf # system protobuf
29 %bcond_without  system_re2              # system re2
30 %bcond_without  system_speex    # system speex
31 %bcond_without  system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
32 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
33 %bcond_with             system_v8               # system v8
34 %bcond_without  system_libvpx   # system libvpx
35 %bcond_without  system_yasm             # system yasm
36 %bcond_without  system_zlib             # system zlib
37 %bcond_without  tcmalloc                # use tcmalloc
38 %bcond_without  verbose                 # verbose build (V=1)
39
40 %ifarch %{ix86}
41 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
42 %undefine       with_system_mesa
43 %endif
44
45 # TODO
46 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
47 # - use_system_skia
48 # - use_system_ssl (use_openssl: http://crbug.com/62803)
49 # - use_system_stlport (android specific)
50 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
51
52 # NOTES:
53 # - mute BEEP mixer if you do not want to hear horrible system bell when
54 #   pressing home/end in url bar or more ^F search results on page.
55 # - space considerations:
56 #   - unpacked sources: ~490MiB
57 #   - built code: ~1.4GiB (x86_64/i686)
58 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
59 # - to look for new tarball, use update-source.sh script
60
61 %define         branch          27.0.1453
62 %define         basever         73
63 #define         patchver        70
64 %define         gyp_rev 1014
65 Summary:        A WebKit powered web browser
66 Name:           chromium-browser
67 %if "%{?patchver}" != ""
68 Version:        %{branch}.%{patchver}
69 %else
70 Version:        %{branch}.%{basever}
71 %endif
72 Release:        0.7
73 License:        BSD, LGPL v2+ (ffmpeg)
74 Group:          X11/Applications/Networking
75 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{branch}.%{basever}.tar.gz
76 # Source0-md5:  eafd6a919faadc8a7446cd673f460c4c
77 %if "%{?patchver}" != ""
78 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
79 # Patch0-md5:   7e2f26d76ca6241961276a328a9230cf
80 %endif
81 Source1:        %{name}.default
82 Source2:        %{name}.sh
83 Source3:        %{name}.desktop
84 Source5:        find-lang.sh
85 Source6:        update-source.sh
86 Source7:        clean-source.sh
87 Source8:        get-source.sh
88 Source9:        master_preferences.json
89 Patch1:         plugin-searchdirs.patch
90 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
91 Patch4:         path-libpdf.patch
92 Patch6:         get-webkit_revision.patch
93 Patch7:         dlopen_sonamed_gl.patch
94 Patch8:         chromium_useragent.patch.in
95 Patch10:        system-libxnvctrl.patch
96 # https://bugs.gentoo.org/show_bug.cgi?id=393471
97 # libjpeg-turbo >= 1.1.90 supports that feature
98 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
99 Patch12:        system-ffmpeg.patch
100 Patch15:        nacl-build-irt.patch
101 Patch16:        nacl-linkingfix.patch
102 Patch18:        nacl-no-untar.patch
103 Patch24:        nacl-verbose.patch
104 Patch25:        gnome3-volume-control.patch
105 Patch26:        master-prefs-path.patch
106 Patch28:        system-mesa.patch
107 Patch29:        speechd-0.8.patch
108 Patch30:        no-pnacl.patch
109 URL:            http://www.chromium.org/Home
110 %{?with_gconf:BuildRequires:    GConf2-devel}
111 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
112 %{?with_system_mesa:BuildRequires:      Mesa-libGLES-devel >= 9.1}
113 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
114 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
115 BuildRequires:  alsa-lib-devel
116 BuildRequires:  atk-devel
117 BuildRequires:  bison
118 BuildRequires:  bzip2-devel
119 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
120 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
121 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
122 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
123 %{?with_cups:BuildRequires:     cups-devel}
124 BuildRequires:  elfutils-devel
125 BuildRequires:  expat-devel
126 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
127 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
128 BuildRequires:  fontconfig-devel
129 BuildRequires:  glib2-devel
130 BuildRequires:  gperf
131 %{?with_gps:BuildRequires:      gpsd-devel}
132 BuildRequires:  gtest-devel
133 BuildRequires:  gtk+2-devel
134 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
135 %{?with_kerberos:BuildRequires: heimdal-devel}
136 BuildRequires:  hicolor-icon-theme
137 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
138 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
139 BuildRequires:  libevent-devel
140 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
141 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
142 BuildRequires:  libicu-devel >= 4.6
143 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
144 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
145 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
146 BuildRequires:  libpng-devel
147 %{?with_selinux:BuildRequires:  libselinux-devel}
148 BuildRequires:  libstdc++-devel
149 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
150 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
151 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
152 BuildRequires:  libxml2-devel
153 BuildRequires:  libxslt-devel
154 BuildRequires:  man-db
155 %{?with_system_minizip:BuildRequires:   minizip-devel}
156 BuildRequires:  nspr-devel
157 BuildRequires:  nss-devel >= 1:3.12.3
158 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
159 BuildRequires:  pam-devel
160 BuildRequires:  pango-devel
161 BuildRequires:  pciutils-devel
162 BuildRequires:  perl-modules
163 BuildRequires:  pkgconfig
164 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
165 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
166 BuildRequires:  python
167 #BuildRequires: python-gyp >= 1-%{gyp_rev}
168 BuildRequires:  python-modules
169 BuildRequires:  python-ply
170 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
171 BuildRequires:  rpm >= 4.4.9-56
172 BuildRequires:  rpmbuild(macros) >= 1.453
173 BuildRequires:  speech-dispatcher-devel >= 0.8
174 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
175 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
176 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
177 BuildRequires:  subversion
178 BuildRequires:  tar >= 1:1.22
179 BuildRequires:  udev-devel
180 BuildRequires:  usbutils
181 BuildRequires:  util-linux
182 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
183 BuildRequires:  which
184 BuildRequires:  xorg-lib-libXScrnSaver-devel
185 BuildRequires:  xz
186 %{?with_system_yasm:BuildRequires:      yasm}
187 %{?with_system_zlib:BuildRequires:      zlib-devel}
188 Requires:       browser-plugins >= 2.0
189 Requires:       desktop-file-utils
190 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
191 # crashes if no fontconfig font present
192 Requires:       fonts-Type1-urw
193 Requires:       hicolor-icon-theme
194 Requires:       libevent >= 2.0.21
195 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
196 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
197 Requires:       lsb-release
198 %{?with_system_re2:Requires:    re2 >= 20130115-2}
199 Requires:       shared-mime-info
200 Requires:       xdg-utils >= 1.0.2-4
201 Requires:       xorg-lib-libX11 >= 1.4.99.1
202 Provides:       wwwbrowser
203 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
204 Obsoletes:      chromium-browser-inspector < 15.0.863.0
205 ExclusiveArch:  %{ix86} %{x8664} arm
206 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
207
208 %define         find_lang       sh find-lang.sh %{buildroot}
209
210 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
211 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
212
213 %if %{without debuginfo}
214 %define         _enable_debug_packages  0
215 %endif
216
217 %description
218 Chromium is an open-source browser project that aims to build a safer,
219 faster, and more stable way for all Internet users to experience the
220 web.
221
222 Chromium serves as a base for Google Chrome, which is Chromium
223 rebranded (name and logo) with very few additions such as usage
224 tracking and an auto-updater system.
225
226 %package l10n
227 Summary:        chromium-browser language packages
228 Group:          I18n
229 Requires:       %{name} = %{version}-%{release}
230 %if "%{_rpmversion}" >= "5"
231 BuildArch:      noarch
232 %endif
233
234 %description l10n
235 Chromium is an open-source browser project that aims to build a safer,
236 faster, and more stable way for all Internet users to experience the
237 web.
238
239 This package contains language packages for 50 languages:
240
241 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
242 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
243 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
244 zh-TW
245
246 %prep
247 %setup -qc
248 %if "%{?patchver}" != ""
249 cd %{name}-%{branch}.%{basever}
250 %patch0 -p1
251 cd ..
252 %endif
253 mv %{name}-%{branch}.%{basever}/* .
254
255 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
256 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
257 . ./chrome/VERSION
258 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
259 test "$chrome" = %{version}
260
261 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
262 test "$gyp_rev" = %{gyp_rev} || :
263
264 . ./v8.sh
265 v8=$MAJOR_VERSION.$MINOR_VERSION.$BUILD_NUMBER.$PATCH_LEVEL
266
267 # add chromium and pld to useragent
268 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
269 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
270         -e 's/@BUILD_DIST_NAME@/PLD/g' \
271         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
272         < %{PATCH8} | %{__patch} -p2
273
274 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
275 ln -s %{SOURCE7} .
276
277 %patch1 -p2
278 %patch3 -p2
279 %patch4 -p3
280 %patch6 -p2
281 %patch7 -p2
282 %patch10 -p2
283 %patch15 -p2
284 %{!?with_libjpegturbo:%patch11 -p0}
285 %patch12 -p1
286 %patch16 -p1
287 %patch28 -p1
288 %patch25 -p2
289 %patch18 -p2
290 %patch24 -p2
291 %patch26 -p2
292 %patch29 -p2
293 %patch30 -p0
294
295 sh -x clean-source.sh \
296         %{!?with_nacl:nacl=0} \
297         %{!?with_system_libvpx:libvpx=0} \
298         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
299         %{!?with_system_mesa:mesa=0} \
300         %{!?with_system_protobuf:protobuf=0} \
301         %{!?with_system_re2:re2=0} \
302         %{!?with_system_sqlite:sqlite=0} \
303         %{!?with_system_v8:v8=0} \
304         %{!?with_system_zlib:zlib=0} \
305         %{nil}
306
307 %build
308 %if %{with nacl}
309 rm -rf native_client/toolchain/linux_x86_newlib
310 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
311 # Make symlinks for NaCL
312 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
313
314 cd native_client/toolchain/linux_x86_newlib
315 ln -s x86_64-nacl/bin bin
316 cd x86_64-nacl/bin
317 __cc='%{__cc}'
318 if [ "${__cc#ccache}" != "$__cc" ]; then
319         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
320         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
321         %{__sed} -i -e '1i#!/bin/sh' gcc g++
322         chmod +x gcc g++
323 else
324         ln -s %{_bindir}/x86_64-nacl-gcc gcc
325         ln -s %{_bindir}/x86_64-nacl-g++ g++
326 fi
327 ln -s gcc x86_64-nacl-gcc
328 ln -s g++ x86_64-nacl-g++
329 ln -s %{_bindir}/x86_64-nacl-ar .
330 ln -s %{_bindir}/x86_64-nacl-ar ar
331 ln -s %{_bindir}/x86_64-nacl-as as
332 ln -s %{_bindir}/x86_64-nacl-ranlib .
333 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
334 ln -s %{_bindir}/x86_64-nacl-strip .
335 ln -s %{_bindir}/x86_64-nacl-strip strip
336 ln -s %{_prefix}/x86_64-nacl/lib ../lib
337 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
338 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
339 cd ../../../../..
340 fi
341 %endif
342
343 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
344 test -e Makefile || \
345         CC="%{__cc}" \
346         CXX="%{__cxx}" \
347         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
348         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
349         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
350 %{__python} build/gyp_chromium \
351         --format=make \
352         --depth=. \
353         build/all.gyp \
354 %ifarch %{ix86}
355         -Dtarget_arch=ia32 \
356 %endif
357 %ifarch %{x8664}
358         -Dtarget_arch=x64 \
359 %endif
360 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
361         -Dno_strict_aliasing=1 -Dgcc_version=44 \
362 %endif
363 %if %{with sandboxing}
364         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
365         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
366 %endif
367         %{!?debug:-Dwerror=} \
368         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
369         %{?with_shared_libs:-Dlibrary=shared_library} \
370         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
371         -Dinclude_tests=0 \
372 %if %{with nacl}
373         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
374         -Ddisable_glibc_untar=1 \
375         -Ddisable_newlib_untar=1 \
376         -Ddisable_glibc=1 \
377         -Ddisable_pnacl=1 \
378         -Dbuild_pnacl_newlib=0 \
379 %else
380         -Ddisable_pnacl_untar=1 \
381         -Ddisable_nacl=1 \
382 %endif
383         %{!?with_sse2:-Ddisable_sse2=1} \
384         %{?with_selinux:-Dselinux=1} \
385         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
386         -Dlinux_link_libpci=1 \
387         -Dlinux_link_libspeechd=1 \
388         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
389         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
390         -Dlinux_use_gold_binary=0 \
391         -Dlinux_use_gold_flags=0 \
392         %{gyp_with cups} \
393         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
394         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
395         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
396         %{gyp_with pulseaudio} \
397         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
398         %{gyp_with system_flac} \
399         %{gyp_with system_harfbuzz} \
400         %{gyp_with system_jsoncpp} \
401         %{gyp_with system_libexif} \
402         %{gyp_with system_libmtp} \
403         %{gyp_with system_libsrtp} \
404         %{gyp_with system_libusb} \
405         %{gyp_with system_libvpx} -Dmedia_use_libvpx=0 \
406         %{gyp_with system_libwebp} \
407         %{gyp_with system_libxnvctrl} \
408         %{gyp_with system_mesa} \
409         %{gyp_with system_minizip} \
410         %{gyp_with system_opus} \
411         %{gyp_with system_protobuf} \
412         %{gyp_with system_re2} \
413         %{gyp_with system_speex} \
414         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
415         %{gyp_with system_v8} \
416         %{gyp_with system_yasm} \
417         %{gyp_with system_zlib} \
418         -Duse_system_bzip2=1 \
419         -Duse_system_expat=1 \
420         -Duse_system_icu=1 \
421         -Duse_system_libevent=1 \
422         -Duse_system_libjpeg=1 \
423         -Duse_system_libpng=1 \
424         -Duse_system_libxml=1 \
425         -Duse_system_libxslt=1 \
426         -Duse_system_nspr=1 \
427         -Duse_system_xdg_utils=1 \
428
429 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
430 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
431         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
432         %{?with_verbose:V=1} \
433         CC.host="%{__cc}" \
434         CXX.host="%{__cxx}" \
435         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
436
437 cd out/%{!?debug:Release}%{?debug:Debug}
438 MANWIDTH=80 man ./chrome.1 > man.out
439 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
440
441 %install
442 rm -rf $RPM_BUILD_ROOT
443 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
444         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
445         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
446
447 cd out/%{!?debug:Release}%{?debug:Debug}
448 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
449 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
450 %{__sed} -i -e '
451         s,@libdir@,%{_libdir}/%{name},
452
453         /@OPTIONS@/ {
454                 r options.txt
455                 d
456         }
457 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
458 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
459 cp -a *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
460 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
461 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
462 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
463 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
464 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
465 %if %{without system_ffmpeg}
466 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
467 %endif
468 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
469 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
470
471 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
472
473 %if %{with nacl}
474 # Install Native Client files on platforms that support it.
475 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
476 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
477 %ifarch %{x8664}
478 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
479 %endif
480 %ifarch %{ix86}
481 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
482 %endif
483 %endif
484
485 cd -
486
487 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
488         size=${icon##*/product_logo_}
489         size=${size%.png}
490
491         # this will skip non-numeric (22_mono_invert, 22_mono)
492         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
493         test -d "$dir" || continue
494
495         install -d $RPM_BUILD_ROOT$dir
496         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
497 done
498
499 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
500 # http://code.google.com/p/chromium/issues/detail?id=24507
501 gecko-mediaplayer*.so
502 EOF
503
504 # find locales
505 %find_lang %{name}.lang
506 # always package en-US
507 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
508
509 %clean
510 rm -rf $RPM_BUILD_ROOT
511
512 %pretrans
513 for d in locales resources; do
514         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
515                 install -d %{_datadir}/%{name}
516                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
517         fi
518 done
519 exit 0
520
521 %post
522 %update_icon_cache hicolor
523 %update_desktop_database
524 %update_browser_plugins
525
526 %postun
527 if [ "$1" = 0 ]; then
528         %update_icon_cache hicolor
529         %update_browser_plugins
530 fi
531
532 %files
533 %defattr(644,root,root,755)
534 %doc AUTHORS LICENSE
535 %{_browserpluginsconfdir}/browsers.d/%{name}.*
536 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
537 %dir %{_sysconfdir}/%{name}
538 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
539 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
540 %attr(755,root,root) %{_bindir}/%{name}
541 %{_mandir}/man1/%{name}.1*
542 %{_desktopdir}/*.desktop
543 %{_iconsdir}/hicolor/*/apps/%{name}.png
544 %dir %{_libdir}/%{name}
545 %{_libdir}/%{name}/chrome*.pak
546 %{_libdir}/%{name}/content_resources.pak
547 %{_libdir}/%{name}/resources.pak
548 %{_libdir}/%{name}/locales
549 %{_libdir}/%{name}/resources
550
551 %dir %{_datadir}/%{name}
552 %dir %{_datadir}/%{name}/locales
553 %{_datadir}/%{name}/locales/en-US.pak
554 %dir %{_datadir}/%{name}/resources
555 %{_datadir}/%{name}/resources/inspector
556
557 %dir %{_libdir}/%{name}/plugins
558 %attr(755,root,root) %{_libdir}/%{name}/%{name}
559 # These unique permissions are intentional and necessary for the sandboxing
560 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
561
562 # ffmpeg libs
563 %if %{without system_ffmpeg}
564 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
565 %endif
566
567 %if %{with nacl}
568 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
569 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
570 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
571 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
572 %endif
573
574 %files l10n -f %{name}.lang
575 %defattr(644,root,root,755)
This page took 0.08312 seconds and 4 git commands to generate.