]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
disable debuginfo on 32bit hosts
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_with     dev                     # with dev optimizations (skip clean source)
6 %bcond_without  gconf                   # with GConf
7 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
8 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
9 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
10 %bcond_without  libjpegturbo    # use libjpeg-turbo features
11 %bcond_with     nacl                    # build Native Client support, disabled: http://crbug.com/269560
12 %bcond_without  ninja                   # use Ninja instead of make to build
13 %bcond_without  pulseaudio              # with pulseaudio
14 %bcond_without  sandboxing              # with sandboxing
15 %bcond_with             selinux                 # with SELinux (need policy first)
16 %bcond_with             shared_libs             # with shared libs
17 %bcond_with             sse2                    # use SSE2 instructions
18 %bcond_without  system_flac             # system flac
19 %bcond_with     system_ffmpeg   # system ffmpeg instead of ffmpegsumo
20 %bcond_without  system_harfbuzz # system harfbuzz
21 %bcond_without  system_jsoncpp  # system jsoncpp
22 %bcond_without  system_libexif  # system libexif
23 %bcond_without  system_libmtp   # system libmtp
24 %bcond_with     system_libusb   # system libusb-1, disabled: http://crbug.com/266149
25 %bcond_without  system_libwebp  # system libwebp
26 %bcond_without  system_libxnvctrl       # system libxnvctrl
27 %bcond_with     system_mesa             # system Mesa
28 %bcond_without  system_minizip  # system minizip
29 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
30 %bcond_without  system_protobuf # system protobuf
31 %bcond_without  system_re2              # system re2
32 %bcond_without  system_snappy   # system snappy
33 %bcond_without  system_speex    # system speex
34 %bcond_with     system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
35 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
36 %bcond_with             system_v8               # system v8
37 %bcond_with     system_libvpx   # system libvpx
38 %bcond_without  system_yasm             # system yasm
39 %bcond_without  system_zlib             # system zlib
40 %bcond_with     tcmalloc                # use tcmalloc
41 %bcond_without  verbose                 # verbose build (V=1)
42
43 %ifarch %{ix86}
44 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
45 %undefine       with_system_mesa
46
47 # unable build with debuginfo on 32bit build systems
48 %undefine       with_debuginfo
49 %endif
50
51 # TODO
52 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
53 # - use_system_skia
54 # - use_system_ssl (use_openssl: http://crbug.com/62803)
55 # - use_system_stlport (android specific)
56 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
57
58 # NOTES:
59 # - mute BEEP mixer if you do not want to hear horrible system bell when
60 #   pressing home/end in url bar or more ^F search results on page.
61 # - space considerations:
62 #   - unpacked sources: ~490MiB
63 #   - built code: ~1.4GiB (x86_64/i686)
64 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
65 # - to look for new tarball, use update-source.sh script
66
67 %define         branch          38.0.2125
68 %define         basever         101
69 #define         patchver        132
70 %define         gyp_rev 1014
71 Summary:        A WebKit powered web browser
72 Name:           chromium-browser
73 %if "%{?patchver}" != ""
74 Version:        %{branch}.%{patchver}
75 %else
76 Version:        %{branch}.%{basever}
77 %endif
78 Release:        1
79 License:        BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
80 Group:          X11/Applications/Networking
81 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
82 # Source0-md5:  f2ec6a50864d8b2ddcda0baef50e9c33
83 %if "%{?patchver}" != ""
84 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
85 # Patch0-md5:   4eafe1e64bd47a11dbfaf61a2dd50b6e
86 %endif
87 Source1:        %{name}.default
88 Source2:        %{name}.sh
89 Source3:        %{name}.desktop
90 Source5:        find-lang.sh
91 Source6:        update-source.sh
92 Source7:        clean-source.sh
93 Source8:        get-source.sh
94 Source9:        master_preferences.json
95 Patch2:         enable-video-decode-accel.patch
96 Patch4:         path-libpdf.patch
97 Patch7:         dlopen_sonamed_gl.patch
98 Patch8:         chromium_useragent.patch.in
99 # https://bugs.gentoo.org/show_bug.cgi?id=393471
100 # libjpeg-turbo >= 1.1.90 supports that feature
101 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
102 Patch15:        nacl-build-irt.patch
103 Patch16:        nacl-linkingfix.patch
104 Patch18:        nacl-no-untar.patch
105 Patch24:        nacl-verbose.patch
106 Patch25:        gnome3-volume-control.patch
107 Patch26:        master-prefs-path.patch
108 Patch28:        system-mesa.patch
109 Patch30:        system-ply.patch
110 Patch31:        system-jinja.patch
111 Patch32:        remove_bundled_libraries-stale.patch
112 Patch35:        etc-dir.patch
113 Patch36:        angle.patch
114 URL:            http://www.chromium.org/Home
115 %{?with_gconf:BuildRequires:    GConf2-devel}
116 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
117 BuildRequires:  Mesa-libGLES-devel >= 9.1
118 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
119 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
120 BuildRequires:  alsa-lib-devel
121 BuildRequires:  atk-devel
122 BuildRequires:  bison
123 BuildRequires:  bzip2-devel
124 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
125 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
126 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
127 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
128 %{?with_cups:BuildRequires:     cups-devel}
129 BuildRequires:  elfutils-devel
130 BuildRequires:  expat-devel
131 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
132 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
133 BuildRequires:  fontconfig-devel
134 BuildRequires:  glib2-devel
135 BuildRequires:  gperf
136 %{?with_gps:BuildRequires:      gpsd-devel}
137 BuildRequires:  gtest-devel
138 BuildRequires:  gtk+2-devel
139 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
140 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-icu-devel}
141 %{?with_kerberos:BuildRequires: heimdal-devel}
142 BuildRequires:  hicolor-icon-theme
143 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
144 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
145 BuildRequires:  libevent-devel
146 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
147 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
148 BuildRequires:  libicu-devel >= 4.6
149 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
150 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
151 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
152 BuildRequires:  libpng-devel
153 %{?with_selinux:BuildRequires:  libselinux-devel}
154 BuildRequires:  libstdc++-devel
155 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
156 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 1.3.0}
157 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.4.0}
158 BuildRequires:  libxml2-devel
159 BuildRequires:  libxslt-devel
160 BuildRequires:  man-db
161 %{?with_system_minizip:BuildRequires:   minizip-devel}
162 %{?with_ninja:BuildRequires:    ninja >= 1.3.0}
163 BuildRequires:  nspr-devel
164 BuildRequires:  nss-devel >= 1:3.12.3
165 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
166 BuildRequires:  pam-devel
167 BuildRequires:  pango-devel
168 BuildRequires:  pciutils-devel
169 BuildRequires:  perl-JSON
170 BuildRequires:  perl-modules
171 BuildRequires:  pkgconfig
172 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
173 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
174 BuildRequires:  python
175 #BuildRequires: python-gyp >= 1-%{gyp_rev}
176 BuildRequires:  python-jinja2 >= 2.7
177 BuildRequires:  python-modules
178 BuildRequires:  python-ply >= 3.4
179 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
180 BuildRequires:  rpm >= 4.4.9-56
181 BuildRequires:  rpmbuild(macros) >= 1.453
182 %{?with_system_snappy:BuildRequires:    snappy-devel}
183 BuildRequires:  speech-dispatcher-devel >= 0.8
184 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
185 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
186 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
187 BuildRequires:  tar >= 1:1.22
188 BuildRequires:  udev-devel
189 BuildRequires:  usbutils
190 BuildRequires:  util-linux
191 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
192 BuildRequires:  which
193 BuildRequires:  xorg-lib-libXScrnSaver-devel
194 BuildRequires:  xorg-lib-libXtst-devel
195 BuildRequires:  xz
196 %{?with_system_yasm:BuildRequires:      yasm}
197 %{?with_system_zlib:BuildRequires:      zlib-devel}
198 Requires:       browser-plugins >= 2.0
199 Requires:       desktop-file-utils
200 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
201 # crashes if no fontconfig font present
202 Requires:       fonts-Type1-urw
203 Requires:       hicolor-icon-theme
204 Requires:       libevent >= 2.0.21
205 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
206 %{?with_system_libvpx:Requires: libvpx >= 1.3.0}
207 Requires:       lsb-release
208 %{?with_system_re2:Requires:    re2 >= 20130115-2}
209 %{?with_system_protobuf:Requires:       protobuf-libs >= 2.5.0-2}
210 Requires:       shared-mime-info
211 %{?with_system_sqlite:Requires: sqlite3(icu)}
212 Requires:       xdg-utils >= 1.0.2-4
213 Requires:       xorg-lib-libX11 >= 1.4.99.1
214 Provides:       wwwbrowser
215 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
216 Obsoletes:      chromium-browser-inspector < 15.0.863.0
217 ExclusiveArch:  %{ix86} %{x8664} arm
218 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
219
220 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
221 # Note: these are for PLD Linux use ONLY.
222 # For your own distribution, please get your own set of keys.
223 %define         google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
224 %define         google_default_client_id 724288223830.apps.googleusercontent.com
225 %define         google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
226
227 %define         find_lang       sh find-lang.sh %{buildroot}
228
229 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
230 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
231
232 %ifarch %{ix86}
233 %define         target_arch ia32
234 %endif
235 %ifarch %{x8664}
236 %define         target_arch x64
237 %endif
238
239 %define         buildtype       %{?debug:Debug}%{!?debug:Release}
240 %define         builddir        out/%{buildtype}
241
242 %if %{without debuginfo}
243 %define         _enable_debug_packages  0
244 %endif
245
246 %description
247 Chromium is an open-source browser project that aims to build a safer,
248 faster, and more stable way for all Internet users to experience the
249 web.
250
251 Chromium serves as a base for Google Chrome, which is Chromium
252 rebranded (name and logo) with very few additions such as usage
253 tracking and an auto-updater system.
254
255 %package l10n
256 Summary:        chromium-browser language packages
257 Group:          I18n
258 Requires:       %{name} = %{version}-%{release}
259 %if "%{_rpmversion}" >= "5"
260 BuildArch:      noarch
261 %endif
262
263 %description l10n
264 Chromium is an open-source browser project that aims to build a safer,
265 faster, and more stable way for all Internet users to experience the
266 web.
267
268 This package contains language packages for 50 languages:
269
270 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
271 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
272 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
273 zh-TW
274
275 %prep
276 %setup -qc
277 %if "%{?patchver}" != ""
278 cd chromium*-%{branch}.%{basever}
279 %patch0 -p1
280 cd ..
281 %endif
282 mv chromium*-%{branch}.%{basever}/* .
283
284 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
285 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
286 . ./chrome/VERSION
287 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
288 test "$chrome" = %{version}
289
290 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
291 test "$gyp_rev" = %{gyp_rev} || :
292
293 # add chromium and pld to useragent
294 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
295 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
296         -e 's/@BUILD_DIST_NAME@/PLD/g' \
297         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
298         < %{PATCH8} | %{__patch} -p1
299
300 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
301 ln -s %{SOURCE7} .
302
303 #%patch2 -p1 NOT COMPILING
304 %patch4 -p3
305 %patch7 -p1
306 %patch15 -p2
307 %{!?with_libjpegturbo:%patch11 -p0}
308 %patch16 -p1
309 %patch28 -p1
310 %patch25 -p1
311 %{?with_nacl:%patch18 -p1}
312 %patch24 -p1
313 %patch26 -p2
314 #%patch30 -p1
315 #%patch31 -p0
316 %patch32 -p1
317 %patch35 -p1
318 %patch36 -p1
319
320 %{?with_dev:exit 0}
321
322 sh -x clean-source.sh \
323         %{!?with_nacl:nacl=0} \
324         %{!?with_system_libvpx:libvpx=0} \
325         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
326         %{!?with_system_mesa:mesa=0} \
327         %{!?with_system_protobuf:protobuf=0} \
328         %{!?with_system_re2:re2=0} \
329         %{!?with_system_snappy:snappy=0} \
330         %{!?with_system_sqlite:sqlite=0} \
331         %{!?with_system_v8:v8=0} \
332         %{!?with_system_libwebp:libwebp=0} \
333         %{!?with_system_zlib:zlib=0} \
334         %{!?with_system_ffmpeg:ffmpeg=0} \
335         %{nil}
336
337 %build
338 %if %{with nacl}
339 rm -rf native_client/toolchain/linux_x86_newlib
340 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
341 # Make symlinks for NaCL
342 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
343
344 cd native_client/toolchain/linux_x86_newlib
345 ln -s x86_64-nacl/bin bin
346 cd x86_64-nacl/bin
347 __cc='%{__cc}'
348 if [ "${__cc#ccache}" != "$__cc" ]; then
349         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
350         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
351         %{__sed} -i -e '1i#!/bin/sh' gcc g++
352         chmod +x gcc g++
353 else
354         ln -s %{_bindir}/x86_64-nacl-gcc gcc
355         ln -s %{_bindir}/x86_64-nacl-g++ g++
356 fi
357 ln -s gcc x86_64-nacl-gcc
358 ln -s g++ x86_64-nacl-g++
359 ln -s %{_bindir}/x86_64-nacl-ar .
360 ln -s %{_bindir}/x86_64-nacl-ar ar
361 ln -s %{_bindir}/x86_64-nacl-as as
362 ln -s %{_bindir}/x86_64-nacl-ranlib .
363 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
364 ln -s %{_bindir}/x86_64-nacl-strip .
365 ln -s %{_bindir}/x86_64-nacl-strip strip
366 ln -s %{_bindir}/x86_64-nacl-objcopy .
367 ln -s %{_prefix}/x86_64-nacl/lib ../lib
368 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
369 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
370 cd ../../../../..
371 fi
372 %endif
373
374 %if %{without system_ffmpeg}
375 if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
376         # Re-configure bundled ffmpeg
377         cd third_party/ffmpeg
378         chromium/scripts/build_ffmpeg.py linux %{target_arch}
379         chromium/scripts/copy_config.sh
380         chromium/scripts/generate_gyp.py
381         cd -
382 fi
383 %endif
384
385 third_party/libaddressinput/chromium/tools/update-strings.py
386
387 flags="
388         -Dtarget_arch=%{target_arch} \
389         -Dpython_arch=%{target_arch} \
390         -Dffmpeg_branding=Chromium \
391         -Dsystem_libdir=%{_lib} \
392         -Dpython_ver=%{py_ver} \
393 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
394         -Dno_strict_aliasing=1 -Dgcc_version=44 \
395 %endif
396         %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
397         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
398         %{?with_shared_libs:-Dlibrary=shared_library} \
399         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
400         -Dinclude_tests__=0 \
401 %if %{with nacl}
402         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
403         -Ddisable_glibc_untar=1 \
404         -Ddisable_newlib_untar=1 \
405         -Ddisable_glibc=1 \
406         -Ddisable_pnacl=1 \
407         -Dbuild_pnacl_newlib=0 \
408 %else
409         -Ddisable_pnacl_untar=1 \
410         -Ddisable_nacl=1 \
411 %endif
412         %{!?with_sse2:-Ddisable_sse2=1} \
413         %{?with_selinux:-Dselinux=1} \
414         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
415         -Dlinux_link_libpci=1 \
416         -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
417         -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
418         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
419         -Dclang=0 \
420         -Dhost_clang=0 \
421         -Dlinux_use_bundled_binutils=0 \
422         -Dlinux_use_bundled_gold=0 \
423         -Dlinux_use_gold_flags=0 \
424         -Dlogging_like_official_build=1 \
425         -Dgoogle_api_key=%{google_api_key} \
426         -Dgoogle_default_client_id=%{google_default_client_id} \
427         -Dgoogle_default_client_secret=%{google_default_client_secret} \
428         %{gyp_with cups} \
429         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
430         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
431         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
432         %{gyp_with pulseaudio} \
433         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
434         %{gyp_with system_flac} \
435         %{gyp_with system_harfbuzz} \
436         %{gyp_with system_jsoncpp} \
437         %{gyp_with system_libexif} \
438         %{gyp_with system_libmtp} \
439         %{gyp_with system_libsrtp} \
440         %{gyp_with system_libusb} \
441         %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
442         %{gyp_with system_libwebp} \
443         %{gyp_with system_libxnvctrl} \
444         %{gyp_with system_mesa} \
445         %{gyp_with system_minizip} \
446         %{gyp_with system_opus} \
447         %{gyp_with system_protobuf} \
448         %{gyp_with system_re2} \
449         %{gyp_with system_snappy} \
450         %{gyp_with system_speex} \
451         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
452         %{gyp_with system_v8} \
453         %{gyp_with system_yasm} \
454         %{gyp_with system_zlib} \
455         -Duse_system_bzip2=1 \
456         -Duse_system_expat=1 \
457         -Duse_system_icu=1 -Dicu_use_data_file_flag=0 \
458         -Duse_system_libevent=1 \
459         -Duse_system_libjpeg=1 \
460         -Duse_system_libpng=1 \
461         -Duse_system_libxml=1 \
462         -Duse_system_libxslt=1 \
463         -Duse_system_nspr=1 \
464         -Duse_system_xdg_utils=1 \
465 "
466
467 build/linux/unbundle/replace_gyp_files.py $flags
468
469 %if %{with ninja}
470 chkfile=%{builddir}/build.ninja
471 %else
472 chkfile=Makefile
473 %endif
474 test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
475 test -e $chkfile || \
476         CC="%{__cc}" \
477         CXX="%{__cxx}" \
478         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
479         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
480         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
481         CC_host="%{__cc}" \
482         CXX_host="%{__cxx}" \
483         LD_host="%{__cxx}" \
484 %{__python} build/gyp_chromium \
485         --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
486         --depth=. \
487         build/all.gyp \
488         $flags
489
490 %if %{with ninja}
491 ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
492 %else
493 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
494 %{__make} -r \
495         BUILDTYPE=%{buildtype} \
496         %{?with_verbose:V=1} \
497         CC.host="%{__cc}" \
498         CXX.host="%{__cxx}" \
499         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
500 %endif
501         chrome %{?with_sandboxing:chrome_sandbox} \
502         %{nil}
503
504 cd %{builddir}
505 MANWIDTH=80 man ./chrome.1 > man.out
506 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
507
508 %install
509 rm -rf $RPM_BUILD_ROOT
510 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
511         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
512         $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
513         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
514
515 cd %{builddir}
516 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
517 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
518 %{__sed} -i -e '
519         s,@libdir@,%{_libdir}/%{name},
520
521         /@OPTIONS@/ {
522                 r options.txt
523                 d
524         }
525 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
526 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
527 cp -p *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
528 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
529 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
530 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
531 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
532 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
533 %if %{without system_ffmpeg}
534 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
535 %endif
536 install -p libpdf.so $RPM_BUILD_ROOT%{_libdir}/%{name}
537 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
538 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
539
540 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
541
542 %if %{with nacl}
543 # Install Native Client files on platforms that support it.
544 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
545 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
546 %ifarch %{x8664}
547 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
548 %endif
549 %ifarch %{ix86}
550 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
551 %endif
552 %endif
553
554 cd -
555
556 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
557         size=${icon##*/product_logo_}
558         size=${size%.png}
559
560         # this will skip non-numeric (22_mono_invert, 22_mono)
561         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
562         test -d "$dir" || continue
563
564         install -d $RPM_BUILD_ROOT$dir
565         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
566 done
567
568 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
569 # http://code.google.com/p/chromium/issues/detail?id=24507
570 gecko-mediaplayer*.so
571 EOF
572
573 # find locales
574 %find_lang %{name}.lang
575 # always package en-US
576 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
577
578 %clean
579 rm -rf $RPM_BUILD_ROOT
580
581 %pretrans
582 for d in locales resources; do
583         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
584                 install -d %{_datadir}/%{name}
585                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
586         fi
587 done
588 exit 0
589
590 %post
591 %update_icon_cache hicolor
592 %update_desktop_database
593 %update_browser_plugins
594
595 %postun
596 if [ "$1" = 0 ]; then
597         %update_icon_cache hicolor
598         %update_browser_plugins
599 fi
600
601 %files
602 %defattr(644,root,root,755)
603 %doc AUTHORS LICENSE
604 %{_browserpluginsconfdir}/browsers.d/%{name}.*
605 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
606 %dir %{_sysconfdir}/%{name}
607 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
608 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
609 %dir %{_sysconfdir}/%{name}/native-messaging-hosts
610 %dir %{_sysconfdir}/%{name}/policies
611 %dir %{_sysconfdir}/%{name}/policies/managed
612 %attr(755,root,root) %{_bindir}/%{name}
613 %{_mandir}/man1/%{name}.1*
614 %{_desktopdir}/*.desktop
615 %{_iconsdir}/hicolor/*/apps/%{name}.png
616 %dir %{_libdir}/%{name}
617 %{_libdir}/%{name}/chrome*.pak
618 %{_libdir}/%{name}/content_resources.pak
619 %{_libdir}/%{name}/keyboard_resources.pak
620 %{_libdir}/%{name}/resources.pak
621 %{_libdir}/%{name}/locales
622 %{_libdir}/%{name}/resources
623
624 # conflicts with browser-plugin-chrome-pdf?
625 %attr(755,root,root) %{_libdir}/%{name}/libpdf.so
626
627 %dir %{_datadir}/%{name}
628 %dir %{_datadir}/%{name}/locales
629 %{_datadir}/%{name}/locales/en-US.pak
630 %dir %{_datadir}/%{name}/resources
631 %{_datadir}/%{name}/resources/inspector
632
633 %dir %{_libdir}/%{name}/plugins
634 %attr(755,root,root) %{_libdir}/%{name}/%{name}
635 # These unique permissions are intentional and necessary for the sandboxing
636 %attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
637
638 # ffmpeg libs
639 %if %{without system_ffmpeg}
640 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
641 %endif
642
643 %if %{with nacl}
644 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
645 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
646 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
647 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
648 %endif
649
650 %files l10n -f %{name}.lang
651 %defattr(644,root,root,755)
This page took 0.15868 seconds and 4 git commands to generate.