]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
- up to 14.0.834.0-0.93870
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_with     verbose         # verbose build (V=1)
4 %bcond_with     selinux         # with SELinux (need policy first)
5 %bcond_with     shared_libs     # with shared libs
6 %bcond_with     sse2            # use SSE2 instructions
7 %bcond_with     system_sqlite   # with system sqlite
8 %bcond_with     system_v8       # with system v8
9 %bcond_without  ffmpegsumo      # build with ffmpegsumo
10 %bcond_without  sandboxing      # with sandboxing
11 %bcond_without  system_zlib     # with system zlib
12 %bcond_without  keyring         # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
13 %bcond_without  debuginfo       # disable debuginfo creation (it is huge)
14
15 # TODO
16 # - check system sqlite linking problems
17
18 # NOTES:
19 # - mute BEEP mixer if you do not want to hear horrible system bell when
20 #   pressing home/end in url bar or more ^F search results on page.
21 # - build i686: -bp: ~570MB; bc: ~928MB; -bb: ~1.0GB
22 # - build x86_64: -bp: ~570MB; bc: ~990MB; -bb: ~1.0GB
23 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
24 # - to look for new tarball, use update-source.sh script
25
26 # NOTE TO USERS:
27 # To use chromium nightly builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
28 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
29 # or:
30 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
31
32 %define         svndate 20110725
33 %define         svnver  93870
34 %define         rel     1
35
36 Summary:        A WebKit powered web browser
37 Name:           chromium-browser
38 Version:        14.0.834.0
39 Release:        0.%{svnver}.%{rel}
40 License:        BSD, LGPL v2+ (ffmpeg)
41 Group:          X11/Applications/Networking
42 Source0:        http://ppa.launchpad.net/chromium-daily/ppa/ubuntu/pool/main/c/chromium-browser/%{name}_%{version}~svn%{svndate}r%{svnver}.orig.tar.gz
43 # Source0-md5:  7b04fbef67d5fff152a3f57b213aeb7a
44 Source2:        %{name}.sh
45 Source3:        %{name}.desktop
46 Source4:        find-lang.sh
47 Source5:        update-source.sh
48 Patch0:         system-libs.patch
49 Patch1:         plugin-searchdirs.patch
50 Patch2:         gyp-system-minizip.patch
51 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
52 # http://aur.archlinux.org/packages/chromium-browser-svn/chromium-browser-svn/search-workaround.patch
53 Patch4:         search-workaround.patch
54 Patch5:         options-support.patch
55 Patch6:         get-webkit_revision.patch
56 Patch7:         dlopen_sonamed_gl.patch
57 Patch8:         chromium_useragent.patch.in
58 URL:            http://code.google.com/chromium/
59 BuildRequires:  GConf2-devel
60 BuildRequires:  OpenGL-GLU-devel
61 BuildRequires:  alsa-lib-devel
62 BuildRequires:  atk-devel
63 BuildRequires:  bison
64 BuildRequires:  bzip2-devel
65 BuildRequires:  cups-devel
66 BuildRequires:  dbus-glib-devel
67 BuildRequires:  flex
68 BuildRequires:  fontconfig-devel
69 BuildRequires:  glib2-devel
70 BuildRequires:  gperf
71 BuildRequires:  gtk+2-devel
72 BuildRequires:  libevent-devel
73 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
74 BuildRequires:  libicu-devel >= 4.6
75 BuildRequires:  libjpeg-devel
76 BuildRequires:  libpng-devel
77 %{?with_selinux:BuildRequires:  libselinux-devel}
78 BuildRequires:  libstdc++-devel
79 BuildRequires:  libvpx-devel >= 0.9.5-2
80 BuildRequires:  libxml2-devel
81 BuildRequires:  libxslt-devel
82 BuildRequires:  lzma
83 BuildRequires:  minizip-devel
84 BuildRequires:  nspr-devel
85 BuildRequires:  nss-devel >= 1:3.12.3
86 BuildRequires:  pam-devel
87 BuildRequires:  pango-devel
88 BuildRequires:  perl-modules
89 BuildRequires:  pkgconfig
90 BuildRequires:  pulseaudio-devel
91 BuildRequires:  python
92 BuildRequires:  rpm >= 4.4.9-56
93 # grep googlecode_url.*gyp src/DEPS |cut -d'"' -f6 | cut -d@ -f2
94 BuildRequires:  python-gyp >= 1-840
95 BuildRequires:  python-modules
96 BuildRequires:  rpmbuild(macros) >= 1.453
97 BuildRequires:  sqlite3-devel >= 3.6.1
98 BuildRequires:  util-linux
99 %{?with_system_v8:BuildRequires:        v8-devel}
100 BuildRequires:  which
101 BuildRequires:  xorg-lib-libXScrnSaver-devel
102 BuildRequires:  xorg-lib-libXt-devel
103 BuildRequires:  xorg-lib-libXtst-devel
104 BuildRequires:  yasm
105 %{?with_system_zlib:BuildRequires:      zlib-devel}
106 Requires:       browser-plugins >= 2.0
107 Requires:       libvpx >= 0.9.5-2
108 Requires:       xdg-utils >= 1.0.2-4
109 Provides:       wwwbrowser
110 Obsoletes:      chromium-browser-bookmark_manager
111 ExclusiveArch:  %{ix86} %{x8664} arm
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         find_lang       sh find-lang.sh %{buildroot}
115
116 %if %{without debuginfo}
117 %define         _enable_debug_packages  0
118 %endif
119
120 %description
121 Chromium is an open-source browser project that aims to build a safer,
122 faster, and more stable way for all Internet users to experience the
123 web.
124
125 Chromium serves as a base for Google Chrome, which is Chromium
126 rebranded (name and logo) with very few additions such as usage
127 tracking and an auto-updater system.
128
129 %package inspector
130 Summary:        Page inspector for the chromium-browser
131 Group:          Development/Tools
132 Requires:       %{name} = %{version}-%{release}
133
134 %description inspector
135 Chromium is an open-source browser project that aims to build a safer,
136 faster, and more stable way for all Internet users to experience the
137 web.
138
139 This package contains 'inspector', allowing web developpers to inspect
140 any element of a web page at runtime (html, javascript, css, ..)
141
142 %package l10n
143 Summary:        chromium-browser language packages
144 Group:          I18n
145 Requires:       %{name} = %{version}-%{release}
146
147 %description l10n
148 Chromium is an open-source browser project that aims to build a safer,
149 faster, and more stable way for all Internet users to experience the
150 web.
151
152 This package contains language packages for 50 languages:
153
154 ar, bg, bn, ca, cs, da, de, el, en-GB, es-419, es, et, fi, fil, fr,
155 gu, he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or,
156 pl, pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi,
157 zh-CN, zh-TW
158
159 %prep
160 %setup -q -n %{name}-%{version}~svn%{svndate}r%{svnver}
161 lzma -dc %{name}-%{version}~svn%{svndate}r%{svnver}-source.tar.lzma | tar x
162 rm -f %{name}-%{version}~svn%{svndate}r%{svnver}-source.tar.lzma
163
164 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
165 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
166 . ./src/chrome/VERSION
167 ver=$MAJOR.$MINOR.$BUILD.$PATCH
168 if [ "$ver" != %{version} ]; then
169         exit 1
170 fi
171
172 # Populate the LASTCHANGE file template as we no longer have the VCS files at this point
173 echo "%{svnver}" > src/build/LASTCHANGE.in
174
175 # add chromium and pld to useragent
176 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
177 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
178     -e 's/@BUILD_DIST_NAME@/PLD/g' \
179     -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
180     < %{PATCH8} | %{__patch} -p1
181
182 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE4} > find-lang.sh
183
184 %patch0 -p1
185 %patch1 -p1
186 %patch2 -p1
187 %patch3 -p1
188 %patch4 -p1
189 %patch5 -p1
190 %patch6 -p1
191 %patch7 -p1
192
193 # drop bundled libs, from gentoo
194 remove_bundled_lib() {
195         echo "Removing bundled library $1 ..."
196         local out
197         out=$(find $1 -mindepth 1 ! -iname '*.gyp' -print -delete)
198         if [ -z "$out" ]; then
199                 echo >&2 "No files matched when removing bundled library $1"
200                 exit 1
201         fi
202 }
203
204 cd src
205 remove_bundled_lib "third_party/bzip2"
206 remove_bundled_lib "third_party/icu"
207 remove_bundled_lib "third_party/libevent"
208 remove_bundled_lib "third_party/libjpeg"
209 remove_bundled_lib "third_party/libpng"
210 # third_party/libvpx/libvpx.h should be kept
211 #remove_bundled_lib "third_party/libvpx"
212 remove_bundled_lib "third_party/libxml"
213 remove_bundled_lib "third_party/libxslt"
214 remove_bundled_lib "third_party/zlib"
215
216 %build
217 cd src
218 %{__python} build/gyp_chromium --format=make build/all.gyp \
219 %ifarch %{ix86}
220         -Dtarget_arch=ia32 \
221 %endif
222 %ifarch %{x8664}
223         -Dtarget_arch=x64 \
224 %endif
225 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
226         -Dno_strict_aliasing=1 -Dgcc_version=44 \
227 %endif
228 %if %{with sandboxing}
229         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
230         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
231 %endif
232         %{!?debug:-Dwerror=} \
233         %{!?debuginfo:-Dfastbuild=1} \
234         %{?with_shared_libs:-Dlibrary=shared_library} \
235         -Djavascript_engine=%{?with_system_v8:system-v8}%{!?with_system_v8:v8} \
236         -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
237         -Duse_system_bzip2=1 \
238         -Duse_system_icu=1 \
239         -Duse_system_libevent=1 \
240         -Duse_system_libjpeg=1 \
241         -Duse_system_libpng=1 \
242         -Duse_system_libxml=1 \
243         -Duse_system_libxslt=1 \
244         -Duse_system_sqlite=%{?with_system_sqlite:1}%{!?with_system_sqlite:0} \
245         -Duse_system_vpx=1 \
246         -Duse_system_xdg_utils=1 \
247         -Duse_system_yasm=1 \
248         -Duse_system_zlib=%{?with_system_zlib:1}%{!?with_system_zlib:0} \
249         -Dffmpeg_branding=Chrome \
250         -Dproprietary_codecs=1 \
251 %if %{with keyring}
252         -Duse_gnome_keyring=1 -Dlinux_link_gnome_keyring=0 \
253 %else
254         -Duse_gnome_keyring=0 \
255 %endif
256         %{!?with_sse2:-Ddisable_sse2=1} \
257 %if %{with selinux}
258         -Dselinux=1 \
259 %endif
260
261 %{__make} chrome %{?with_sandboxing:chrome_sandbox} \
262         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
263         %{?with_verbose:V=1} \
264         CC="%{__cc}" \
265         CXX="%{__cxx}" \
266         CC.host="%{__cc}" \
267         CXX.host="%{__cxx}" \
268         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
269         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
270
271 %install
272 rm -rf $RPM_BUILD_ROOT
273 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}/{themes,locales,plugins,extensions,resources},%{_mandir}/man1,%{_pixmapsdir},%{_desktopdir}}
274
275 cd src/out/%{!?debug:Release}%{?debug:Debug}
276 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
277 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
278 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
279 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
280 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
281 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
282 %if %{with ffmpegsumo}
283 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
284 %endif
285 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
286 cd -
287
288 cp -p src/chrome/app/theme/chromium/product_logo_48.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
289
290 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
291 # http://code.google.com/p/chromium/issues/detail?id=24507
292 gecko-mediaplayer*.so
293 EOF
294
295 # find locales
296 %find_lang %{name}.lang
297 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
298
299 %clean
300 rm -rf $RPM_BUILD_ROOT
301
302 %post
303 %update_browser_plugins
304
305 %postun
306 if [ "$1" = 0 ]; then
307         %update_browser_plugins
308 fi
309
310 %files -f %{name}.lang
311 %defattr(644,root,root,755)
312 %{_browserpluginsconfdir}/browsers.d/%{name}.*
313 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
314 %attr(755,root,root) %{_bindir}/%{name}
315 %{_mandir}/man1/%{name}.1*
316 %{_pixmapsdir}/%{name}.png
317 %{_desktopdir}/*.desktop
318 %dir %{_libdir}/%{name}
319 %{_libdir}/%{name}/chrome.pak
320 %{_libdir}/%{name}/resources.pak
321 %dir %{_libdir}/%{name}/locales
322 %{_libdir}/%{name}/locales/en-US.pak
323 %dir %{_libdir}/%{name}/resources
324 %dir %{_libdir}/%{name}/themes
325 %dir %{_libdir}/%{name}/extensions
326 %dir %{_libdir}/%{name}/plugins
327 %attr(755,root,root) %{_libdir}/%{name}/%{name}
328 # These unique permissions are intentional and necessary for the sandboxing
329 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
330
331 # ffmpeg libs
332 %if %{with ffmpegsumo}
333 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
334 %endif
335
336 %files inspector
337 %defattr(644,root,root,755)
338 %{_libdir}/%{name}/resources/inspector
339
340 %files l10n -f %{name}.lang
341 %defattr(644,root,root,755)
This page took 0.056751 seconds and 4 git commands to generate.