]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
- rel 2 (rebuild against new libevent)
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_with     verbose         # verbose build (V=1)
4 %bcond_with     selinux         # with SELinux (need policy first)
5 %bcond_with     shared_libs     # with shared libs
6 %bcond_with     sse2            # use SSE2 instructions
7 %bcond_with     system_sqlite   # with system sqlite
8 %bcond_with     system_v8       # with system v8
9 %bcond_without  ffmpegsumo      # build with ffmpegsumo
10 %bcond_without  sandboxing      # with sandboxing
11 %bcond_without  system_zlib     # with system zlib
12 %bcond_without  debuginfo       # disable debuginfo creation (it is huge)
13
14 # TODO
15 # - check system sqlite linking problems
16
17 # NOTES:
18 # - mute BEEP mixer if you do not want to hear horrible system bell when
19 #   pressing home/end in url bar or more ^F search results on page.
20 # - build i686: -bp: ~570MB; bc: ~928MB; -bb: ~1.0GB
21 # - build x86_64: -bp: ~570MB; bc: ~990MB; -bb: ~1.0GB
22 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
23 # - to look for new tarball, use update-source.sh script
24
25 # NOTE TO USERS:
26 # To use chromium nightly builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
27 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
28 # or:
29 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
30
31 %define         svndate 20110216
32 %define         svnver  75059
33 %define         rel     2
34
35 Summary:        A WebKit powered web browser
36 Name:           chromium-browser
37 Version:        11.0.673.0
38 Release:        0.%{svnver}.%{rel}
39 License:        BSD, LGPL v2+ (ffmpeg)
40 Group:          X11/Applications/Networking
41 Source0:        http://ppa.launchpad.net/chromium-daily/ppa/ubuntu/pool/main/c/chromium-browser/%{name}_%{version}~svn%{svndate}r%{svnver}.orig.tar.gz
42 # Source0-md5:  41504d0065f4fc7f2b95688b69e2abde
43 Source2:        %{name}.sh
44 Source3:        %{name}.desktop
45 Source4:        find-lang.sh
46 Source5:        update-source.sh
47 Patch0:         system-libs.patch
48 Patch1:         plugin-searchdirs.patch
49 Patch2:         gyp-system-minizip.patch
50 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch.diff
51 # http://aur.archlinux.org/packages/chromium-browser-svn/chromium-browser-svn/search-workaround.patch
52 Patch4:         search-workaround.patch
53 Patch5:         options-support.patch
54 Patch6:         get-webkit_revision.patch
55 Patch7:         chromium-system-vpx.patch
56 URL:            http://code.google.com/chromium/
57 BuildRequires:  GConf2-devel
58 BuildRequires:  OpenGL-GLU-devel
59 BuildRequires:  alsa-lib-devel
60 BuildRequires:  atk-devel
61 BuildRequires:  bison
62 BuildRequires:  bzip2-devel
63 BuildRequires:  cups-devel
64 BuildRequires:  dbus-glib-devel
65 BuildRequires:  flex
66 BuildRequires:  fontconfig-devel
67 BuildRequires:  glib2-devel
68 BuildRequires:  gperf
69 BuildRequires:  gtk+2-devel
70 BuildRequires:  libevent-devel
71 BuildRequires:  libgnome-keyring-devel
72 BuildRequires:  libjpeg-devel
73 BuildRequires:  libpng-devel
74 %{?with_selinux:BuildRequires:  libselinux-devel}
75 BuildRequires:  libstdc++-devel
76 BuildRequires:  libvpx-devel >= 0.9.5-2
77 BuildRequires:  libxml2-devel
78 BuildRequires:  libxslt-devel
79 BuildRequires:  lzma
80 BuildRequires:  minizip-devel
81 BuildRequires:  nspr-devel
82 BuildRequires:  nss-devel >= 1:3.12.3
83 BuildRequires:  pango-devel
84 BuildRequires:  perl-modules
85 BuildRequires:  pkgconfig
86 BuildRequires:  python
87 # grep gyp.googlecode.com src/DEPS | cut -d'"' -f2 | cut -d@ -f2
88 BuildRequires:  python-gyp >= 1-840
89 BuildRequires:  python-modules
90 BuildRequires:  rpmbuild(macros) >= 1.453
91 BuildRequires:  sqlite3-devel >= 3.6.1
92 BuildRequires:  util-linux
93 %{?with_system_v8:BuildRequires:        v8-devel}
94 BuildRequires:  which
95 BuildRequires:  xorg-lib-libXScrnSaver-devel
96 BuildRequires:  xorg-lib-libXt-devel
97 BuildRequires:  xorg-lib-libXtst-devel
98 BuildRequires:  yasm
99 %{?with_system_zlib:BuildRequires:      zlib-devel}
100 Requires:       browser-plugins >= 2.0
101 Requires:       libvpx >= 0.9.5-2
102 Requires:       xdg-utils >= 1.0.2-4
103 Provides:       wwwbrowser
104 Obsoletes:      chromium-browser-bookmark_manager
105 ExclusiveArch:  %{ix86} %{x8664} arm
106 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
108 %define         find_lang       sh find-lang.sh %{buildroot}
109
110 %if %{without debuginfo}
111 %define         _enable_debug_packages  0
112 %endif
113
114 %description
115 Chromium is an open-source browser project that aims to build a safer,
116 faster, and more stable way for all Internet users to experience the
117 web.
118
119 Chromium serves as a base for Google Chrome, which is Chromium
120 rebranded (name and logo) with very few additions such as usage
121 tracking and an auto-updater system.
122
123 This package contains the Chromium browser.
124
125 %package inspector
126 Summary:        Page inspector for the chromium-browser
127 Group:          Development/Tools
128 Requires:       %{name} = %{version}-%{release}
129
130 %description inspector
131 Chromium is an open-source browser project that aims to build a safer,
132 faster, and more stable way for all Internet users to experience the
133 web.
134
135 This package contains 'inspector', allowing web developpers to inspect
136 any element of a web page at runtime (html, javascript, css, ..)
137
138 %package l10n
139 Summary:        chromium-browser language packages
140 Group:          I18n
141 Requires:       %{name} = %{version}-%{release}
142
143 %description l10n
144 Chromium is an open-source browser project that aims to build a safer,
145 faster, and more stable way for all Internet users to experience the
146 web.
147
148 This package contains language packages for 50 languages:
149
150 ar, bg, bn, ca, cs, da, de, el, en-GB, es-419, es, et, fi, fil, fr,
151 gu, he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or,
152 pl, pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi,
153 zh-CN, zh-TW
154
155 %prep
156 %setup -q -n %{name}-%{version}~svn%{svndate}r%{svnver}
157 lzma -dc %{name}-%{version}~svn%{svndate}r%{svnver}-source.tar.lzma | tar x
158 rm -f %{name}-%{version}~svn%{svndate}r%{svnver}-source.tar.lzma
159
160 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
161 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
162 . ./src/chrome/VERSION
163 ver=$MAJOR.$MINOR.$BUILD.$PATCH
164 if [ "$ver" != %{version} ]; then
165         exit 1
166 fi
167
168 # Populate the LASTCHANGE file template as we no longer have the VCS files at this point
169 echo "%{svnver}" > src/build/LASTCHANGE.in
170
171 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE4} > find-lang.sh
172
173 %patch0 -p1
174 %patch1 -p1
175 %patch2 -p1
176 %patch3 -p0
177 %patch4 -p1
178 %patch5 -p1
179 %patch6 -p1
180 cd src
181 %patch7 -p0
182 cd ..
183
184 # drop bundled libs, from gentoo
185 remove_bundled_lib() {
186         echo "Removing bundled library $1 ..."
187         local out
188         out=$(find $1 -mindepth 1 ! -iname '*.gyp' -print -delete)
189         if [ -z "$out" ]; then
190                 echo >&2 "No files matched when removing bundled library $1"
191                 exit 1
192         fi
193 }
194
195 cd src
196 remove_bundled_lib "third_party/bzip2"
197 remove_bundled_lib "third_party/libevent"
198 remove_bundled_lib "third_party/libjpeg"
199 remove_bundled_lib "third_party/libpng"
200 remove_bundled_lib "third_party/libvpx"
201 remove_bundled_lib "third_party/libxml"
202 remove_bundled_lib "third_party/libxslt"
203 remove_bundled_lib "third_party/zlib"
204
205 %build
206 cd src
207 %{__python} build/gyp_chromium --format=make build/all.gyp \
208 %ifarch %{ix86}
209         -Dtarget_arch=ia32 \
210 %endif
211 %ifarch %{x8664}
212         -Dtarget_arch=x64 \
213 %endif
214 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
215         -Dno_strict_aliasing=1 -Dgcc_version=44 \
216 %endif
217 %if %{with sandboxing}
218         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
219         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
220 %endif
221         %{!?debug:-Dwerror=} \
222         %{!?debuginfo:-Dfastbuild=1} \
223         %{?with_shared_libs:-Dlibrary=shared_library} \
224         -Djavascript_engine=%{?with_system_v8:system-v8}%{!?with_system_v8:v8} \
225         -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
226         -Duse_system_bzip2=1 \
227         -Duse_system_libevent=1 \
228         -Duse_system_libjpeg=1 \
229         -Duse_system_libpng=1 \
230         -Duse_system_libxml=1 \
231         -Duse_system_libxslt=1 \
232         -Duse_system_sqlite=%{?with_system_sqlite:1}%{!?with_system_sqlite:0} \
233         -Duse_system_zlib=%{?with_system_zlib:1}%{!?with_system_zlib:0} \
234         -Duse_system_vpx=1 \
235         -Duse_system_yasm=1 \
236         -Dffmpeg_branding=Chrome \
237         -Dproprietary_codecs=1 \
238         %{!?with_sse2:-Ddisable_sse2=1} \
239 %if %{with selinux}
240         -Dselinux=1 \
241 %endif
242
243 %{__make} chrome %{?with_sandboxing:chrome_sandbox} \
244         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
245         %{?with_verbose:V=1} \
246         CC="%{__cc}" \
247         CXX="%{__cxx}" \
248         CC.host="%{__cc}" \
249         CXX.host="%{__cxx}" \
250         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
251         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
252
253 %install
254 rm -rf $RPM_BUILD_ROOT
255 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}/{themes,locales,plugins,extensions,resources},%{_mandir}/man1,%{_pixmapsdir},%{_desktopdir}}
256
257 cd src/out/%{!?debug:Release}%{?debug:Debug}
258
259 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
260 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
261 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
262 cp -a chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
263 cp -a product_logo_48.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
264 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
265 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
266 %if %{with ffmpegsumo}
267 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
268 %endif
269 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
270 cd -
271
272 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
273 # http://code.google.com/p/chromium/issues/detail?id=24507
274 gecko-mediaplayer*.so
275 EOF
276
277 # find locales
278 %find_lang %{name}.lang
279 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
280
281 %clean
282 rm -rf $RPM_BUILD_ROOT
283
284 %post
285 %update_browser_plugins
286
287 %postun
288 if [ "$1" = 0 ]; then
289         %update_browser_plugins
290 fi
291
292 %files -f %{name}.lang
293 %defattr(644,root,root,755)
294 %{_browserpluginsconfdir}/browsers.d/%{name}.*
295 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
296 %attr(755,root,root) %{_bindir}/%{name}
297 %{_mandir}/man1/%{name}.1*
298 %{_pixmapsdir}/%{name}.png
299 %{_desktopdir}/*.desktop
300 %dir %{_libdir}/%{name}
301 %{_libdir}/%{name}/chrome.pak
302 %{_libdir}/%{name}/resources.pak
303 %dir %{_libdir}/%{name}/locales
304 %{_libdir}/%{name}/locales/en-US.pak
305 %dir %{_libdir}/%{name}/resources
306 %dir %{_libdir}/%{name}/themes
307 %dir %{_libdir}/%{name}/extensions
308 %dir %{_libdir}/%{name}/plugins
309 %attr(755,root,root) %{_libdir}/%{name}/%{name}
310 # These unique permissions are intentional and necessary for the sandboxing
311 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
312
313 # ffmpeg libs
314 %if %{with ffmpegsumo}
315 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
316 %endif
317
318 %files inspector
319 %defattr(644,root,root,755)
320 %{_libdir}/%{name}/resources/inspector
321
322 %files l10n -f %{name}.lang
323 %defattr(644,root,root,755)
This page took 0.060965 seconds and 4 git commands to generate.