]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
- up to 18.0.1025.162
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
4 %bcond_without  ffmpegsumo              # build with ffmpegsumo
5 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
6 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
7 %bcond_without  cups                    # with cups
8 %bcond_without  gconf                   # with GConf
9 %bcond_without  pulseaudio              # with pulseaudio
10 %bcond_with             nacl                    # build Native Client support
11 %bcond_without  sandboxing              # with sandboxing
12 %bcond_with             selinux                 # with SELinux (need policy first)
13 %bcond_with             shared_libs             # with shared libs
14 %bcond_with             sse2                    # use SSE2 instructions
15 %bcond_with             system_sqlite   # with system sqlite
16 %bcond_without  system_flac             # with system flac
17 %bcond_without  system_libwebp  # with system libwebp
18 %bcond_without  system_speex    # with system speex
19 %bcond_with             system_v8               # with system v8
20 %bcond_without  system_vpx              # with system vpx
21 %bcond_without  system_yasm             # with system yasm
22 %bcond_without  system_zlib             # with system zlib
23 %bcond_without  libjpegturbo            # use libjpeg-turbo features
24 %bcond_with             verbose                 # verbose build (V=1)
25
26 # TODO
27 # - check system sqlite linking problems
28 # - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
29 # - use_system_ssl (use_openssl: http://crbug.com/62803)
30 # - use_system_ffmpeg && build_ffmpegsumo
31 # - use_system_hunspell
32 # - use_system_stlport
33 # - other defaults: src/build/common.gypi
34
35 # NOTES:
36 # - mute BEEP mixer if you do not want to hear horrible system bell when
37 #   pressing home/end in url bar or more ^F search results on page.
38 # - build -bp: 1.2G
39 # - build i686: -bc: 2.7G; -bb: ~1.0GB
40 # - build x86_64: ~1.9G
41 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
42 # - to look for new tarball, use update-source.sh script
43
44 # NOTE TO USERS:
45 # To use chromium nightly builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
46 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
47 # or:
48 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
49
50 %define         gyp_rev 1014
51 Summary:        A WebKit powered web browser
52 Name:           chromium-browser
53 Version:        18.0.1025.162
54 Release:        1
55 License:        BSD, LGPL v2+ (ffmpeg)
56 Group:          X11/Applications/Networking
57 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.tar.xz
58 # Source0-md5:  189c506b33faeecf2c80617b170201b8
59 Source2:        %{name}.sh
60 Source3:        %{name}.desktop
61 Source5:        find-lang.sh
62 Source6:        update-source.sh
63 Source7:        clean-source.sh
64 Source8:        get-source.sh
65 Patch0:         system-libs.patch
66 Patch1:         plugin-searchdirs.patch
67 Patch2:         gyp-system-minizip.patch
68 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
69 Patch5:         options-support.patch
70 Patch6:         get-webkit_revision.patch
71 Patch7:         dlopen_sonamed_gl.patch
72 Patch8:         chromium_useragent.patch.in
73 Patch9:         system-expat.patch
74 Patch10:        %{name}-pulse.patch
75 # https://bugs.gentoo.org/show_bug.cgi?id=393471
76 # libjpeg-turbo >= 1.1.90 supports that feature
77 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
78 Patch12:        chromium-glib.patch
79 URL:            http://www.chromium.org/Home
80 %{?with_gconf:BuildRequires:    GConf2-devel}
81 BuildRequires:  OpenGL-GLU-devel
82 BuildRequires:  alsa-lib-devel
83 BuildRequires:  atk-devel
84 BuildRequires:  bison
85 BuildRequires:  bzip2-devel
86 %{?with_cups:BuildRequires:     cups-devel}
87 BuildRequires:  dbus-glib-devel
88 BuildRequires:  expat-devel
89 %{?with_system_flac:BuildRequires:      flac-devel}
90 BuildRequires:  flex
91 BuildRequires:  fontconfig-devel
92 BuildRequires:  glib2-devel
93 BuildRequires:  gperf
94 BuildRequires:  gtk+2-devel
95 %{?with_kerberos:BuildRequires: heimdal-devel}
96 BuildRequires:  hicolor-icon-theme
97 BuildRequires:  libevent-devel
98 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
99 BuildRequires:  libicu-devel >= 4.6
100 BuildRequires:  libjpeg-devel
101 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
102 BuildRequires:  libpng-devel
103 %{?with_selinux:BuildRequires:  libselinux-devel}
104 BuildRequires:  libstdc++-devel
105 %{?with_system_vpx:BuildRequires:       libvpx-devel >= 0.9.5-2}
106 %{?with_system_libwebp:BuildRequires:   libwebp-devel}
107 BuildRequires:  libxml2-devel
108 BuildRequires:  libxslt-devel
109 BuildRequires:  lzma
110 BuildRequires:  minizip-devel
111 %{?with_nacl:BuildRequires:     nacl-toolchain-newlib >= 0.6941}
112 BuildRequires:  nspr-devel
113 BuildRequires:  nss-devel >= 1:3.12.3
114 BuildRequires:  pam-devel
115 BuildRequires:  pango-devel
116 BuildRequires:  perl-modules
117 BuildRequires:  pkgconfig
118 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
119 BuildRequires:  python
120 #BuildRequires: python-gyp >= 1-%{gyp_rev}
121 BuildRequires:  python-modules
122 BuildRequires:  rpm >= 4.4.9-56
123 BuildRequires:  rpmbuild(macros) >= 1.453
124 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
125 BuildRequires:  sqlite3-devel >= 3.6.1
126 BuildRequires:  tar >= 1:1.22
127 BuildRequires:  util-linux
128 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
129 BuildRequires:  which
130 BuildRequires:  xorg-lib-libXScrnSaver-devel
131 BuildRequires:  xorg-lib-libXt-devel
132 BuildRequires:  xorg-lib-libXtst-devel
133 BuildRequires:  xz
134 %{?with_system_yasm:BuildRequires:      yasm}
135 %{?with_system_zlib:BuildRequires:      zlib-devel}
136 Requires:       browser-plugins >= 2.0
137 Requires:       desktop-file-utils
138 Requires:       hicolor-icon-theme
139 %{?with_system_vpx:Requires:    libvpx >= 0.9.5-2}
140 Requires:       xdg-utils >= 1.0.2-4
141 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
142 Provides:       wwwbrowser
143 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
144 Obsoletes:      chromium-browser-inspector < 15.0.863.0
145 ExclusiveArch:  %{ix86} %{x8664} arm
146 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
147
148 %define         find_lang       sh find-lang.sh %{buildroot}
149 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
150 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
151
152 %if %{without debuginfo}
153 %define         _enable_debug_packages  0
154 %endif
155
156 %description
157 Chromium is an open-source browser project that aims to build a safer,
158 faster, and more stable way for all Internet users to experience the
159 web.
160
161 Chromium serves as a base for Google Chrome, which is Chromium
162 rebranded (name and logo) with very few additions such as usage
163 tracking and an auto-updater system.
164
165 %package l10n
166 Summary:        chromium-browser language packages
167 Group:          I18n
168 Requires:       %{name} = %{version}-%{release}
169
170 %description l10n
171 Chromium is an open-source browser project that aims to build a safer,
172 faster, and more stable way for all Internet users to experience the
173 web.
174
175 This package contains language packages for 50 languages:
176
177 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
178 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
179 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
180 zh-TW
181
182 %prep
183 %setup -q
184
185 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
186 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
187 . ./src/chrome/VERSION
188 ver=$MAJOR.$MINOR.$BUILD.$PATCH
189 test "$ver" = %{version}
190
191 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
192 test "$gyp_rev" = %{gyp_rev} || :
193
194 v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
195
196 # Populate the LASTCHANGE file template as we no longer have the VCS files at this point
197 #echo "%{svnver}" > src/build/LASTCHANGE.in
198
199 # add chromium and pld to useragent
200 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
201 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
202     -e 's/@BUILD_DIST_NAME@/PLD/g' \
203     -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
204     < %{PATCH8} | %{__patch} -p1
205
206 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
207 ln -s %{SOURCE7} src
208
209 %patch0 -p1
210 %patch1 -p1
211 %patch2 -p1
212 %patch3 -p1
213 %patch5 -p1
214 %patch6 -p1
215 %patch7 -p1
216 cd src
217 %patch9 -p1
218 %patch10 -p1
219 %{!?with_libjpegturbo:%patch11 -p0}
220 %patch12 -p3
221 cd ..
222
223 cd src
224 sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0}
225
226 %build
227 cd src
228 test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
229 %ifarch %{ix86}
230         -Dtarget_arch=ia32 \
231 %endif
232 %ifarch %{x8664}
233         -Dtarget_arch=x64 \
234 %endif
235 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
236         -Dno_strict_aliasing=1 -Dgcc_version=44 \
237 %endif
238 %if %{with sandboxing}
239         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
240         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
241 %endif
242         %{!?debug:-Dwerror=} \
243         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
244         %{?with_shared_libs:-Dlibrary=shared_library} \
245         -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
246         -Dffmpeg_branding=Chrome \
247         -Dproprietary_codecs=1 \
248         %{!?with_nacl:-Ddisable_nacl=1} \
249         %{!?with_sse2:-Ddisable_sse2=1} \
250         %{?with_selinux:-Dselinux=1} \
251         %{gyp_with cups} \
252         %{gyp_with flac} \
253         %{gyp_with gconf} \
254         %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
255         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
256         %{gyp_with pulseaudio} \
257         %{gyp_with system_libwebp} \
258         %{gyp_with system_speex} \
259         %{gyp_with system_sqlite} \
260         %{gyp_with system_v8} \
261         %{gyp_with system_vpx} \
262         %{gyp_with system_yasm} \
263         %{gyp_with system_zlib} \
264         -Duse_system_bzip2=1 \
265         -Duse_system_icu=1 \
266         -Duse_system_libevent=1 \
267         -Duse_system_libjpeg=1 \
268         -Duse_system_libpng=1 \
269         -Duse_system_libxml=1 \
270         -Duse_system_libxslt=1 \
271         -Duse_system_xdg_utils=1 \
272
273 %{__make} chrome %{?with_sandboxing:chrome_sandbox} \
274         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
275         %{?with_verbose:V=1} \
276         CC="%{__cc}" \
277         CXX="%{__cxx}" \
278         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
279         CC.host="%{__cc}" \
280         CXX.host="%{__cxx}" \
281         LDFLAGS.host="%{rpmldflags}" \
282         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
283         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
284
285 %install
286 rm -rf $RPM_BUILD_ROOT
287 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
288         $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}}
289
290 cd src/out/%{!?debug:Release}%{?debug:Debug}
291 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
292 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
293 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
294 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
295 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
296 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
297 %if %{with ffmpegsumo}
298 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
299 %endif
300 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
301
302 %if %{with nacl}
303 # Install Native Client files on platforms that support it.
304 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
305 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
306 %ifarch %{x8664}
307 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
308 %endif
309 %ifarch %{ix86}
310 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
311 %endif
312 %endif
313
314 cd -
315
316 for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
317         size=${icon##*/product_logo_}
318         size=${size%.png}
319
320         # this will skip non-numeric (22_mono_invert, 22_mono)
321         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
322         test -d "$dir" || continue
323
324         install -d $RPM_BUILD_ROOT$dir
325         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
326 done
327
328 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
329 # http://code.google.com/p/chromium/issues/detail?id=24507
330 gecko-mediaplayer*.so
331 EOF
332
333 # find locales
334 %find_lang %{name}.lang
335 # always package en-US
336 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
337
338 %clean
339 rm -rf $RPM_BUILD_ROOT
340
341 %post
342 %update_icon_cache hicolor
343 %update_desktop_database
344 %update_browser_plugins
345
346 %postun
347 if [ "$1" = 0 ]; then
348         %update_icon_cache hicolor
349         %update_browser_plugins
350 fi
351
352 %files -f %{name}.lang
353 %defattr(644,root,root,755)
354 %{_browserpluginsconfdir}/browsers.d/%{name}.*
355 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
356 %attr(755,root,root) %{_bindir}/%{name}
357 %{_mandir}/man1/%{name}.1*
358 %{_desktopdir}/*.desktop
359 %{_iconsdir}/hicolor/*/apps/%{name}.png
360 %dir %{_libdir}/%{name}
361 %{_libdir}/%{name}/chrome.pak
362 %{_libdir}/%{name}/content_resources.pak
363 %{_libdir}/%{name}/resources.pak
364 %dir %{_libdir}/%{name}/locales
365 %{_libdir}/%{name}/locales/en-US.pak
366 %dir %{_libdir}/%{name}/resources
367 %{_libdir}/%{name}/resources/inspector
368 %dir %{_libdir}/%{name}/themes
369 %dir %{_libdir}/%{name}/extensions
370 %dir %{_libdir}/%{name}/plugins
371 %attr(755,root,root) %{_libdir}/%{name}/%{name}
372 # These unique permissions are intentional and necessary for the sandboxing
373 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
374
375 # ffmpeg libs
376 %if %{with ffmpegsumo}
377 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
378 %endif
379
380 %if %{with nacl}
381 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
382 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
383 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
384 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
385 %endif
386
387 %files l10n -f %{name}.lang
388 %defattr(644,root,root,755)
This page took 0.048223 seconds and 4 git commands to generate.