]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
disable debuginfo on x64_86 as well
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_with     dev                     # with dev optimizations (skip clean source)
6 %bcond_without  gconf                   # with GConf
7 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
8 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
9 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
10 %bcond_without  libjpegturbo    # use libjpeg-turbo features
11 %bcond_with     nacl                    # build Native Client support, disabled: http://crbug.com/269560
12 %bcond_without  ninja                   # use Ninja instead of make to build
13 %bcond_without  pulseaudio              # with pulseaudio
14 %bcond_without  sandboxing              # with sandboxing
15 %bcond_with             selinux                 # with SELinux (need policy first)
16 %bcond_with             shared_libs             # with shared libs
17 %bcond_with             sse2                    # use SSE2 instructions
18 %bcond_without  system_flac             # system flac
19 %bcond_with     system_ffmpeg   # system ffmpeg instead of ffmpegsumo
20 %bcond_without  system_harfbuzz # system harfbuzz
21 %bcond_without  system_jsoncpp  # system jsoncpp
22 %bcond_without  system_libexif  # system libexif
23 %bcond_without  system_libmtp   # system libmtp
24 %bcond_with     system_libusb   # system libusb-1, disabled: http://crbug.com/266149
25 %bcond_without  system_libwebp  # system libwebp
26 %bcond_without  system_libxnvctrl       # system libxnvctrl
27 %bcond_with     system_mesa             # system Mesa
28 %bcond_without  system_minizip  # system minizip
29 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
30 %bcond_without  system_protobuf # system protobuf
31 %bcond_without  system_re2              # system re2
32 %bcond_without  system_snappy   # system snappy
33 %bcond_without  system_speex    # system speex
34 %bcond_with     system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
35 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
36 %bcond_with             system_v8               # system v8
37 %bcond_with     system_libvpx   # system libvpx
38 %bcond_without  system_yasm             # system yasm
39 %bcond_without  system_zlib             # system zlib
40 %bcond_with     tcmalloc                # use tcmalloc
41 %bcond_without  verbose                 # verbose build (V=1)
42
43 %ifarch %{ix86}
44 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
45 %undefine       with_system_mesa
46
47 # unable build with debuginfo on 32bit build systems
48 # /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
49 %undefine       with_debuginfo
50 %endif
51
52 %ifarch %{x8664}
53 # x86_64 systems fail with debugedit crashing
54 # /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
55 %undefine       with_debuginfo
56 %endif
57
58 # TODO
59 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
60 # - use_system_skia
61 # - use_system_ssl (use_openssl: http://crbug.com/62803)
62 # - use_system_stlport (android specific)
63 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
64
65 # NOTES:
66 # - mute BEEP mixer if you do not want to hear horrible system bell when
67 #   pressing home/end in url bar or more ^F search results on page.
68 # - space considerations:
69 #   - unpacked sources: ~490MiB
70 #   - built code: ~1.4GiB (x86_64/i686)
71 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
72 # - to look for new tarball, use update-source.sh script
73
74 %define         branch          38.0.2125
75 %define         basever         101
76 #define         patchver        132
77 %define         gyp_rev 1014
78 Summary:        A WebKit powered web browser
79 Name:           chromium-browser
80 %if "%{?patchver}" != ""
81 Version:        %{branch}.%{patchver}
82 %else
83 Version:        %{branch}.%{basever}
84 %endif
85 Release:        1
86 License:        BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
87 Group:          X11/Applications/Networking
88 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
89 # Source0-md5:  f2ec6a50864d8b2ddcda0baef50e9c33
90 %if "%{?patchver}" != ""
91 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
92 # Patch0-md5:   4eafe1e64bd47a11dbfaf61a2dd50b6e
93 %endif
94 Source1:        %{name}.default
95 Source2:        %{name}.sh
96 Source3:        %{name}.desktop
97 Source5:        find-lang.sh
98 Source6:        update-source.sh
99 Source7:        clean-source.sh
100 Source8:        get-source.sh
101 Source9:        master_preferences.json
102 Patch2:         enable-video-decode-accel.patch
103 Patch4:         path-libpdf.patch
104 Patch7:         dlopen_sonamed_gl.patch
105 Patch8:         chromium_useragent.patch.in
106 # https://bugs.gentoo.org/show_bug.cgi?id=393471
107 # libjpeg-turbo >= 1.1.90 supports that feature
108 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
109 Patch15:        nacl-build-irt.patch
110 Patch16:        nacl-linkingfix.patch
111 Patch18:        nacl-no-untar.patch
112 Patch24:        nacl-verbose.patch
113 Patch25:        gnome3-volume-control.patch
114 Patch26:        master-prefs-path.patch
115 Patch28:        system-mesa.patch
116 Patch30:        system-ply.patch
117 Patch31:        system-jinja.patch
118 Patch32:        remove_bundled_libraries-stale.patch
119 Patch35:        etc-dir.patch
120 Patch36:        angle.patch
121 URL:            http://www.chromium.org/Home
122 %{?with_gconf:BuildRequires:    GConf2-devel}
123 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
124 BuildRequires:  Mesa-libGLES-devel >= 9.1
125 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
126 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
127 BuildRequires:  alsa-lib-devel
128 BuildRequires:  atk-devel
129 BuildRequires:  bison
130 BuildRequires:  bzip2-devel
131 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
132 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
133 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
134 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
135 %{?with_cups:BuildRequires:     cups-devel}
136 BuildRequires:  elfutils-devel
137 BuildRequires:  expat-devel
138 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
139 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
140 BuildRequires:  fontconfig-devel
141 BuildRequires:  glib2-devel
142 BuildRequires:  gperf
143 %{?with_gps:BuildRequires:      gpsd-devel}
144 BuildRequires:  gtest-devel
145 BuildRequires:  gtk+2-devel
146 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
147 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-icu-devel}
148 %{?with_kerberos:BuildRequires: heimdal-devel}
149 BuildRequires:  hicolor-icon-theme
150 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
151 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
152 BuildRequires:  libevent-devel
153 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
154 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
155 BuildRequires:  libicu-devel >= 4.6
156 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
157 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
158 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
159 BuildRequires:  libpng-devel
160 %{?with_selinux:BuildRequires:  libselinux-devel}
161 BuildRequires:  libstdc++-devel
162 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
163 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 1.3.0}
164 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.4.0}
165 BuildRequires:  libxml2-devel
166 BuildRequires:  libxslt-devel
167 BuildRequires:  man-db
168 %{?with_system_minizip:BuildRequires:   minizip-devel}
169 %{?with_ninja:BuildRequires:    ninja >= 1.3.0}
170 BuildRequires:  nspr-devel
171 BuildRequires:  nss-devel >= 1:3.12.3
172 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
173 BuildRequires:  pam-devel
174 BuildRequires:  pango-devel
175 BuildRequires:  pciutils-devel
176 BuildRequires:  perl-JSON
177 BuildRequires:  perl-modules
178 BuildRequires:  pkgconfig
179 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
180 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
181 BuildRequires:  python
182 #BuildRequires: python-gyp >= 1-%{gyp_rev}
183 BuildRequires:  python-jinja2 >= 2.7
184 BuildRequires:  python-modules
185 BuildRequires:  python-ply >= 3.4
186 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
187 BuildRequires:  rpm >= 4.4.9-56
188 BuildRequires:  rpmbuild(macros) >= 1.453
189 %{?with_system_snappy:BuildRequires:    snappy-devel}
190 BuildRequires:  speech-dispatcher-devel >= 0.8
191 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
192 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
193 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
194 BuildRequires:  tar >= 1:1.22
195 BuildRequires:  udev-devel
196 BuildRequires:  usbutils
197 BuildRequires:  util-linux
198 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
199 BuildRequires:  which
200 BuildRequires:  xorg-lib-libXScrnSaver-devel
201 BuildRequires:  xorg-lib-libXtst-devel
202 BuildRequires:  xz
203 %{?with_system_yasm:BuildRequires:      yasm}
204 %{?with_system_zlib:BuildRequires:      zlib-devel}
205 Requires:       browser-plugins >= 2.0
206 Requires:       desktop-file-utils
207 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
208 # crashes if no fontconfig font present
209 Requires:       fonts-Type1-urw
210 Requires:       hicolor-icon-theme
211 Requires:       libevent >= 2.0.21
212 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
213 %{?with_system_libvpx:Requires: libvpx >= 1.3.0}
214 Requires:       lsb-release
215 %{?with_system_re2:Requires:    re2 >= 20130115-2}
216 %{?with_system_protobuf:Requires:       protobuf-libs >= 2.5.0-2}
217 Requires:       shared-mime-info
218 %{?with_system_sqlite:Requires: sqlite3(icu)}
219 Requires:       xdg-utils >= 1.0.2-4
220 Requires:       xorg-lib-libX11 >= 1.4.99.1
221 Provides:       wwwbrowser
222 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
223 Obsoletes:      chromium-browser-inspector < 15.0.863.0
224 ExclusiveArch:  %{ix86} %{x8664} arm
225 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
226
227 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
228 # Note: these are for PLD Linux use ONLY.
229 # For your own distribution, please get your own set of keys.
230 %define         google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
231 %define         google_default_client_id 724288223830.apps.googleusercontent.com
232 %define         google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
233
234 %define         find_lang       sh find-lang.sh %{buildroot}
235
236 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
237 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
238
239 %ifarch %{ix86}
240 %define         target_arch ia32
241 %endif
242 %ifarch %{x8664}
243 %define         target_arch x64
244 %endif
245
246 %define         buildtype       %{?debug:Debug}%{!?debug:Release}
247 %define         builddir        out/%{buildtype}
248
249 %if %{without debuginfo}
250 %define         _enable_debug_packages  0
251 %endif
252
253 %description
254 Chromium is an open-source browser project that aims to build a safer,
255 faster, and more stable way for all Internet users to experience the
256 web.
257
258 Chromium serves as a base for Google Chrome, which is Chromium
259 rebranded (name and logo) with very few additions such as usage
260 tracking and an auto-updater system.
261
262 %package l10n
263 Summary:        chromium-browser language packages
264 Group:          I18n
265 Requires:       %{name} = %{version}-%{release}
266 %if "%{_rpmversion}" >= "5"
267 BuildArch:      noarch
268 %endif
269
270 %description l10n
271 Chromium is an open-source browser project that aims to build a safer,
272 faster, and more stable way for all Internet users to experience the
273 web.
274
275 This package contains language packages for 50 languages:
276
277 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
278 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
279 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
280 zh-TW
281
282 %prep
283 %setup -qc
284 %if "%{?patchver}" != ""
285 cd chromium*-%{branch}.%{basever}
286 %patch0 -p1
287 cd ..
288 %endif
289 mv chromium*-%{branch}.%{basever}/* .
290
291 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
292 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
293 . ./chrome/VERSION
294 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
295 test "$chrome" = %{version}
296
297 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
298 test "$gyp_rev" = %{gyp_rev} || :
299
300 # add chromium and pld to useragent
301 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
302 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
303         -e 's/@BUILD_DIST_NAME@/PLD/g' \
304         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
305         < %{PATCH8} | %{__patch} -p1
306
307 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
308 ln -s %{SOURCE7} .
309
310 #%patch2 -p1 NOT COMPILING
311 %patch4 -p3
312 %patch7 -p1
313 %patch15 -p2
314 %{!?with_libjpegturbo:%patch11 -p0}
315 %patch16 -p1
316 %patch28 -p1
317 %patch25 -p1
318 %{?with_nacl:%patch18 -p1}
319 %patch24 -p1
320 %patch26 -p2
321 #%patch30 -p1
322 #%patch31 -p0
323 %patch32 -p1
324 %patch35 -p1
325 %patch36 -p1
326
327 %{?with_dev:exit 0}
328
329 sh -x clean-source.sh \
330         %{!?with_nacl:nacl=0} \
331         %{!?with_system_libvpx:libvpx=0} \
332         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
333         %{!?with_system_mesa:mesa=0} \
334         %{!?with_system_protobuf:protobuf=0} \
335         %{!?with_system_re2:re2=0} \
336         %{!?with_system_snappy:snappy=0} \
337         %{!?with_system_sqlite:sqlite=0} \
338         %{!?with_system_v8:v8=0} \
339         %{!?with_system_libwebp:libwebp=0} \
340         %{!?with_system_zlib:zlib=0} \
341         %{!?with_system_ffmpeg:ffmpeg=0} \
342         %{nil}
343
344 %build
345 %if %{with nacl}
346 rm -rf native_client/toolchain/linux_x86_newlib
347 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
348 # Make symlinks for NaCL
349 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
350
351 cd native_client/toolchain/linux_x86_newlib
352 ln -s x86_64-nacl/bin bin
353 cd x86_64-nacl/bin
354 __cc='%{__cc}'
355 if [ "${__cc#ccache}" != "$__cc" ]; then
356         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
357         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
358         %{__sed} -i -e '1i#!/bin/sh' gcc g++
359         chmod +x gcc g++
360 else
361         ln -s %{_bindir}/x86_64-nacl-gcc gcc
362         ln -s %{_bindir}/x86_64-nacl-g++ g++
363 fi
364 ln -s gcc x86_64-nacl-gcc
365 ln -s g++ x86_64-nacl-g++
366 ln -s %{_bindir}/x86_64-nacl-ar .
367 ln -s %{_bindir}/x86_64-nacl-ar ar
368 ln -s %{_bindir}/x86_64-nacl-as as
369 ln -s %{_bindir}/x86_64-nacl-ranlib .
370 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
371 ln -s %{_bindir}/x86_64-nacl-strip .
372 ln -s %{_bindir}/x86_64-nacl-strip strip
373 ln -s %{_bindir}/x86_64-nacl-objcopy .
374 ln -s %{_prefix}/x86_64-nacl/lib ../lib
375 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
376 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
377 cd ../../../../..
378 fi
379 %endif
380
381 %if %{without system_ffmpeg}
382 if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
383         # Re-configure bundled ffmpeg
384         cd third_party/ffmpeg
385         chromium/scripts/build_ffmpeg.py linux %{target_arch}
386         chromium/scripts/copy_config.sh
387         chromium/scripts/generate_gyp.py
388         cd -
389 fi
390 %endif
391
392 third_party/libaddressinput/chromium/tools/update-strings.py
393
394 flags="
395         -Dtarget_arch=%{target_arch} \
396         -Dpython_arch=%{target_arch} \
397         -Dffmpeg_branding=Chromium \
398         -Dsystem_libdir=%{_lib} \
399         -Dpython_ver=%{py_ver} \
400 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
401         -Dno_strict_aliasing=1 -Dgcc_version=44 \
402 %endif
403         %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
404         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
405         %{?with_shared_libs:-Dlibrary=shared_library} \
406         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
407         -Dinclude_tests__=0 \
408 %if %{with nacl}
409         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
410         -Ddisable_glibc_untar=1 \
411         -Ddisable_newlib_untar=1 \
412         -Ddisable_glibc=1 \
413         -Ddisable_pnacl=1 \
414         -Dbuild_pnacl_newlib=0 \
415 %else
416         -Ddisable_pnacl_untar=1 \
417         -Ddisable_nacl=1 \
418 %endif
419         %{!?with_sse2:-Ddisable_sse2=1} \
420         %{?with_selinux:-Dselinux=1} \
421         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
422         -Dlinux_link_libpci=1 \
423         -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
424         -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
425         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
426         -Dclang=0 \
427         -Dhost_clang=0 \
428         -Dlinux_use_bundled_binutils=0 \
429         -Dlinux_use_bundled_gold=0 \
430         -Dlinux_use_gold_flags=0 \
431         -Dlogging_like_official_build=1 \
432         -Dgoogle_api_key=%{google_api_key} \
433         -Dgoogle_default_client_id=%{google_default_client_id} \
434         -Dgoogle_default_client_secret=%{google_default_client_secret} \
435         %{gyp_with cups} \
436         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
437         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
438         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
439         %{gyp_with pulseaudio} \
440         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
441         %{gyp_with system_flac} \
442         %{gyp_with system_harfbuzz} \
443         %{gyp_with system_jsoncpp} \
444         %{gyp_with system_libexif} \
445         %{gyp_with system_libmtp} \
446         %{gyp_with system_libsrtp} \
447         %{gyp_with system_libusb} \
448         %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
449         %{gyp_with system_libwebp} \
450         %{gyp_with system_libxnvctrl} \
451         %{gyp_with system_mesa} \
452         %{gyp_with system_minizip} \
453         %{gyp_with system_opus} \
454         %{gyp_with system_protobuf} \
455         %{gyp_with system_re2} \
456         %{gyp_with system_snappy} \
457         %{gyp_with system_speex} \
458         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
459         %{gyp_with system_v8} \
460         %{gyp_with system_yasm} \
461         %{gyp_with system_zlib} \
462         -Duse_system_bzip2=1 \
463         -Duse_system_expat=1 \
464         -Duse_system_icu=1 -Dicu_use_data_file_flag=0 \
465         -Duse_system_libevent=1 \
466         -Duse_system_libjpeg=1 \
467         -Duse_system_libpng=1 \
468         -Duse_system_libxml=1 \
469         -Duse_system_libxslt=1 \
470         -Duse_system_nspr=1 \
471         -Duse_system_xdg_utils=1 \
472 "
473
474 build/linux/unbundle/replace_gyp_files.py $flags
475
476 %if %{with ninja}
477 chkfile=%{builddir}/build.ninja
478 %else
479 chkfile=Makefile
480 %endif
481 test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
482 test -e $chkfile || \
483         CC="%{__cc}" \
484         CXX="%{__cxx}" \
485         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
486         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
487         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
488         CC_host="%{__cc}" \
489         CXX_host="%{__cxx}" \
490         LD_host="%{__cxx}" \
491 %{__python} build/gyp_chromium \
492         --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
493         --depth=. \
494         build/all.gyp \
495         $flags
496
497 %if %{with ninja}
498 ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
499 %else
500 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
501 %{__make} -r \
502         BUILDTYPE=%{buildtype} \
503         %{?with_verbose:V=1} \
504         CC.host="%{__cc}" \
505         CXX.host="%{__cxx}" \
506         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
507 %endif
508         chrome %{?with_sandboxing:chrome_sandbox} \
509         %{nil}
510
511 cd %{builddir}
512 MANWIDTH=80 man ./chrome.1 > man.out
513 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
514
515 %install
516 rm -rf $RPM_BUILD_ROOT
517 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
518         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
519         $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
520         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
521
522 cd %{builddir}
523 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
524 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
525 %{__sed} -i -e '
526         s,@libdir@,%{_libdir}/%{name},
527
528         /@OPTIONS@/ {
529                 r options.txt
530                 d
531         }
532 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
533 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
534 cp -p *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
535 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
536 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
537 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
538 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
539 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
540 %if %{without system_ffmpeg}
541 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
542 %endif
543 install -p libpdf.so $RPM_BUILD_ROOT%{_libdir}/%{name}
544 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
545 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
546
547 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
548
549 %if %{with nacl}
550 # Install Native Client files on platforms that support it.
551 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
552 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
553 %ifarch %{x8664}
554 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
555 %endif
556 %ifarch %{ix86}
557 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
558 %endif
559 %endif
560
561 cd -
562
563 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
564         size=${icon##*/product_logo_}
565         size=${size%.png}
566
567         # this will skip non-numeric (22_mono_invert, 22_mono)
568         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
569         test -d "$dir" || continue
570
571         install -d $RPM_BUILD_ROOT$dir
572         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
573 done
574
575 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
576 # http://code.google.com/p/chromium/issues/detail?id=24507
577 gecko-mediaplayer*.so
578 EOF
579
580 # find locales
581 %find_lang %{name}.lang
582 # always package en-US
583 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
584
585 %clean
586 rm -rf $RPM_BUILD_ROOT
587
588 %pretrans
589 for d in locales resources; do
590         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
591                 install -d %{_datadir}/%{name}
592                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
593         fi
594 done
595 exit 0
596
597 %post
598 %update_icon_cache hicolor
599 %update_desktop_database
600 %update_browser_plugins
601
602 %postun
603 if [ "$1" = 0 ]; then
604         %update_icon_cache hicolor
605         %update_browser_plugins
606 fi
607
608 %files
609 %defattr(644,root,root,755)
610 %doc AUTHORS LICENSE
611 %{_browserpluginsconfdir}/browsers.d/%{name}.*
612 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
613 %dir %{_sysconfdir}/%{name}
614 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
615 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
616 %dir %{_sysconfdir}/%{name}/native-messaging-hosts
617 %dir %{_sysconfdir}/%{name}/policies
618 %dir %{_sysconfdir}/%{name}/policies/managed
619 %attr(755,root,root) %{_bindir}/%{name}
620 %{_mandir}/man1/%{name}.1*
621 %{_desktopdir}/*.desktop
622 %{_iconsdir}/hicolor/*/apps/%{name}.png
623 %dir %{_libdir}/%{name}
624 %{_libdir}/%{name}/chrome*.pak
625 %{_libdir}/%{name}/content_resources.pak
626 %{_libdir}/%{name}/keyboard_resources.pak
627 %{_libdir}/%{name}/resources.pak
628 %{_libdir}/%{name}/locales
629 %{_libdir}/%{name}/resources
630
631 # conflicts with browser-plugin-chrome-pdf?
632 %attr(755,root,root) %{_libdir}/%{name}/libpdf.so
633
634 %dir %{_datadir}/%{name}
635 %dir %{_datadir}/%{name}/locales
636 %{_datadir}/%{name}/locales/en-US.pak
637 %dir %{_datadir}/%{name}/resources
638 %{_datadir}/%{name}/resources/inspector
639
640 %dir %{_libdir}/%{name}/plugins
641 %attr(755,root,root) %{_libdir}/%{name}/%{name}
642 # These unique permissions are intentional and necessary for the sandboxing
643 %attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
644
645 # ffmpeg libs
646 %if %{without system_ffmpeg}
647 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
648 %endif
649
650 %if %{with nacl}
651 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
652 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
653 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
654 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
655 %endif
656
657 %files l10n -f %{name}.lang
658 %defattr(644,root,root,755)
This page took 0.070649 seconds and 4 git commands to generate.