]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
- release 2
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
4 %bcond_without  ffmpegsumo              # build with ffmpegsumo
5 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
6 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
7 %bcond_without  cups                    # with cups
8 %bcond_without  gconf                   # with GConf
9 %bcond_without  pulseaudio              # with pulseaudio
10 %bcond_with             nacl                    # build Native Client support
11 %bcond_without  sandboxing              # with sandboxing
12 %bcond_with             selinux                 # with SELinux (need policy first)
13 %bcond_with             shared_libs             # with shared libs
14 %bcond_with             sse2                    # use SSE2 instructions
15 %bcond_with             system_sqlite   # with system sqlite
16 %bcond_without  system_flac             # with system flac
17 %bcond_without  system_libwebp  # with system libwebp
18 %bcond_without  system_speex    # with system speex
19 %bcond_with             system_v8               # with system v8
20 %bcond_without  system_vpx              # with system vpx
21 %bcond_without  system_yasm             # with system yasm
22 %bcond_without  system_zlib             # with system zlib
23 %bcond_with             verbose                 # verbose build (V=1)
24
25 # TODO
26 # - check system sqlite linking problems
27 # - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
28 # - use_system_ssl (use_openssl: http://crbug.com/62803)
29 # - use_system_ffmpeg && build_ffmpegsumo
30 # - use_system_hunspell
31 # - use_system_stlport
32 # - other defaults: src/build/common.gypi
33
34 # NOTES:
35 # - mute BEEP mixer if you do not want to hear horrible system bell when
36 #   pressing home/end in url bar or more ^F search results on page.
37 # - build -bp: 1.2G
38 # - build i686: -bc: 2.7G; -bb: ~1.0GB
39 # - build x86_64: ~1.9G
40 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
41 # - to look for new tarball, use update-source.sh script
42
43 # NOTE TO USERS:
44 # To use chromium nightly builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
45 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
46 # or:
47 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
48
49 %define         gyp_rev 1014
50 Summary:        A WebKit powered web browser
51 Name:           chromium-browser
52 Version:        17.0.963.46
53 Release:        2
54 License:        BSD, LGPL v2+ (ffmpeg)
55 Group:          X11/Applications/Networking
56 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{version}.tar.xz
57 # Source0-md5:  2799babdc6837530775219ff8a1b322b
58 #SourceX:       http://ppa.launchpad.net/chromium-daily/ppa/ubuntu/pool/main/c/chromium-browser/%{name}_%{version}~svn%{svndate}r%{svnver}.orig.tar.gz
59 Source2:        %{name}.sh
60 Source3:        %{name}.desktop
61 Source5:        find-lang.sh
62 Source6:        update-source.sh
63 Source7:        clean-source.sh
64 Source8:        get-source.sh
65 Patch0:         system-libs.patch
66 Patch1:         plugin-searchdirs.patch
67 Patch2:         gyp-system-minizip.patch
68 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
69 Patch5:         options-support.patch
70 Patch6:         get-webkit_revision.patch
71 Patch7:         dlopen_sonamed_gl.patch
72 Patch8:         chromium_useragent.patch.in
73 Patch9:         system-expat.patch
74 Patch10:        dlopen-sonames.patch
75 # https://bugs.gentoo.org/show_bug.cgi?id=393471
76 # libjpeg-turbo >= 1.1.90 supports that feature
77 # but there is no autodetection currently, so revert for now
78 Patch11:        chromium-revert-jpeg-swizzle-r0.patch
79 URL:            http://www.chromium.org/Home
80 %{?with_gconf:BuildRequires:    GConf2-devel}
81 BuildRequires:  OpenGL-GLU-devel
82 BuildRequires:  alsa-lib-devel
83 BuildRequires:  atk-devel
84 BuildRequires:  bison
85 BuildRequires:  bzip2-devel
86 %{?with_cups:BuildRequires:     cups-devel}
87 BuildRequires:  dbus-glib-devel
88 BuildRequires:  expat-devel
89 %{?with_system_flac:BuildRequires:      flac-devel}
90 BuildRequires:  flex
91 BuildRequires:  fontconfig-devel
92 BuildRequires:  glib2-devel
93 BuildRequires:  gperf
94 BuildRequires:  gtk+2-devel
95 %{?with_kerberos:BuildRequires: heimdal-devel}
96 BuildRequires:  hicolor-icon-theme
97 BuildRequires:  libevent-devel
98 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
99 BuildRequires:  libicu-devel >= 4.6
100 BuildRequires:  libjpeg-devel
101 BuildRequires:  libpng-devel
102 %{?with_selinux:BuildRequires:  libselinux-devel}
103 BuildRequires:  libstdc++-devel
104 %{?with_system_vpx:BuildRequires:       libvpx-devel >= 0.9.5-2}
105 %{?with_system_libwebp:BuildRequires:   libwebp-devel}
106 BuildRequires:  libxml2-devel
107 BuildRequires:  libxslt-devel
108 BuildRequires:  lzma
109 BuildRequires:  minizip-devel
110 %{?with_nacl:BuildRequires:     nacl-toolchain-newlib >= 0.6941}
111 BuildRequires:  nspr-devel
112 BuildRequires:  nss-devel >= 1:3.12.3
113 BuildRequires:  pam-devel
114 BuildRequires:  pango-devel
115 BuildRequires:  perl-modules
116 BuildRequires:  pkgconfig
117 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
118 BuildRequires:  python
119 #BuildRequires: python-gyp >= 1-%{gyp_rev}
120 BuildRequires:  python-modules
121 BuildRequires:  rpm >= 4.4.9-56
122 BuildRequires:  rpmbuild(macros) >= 1.453
123 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
124 BuildRequires:  sqlite3-devel >= 3.6.1
125 BuildRequires:  tar >= 1:1.22
126 BuildRequires:  util-linux
127 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
128 BuildRequires:  which
129 BuildRequires:  xorg-lib-libXScrnSaver-devel
130 BuildRequires:  xorg-lib-libXt-devel
131 BuildRequires:  xorg-lib-libXtst-devel
132 BuildRequires:  xz
133 %{?with_system_yasm:BuildRequires:      yasm}
134 %{?with_system_zlib:BuildRequires:      zlib-devel}
135 Requires:       browser-plugins >= 2.0
136 Requires:       desktop-file-utils
137 Requires:       hicolor-icon-theme
138 %{?with_system_vpx:Requires:    libvpx >= 0.9.5-2}
139 Requires:       xdg-utils >= 1.0.2-4
140 Provides:       wwwbrowser
141 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
142 Obsoletes:      chromium-browser-inspector < 15.0.863.0
143 ExclusiveArch:  %{ix86} %{x8664} arm
144 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
145
146 %define         find_lang       sh find-lang.sh %{buildroot}
147 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
148 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
149
150 %if %{without debuginfo}
151 %define         _enable_debug_packages  0
152 %endif
153
154 %description
155 Chromium is an open-source browser project that aims to build a safer,
156 faster, and more stable way for all Internet users to experience the
157 web.
158
159 Chromium serves as a base for Google Chrome, which is Chromium
160 rebranded (name and logo) with very few additions such as usage
161 tracking and an auto-updater system.
162
163 %package l10n
164 Summary:        chromium-browser language packages
165 Group:          I18n
166 Requires:       %{name} = %{version}-%{release}
167
168 %description l10n
169 Chromium is an open-source browser project that aims to build a safer,
170 faster, and more stable way for all Internet users to experience the
171 web.
172
173 This package contains language packages for 50 languages:
174
175 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
176 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
177 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
178 zh-TW
179
180 %prep
181 %setup -q
182
183 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
184 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
185 . ./src/chrome/VERSION
186 ver=$MAJOR.$MINOR.$BUILD.$PATCH
187 test "$ver" = %{version}
188
189 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
190 test "$gyp_rev" = %{gyp_rev} || :
191
192 v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
193
194 # Populate the LASTCHANGE file template as we no longer have the VCS files at this point
195 #echo "%{svnver}" > src/build/LASTCHANGE.in
196
197 # add chromium and pld to useragent
198 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
199 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
200     -e 's/@BUILD_DIST_NAME@/PLD/g' \
201     -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
202     < %{PATCH8} | %{__patch} -p1
203
204 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
205 ln -s %{SOURCE7} src
206
207 %patch0 -p1
208 %patch1 -p1
209 %patch2 -p1
210 %patch3 -p1
211 %patch5 -p1
212 %patch6 -p1
213 %patch7 -p1
214 cd src
215 %patch9 -p1
216 cd ..
217 %patch10 -p1
218 cd src
219 %patch11 -p0
220 cd ..
221
222 cd src
223 sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0}
224
225 %build
226 cd src
227 test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
228 %ifarch %{ix86}
229         -Dtarget_arch=ia32 \
230 %endif
231 %ifarch %{x8664}
232         -Dtarget_arch=x64 \
233 %endif
234 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
235         -Dno_strict_aliasing=1 -Dgcc_version=44 \
236 %endif
237 %if %{with sandboxing}
238         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
239         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
240 %endif
241         %{!?debug:-Dwerror=} \
242         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
243         %{?with_shared_libs:-Dlibrary=shared_library} \
244         -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
245         -Dffmpeg_branding=Chrome \
246         -Dproprietary_codecs=1 \
247         %{!?with_nacl:-Ddisable_nacl=1} \
248         %{!?with_sse2:-Ddisable_sse2=1} \
249         %{?with_selinux:-Dselinux=1} \
250         %{gyp_with cups} \
251         %{gyp_with flac} \
252         %{gyp_with gconf} \
253         %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
254         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
255         %{gyp_with pulseaudio} \
256         %{gyp_with system_libwebp} \
257         %{gyp_with system_speex} \
258         %{gyp_with system_sqlite} \
259         %{gyp_with system_v8} \
260         %{gyp_with system_vpx} \
261         %{gyp_with system_yasm} \
262         %{gyp_with system_zlib} \
263         -Duse_system_bzip2=1 \
264         -Duse_system_icu=1 \
265         -Duse_system_libevent=1 \
266         -Duse_system_libjpeg=1 \
267         -Duse_system_libpng=1 \
268         -Duse_system_libxml=1 \
269         -Duse_system_libxslt=1 \
270         -Duse_system_xdg_utils=1 \
271
272 %{__make} chrome %{?with_sandboxing:chrome_sandbox} \
273         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
274         %{?with_verbose:V=1} \
275         CC="%{__cc}" \
276         CXX="%{__cxx}" \
277         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
278         CC.host="%{__cc}" \
279         CXX.host="%{__cxx}" \
280         LDFLAGS.host="%{rpmldflags}" \
281         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
282         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
283
284 %install
285 rm -rf $RPM_BUILD_ROOT
286 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
287         $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}}
288
289 cd src/out/%{!?debug:Release}%{?debug:Debug}
290 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
291 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
292 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
293 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
294 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
295 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
296 %if %{with ffmpegsumo}
297 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
298 %endif
299 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
300
301 %if %{with nacl}
302 # Install Native Client files on platforms that support it.
303 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
304 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
305 %ifarch %{x8664}
306 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
307 %endif
308 %ifarch %{ix86}
309 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
310 %endif
311 %endif
312
313 cd -
314
315 for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
316         size=${icon##*/product_logo_}
317         size=${size%.png}
318
319         # this will skip non-numeric (22_mono_invert, 22_mono)
320         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
321         test -d "$dir" || continue
322
323         install -d $RPM_BUILD_ROOT$dir
324         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
325 done
326
327 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
328 # http://code.google.com/p/chromium/issues/detail?id=24507
329 gecko-mediaplayer*.so
330 EOF
331
332 # find locales
333 %find_lang %{name}.lang
334 # always package en-US
335 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
336
337 %clean
338 rm -rf $RPM_BUILD_ROOT
339
340 %post
341 %update_icon_cache hicolor
342 %update_desktop_database
343 %update_browser_plugins
344
345 %postun
346 if [ "$1" = 0 ]; then
347         %update_icon_cache hicolor
348         %update_browser_plugins
349 fi
350
351 %files -f %{name}.lang
352 %defattr(644,root,root,755)
353 %{_browserpluginsconfdir}/browsers.d/%{name}.*
354 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
355 %attr(755,root,root) %{_bindir}/%{name}
356 %{_mandir}/man1/%{name}.1*
357 %{_desktopdir}/*.desktop
358 %{_iconsdir}/hicolor/*/apps/%{name}.png
359 %dir %{_libdir}/%{name}
360 %{_libdir}/%{name}/chrome.pak
361 %{_libdir}/%{name}/content_resources.pak
362 %{_libdir}/%{name}/resources.pak
363 %dir %{_libdir}/%{name}/locales
364 %{_libdir}/%{name}/locales/en-US.pak
365 %dir %{_libdir}/%{name}/resources
366 %{_libdir}/%{name}/resources/inspector
367 %dir %{_libdir}/%{name}/themes
368 %dir %{_libdir}/%{name}/extensions
369 %dir %{_libdir}/%{name}/plugins
370 %attr(755,root,root) %{_libdir}/%{name}/%{name}
371 # These unique permissions are intentional and necessary for the sandboxing
372 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
373
374 # ffmpeg libs
375 %if %{with ffmpegsumo}
376 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
377 %endif
378
379 %if %{with nacl}
380 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
381 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
382 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
383 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
384 %endif
385
386 %files l10n -f %{name}.lang
387 %defattr(644,root,root,755)
This page took 0.116422 seconds and 4 git commands to generate.