]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
- revert jpeg speedup change that causes jpeg corruption as it only works with lijpeg...
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
4 %bcond_without  ffmpegsumo              # build with ffmpegsumo
5 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
6 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
7 %bcond_without  cups                    # with cups
8 %bcond_without  gconf                   # with GConf
9 %bcond_without  pulseaudio              # with pulseaudio
10 %bcond_with             nacl                    # build Native Client support
11 %bcond_without  sandboxing              # with sandboxing
12 %bcond_with             selinux                 # with SELinux (need policy first)
13 %bcond_with             shared_libs             # with shared libs
14 %bcond_with             sse2                    # use SSE2 instructions
15 %bcond_with             system_sqlite   # with system sqlite
16 %bcond_without  system_flac             # with system flac
17 %bcond_without  system_libwebp  # with system libwebp
18 %bcond_without  system_speex    # with system speex
19 %bcond_with             system_v8               # with system v8
20 %bcond_without  system_vpx              # with system vpx
21 %bcond_without  system_yasm             # with system yasm
22 %bcond_without  system_zlib             # with system zlib
23 %bcond_with             verbose                 # verbose build (V=1)
24
25 # TODO
26 # - check system sqlite linking problems
27 # - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
28 # - use_system_ssl (use_openssl: http://crbug.com/62803)
29 # - use_system_ffmpeg && build_ffmpegsumo
30 # - use_system_hunspell
31 # - use_system_stlport
32 # - other defaults: src/build/common.gypi
33
34 # NOTES:
35 # - mute BEEP mixer if you do not want to hear horrible system bell when
36 #   pressing home/end in url bar or more ^F search results on page.
37 # - build -bp: 1.2G
38 # - build i686: -bc: 2.7G; -bb: ~1.0GB
39 # - build x86_64: ~1.9G
40 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
41 # - to look for new tarball, use update-source.sh script
42
43 # NOTE TO USERS:
44 # To use chromium nightly builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
45 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
46 # or:
47 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
48
49 %define         gyp_rev 1014
50 Summary:        A WebKit powered web browser
51 Name:           chromium-browser
52 Version:        17.0.963.33
53 Release:        1
54 License:        BSD, LGPL v2+ (ffmpeg)
55 Group:          X11/Applications/Networking
56 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{version}.tar.xz
57 # Source0-md5:  e402820a7d57a5f39a8b2428996a5bd0
58 #SourceX:       http://ppa.launchpad.net/chromium-daily/ppa/ubuntu/pool/main/c/chromium-browser/%{name}_%{version}~svn%{svndate}r%{svnver}.orig.tar.gz
59 Source2:        %{name}.sh
60 Source3:        %{name}.desktop
61 Source5:        find-lang.sh
62 Source6:        update-source.sh
63 Source7:        clean-source.sh
64 Source8:        get-source.sh
65 Patch0:         system-libs.patch
66 Patch1:         plugin-searchdirs.patch
67 Patch2:         gyp-system-minizip.patch
68 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
69 Patch5:         options-support.patch
70 Patch6:         get-webkit_revision.patch
71 Patch7:         dlopen_sonamed_gl.patch
72 Patch8:         chromium_useragent.patch.in
73 Patch9:         system-expat.patch
74 Patch10:        dlopen-sonames.patch
75 # https://bugs.gentoo.org/show_bug.cgi?id=393471
76 # libjpeg-turbo >= 1.1.90 supports that feature
77 # but there is no autodetection currently, so revert for now
78 Patch11:        chromium-revert-jpeg-swizzle-r0.patch
79 URL:            http://www.chromium.org/Home
80 %{?with_gconf:BuildRequires:    GConf2-devel}
81 BuildRequires:  OpenGL-GLU-devel
82 BuildRequires:  alsa-lib-devel
83 BuildRequires:  atk-devel
84 BuildRequires:  bison
85 BuildRequires:  bzip2-devel
86 %{?with_cups:BuildRequires:     cups-devel}
87 BuildRequires:  dbus-glib-devel
88 BuildRequires:  expat-devel
89 %{?with_system_flac:BuildRequires:      flac-devel}
90 BuildRequires:  flex
91 BuildRequires:  fontconfig-devel
92 BuildRequires:  glib2-devel
93 BuildRequires:  gperf
94 BuildRequires:  gtk+2-devel
95 %{?with_kerberos:BuildRequires: heimdal-devel}
96 BuildRequires:  libevent-devel
97 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
98 BuildRequires:  libicu-devel >= 4.6
99 BuildRequires:  libjpeg-devel
100 BuildRequires:  libpng-devel
101 %{?with_selinux:BuildRequires:  libselinux-devel}
102 BuildRequires:  libstdc++-devel
103 %{?with_system_vpx:BuildRequires:       libvpx-devel >= 0.9.5-2}
104 %{?with_system_libwebp:BuildRequires:   libwebp-devel}
105 BuildRequires:  libxml2-devel
106 BuildRequires:  libxslt-devel
107 BuildRequires:  lzma
108 BuildRequires:  minizip-devel
109 %{?with_nacl:BuildRequires:     nacl-toolchain-newlib >= 0.6941}
110 BuildRequires:  nspr-devel
111 BuildRequires:  nss-devel >= 1:3.12.3
112 BuildRequires:  pam-devel
113 BuildRequires:  pango-devel
114 BuildRequires:  perl-modules
115 BuildRequires:  pkgconfig
116 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
117 BuildRequires:  python
118 #BuildRequires: python-gyp >= 1-%{gyp_rev}
119 BuildRequires:  python-modules
120 BuildRequires:  rpm >= 4.4.9-56
121 BuildRequires:  rpmbuild(macros) >= 1.453
122 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
123 BuildRequires:  sqlite3-devel >= 3.6.1
124 BuildRequires:  tar >= 1:1.22
125 BuildRequires:  util-linux
126 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
127 BuildRequires:  which
128 BuildRequires:  xorg-lib-libXScrnSaver-devel
129 BuildRequires:  xorg-lib-libXt-devel
130 BuildRequires:  xorg-lib-libXtst-devel
131 BuildRequires:  xz
132 %{?with_system_yasm:BuildRequires:      yasm}
133 %{?with_system_zlib:BuildRequires:      zlib-devel}
134 Requires:       browser-plugins >= 2.0
135 Requires:       desktop-file-utils
136 %{?with_system_vpx:Requires:    libvpx >= 0.9.5-2}
137 Requires:       xdg-utils >= 1.0.2-4
138 Provides:       wwwbrowser
139 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
140 Obsoletes:      chromium-browser-inspector < 15.0.863.0
141 ExclusiveArch:  %{ix86} %{x8664} arm
142 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
143
144 %define         find_lang       sh find-lang.sh %{buildroot}
145 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
146 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
147
148 %if %{without debuginfo}
149 %define         _enable_debug_packages  0
150 %endif
151
152 %description
153 Chromium is an open-source browser project that aims to build a safer,
154 faster, and more stable way for all Internet users to experience the
155 web.
156
157 Chromium serves as a base for Google Chrome, which is Chromium
158 rebranded (name and logo) with very few additions such as usage
159 tracking and an auto-updater system.
160
161 %package l10n
162 Summary:        chromium-browser language packages
163 Group:          I18n
164 Requires:       %{name} = %{version}-%{release}
165
166 %description l10n
167 Chromium is an open-source browser project that aims to build a safer,
168 faster, and more stable way for all Internet users to experience the
169 web.
170
171 This package contains language packages for 50 languages:
172
173 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
174 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
175 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
176 zh-TW
177
178 %prep
179 %setup -q
180
181 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
182 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
183 . ./src/chrome/VERSION
184 ver=$MAJOR.$MINOR.$BUILD.$PATCH
185 test "$ver" = %{version}
186
187 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
188 test "$gyp_rev" = %{gyp_rev} || :
189
190 v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
191
192 # Populate the LASTCHANGE file template as we no longer have the VCS files at this point
193 #echo "%{svnver}" > src/build/LASTCHANGE.in
194
195 # add chromium and pld to useragent
196 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
197 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
198     -e 's/@BUILD_DIST_NAME@/PLD/g' \
199     -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
200     < %{PATCH8} | %{__patch} -p1
201
202 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
203 ln -s %{SOURCE7} src
204
205 %patch0 -p1
206 %patch1 -p1
207 %patch2 -p1
208 %patch3 -p1
209 %patch5 -p1
210 %patch6 -p1
211 %patch7 -p1
212 cd src
213 %patch9 -p1
214 cd ..
215 %patch10 -p1
216 cd src
217 %patch11 -p0
218 cd ..
219
220 cd src
221 sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0}
222
223 %build
224 cd src
225 test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
226 %ifarch %{ix86}
227         -Dtarget_arch=ia32 \
228 %endif
229 %ifarch %{x8664}
230         -Dtarget_arch=x64 \
231 %endif
232 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
233         -Dno_strict_aliasing=1 -Dgcc_version=44 \
234 %endif
235 %if %{with sandboxing}
236         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
237         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
238 %endif
239         %{!?debug:-Dwerror=} \
240         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
241         %{?with_shared_libs:-Dlibrary=shared_library} \
242         -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
243         -Dffmpeg_branding=Chrome \
244         -Dproprietary_codecs=1 \
245         %{!?with_nacl:-Ddisable_nacl=1} \
246         %{!?with_sse2:-Ddisable_sse2=1} \
247         %{?with_selinux:-Dselinux=1} \
248         %{gyp_with cups} \
249         %{gyp_with flac} \
250         %{gyp_with gconf} \
251         %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
252         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
253         %{gyp_with pulseaudio} \
254         %{gyp_with system_libwebp} \
255         %{gyp_with system_speex} \
256         %{gyp_with system_sqlite} \
257         %{gyp_with system_v8} \
258         %{gyp_with system_vpx} \
259         %{gyp_with system_yasm} \
260         %{gyp_with system_zlib} \
261         -Duse_system_bzip2=1 \
262         -Duse_system_icu=1 \
263         -Duse_system_libevent=1 \
264         -Duse_system_libjpeg=1 \
265         -Duse_system_libpng=1 \
266         -Duse_system_libxml=1 \
267         -Duse_system_libxslt=1 \
268         -Duse_system_xdg_utils=1 \
269
270 %{__make} chrome %{?with_sandboxing:chrome_sandbox} \
271         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
272         %{?with_verbose:V=1} \
273         CC="%{__cc}" \
274         CXX="%{__cxx}" \
275         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
276         CC.host="%{__cc}" \
277         CXX.host="%{__cxx}" \
278         LDFLAGS.host="%{rpmldflags}" \
279         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
280         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
281
282 %install
283 rm -rf $RPM_BUILD_ROOT
284 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
285         $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_pixmapsdir},%{_desktopdir}}
286
287 cd src/out/%{!?debug:Release}%{?debug:Debug}
288 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
289 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
290 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
291 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
292 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
293 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
294 %if %{with ffmpegsumo}
295 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
296 %endif
297 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
298
299 %if %{with nacl}
300 # Install Native Client files on platforms that support it.
301 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
302 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
303 %ifarch %{x8664}
304 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
305 %endif
306 %ifarch %{ix86}
307 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
308 %endif
309 %endif
310
311 cd -
312
313 cp -p src/chrome/app/theme/chromium/product_logo_48.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
314
315 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
316 # http://code.google.com/p/chromium/issues/detail?id=24507
317 gecko-mediaplayer*.so
318 EOF
319
320 # find locales
321 %find_lang %{name}.lang
322 # always package en-US
323 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
324
325 %clean
326 rm -rf $RPM_BUILD_ROOT
327
328 %post
329 %update_desktop_database
330 %update_browser_plugins
331
332 %postun
333 if [ "$1" = 0 ]; then
334         %update_browser_plugins
335 fi
336
337 %files -f %{name}.lang
338 %defattr(644,root,root,755)
339 %{_browserpluginsconfdir}/browsers.d/%{name}.*
340 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
341 %attr(755,root,root) %{_bindir}/%{name}
342 %{_mandir}/man1/%{name}.1*
343 %{_pixmapsdir}/%{name}.png
344 %{_desktopdir}/*.desktop
345 %dir %{_libdir}/%{name}
346 %{_libdir}/%{name}/chrome.pak
347 %{_libdir}/%{name}/content_resources.pak
348 %{_libdir}/%{name}/resources.pak
349 %dir %{_libdir}/%{name}/locales
350 %{_libdir}/%{name}/locales/en-US.pak
351 %dir %{_libdir}/%{name}/resources
352 %{_libdir}/%{name}/resources/inspector
353 %dir %{_libdir}/%{name}/themes
354 %dir %{_libdir}/%{name}/extensions
355 %dir %{_libdir}/%{name}/plugins
356 %attr(755,root,root) %{_libdir}/%{name}/%{name}
357 # These unique permissions are intentional and necessary for the sandboxing
358 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
359
360 # ffmpeg libs
361 %if %{with ffmpegsumo}
362 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
363 %endif
364
365 %if %{with nacl}
366 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
367 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
368 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
369 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
370 %endif
371
372 %files l10n -f %{name}.lang
373 %defattr(644,root,root,755)
This page took 0.06882 seconds and 4 git commands to generate.