]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
allow setting sync client name via SYNC_SESSION_NAME env. crbug.com/123827
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
9 %bcond_without  libjpegturbo    # use libjpeg-turbo features
10 %bcond_without  nacl                    # build Native Client support
11 %bcond_without  pulseaudio              # with pulseaudio
12 %bcond_without  sandboxing              # with sandboxing
13 %bcond_with             selinux                 # with SELinux (need policy first)
14 %bcond_with             shared_libs             # with shared libs
15 %bcond_with             sse2                    # use SSE2 instructions
16 %bcond_without  system_flac             # system flac
17 %bcond_without  system_ffmpeg   # system ffmpeg instead of ffmpegsumo
18 %bcond_without  system_harfbuzz # system harfbuzz
19 %bcond_without  system_jsoncpp  # system jsoncpp
20 %bcond_without  system_libexif  # system libexif
21 %bcond_without  system_libmtp   # system libmtp
22 %bcond_without  system_libusb   # system libusb-1
23 %bcond_without  system_libwebp  # system libwebp
24 %bcond_without  system_libxnvctrl       # system libxnvctrl
25 %bcond_without  system_mesa             # system Mesa
26 %bcond_without  system_minizip  # system minizip
27 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
28 %bcond_without  system_protobuf # system protobuf
29 %bcond_without  system_re2              # system re2
30 %bcond_without  system_speex    # system speex
31 %bcond_without  system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
32 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
33 %bcond_with             system_v8               # system v8
34 %bcond_without  system_libvpx   # system libvpx
35 %bcond_without  system_yasm             # system yasm
36 %bcond_without  system_zlib             # system zlib
37 %bcond_without  tcmalloc                # use tcmalloc
38 %bcond_without  verbose                 # verbose build (V=1)
39
40 %ifarch %{ix86}
41 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
42 %undefine       with_system_mesa
43 %endif
44
45 # TODO
46 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
47 # - use_system_skia
48 # - use_system_ssl (use_openssl: http://crbug.com/62803)
49 # - use_system_stlport (android specific)
50 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
51
52 # NOTES:
53 # - mute BEEP mixer if you do not want to hear horrible system bell when
54 #   pressing home/end in url bar or more ^F search results on page.
55 # - space considerations:
56 #   - unpacked sources: ~490MiB
57 #   - built code: ~1.4GiB (x86_64/i686)
58 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
59 # - to look for new tarball, use update-source.sh script
60
61 %define         branch          27.0.1453
62 %define         basever         73
63 #define         patchver        70
64 %define         gyp_rev 1014
65 Summary:        A WebKit powered web browser
66 Name:           chromium-browser
67 %if "%{?patchver}" != ""
68 Version:        %{branch}.%{patchver}
69 %else
70 Version:        %{branch}.%{basever}
71 %endif
72 Release:        0.10
73 License:        BSD, LGPL v2+ (ffmpeg)
74 Group:          X11/Applications/Networking
75 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{branch}.%{basever}.tar.gz
76 # Source0-md5:  eafd6a919faadc8a7446cd673f460c4c
77 %if "%{?patchver}" != ""
78 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
79 # Patch0-md5:   7e2f26d76ca6241961276a328a9230cf
80 %endif
81 Source1:        %{name}.default
82 Source2:        %{name}.sh
83 Source3:        %{name}.desktop
84 Source5:        find-lang.sh
85 Source6:        update-source.sh
86 Source7:        clean-source.sh
87 Source8:        get-source.sh
88 Source9:        master_preferences.json
89 Patch1:         plugin-searchdirs.patch
90 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
91 Patch4:         path-libpdf.patch
92 Patch6:         get-webkit_revision.patch
93 Patch7:         dlopen_sonamed_gl.patch
94 Patch8:         chromium_useragent.patch.in
95 Patch10:        system-libxnvctrl.patch
96 # https://bugs.gentoo.org/show_bug.cgi?id=393471
97 # libjpeg-turbo >= 1.1.90 supports that feature
98 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
99 Patch12:        system-ffmpeg.patch
100 Patch15:        nacl-build-irt.patch
101 Patch16:        nacl-linkingfix.patch
102 Patch18:        nacl-no-untar.patch
103 Patch24:        nacl-verbose.patch
104 Patch25:        gnome3-volume-control.patch
105 Patch26:        master-prefs-path.patch
106 Patch28:        system-mesa.patch
107 Patch29:        speechd-0.8.patch
108 Patch30:        no-pnacl.patch
109 Patch31:        sync-session-name.patch
110 URL:            http://www.chromium.org/Home
111 %{?with_gconf:BuildRequires:    GConf2-devel}
112 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
113 %{?with_system_mesa:BuildRequires:      Mesa-libGLES-devel >= 9.1}
114 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
115 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
116 BuildRequires:  alsa-lib-devel
117 BuildRequires:  atk-devel
118 BuildRequires:  bison
119 BuildRequires:  bzip2-devel
120 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
121 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
122 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
123 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
124 %{?with_cups:BuildRequires:     cups-devel}
125 BuildRequires:  elfutils-devel
126 BuildRequires:  expat-devel
127 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
128 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
129 BuildRequires:  fontconfig-devel
130 BuildRequires:  glib2-devel
131 BuildRequires:  gperf
132 %{?with_gps:BuildRequires:      gpsd-devel}
133 BuildRequires:  gtest-devel
134 BuildRequires:  gtk+2-devel
135 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
136 %{?with_kerberos:BuildRequires: heimdal-devel}
137 BuildRequires:  hicolor-icon-theme
138 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
139 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
140 BuildRequires:  libevent-devel
141 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
142 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
143 BuildRequires:  libicu-devel >= 4.6
144 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
145 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
146 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
147 BuildRequires:  libpng-devel
148 %{?with_selinux:BuildRequires:  libselinux-devel}
149 BuildRequires:  libstdc++-devel
150 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
151 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
152 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
153 BuildRequires:  libxml2-devel
154 BuildRequires:  libxslt-devel
155 BuildRequires:  man-db
156 %{?with_system_minizip:BuildRequires:   minizip-devel}
157 BuildRequires:  nspr-devel
158 BuildRequires:  nss-devel >= 1:3.12.3
159 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
160 BuildRequires:  pam-devel
161 BuildRequires:  pango-devel
162 BuildRequires:  pciutils-devel
163 BuildRequires:  perl-modules
164 BuildRequires:  pkgconfig
165 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
166 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
167 BuildRequires:  python
168 #BuildRequires: python-gyp >= 1-%{gyp_rev}
169 BuildRequires:  python-modules
170 BuildRequires:  python-ply
171 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
172 BuildRequires:  rpm >= 4.4.9-56
173 BuildRequires:  rpmbuild(macros) >= 1.453
174 BuildRequires:  speech-dispatcher-devel >= 0.8
175 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
176 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
177 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
178 BuildRequires:  subversion
179 BuildRequires:  tar >= 1:1.22
180 BuildRequires:  udev-devel
181 BuildRequires:  usbutils
182 BuildRequires:  util-linux
183 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
184 BuildRequires:  which
185 BuildRequires:  xorg-lib-libXScrnSaver-devel
186 BuildRequires:  xz
187 %{?with_system_yasm:BuildRequires:      yasm}
188 %{?with_system_zlib:BuildRequires:      zlib-devel}
189 Requires:       browser-plugins >= 2.0
190 Requires:       desktop-file-utils
191 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
192 # crashes if no fontconfig font present
193 Requires:       fonts-Type1-urw
194 Requires:       hicolor-icon-theme
195 Requires:       libevent >= 2.0.21
196 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
197 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
198 Requires:       lsb-release
199 %{?with_system_re2:Requires:    re2 >= 20130115-2}
200 Requires:       shared-mime-info
201 Requires:       xdg-utils >= 1.0.2-4
202 Requires:       xorg-lib-libX11 >= 1.4.99.1
203 Provides:       wwwbrowser
204 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
205 Obsoletes:      chromium-browser-inspector < 15.0.863.0
206 ExclusiveArch:  %{ix86} %{x8664} arm
207 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
208
209 %define         find_lang       sh find-lang.sh %{buildroot}
210
211 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
212 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
213
214 %if %{without debuginfo}
215 %define         _enable_debug_packages  0
216 %endif
217
218 %description
219 Chromium is an open-source browser project that aims to build a safer,
220 faster, and more stable way for all Internet users to experience the
221 web.
222
223 Chromium serves as a base for Google Chrome, which is Chromium
224 rebranded (name and logo) with very few additions such as usage
225 tracking and an auto-updater system.
226
227 %package l10n
228 Summary:        chromium-browser language packages
229 Group:          I18n
230 Requires:       %{name} = %{version}-%{release}
231 %if "%{_rpmversion}" >= "5"
232 BuildArch:      noarch
233 %endif
234
235 %description l10n
236 Chromium is an open-source browser project that aims to build a safer,
237 faster, and more stable way for all Internet users to experience the
238 web.
239
240 This package contains language packages for 50 languages:
241
242 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
243 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
244 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
245 zh-TW
246
247 %prep
248 %setup -qc
249 %if "%{?patchver}" != ""
250 cd %{name}-%{branch}.%{basever}
251 %patch0 -p1
252 cd ..
253 %endif
254 mv %{name}-%{branch}.%{basever}/* .
255
256 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
257 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
258 . ./chrome/VERSION
259 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
260 test "$chrome" = %{version}
261
262 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
263 test "$gyp_rev" = %{gyp_rev} || :
264
265 . ./v8.sh
266 v8=$MAJOR_VERSION.$MINOR_VERSION.$BUILD_NUMBER.$PATCH_LEVEL
267
268 # add chromium and pld to useragent
269 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
270 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
271         -e 's/@BUILD_DIST_NAME@/PLD/g' \
272         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
273         < %{PATCH8} | %{__patch} -p2
274
275 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
276 ln -s %{SOURCE7} .
277
278 %patch1 -p2
279 %patch3 -p2
280 %patch4 -p3
281 %patch6 -p2
282 %patch7 -p2
283 %patch10 -p2
284 %patch15 -p2
285 %{!?with_libjpegturbo:%patch11 -p0}
286 %patch12 -p1
287 %patch16 -p1
288 %patch28 -p1
289 %patch25 -p2
290 %patch18 -p2
291 %patch24 -p2
292 %patch26 -p2
293 %patch29 -p2
294 %patch30 -p0
295 %patch31 -p1
296
297 sh -x clean-source.sh \
298         %{!?with_nacl:nacl=0} \
299         %{!?with_system_libvpx:libvpx=0} \
300         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
301         %{!?with_system_mesa:mesa=0} \
302         %{!?with_system_protobuf:protobuf=0} \
303         %{!?with_system_re2:re2=0} \
304         %{!?with_system_sqlite:sqlite=0} \
305         %{!?with_system_v8:v8=0} \
306         %{!?with_system_zlib:zlib=0} \
307         %{nil}
308
309 %build
310 %if %{with nacl}
311 rm -rf native_client/toolchain/linux_x86_newlib
312 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
313 # Make symlinks for NaCL
314 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
315
316 cd native_client/toolchain/linux_x86_newlib
317 ln -s x86_64-nacl/bin bin
318 cd x86_64-nacl/bin
319 __cc='%{__cc}'
320 if [ "${__cc#ccache}" != "$__cc" ]; then
321         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
322         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
323         %{__sed} -i -e '1i#!/bin/sh' gcc g++
324         chmod +x gcc g++
325 else
326         ln -s %{_bindir}/x86_64-nacl-gcc gcc
327         ln -s %{_bindir}/x86_64-nacl-g++ g++
328 fi
329 ln -s gcc x86_64-nacl-gcc
330 ln -s g++ x86_64-nacl-g++
331 ln -s %{_bindir}/x86_64-nacl-ar .
332 ln -s %{_bindir}/x86_64-nacl-ar ar
333 ln -s %{_bindir}/x86_64-nacl-as as
334 ln -s %{_bindir}/x86_64-nacl-ranlib .
335 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
336 ln -s %{_bindir}/x86_64-nacl-strip .
337 ln -s %{_bindir}/x86_64-nacl-strip strip
338 ln -s %{_prefix}/x86_64-nacl/lib ../lib
339 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
340 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
341 cd ../../../../..
342 fi
343 %endif
344
345 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
346 test -e Makefile || \
347         CC="%{__cc}" \
348         CXX="%{__cxx}" \
349         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
350         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
351         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
352 %{__python} build/gyp_chromium \
353         --format=make \
354         --depth=. \
355         build/all.gyp \
356 %ifarch %{ix86}
357         -Dtarget_arch=ia32 \
358 %endif
359 %ifarch %{x8664}
360         -Dtarget_arch=x64 \
361 %endif
362 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
363         -Dno_strict_aliasing=1 -Dgcc_version=44 \
364 %endif
365 %if %{with sandboxing}
366         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
367         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
368 %endif
369         %{!?debug:-Dwerror=} \
370         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
371         %{?with_shared_libs:-Dlibrary=shared_library} \
372         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
373         -Dinclude_tests=0 \
374 %if %{with nacl}
375         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
376         -Ddisable_glibc_untar=1 \
377         -Ddisable_newlib_untar=1 \
378         -Ddisable_glibc=1 \
379         -Ddisable_pnacl=1 \
380         -Dbuild_pnacl_newlib=0 \
381 %else
382         -Ddisable_pnacl_untar=1 \
383         -Ddisable_nacl=1 \
384 %endif
385         %{!?with_sse2:-Ddisable_sse2=1} \
386         %{?with_selinux:-Dselinux=1} \
387         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
388         -Dlinux_link_libpci=1 \
389         -Dlinux_link_libspeechd=1 \
390         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
391         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
392         -Dlinux_use_gold_binary=0 \
393         -Dlinux_use_gold_flags=0 \
394         %{gyp_with cups} \
395         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
396         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
397         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
398         %{gyp_with pulseaudio} \
399         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
400         %{gyp_with system_flac} \
401         %{gyp_with system_harfbuzz} \
402         %{gyp_with system_jsoncpp} \
403         %{gyp_with system_libexif} \
404         %{gyp_with system_libmtp} \
405         %{gyp_with system_libsrtp} \
406         %{gyp_with system_libusb} \
407         %{gyp_with system_libvpx} -Dmedia_use_libvpx=0 \
408         %{gyp_with system_libwebp} \
409         %{gyp_with system_libxnvctrl} \
410         %{gyp_with system_mesa} \
411         %{gyp_with system_minizip} \
412         %{gyp_with system_opus} \
413         %{gyp_with system_protobuf} \
414         %{gyp_with system_re2} \
415         %{gyp_with system_speex} \
416         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
417         %{gyp_with system_v8} \
418         %{gyp_with system_yasm} \
419         %{gyp_with system_zlib} \
420         -Duse_system_bzip2=1 \
421         -Duse_system_expat=1 \
422         -Duse_system_icu=1 \
423         -Duse_system_libevent=1 \
424         -Duse_system_libjpeg=1 \
425         -Duse_system_libpng=1 \
426         -Duse_system_libxml=1 \
427         -Duse_system_libxslt=1 \
428         -Duse_system_nspr=1 \
429         -Duse_system_xdg_utils=1 \
430
431 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
432 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
433         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
434         %{?with_verbose:V=1} \
435         CC.host="%{__cc}" \
436         CXX.host="%{__cxx}" \
437         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
438
439 cd out/%{!?debug:Release}%{?debug:Debug}
440 MANWIDTH=80 man ./chrome.1 > man.out
441 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
442
443 %install
444 rm -rf $RPM_BUILD_ROOT
445 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
446         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
447         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
448
449 cd out/%{!?debug:Release}%{?debug:Debug}
450 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
451 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
452 %{__sed} -i -e '
453         s,@libdir@,%{_libdir}/%{name},
454
455         /@OPTIONS@/ {
456                 r options.txt
457                 d
458         }
459 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
460 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
461 cp -a *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
462 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
463 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
464 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
465 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
466 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
467 %if %{without system_ffmpeg}
468 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
469 %endif
470 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
471 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
472
473 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
474
475 %if %{with nacl}
476 # Install Native Client files on platforms that support it.
477 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
478 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
479 %ifarch %{x8664}
480 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
481 %endif
482 %ifarch %{ix86}
483 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
484 %endif
485 %endif
486
487 cd -
488
489 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
490         size=${icon##*/product_logo_}
491         size=${size%.png}
492
493         # this will skip non-numeric (22_mono_invert, 22_mono)
494         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
495         test -d "$dir" || continue
496
497         install -d $RPM_BUILD_ROOT$dir
498         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
499 done
500
501 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
502 # http://code.google.com/p/chromium/issues/detail?id=24507
503 gecko-mediaplayer*.so
504 EOF
505
506 # find locales
507 %find_lang %{name}.lang
508 # always package en-US
509 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
510
511 %clean
512 rm -rf $RPM_BUILD_ROOT
513
514 %pretrans
515 for d in locales resources; do
516         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
517                 install -d %{_datadir}/%{name}
518                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
519         fi
520 done
521 exit 0
522
523 %post
524 %update_icon_cache hicolor
525 %update_desktop_database
526 %update_browser_plugins
527
528 %postun
529 if [ "$1" = 0 ]; then
530         %update_icon_cache hicolor
531         %update_browser_plugins
532 fi
533
534 %files
535 %defattr(644,root,root,755)
536 %doc AUTHORS LICENSE
537 %{_browserpluginsconfdir}/browsers.d/%{name}.*
538 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
539 %dir %{_sysconfdir}/%{name}
540 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
541 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
542 %attr(755,root,root) %{_bindir}/%{name}
543 %{_mandir}/man1/%{name}.1*
544 %{_desktopdir}/*.desktop
545 %{_iconsdir}/hicolor/*/apps/%{name}.png
546 %dir %{_libdir}/%{name}
547 %{_libdir}/%{name}/chrome*.pak
548 %{_libdir}/%{name}/content_resources.pak
549 %{_libdir}/%{name}/resources.pak
550 %{_libdir}/%{name}/locales
551 %{_libdir}/%{name}/resources
552
553 %dir %{_datadir}/%{name}
554 %dir %{_datadir}/%{name}/locales
555 %{_datadir}/%{name}/locales/en-US.pak
556 %dir %{_datadir}/%{name}/resources
557 %{_datadir}/%{name}/resources/inspector
558
559 %dir %{_libdir}/%{name}/plugins
560 %attr(755,root,root) %{_libdir}/%{name}/%{name}
561 # These unique permissions are intentional and necessary for the sandboxing
562 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
563
564 # ffmpeg libs
565 %if %{without system_ffmpeg}
566 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
567 %endif
568
569 %if %{with nacl}
570 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
571 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
572 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
573 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
574 %endif
575
576 %files l10n -f %{name}.lang
577 %defattr(644,root,root,755)
This page took 0.119057 seconds and 4 git commands to generate.