]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
drop tcmalloc glibc 2.16 patch, siginfo_t is correct
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
9 %bcond_without  libjpegturbo    # use libjpeg-turbo features
10 %bcond_without  nacl                    # build Native Client support
11 %bcond_without  pulseaudio              # with pulseaudio
12 %bcond_without  sandboxing              # with sandboxing
13 %bcond_with             selinux                 # with SELinux (need policy first)
14 %bcond_with             shared_libs             # with shared libs
15 %bcond_with             sse2                    # use SSE2 instructions
16 %bcond_without  system_flac             # system flac
17 %bcond_without  system_ffmpeg   # system ffmpeg instead of ffmpegsumo
18 %bcond_without  system_harfbuzz # system harfbuzz
19 %bcond_without  system_jsoncpp  # system jsoncpp
20 %bcond_without  system_libexif  # system libexif
21 %bcond_without  system_libmtp   # system libmtp
22 %bcond_without  system_libusb   # system libusb-1
23 %bcond_without  system_libwebp  # system libwebp
24 %bcond_without  system_libxnvctrl       # system libxnvctrl
25 %bcond_without  system_mesa             # system Mesa
26 %bcond_without  system_minizip  # system minizip
27 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
28 %bcond_without  system_protobuf # system protobuf
29 %bcond_without  system_re2              # system re2
30 %bcond_without  system_speex    # system speex
31 %bcond_without  system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
32 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
33 %bcond_with             system_v8               # system v8
34 %bcond_without  system_libvpx   # system libvpx
35 %bcond_without  system_yasm             # system yasm
36 %bcond_without  system_zlib             # system zlib
37 %bcond_without  tcmalloc                # use tcmalloc
38 %bcond_without  verbose                 # verbose build (V=1)
39
40 %ifarch %{ix86}
41 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
42 %undefine       with_system_mesa
43 %endif
44
45 # TODO
46 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
47 # - use_system_skia
48 # - use_system_ssl (use_openssl: http://crbug.com/62803)
49 # - use_system_stlport (android specific)
50 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
51
52 # NOTES:
53 # - mute BEEP mixer if you do not want to hear horrible system bell when
54 #   pressing home/end in url bar or more ^F search results on page.
55 # - space considerations:
56 #   - unpacked sources: ~490MiB
57 #   - built code: ~1.4GiB (x86_64/i686)
58 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
59 # - to look for new tarball, use update-source.sh script
60
61 # NOTE TO USERS:
62 # To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
63 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
64 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
65
66 %define         branch          27.0.1453
67 %define         basever         6
68 #define         patchver        70
69 %define         gyp_rev 1014
70 Summary:        A WebKit powered web browser
71 Name:           chromium-browser
72 %if "%{?patchver}" != ""
73 Version:        %{branch}.%{patchver}
74 %else
75 Version:        %{branch}.%{basever}
76 %endif
77 Release:        0.4
78 License:        BSD, LGPL v2+ (ffmpeg)
79 Group:          X11/Applications/Networking
80 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/dev/%{name}-%{branch}.%{basever}.tar.gz
81 # Source0-md5:  eafd6a919faadc8a7446cd673f460c4c
82 %if "%{?patchver}" != ""
83 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
84 # Patch0-md5:   7e2f26d76ca6241961276a328a9230cf
85 %endif
86 Source1:        %{name}.default
87 Source2:        %{name}.sh
88 Source3:        %{name}.desktop
89 Source5:        find-lang.sh
90 Source6:        update-source.sh
91 Source7:        clean-source.sh
92 Source8:        get-source.sh
93 Source9:        master_preferences.json
94 Patch1:         plugin-searchdirs.patch
95 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
96 Patch4:         path-libpdf.patch
97 Patch6:         get-webkit_revision.patch
98 Patch7:         dlopen_sonamed_gl.patch
99 Patch8:         chromium_useragent.patch.in
100 Patch10:        system-libxnvctrl.patch
101 # https://bugs.gentoo.org/show_bug.cgi?id=393471
102 # libjpeg-turbo >= 1.1.90 supports that feature
103 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
104 Patch12:        system-ffmpeg.patch
105 Patch15:        nacl-build-irt.patch
106 Patch16:        nacl-linkingfix.patch
107 Patch18:        nacl-no-untar.patch
108 Patch24:        nacl-verbose.patch
109 Patch25:        gnome3-volume-control.patch
110 Patch26:        master-prefs-path.patch
111 Patch28:        system-mesa.patch
112 Patch29:        speechd-0.8.patch
113 URL:            http://www.chromium.org/Home
114 %{?with_gconf:BuildRequires:    GConf2-devel}
115 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
116 %{?with_system_mesa:BuildRequires:      Mesa-libGLES-devel >= 9.1}
117 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
118 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
119 BuildRequires:  alsa-lib-devel
120 BuildRequires:  atk-devel
121 BuildRequires:  bison
122 BuildRequires:  bzip2-devel
123 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
124 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
125 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
126 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
127 %{?with_cups:BuildRequires:     cups-devel}
128 BuildRequires:  elfutils-devel
129 BuildRequires:  expat-devel
130 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
131 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
132 BuildRequires:  fontconfig-devel
133 BuildRequires:  glib2-devel
134 BuildRequires:  gperf
135 %{?with_gps:BuildRequires:      gpsd-devel}
136 BuildRequires:  gtest-devel
137 BuildRequires:  gtk+2-devel
138 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
139 %{?with_kerberos:BuildRequires: heimdal-devel}
140 BuildRequires:  hicolor-icon-theme
141 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
142 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
143 BuildRequires:  libevent-devel
144 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
145 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
146 BuildRequires:  libicu-devel >= 4.6
147 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
148 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
149 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
150 BuildRequires:  libpng-devel
151 %{?with_selinux:BuildRequires:  libselinux-devel}
152 BuildRequires:  libstdc++-devel
153 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
154 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
155 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
156 BuildRequires:  libxml2-devel
157 BuildRequires:  libxslt-devel
158 BuildRequires:  man-db
159 %{?with_system_minizip:BuildRequires:   minizip-devel}
160 BuildRequires:  nspr-devel
161 BuildRequires:  nss-devel >= 1:3.12.3
162 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
163 BuildRequires:  pam-devel
164 BuildRequires:  pango-devel
165 BuildRequires:  pciutils-devel
166 BuildRequires:  perl-modules
167 BuildRequires:  pkgconfig
168 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
169 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
170 BuildRequires:  python
171 #BuildRequires: python-gyp >= 1-%{gyp_rev}
172 BuildRequires:  python-modules
173 BuildRequires:  python-ply
174 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
175 BuildRequires:  rpm >= 4.4.9-56
176 BuildRequires:  rpmbuild(macros) >= 1.453
177 BuildRequires:  speech-dispatcher-devel >= 0.8
178 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
179 BuildRequires:  sqlite3-devel >= 3.6.1
180 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
181 BuildRequires:  subversion
182 BuildRequires:  tar >= 1:1.22
183 BuildRequires:  udev-devel
184 BuildRequires:  usbutils
185 BuildRequires:  util-linux
186 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
187 BuildRequires:  which
188 BuildRequires:  xorg-lib-libXScrnSaver-devel
189 BuildRequires:  xz
190 %{?with_system_yasm:BuildRequires:      yasm}
191 %{?with_system_zlib:BuildRequires:      zlib-devel}
192 Requires:       browser-plugins >= 2.0
193 Requires:       desktop-file-utils
194 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
195 # crashes if no fontconfig font present
196 Requires:       fonts-Type1-urw
197 Requires:       hicolor-icon-theme
198 Requires:       libevent >= 2.0.21
199 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
200 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
201 Requires:       lsb-release
202 %{?with_system_re2:Requires:    re2 >= 20130115-2}
203 Requires:       shared-mime-info
204 Requires:       xdg-utils >= 1.0.2-4
205 Requires:       xorg-lib-libX11 >= 1.4.99.1
206 Provides:       wwwbrowser
207 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
208 Obsoletes:      chromium-browser-inspector < 15.0.863.0
209 ExclusiveArch:  %{ix86} %{x8664} arm
210 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
211
212 %define         find_lang       sh find-lang.sh %{buildroot}
213
214 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
215 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
216
217 %if %{without debuginfo}
218 %define         _enable_debug_packages  0
219 %endif
220
221 %description
222 Chromium is an open-source browser project that aims to build a safer,
223 faster, and more stable way for all Internet users to experience the
224 web.
225
226 Chromium serves as a base for Google Chrome, which is Chromium
227 rebranded (name and logo) with very few additions such as usage
228 tracking and an auto-updater system.
229
230 %package l10n
231 Summary:        chromium-browser language packages
232 Group:          I18n
233 Requires:       %{name} = %{version}-%{release}
234
235 %description l10n
236 Chromium is an open-source browser project that aims to build a safer,
237 faster, and more stable way for all Internet users to experience the
238 web.
239
240 This package contains language packages for 50 languages:
241
242 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
243 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
244 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
245 zh-TW
246
247 %prep
248 %setup -qc
249 %if "%{?patchver}" != ""
250 cd %{name}-%{branch}.%{basever}
251 %patch0 -p1
252 cd ..
253 %endif
254 mv %{name}-%{branch}.%{basever}/* .
255
256 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
257 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
258 . ./chrome/VERSION
259 ver=$MAJOR.$MINOR.$BUILD.$PATCH
260 test "$ver" = %{version}
261
262 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
263 test "$gyp_rev" = %{gyp_rev} || :
264
265 v8_ver=$(awk 'NR=1 {print $NF; exit}' v8/ChangeLog || :)
266
267 # add chromium and pld to useragent
268 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
269 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
270         -e 's/@BUILD_DIST_NAME@/PLD/g' \
271         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
272         < %{PATCH8} | %{__patch} -p2
273
274 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
275 ln -s %{SOURCE7} .
276
277 %patch1 -p2
278 %patch3 -p2
279 %patch4 -p3
280 %patch6 -p2
281 %patch7 -p2
282 %patch10 -p2
283 %patch15 -p2
284 %{!?with_libjpegturbo:%patch11 -p0}
285 %patch12 -p1
286 %patch16 -p1
287 %patch28 -p1
288 %patch25 -p2
289 %patch18 -p2
290 %patch24 -p2
291 %patch26 -p2
292 %patch29 -p2
293
294 sh -x clean-source.sh \
295         %{!?with_nacl:nacl=0} \
296         %{!?with_system_libvpx:libvpx=0} \
297         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
298         %{!?with_system_mesa:mesa=0} \
299         %{!?with_system_protobuf:protobuf=0} \
300         %{!?with_system_re2:re2=0} \
301         %{!?with_system_v8:v8=0} \
302         %{!?with_system_zlib:zlib=0} \
303         %{nil}
304
305 %build
306 %if %{with nacl}
307 rm -rf native_client/toolchain/linux_x86_newlib
308 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
309 # Make symlinks for NaCL
310 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
311
312 cd native_client/toolchain/linux_x86_newlib
313 ln -s x86_64-nacl/bin bin
314 cd x86_64-nacl/bin
315 __cc='%{__cc}'
316 if [ "${__cc#ccache}" != "$__cc" ]; then
317         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
318         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
319         %{__sed} -i -e '1i#!/bin/sh' gcc g++
320         chmod +x gcc g++
321 else
322         ln -s %{_bindir}/x86_64-nacl-gcc gcc
323         ln -s %{_bindir}/x86_64-nacl-g++ g++
324 fi
325 ln -s gcc x86_64-nacl-gcc
326 ln -s g++ x86_64-nacl-g++
327 ln -s %{_bindir}/x86_64-nacl-ar .
328 ln -s %{_bindir}/x86_64-nacl-ar ar
329 ln -s %{_bindir}/x86_64-nacl-as as
330 ln -s %{_bindir}/x86_64-nacl-ranlib .
331 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
332 ln -s %{_bindir}/x86_64-nacl-strip .
333 ln -s %{_bindir}/x86_64-nacl-strip strip
334 ln -s %{_prefix}/x86_64-nacl/lib ../lib
335 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
336 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
337 cd ../../../../..
338 fi
339 %endif
340
341 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
342 test -e Makefile || \
343         CC="%{__cc}" \
344         CXX="%{__cxx}" \
345         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
346         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
347         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
348 %{__python} build/gyp_chromium \
349         --format=make \
350         --depth=. \
351         build/all.gyp \
352 %ifarch %{ix86}
353         -Dtarget_arch=ia32 \
354 %endif
355 %ifarch %{x8664}
356         -Dtarget_arch=x64 \
357 %endif
358 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
359         -Dno_strict_aliasing=1 -Dgcc_version=44 \
360 %endif
361 %if %{with sandboxing}
362         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
363         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
364 %endif
365         %{!?debug:-Dwerror=} \
366         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
367         %{?with_shared_libs:-Dlibrary=shared_library} \
368         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} -Dproprietary_codecs=1 \
369         -Dinclude_tests=0 \
370 %if %{with nacl}
371         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
372         -Ddisable_glibc_untar=1 \
373         -Ddisable_newlib_untar=1 \
374         -Ddisable_glibc=1 \
375         -Ddisable_pnacl=1 \
376         -Dbuild_pnacl_newlib=0 \
377 %else
378         -Ddisable_pnacl_untar=1 \
379         -Ddisable_nacl=1 \
380 %endif
381         %{!?with_sse2:-Ddisable_sse2=1} \
382         %{?with_selinux:-Dselinux=1} \
383         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
384         -Dlinux_link_libpci=1 \
385         -Dlinux_link_libspeechd=1 \
386         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
387         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
388         -Dlinux_use_gold_binary=0 \
389         -Dlinux_use_gold_flags=0 \
390         %{gyp_with cups} \
391         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
392         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
393         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
394         %{gyp_with pulseaudio} \
395         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
396         %{gyp_with system_flac} \
397         %{gyp_with system_harfbuzz} \
398         %{gyp_with system_jsoncpp} \
399         %{gyp_with system_libexif} \
400         %{gyp_with system_libmtp} \
401         %{gyp_with system_libsrtp} \
402         %{gyp_with system_libusb} \
403         %{gyp_with system_libvpx} -Dmedia_use_libvpx=0 \
404         %{gyp_with system_libwebp} \
405         %{gyp_with system_libxnvctrl} \
406         %{gyp_with system_mesa} \
407         %{gyp_with system_minizip} \
408         %{gyp_with system_opus} \
409         %{gyp_with system_protobuf} \
410         %{gyp_with system_re2} \
411         %{gyp_with system_speex} \
412         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
413         %{gyp_with system_v8} \
414         %{gyp_with system_yasm} \
415         %{gyp_with system_zlib} \
416         -Duse_system_bzip2=1 \
417         -Duse_system_expat=1 \
418         -Duse_system_icu=1 \
419         -Duse_system_libevent=1 \
420         -Duse_system_libjpeg=1 \
421         -Duse_system_libpng=1 \
422         -Duse_system_libxml=1 \
423         -Duse_system_libxslt=1 \
424         -Duse_system_nspr=1 \
425         -Duse_system_xdg_utils=1 \
426
427 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
428 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
429         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
430         %{?with_verbose:V=1} \
431         CC.host="%{__cc}" \
432         CXX.host="%{__cxx}" \
433         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
434
435 cd out/%{!?debug:Release}%{?debug:Debug}
436 MANWIDTH=80 man ./chrome.1 > man.out
437 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
438
439 %install
440 rm -rf $RPM_BUILD_ROOT
441 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
442         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
443
444 cd out/%{!?debug:Release}%{?debug:Debug}
445 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
446 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
447 %{__sed} -i -e '
448         s,@libdir@,%{_libdir}/%{name},
449
450         /@OPTIONS@/ {
451                 r options.txt
452                 d
453         }
454 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
455 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
456 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
457 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
458 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
459 %if %{without system_ffmpeg}
460 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
461 %endif
462 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
463 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
464
465 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
466
467 %if %{with nacl}
468 # Install Native Client files on platforms that support it.
469 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
470 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
471 %ifarch %{x8664}
472 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
473 %endif
474 %ifarch %{ix86}
475 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
476 %endif
477 %endif
478
479 cd -
480
481 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
482         size=${icon##*/product_logo_}
483         size=${size%.png}
484
485         # this will skip non-numeric (22_mono_invert, 22_mono)
486         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
487         test -d "$dir" || continue
488
489         install -d $RPM_BUILD_ROOT$dir
490         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
491 done
492
493 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
494 # http://code.google.com/p/chromium/issues/detail?id=24507
495 gecko-mediaplayer*.so
496 EOF
497
498 # find locales
499 %find_lang %{name}.lang
500 # always package en-US
501 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
502
503 %clean
504 rm -rf $RPM_BUILD_ROOT
505
506 %post
507 %update_icon_cache hicolor
508 %update_desktop_database
509 %update_browser_plugins
510
511 %postun
512 if [ "$1" = 0 ]; then
513         %update_icon_cache hicolor
514         %update_browser_plugins
515 fi
516
517 %files
518 %defattr(644,root,root,755)
519 %doc AUTHORS LICENSE
520 %{_browserpluginsconfdir}/browsers.d/%{name}.*
521 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
522 %dir %{_sysconfdir}/%{name}
523 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
524 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
525 %attr(755,root,root) %{_bindir}/%{name}
526 %{_mandir}/man1/%{name}.1*
527 %{_desktopdir}/*.desktop
528 %{_iconsdir}/hicolor/*/apps/%{name}.png
529 %dir %{_libdir}/%{name}
530 %{_libdir}/%{name}/chrome*.pak
531 %{_libdir}/%{name}/content_resources.pak
532 %{_libdir}/%{name}/resources.pak
533 %dir %{_libdir}/%{name}/locales
534 %{_libdir}/%{name}/locales/en-US.pak
535 %dir %{_libdir}/%{name}/resources
536 %{_libdir}/%{name}/resources/inspector
537 %dir %{_libdir}/%{name}/themes
538 %dir %{_libdir}/%{name}/extensions
539 %dir %{_libdir}/%{name}/plugins
540 %attr(755,root,root) %{_libdir}/%{name}/%{name}
541 # These unique permissions are intentional and necessary for the sandboxing
542 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
543
544 # ffmpeg libs
545 %if %{without system_ffmpeg}
546 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
547 %endif
548
549 %if %{with nacl}
550 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
551 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
552 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
553 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
554 %endif
555
556 %files l10n -f %{name}.lang
557 %defattr(644,root,root,755)
This page took 0.086795 seconds and 4 git commands to generate.