]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
- up to 47994
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_with     verbose         # verbose build (V=1)
4 %bcond_with     selinux         # with SELinux (need policy first)
5 %bcond_with     system_v8       # with system v8
6 %bcond_without  system_zlib     # with system zlib
7 %bcond_with     system_sqlite   # with system sqlite
8 %bcond_without  ffmpegsumo      # build with ffmpegsumo
9 %bcond_without  sandboxing      # with sandboxing
10 %bcond_with     shared_libs     # with shared libs
11 %bcond_without  debuginfo       # disable debuginfo creation (it is huge)
12
13 # TODO
14 # - check system sqlite linking problems
15 # - enable H264 video support if possible (test:  youtube.com/html5 and join html5 there)
16 # - http://groups.google.com/a/chromium.org/group/chromium-discuss/browse_thread/thread/c82bf49672a213f4/9267df53f5d734c4
17
18 # NOTES:
19 # - mute BEEP mixer if you do not want to hear horrible system bell when
20 #   pressing home/end in url bar or more ^F search results on page.
21 # - build i686: -bp: ~570MB; bc: ~928MB; -bb: ~1.0GB
22 # - build x86_64: -bp: ~570MB; bc: ~990MB; -bb: ~1.0GB
23 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
24 # - to look for new tarball, use update-source.sh script
25
26 %define         svndate 20100523
27 %define         svnver  47994
28 %define         rel             1
29
30 Summary:        A WebKit powered web browser
31 Name:           chromium-browser
32 Version:        6.0.414.0
33 Release:        %{svnver}.%{rel}
34 License:        BSD, LGPL v2+ (ffmpeg)
35 Group:          X11/Applications/Networking
36 Source0:        http://ppa.launchpad.net/chromium-daily/ppa/ubuntu/pool/main/c/chromium-browser/%{name}_%{version}~svn%{svndate}r%{svnver}.orig.tar.gz
37 # Source0-md5:  7f5c0c46d1f5f115a0bf0456a3b983d3
38 Source2:        %{name}.sh
39 Source3:        %{name}.desktop
40 Source4:        find-lang.sh
41 Source5:        update-source.sh
42 Patch0:         system-libs.patch
43 Patch1:         plugin-searchdirs.patch
44 Patch2:         gyp-system-minizip.patch
45 # http://bazaar.launchpad.net/~chromium-team/chromium-browser/chromium-browser.head/annotate/head%3A/debian/patches/html5_video_mimetypes.patch
46 Patch5:         options-support.patch
47 Patch11:        memory_details-iceweasel.patch
48 URL:            http://code.google.com/chromium/
49 BuildRequires:  GConf2-devel
50 BuildRequires:  OpenGL-GLU-devel
51 BuildRequires:  alsa-lib-devel
52 BuildRequires:  atk-devel
53 BuildRequires:  bison
54 BuildRequires:  bzip2-devel
55 BuildRequires:  dbus-devel
56 BuildRequires:  flex
57 BuildRequires:  fontconfig-devel
58 BuildRequires:  glib2-devel
59 BuildRequires:  gperf
60 BuildRequires:  gtk+2-devel
61 BuildRequires:  libevent-devel
62 BuildRequires:  libjpeg-devel
63 BuildRequires:  libpng-devel
64 %{?with_selinux:BuildRequires:  libselinux-devel}
65 BuildRequires:  libstdc++-devel
66 BuildRequires:  libvpx-devel
67 BuildRequires:  libxml2-devel
68 BuildRequires:  libxslt-devel
69 BuildRequires:  lzma
70 BuildRequires:  minizip-devel
71 BuildRequires:  nspr-devel
72 BuildRequires:  nss-devel >= 1:3.12.3
73 BuildRequires:  pango-devel
74 BuildRequires:  perl-modules
75 BuildRequires:  pkgconfig
76 BuildRequires:  python
77 # grep gyp.googlecode.com src/DEPS | cut -d'"' -f2 | cut -d@ -f2
78 BuildRequires:  python-gyp >= 0.1-795
79 BuildRequires:  python-modules
80 BuildRequires:  rpmbuild(macros) >= 1.453
81 BuildRequires:  sqlite3-devel >= 3.6.1
82 %{?with_system_v8:BuildRequires:        v8-devel}
83 BuildRequires:  xorg-lib-libXScrnSaver-devel
84 %{?with_system_zlib:BuildRequires:      zlib-devel}
85 Requires:       browser-plugins >= 2.0
86 Requires:       xdg-utils
87 Provides:       wwwbrowser
88 ExclusiveArch:  %{ix86} %{x8664} arm
89 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
91 %define         find_lang       sh find-lang.sh %{buildroot}
92
93 %if %{without debuginfo}
94 %define         _enable_debug_packages  0
95 %endif
96
97 %description
98 Chromium is an open-source browser project that aims to build a safer,
99 faster, and more stable way for all Internet users to experience the
100 web.
101
102 Chromium serves as a base for Google Chrome, which is Chromium
103 rebranded (name and logo) with very few additions such as usage
104 tracking and an auto-updater system.
105
106 This package contains the Chromium browser.
107
108 %package inspector
109 Summary:        Page inspector for the chromium-browser
110 Group:          Development/Tools
111 Requires:       %{name} = %{version}-%{release}
112
113 %description inspector
114 Chromium is an open-source browser project that aims to build a safer,
115 faster, and more stable way for all Internet users to experience the
116 web.
117
118 This package contains 'inspector', allowing web developpers to inspect
119 any element of a web page at runtime (html, javascript, css, ..)
120
121 %package l10n
122 Summary:        chromium-browser language packages
123 Group:          I18n
124 Requires:       %{name} = %{version}-%{release}
125
126 %description l10n
127 Chromium is an open-source browser project that aims to build a safer,
128 faster, and more stable way for all Internet users to experience the
129 web.
130
131 This package contains language packages for 50 languages:
132
133 ar, bg, bn, ca, cs, da, de, el, en-GB, es-419, es, et, fi, fil, fr,
134 gu, he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or,
135 pl, pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi,
136 zh-CN, zh-TW
137
138 %prep
139 %setup -q -n %{name}-%{version}~svn%{svndate}r%{svnver}
140 lzma -dc %{name}-%{version}~svn%{svndate}r%{svnver}-source.tar.lzma | tar x
141 rm -f %{name}-%{version}~svn%{svndate}r%{svnver}-source.tar.lzma
142
143 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
144 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
145 . ./src/chrome/VERSION
146 ver=$MAJOR.$MINOR.$BUILD.$PATCH
147 if [ "$ver" != %{version} ]; then
148         exit 1
149 fi
150
151 # Populate the LASTCHANGE file template as we no longer have the VCS files at this point
152 echo "%{svnver}" > src/build/LASTCHANGE.in
153
154 sed -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE4} > find-lang.sh
155
156 %patch0 -p1
157 %patch1 -p1
158 %patch2 -p1
159 %patch5 -p1
160 %patch11 -p1
161
162 %build
163 cd src
164 %{__python} build/gyp_chromium --format=make build/all.gyp \
165 %ifarch %{ix86}
166         -Dtarget_arch=ia32 \
167 %endif
168 %ifarch %{x8664}
169         -Dtarget_arch=x64 \
170 %endif
171 %if "%{cc_version}" >= "4.4.0"
172         -Dno_strict_aliasing=1 -Dgcc_version=$(echo %{cc_version} | cut -d. -f1-2 | tr -d .) \
173 %endif
174 %if %{with sandboxing}
175         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
176         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
177 %endif
178         %{!?debug:-Dwerror=} \
179         %{?with_shared_libs:-Dlibrary=shared_library} \
180         -Djavascript_engine=%{?with_system_v8:system-v8}%{!?with_system_v8:v8} \
181         -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
182         -Duse_system_bzip2=1 \
183         -Duse_system_libevent=1 \
184         -Duse_system_libjpeg=1 \
185         -Duse_system_libpng=1 \
186         -Duse_system_libxml=1 \
187         -Duse_system_libxslt=1 \
188         -Duse_system_sqlite=%{?with_system_sqlite:1}%{!?with_system_sqlite:0} \
189         -Duse_system_zlib=%{?with_system_zlib:1}%{!?with_system_zlib:0} \
190         -Dproprietary_codecs=1 \
191 %if %{with arch}
192         -Duse_system_yasm=1 \
193         -Dffmpeg_branding=Chrome \
194 %endif
195 %if %{with selinux}
196         -Dselinux=1 \
197 %endif
198
199 %{__make} chrome %{?with_sandboxing:chrome_sandbox} \
200         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
201         %{?with_verbose:V=1} \
202         CC="%{__cc}" \
203         CXX="%{__cxx}" \
204         CC.host="%{__cc}" \
205         CXX.host="%{__cxx}" \
206         CFLAGS="%{rpmcflags}" \
207         CXXFLAGS="%{rpmcxxflags}"
208
209 %install
210 rm -rf $RPM_BUILD_ROOT
211 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}/{themes,locales,plugins,extensions,resources},%{_mandir}/man1,%{_pixmapsdir},%{_desktopdir}}
212
213 cd src/out/%{!?debug:Release}%{?debug:Debug}
214
215 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
216 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
217 cp -a chrome.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
218 cp -a locales/*.pak $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
219 cp -a resources/* $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
220 cp -a chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
221 cp -a product_logo_48.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
222 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
223 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
224 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
225 install -p xdg-settings $RPM_BUILD_ROOT%{_libdir}/%{name}
226 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
227 cd -
228
229 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
230 # http://code.google.com/p/chromium/issues/detail?id=24507
231 gecko-mediaplayer*.so
232 EOF
233
234 # find locales
235 %find_lang %{name}.lang
236 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
237
238 %clean
239 rm -rf $RPM_BUILD_ROOT
240
241 %post
242 %update_browser_plugins
243
244 %postun
245 if [ "$1" = 0 ]; then
246         %update_browser_plugins
247 fi
248
249 %files -f %{name}.lang
250 %defattr(644,root,root,755)
251 %{_browserpluginsconfdir}/browsers.d/%{name}.*
252 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
253 %attr(755,root,root) %{_bindir}/%{name}
254 %{_mandir}/man1/%{name}.1*
255 %{_pixmapsdir}/%{name}.png
256 %{_desktopdir}/*.desktop
257 %dir %{_libdir}/%{name}
258 %{_libdir}/%{name}/chrome.pak
259 %dir %{_libdir}/%{name}/locales
260 %{_libdir}/%{name}/locales/en-US.pak
261 %dir %{_libdir}/%{name}/resources
262 %dir %{_libdir}/%{name}/themes
263 %dir %{_libdir}/%{name}/extensions
264 %dir %{_libdir}/%{name}/plugins
265 %attr(755,root,root) %{_libdir}/%{name}/%{name}
266 # These unique permissions are intentional and necessary for the sandboxing
267 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
268
269 # ffmpeg libs
270 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
271
272 # bundle this copy until xdg-utils will have this itself
273 %attr(755,root,root) %{_libdir}/%{name}/xdg-settings
274
275 %{_libdir}/%{name}/resources/bookmark_manager
276 %{_libdir}/%{name}/resources/calendar_app
277 %{_libdir}/%{name}/resources/docs_app
278 %{_libdir}/%{name}/resources/gmail_app
279 %{_libdir}/%{name}/resources/net_internals
280 %{_libdir}/%{name}/resources/shared
281
282 %files inspector
283 %defattr(644,root,root,755)
284 %{_libdir}/%{name}/resources/inspector
285
286 %files l10n -f %{name}.lang
287 %defattr(644,root,root,755)
This page took 0.057852 seconds and 3 git commands to generate.