]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
up to 26.0.1410.33
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
9 %bcond_without  libjpegturbo    # use libjpeg-turbo features
10 %bcond_without  nacl                    # build Native Client support
11 %bcond_without  pulseaudio              # with pulseaudio
12 %bcond_without  sandboxing              # with sandboxing
13 %bcond_with             selinux                 # with SELinux (need policy first)
14 %bcond_with             shared_libs             # with shared libs
15 %bcond_with             sse2                    # use SSE2 instructions
16 %bcond_without  system_flac             # system flac
17 %bcond_without  system_ffmpeg   # system ffmpeg instead of ffmpegsumo
18 %bcond_without  system_harfbuzz # system harfbuzz
19 %bcond_without  system_jsoncpp  # system jsoncpp
20 %bcond_without  system_libexif  # system libexif
21 %bcond_without  system_libmtp   # system libmtp
22 %bcond_without  system_libusb   # system libusb-1
23 %bcond_without  system_libwebp  # system libwebp
24 %bcond_without  system_libxnvctrl       # system libxnvctrl
25 %bcond_without  system_mesa             # system Mesa
26 %bcond_without  system_minizip  # system minizip
27 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
28 %bcond_without  system_protobuf # system protobuf
29 %bcond_with             system_re2              # system re2
30 %bcond_without  system_speex    # system speex
31 %bcond_with             system_sqlite   # system sqlite
32 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
33 %bcond_with             system_v8               # system v8
34 %bcond_without  system_libvpx   # system libvpx
35 %bcond_without  system_yasm             # system yasm
36 %bcond_without  system_zlib             # system zlib
37 %bcond_without  tcmalloc                # use tcmalloc
38 %bcond_without  verbose                 # verbose build (V=1)
39
40 %ifarch %{ix86}
41 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
42 %undefine       with_system_mesa
43 %endif
44
45 # TODO
46 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
47 # - use_system_skia
48 # - use_system_ssl (use_openssl: http://crbug.com/62803)
49 # - use_system_stlport (android specific)
50 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
51
52 # NOTES:
53 # - mute BEEP mixer if you do not want to hear horrible system bell when
54 #   pressing home/end in url bar or more ^F search results on page.
55 # - space considerations:
56 #   - unpacked sources: ~490MiB
57 #   - built code: ~1.4GiB (x86_64/i686)
58 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
59 # - to look for new tarball, use update-source.sh script
60
61 # NOTE TO USERS:
62 # To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
63 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
64 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
65
66 %define         branch          26.0.1410
67 %define         basever         33
68 #define         patchver        70
69 %define         gyp_rev 1014
70 Summary:        A WebKit powered web browser
71 Name:           chromium-browser
72 %if "%{?patchver}" != ""
73 Version:        %{branch}.%{patchver}
74 %else
75 Version:        %{branch}.%{basever}
76 %endif
77 Release:        0.32
78 License:        BSD, LGPL v2+ (ffmpeg)
79 Group:          X11/Applications/Networking
80 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{branch}.%{basever}.tar.gz
81 # Source0-md5:  e42f86208205701bd23b34ba963e7d83
82 %if "%{?patchver}" != ""
83 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
84 # Patch0-md5:   37675cd75c578d26d6210259877f3947
85 %endif
86 Source1:        %{name}.default
87 Source2:        %{name}.sh
88 Source3:        %{name}.desktop
89 Source5:        find-lang.sh
90 Source6:        update-source.sh
91 Source7:        clean-source.sh
92 Source8:        get-source.sh
93 Source9:        master_preferences.json
94 Patch1:         plugin-searchdirs.patch
95 #Patch2:                system-nspr.patch
96 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
97 Patch4:         path-libpdf.patch
98 Patch6:         get-webkit_revision.patch
99 Patch7:         dlopen_sonamed_gl.patch
100 Patch8:         chromium_useragent.patch.in
101 Patch9:         chromium-ppapi.patch
102 Patch10:        system-libxnvctrl.patch
103 # https://bugs.gentoo.org/show_bug.cgi?id=393471
104 # libjpeg-turbo >= 1.1.90 supports that feature
105 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
106 Patch12:        system-ffmpeg.patch
107 Patch15:        nacl-build-irt.patch
108 Patch16:        nacl-linkingfix.patch
109 Patch18:        nacl-no-untar.patch
110 Patch19:        system-jsoncpp.patch
111 Patch24:        nacl-verbose.patch
112 Patch25:        gnome3-volume-control.patch
113 Patch26:        master-prefs-path.patch
114 Patch27:        tcmalloc-glibc2.16.patch
115 Patch28:        system-mesa.patch
116 Patch29:        speechd-0.8.patch
117 URL:            http://www.chromium.org/Home
118 %{?with_gconf:BuildRequires:    GConf2-devel}
119 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
120 %{?with_system_mesa:BuildRequires:      Mesa-libGLES-devel >= 9.1}
121 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
122 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
123 BuildRequires:  alsa-lib-devel
124 BuildRequires:  atk-devel
125 BuildRequires:  bison
126 BuildRequires:  bzip2-devel
127 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
128 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
129 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
130 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
131 %{?with_cups:BuildRequires:     cups-devel}
132 BuildRequires:  elfutils-devel
133 BuildRequires:  expat-devel
134 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
135 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
136 BuildRequires:  fontconfig-devel
137 BuildRequires:  glib2-devel
138 BuildRequires:  gperf
139 %{?with_gps:BuildRequires:      gpsd-devel}
140 BuildRequires:  gtest-devel
141 BuildRequires:  gtk+2-devel
142 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
143 %{?with_kerberos:BuildRequires: heimdal-devel}
144 BuildRequires:  hicolor-icon-theme
145 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
146 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
147 BuildRequires:  libevent-devel
148 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
149 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
150 BuildRequires:  libicu-devel >= 4.6
151 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
152 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
153 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
154 BuildRequires:  libpng-devel
155 %{?with_selinux:BuildRequires:  libselinux-devel}
156 BuildRequires:  libstdc++-devel
157 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
158 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
159 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
160 BuildRequires:  libxml2-devel
161 BuildRequires:  libxslt-devel
162 BuildRequires:  man-db
163 %{?with_system_minizip:BuildRequires:   minizip-devel}
164 BuildRequires:  nspr-devel
165 BuildRequires:  nss-devel >= 1:3.12.3
166 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
167 BuildRequires:  pam-devel
168 BuildRequires:  pango-devel
169 BuildRequires:  pciutils-devel
170 BuildRequires:  perl-modules
171 BuildRequires:  pkgconfig
172 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
173 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
174 BuildRequires:  python
175 #BuildRequires: python-gyp >= 1-%{gyp_rev}
176 BuildRequires:  python-modules
177 BuildRequires:  python-ply
178 %{?with_system_re2:BuildRequires:       re2-devel}
179 BuildRequires:  rpm >= 4.4.9-56
180 BuildRequires:  rpmbuild(macros) >= 1.453
181 BuildRequires:  speech-dispatcher-devel >= 0.8
182 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
183 BuildRequires:  sqlite3-devel >= 3.6.1
184 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
185 BuildRequires:  subversion
186 BuildRequires:  tar >= 1:1.22
187 BuildRequires:  udev-devel
188 BuildRequires:  usbutils
189 BuildRequires:  util-linux
190 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
191 BuildRequires:  which
192 BuildRequires:  xorg-lib-libXScrnSaver-devel
193 BuildRequires:  xz
194 %{?with_system_yasm:BuildRequires:      yasm}
195 %{?with_system_zlib:BuildRequires:      zlib-devel}
196 Requires:       browser-plugins >= 2.0
197 Requires:       desktop-file-utils
198 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
199 # crashes if no fontconfig font present
200 Requires:       fonts-Type1-urw
201 Requires:       hicolor-icon-theme
202 Requires:       libevent >= 2.0.21
203 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
204 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
205 Requires:       lsb-release
206 Requires:       shared-mime-info
207 Requires:       xdg-utils >= 1.0.2-4
208 Requires:       xorg-lib-libX11 >= 1.4.99.1
209 Provides:       wwwbrowser
210 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
211 Obsoletes:      chromium-browser-inspector < 15.0.863.0
212 ExclusiveArch:  %{ix86} %{x8664} arm
213 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
214
215 %define         find_lang       sh find-lang.sh %{buildroot}
216
217 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
218 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
219
220 %if %{without debuginfo}
221 %define         _enable_debug_packages  0
222 %endif
223
224 %description
225 Chromium is an open-source browser project that aims to build a safer,
226 faster, and more stable way for all Internet users to experience the
227 web.
228
229 Chromium serves as a base for Google Chrome, which is Chromium
230 rebranded (name and logo) with very few additions such as usage
231 tracking and an auto-updater system.
232
233 %package l10n
234 Summary:        chromium-browser language packages
235 Group:          I18n
236 Requires:       %{name} = %{version}-%{release}
237
238 %description l10n
239 Chromium is an open-source browser project that aims to build a safer,
240 faster, and more stable way for all Internet users to experience the
241 web.
242
243 This package contains language packages for 50 languages:
244
245 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
246 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
247 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
248 zh-TW
249
250 %prep
251 %setup -qc
252 %if "%{?patchver}" != ""
253 cd %{name}-%{branch}.%{basever}
254 %patch0 -p1
255 cd ..
256 %endif
257 mv %{name}-%{branch}.%{basever}/src .
258
259 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
260 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
261 . ./src/chrome/VERSION
262 ver=$MAJOR.$MINOR.$BUILD.$PATCH
263 test "$ver" = %{version}
264
265 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
266 test "$gyp_rev" = %{gyp_rev} || :
267
268 v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
269
270 # add chromium and pld to useragent
271 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
272 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
273         -e 's/@BUILD_DIST_NAME@/PLD/g' \
274         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
275         < %{PATCH8} | %{__patch} -p1
276
277 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
278 ln -s %{SOURCE7} src
279
280 %patch1 -p1
281 %patch3 -p1
282 %patch4 -p1
283 %patch6 -p1
284 %patch7 -p1
285 %patch10 -p1
286 %patch15 -p1
287 cd src
288 %patch9 -p0
289 #%patch2 -p1
290 %{!?with_libjpegturbo:%patch11 -p0}
291 %patch12 -p1
292 %patch16 -p1
293 %patch19 -p1
294 %patch27 -p1
295 %patch28 -p1
296 cd ..
297 %patch25 -p1
298 %patch18 -p1
299 %patch24 -p1
300 %patch26 -p1
301 %patch29 -p1
302
303 cd src
304
305 sh -x clean-source.sh \
306         %{!?with_nacl:nacl=0} \
307         %{!?with_system_libvpx:libvpx=0} \
308         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
309         %{!?with_system_mesa:mesa=0} \
310         %{!?with_system_protobuf:protobuf=0} \
311         %{!?with_system_re2:re2=0} \
312         %{!?with_system_v8:v8=0} \
313         %{!?with_system_zlib:zlib=0} \
314         %{nil}
315
316 %build
317 cd src
318
319 %if %{with nacl}
320 rm -rf native_client/toolchain/linux_x86_newlib
321 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
322 # Make symlinks for NaCL
323 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
324
325 cd native_client/toolchain/linux_x86_newlib
326 ln -s x86_64-nacl/bin bin
327 cd x86_64-nacl/bin
328 __cc='%{__cc}'
329 if [ "${__cc#ccache}" != "$__cc" ]; then
330         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
331         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
332         %{__sed} -i -e '1i#!/bin/sh' gcc g++
333         chmod +x gcc g++
334 else
335         ln -s %{_bindir}/x86_64-nacl-gcc gcc
336         ln -s %{_bindir}/x86_64-nacl-g++ g++
337 fi
338 ln -s gcc x86_64-nacl-gcc
339 ln -s g++ x86_64-nacl-g++
340 ln -s %{_bindir}/x86_64-nacl-ar .
341 ln -s %{_bindir}/x86_64-nacl-ar ar
342 ln -s %{_bindir}/x86_64-nacl-as as
343 ln -s %{_bindir}/x86_64-nacl-ranlib .
344 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
345 ln -s %{_bindir}/x86_64-nacl-strip .
346 ln -s %{_bindir}/x86_64-nacl-strip strip
347 ln -s %{_prefix}/x86_64-nacl/lib ../lib
348 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
349 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
350 cd ../../../../..
351 fi
352 %endif
353
354 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
355 test -e Makefile || \
356         CC="%{__cc}" \
357         CXX="%{__cxx}" \
358         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
359         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
360         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
361 %{__python} build/gyp_chromium \
362         --format=make \
363         -Goutput_dir=../out \
364         build/all.gyp \
365 %ifarch %{ix86}
366         -Dtarget_arch=ia32 \
367 %endif
368 %ifarch %{x8664}
369         -Dtarget_arch=x64 \
370 %endif
371 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
372         -Dno_strict_aliasing=1 -Dgcc_version=44 \
373 %endif
374 %if %{with sandboxing}
375         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
376         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
377 %endif
378         %{!?debug:-Dwerror=} \
379         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
380         %{?with_shared_libs:-Dlibrary=shared_library} \
381         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
382         -Dinclude_tests=0 \
383 %if %{with nacl}
384         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
385         -Ddisable_glibc_untar=1 \
386         -Ddisable_newlib_untar=1 \
387         -Ddisable_glibc=1 \
388         -Ddisable_pnacl=1 \
389         -Dbuild_pnacl_newlib=0 \
390 %else
391         -Ddisable_pnacl_untar=1 \
392         -Ddisable_nacl=1 \
393 %endif
394         %{!?with_sse2:-Ddisable_sse2=1} \
395         %{?with_selinux:-Dselinux=1} \
396         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
397         -Dlinux_link_libpci=1 \
398         -Dlinux_link_libspeechd=1 \
399         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
400         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
401         -Dlinux_use_gold_binary=0 \
402         -Dlinux_use_gold_flags=0 \
403         %{gyp_with cups} \
404         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
405         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
406         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
407         %{gyp_with pulseaudio} \
408         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
409         %{gyp_with system_flac} \
410         %{gyp_with system_harfbuzz} \
411         %{gyp_with system_libexif} \
412         %{gyp_with system_libmtp} \
413         %{gyp_with system_libsrtp} \
414         %{gyp_with system_libusb} \
415         %{gyp_with system_libvpx} -Dmedia_use_libvpx=0 \
416         %{gyp_with system_libwebp} \
417         %{gyp_with system_libxnvctrl} \
418         %{gyp_with system_mesa} \
419         %{gyp_with system_minizip} \
420         %{gyp_with system_opus} \
421         %{gyp_with system_protobuf} \
422         %{gyp_with system_re2} \
423         %{gyp_with system_speex} \
424         %{gyp_with system_sqlite} \
425         %{gyp_with system_v8} \
426         %{gyp_with system_yasm} \
427         %{gyp_with system_zlib} \
428         -Duse_system_bzip2=1 \
429         -Duse_system_expat=1 \
430         -Duse_system_icu=1 \
431         -Duse_system_libevent=1 \
432         -Duse_system_libjpeg=1 \
433         -Duse_system_libpng=1 \
434         -Duse_system_libxml=1 \
435         -Duse_system_libxslt=1 \
436         -Duse_system_nspr=1 \
437         -Duse_system_xdg_utils=1 \
438
439 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
440 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
441         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
442         %{?with_verbose:V=1} \
443         CC.host="%{__cc}" \
444         CXX.host="%{__cxx}" \
445         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
446
447 cd ../out/%{!?debug:Release}%{?debug:Debug}
448 MANWIDTH=80 man ./chrome.1 > man.out
449 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
450
451 %install
452 rm -rf $RPM_BUILD_ROOT
453 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
454         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
455
456 cd out/%{!?debug:Release}%{?debug:Debug}
457 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
458 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
459 %{__sed} -i -e '
460         s,@libdir@,%{_libdir}/%{name},
461
462         /@OPTIONS@/ {
463                 r options.txt
464                 d
465         }
466 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
467 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
468 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
469 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
470 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
471 %if %{without system_ffmpeg}
472 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
473 %endif
474 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
475 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
476
477 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
478
479 %if %{with nacl}
480 # Install Native Client files on platforms that support it.
481 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
482 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
483 %ifarch %{x8664}
484 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
485 %endif
486 %ifarch %{ix86}
487 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
488 %endif
489 %endif
490
491 cd -
492
493 for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
494         size=${icon##*/product_logo_}
495         size=${size%.png}
496
497         # this will skip non-numeric (22_mono_invert, 22_mono)
498         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
499         test -d "$dir" || continue
500
501         install -d $RPM_BUILD_ROOT$dir
502         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
503 done
504
505 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
506 # http://code.google.com/p/chromium/issues/detail?id=24507
507 gecko-mediaplayer*.so
508 EOF
509
510 # find locales
511 %find_lang %{name}.lang
512 # always package en-US
513 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
514
515 %clean
516 rm -rf $RPM_BUILD_ROOT
517
518 %post
519 %update_icon_cache hicolor
520 %update_desktop_database
521 %update_browser_plugins
522
523 %postun
524 if [ "$1" = 0 ]; then
525         %update_icon_cache hicolor
526         %update_browser_plugins
527 fi
528
529 %files
530 %defattr(644,root,root,755)
531 %doc src/{AUTHORS,LICENSE}
532 %{_browserpluginsconfdir}/browsers.d/%{name}.*
533 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
534 %dir %{_sysconfdir}/%{name}
535 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
536 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
537 %attr(755,root,root) %{_bindir}/%{name}
538 %{_mandir}/man1/%{name}.1*
539 %{_desktopdir}/*.desktop
540 %{_iconsdir}/hicolor/*/apps/%{name}.png
541 %dir %{_libdir}/%{name}
542 %{_libdir}/%{name}/chrome*.pak
543 %{_libdir}/%{name}/content_resources.pak
544 %{_libdir}/%{name}/resources.pak
545 %dir %{_libdir}/%{name}/locales
546 %{_libdir}/%{name}/locales/en-US.pak
547 %dir %{_libdir}/%{name}/resources
548 %{_libdir}/%{name}/resources/inspector
549 %dir %{_libdir}/%{name}/themes
550 %dir %{_libdir}/%{name}/extensions
551 %dir %{_libdir}/%{name}/plugins
552 %attr(755,root,root) %{_libdir}/%{name}/%{name}
553 # These unique permissions are intentional and necessary for the sandboxing
554 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
555
556 # ffmpeg libs
557 %if %{without system_ffmpeg}
558 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
559 %endif
560
561 %if %{with nacl}
562 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
563 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
564 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
565 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
566 %endif
567
568 %files l10n -f %{name}.lang
569 %defattr(644,root,root,755)
This page took 0.096173 seconds and 3 git commands to generate.