]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
- add chromium-service.desktop to autostart
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
4 %bcond_without  ffmpegsumo              # build with ffmpegsumo
5 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
6 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
7 %bcond_without  cups                    # with cups
8 %bcond_without  gconf                   # with GConf
9 %bcond_without  pulseaudio              # with pulseaudio
10 %bcond_with             nacl                    # build Native Client support
11 %bcond_without  sandboxing              # with sandboxing
12 %bcond_with             selinux                 # with SELinux (need policy first)
13 %bcond_with             shared_libs             # with shared libs
14 %bcond_with             sse2                    # use SSE2 instructions
15 %bcond_with             system_sqlite   # with system sqlite
16 %bcond_without  system_flac             # with system flac
17 %bcond_without  system_libwebp  # with system libwebp
18 %bcond_without  system_speex    # with system speex
19 %bcond_without  system_v8               # with system v8
20 %bcond_without  system_vpx              # with system vpx
21 %bcond_without  system_yasm             # with system yasm
22 %bcond_without  system_zlib             # with system zlib
23 %bcond_with             verbose                 # verbose build (V=1)
24
25 # TODO
26 # - check system sqlite linking problems
27 # - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
28 # - use_system_ssl (use_openssl: http://crbug.com/62803)
29 # - use_system_ffmpeg && build_ffmpegsumo
30 # - use_system_hunspell
31 # - use_system_stlport
32 # - other defaults: src/build/common.gypi
33
34 # NOTES:
35 # - mute BEEP mixer if you do not want to hear horrible system bell when
36 #   pressing home/end in url bar or more ^F search results on page.
37 # - build -bp: 1.2G
38 # - build i686: -bc: 2.7G; -bb: ~1.0GB
39 # - build x86_64: ~1.9G
40 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
41 # - to look for new tarball, use update-source.sh script
42
43 # NOTE TO USERS:
44 # To use chromium nightly builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
45 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
46 # or:
47 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
48
49 %define         svndate %{nil}
50 %define         svnver  113337
51 %define         rel             1
52
53 %define         gyp_rev 1014
54 Summary:        A WebKit powered web browser
55 Name:           chromium-browser
56 Version:        16.0.912.63
57 Release:        0.%{svnver}.%{rel}
58 License:        BSD, LGPL v2+ (ffmpeg)
59 Group:          X11/Applications/Networking
60 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}_%{version}~r%{svnver}.orig.tar.gz
61 # Source0-md5:  c01869f276a9bf5f651771d93b07dac8
62 #SourceX:       http://ppa.launchpad.net/chromium-daily/ppa/ubuntu/pool/main/c/chromium-browser/%{name}_%{version}~svn%{svndate}r%{svnver}.orig.tar.gz
63 Source2:        %{name}.sh
64 Source3:        %{name}.desktop
65 Source4:        chromium-service.desktop
66 Source5:        find-lang.sh
67 Source6:        update-source.sh
68 Source7:        clean-source.sh
69 Patch0:         system-libs.patch
70 Patch1:         plugin-searchdirs.patch
71 Patch2:         gyp-system-minizip.patch
72 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
73 Patch5:         options-support.patch
74 Patch6:         get-webkit_revision.patch
75 Patch7:         dlopen_sonamed_gl.patch
76 Patch8:         chromium_useragent.patch.in
77 Patch9:         system-expat.patch
78 URL:            http://www.chromium.org/Home
79 %{?with_gconf:BuildRequires:    GConf2-devel}
80 BuildRequires:  OpenGL-GLU-devel
81 BuildRequires:  alsa-lib-devel
82 BuildRequires:  atk-devel
83 BuildRequires:  bison
84 BuildRequires:  bzip2-devel
85 %{?with_cups:BuildRequires:     cups-devel}
86 BuildRequires:  dbus-glib-devel
87 BuildRequires:  expat-devel
88 %{?with_system_flac:BuildRequires:      flac-devel}
89 BuildRequires:  flex
90 BuildRequires:  fontconfig-devel
91 BuildRequires:  glib2-devel
92 BuildRequires:  gperf
93 BuildRequires:  gtk+2-devel
94 %{?with_kerberos:BuildRequires: heimdal-devel}
95 BuildRequires:  libevent-devel
96 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
97 BuildRequires:  libicu-devel >= 4.6
98 BuildRequires:  libjpeg-devel
99 BuildRequires:  libpng-devel
100 %{?with_selinux:BuildRequires:  libselinux-devel}
101 BuildRequires:  libstdc++-devel
102 %{?with_system_vpx:BuildRequires:       libvpx-devel >= 0.9.5-2}
103 %{?with_system_libwebp:BuildRequires:   libwebp-devel}
104 BuildRequires:  libxml2-devel
105 BuildRequires:  libxslt-devel
106 BuildRequires:  lzma
107 BuildRequires:  minizip-devel
108 %{?with_nacl:BuildRequires:     nacl-toolchain-newlib >= 0.6941}
109 BuildRequires:  nspr-devel
110 BuildRequires:  nss-devel >= 1:3.12.3
111 BuildRequires:  pam-devel
112 BuildRequires:  pango-devel
113 BuildRequires:  perl-modules
114 BuildRequires:  pkgconfig
115 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
116 BuildRequires:  python
117 #BuildRequires: python-gyp >= 1-%{gyp_rev}
118 BuildRequires:  python-modules
119 BuildRequires:  rpm >= 4.4.9-56
120 BuildRequires:  rpmbuild(macros) >= 1.453
121 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
122 BuildRequires:  sqlite3-devel >= 3.6.1
123 BuildRequires:  tar >= 1:1.22
124 BuildRequires:  util-linux
125 %{?with_system_v8:BuildRequires:        v8-devel >= 3.6}
126 BuildRequires:  which
127 BuildRequires:  xorg-lib-libXScrnSaver-devel
128 BuildRequires:  xorg-lib-libXt-devel
129 BuildRequires:  xorg-lib-libXtst-devel
130 %{?with_system_yasm:BuildRequires:      yasm}
131 %{?with_system_zlib:BuildRequires:      zlib-devel}
132 Requires:       browser-plugins >= 2.0
133 Requires:       desktop-file-utils
134 %{?with_system_vpx:Requires:    libvpx >= 0.9.5-2}
135 Requires:       xdg-utils >= 1.0.2-4
136 Provides:       wwwbrowser
137 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
138 Obsoletes:      chromium-browser-inspector < 15.0.863.0
139 ExclusiveArch:  %{ix86} %{x8664} arm
140 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
141
142 %define         find_lang       sh find-lang.sh %{buildroot}
143 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
144 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
145
146 %if %{without debuginfo}
147 %define         _enable_debug_packages  0
148 %endif
149
150 # undefine if empty, makes prep simplier
151 %if "%{svndate}" == "%{nil}"
152 %undefine       svndate
153 %endif
154
155 %description
156 Chromium is an open-source browser project that aims to build a safer,
157 faster, and more stable way for all Internet users to experience the
158 web.
159
160 Chromium serves as a base for Google Chrome, which is Chromium
161 rebranded (name and logo) with very few additions such as usage
162 tracking and an auto-updater system.
163
164 %package l10n
165 Summary:        chromium-browser language packages
166 Group:          I18n
167 Requires:       %{name} = %{version}-%{release}
168
169 %description l10n
170 Chromium is an open-source browser project that aims to build a safer,
171 faster, and more stable way for all Internet users to experience the
172 web.
173
174 This package contains language packages for 50 languages:
175
176 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
177 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
178 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
179 zh-TW
180
181 %prep
182 %setup -q -n %{name}-%{version}~%{?svndate:svn%{svndate}}r%{svnver}
183 SRC=%{name}-%{version}~%{?svndate:svn%{svndate}}r%{svnver}-source.tar.*
184 tar xf $SRC
185 %{__rm} $SRC
186
187 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
188 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
189 . ./src/chrome/VERSION
190 ver=$MAJOR.$MINOR.$BUILD.$PATCH
191 test "$ver" = %{version}
192
193 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
194 test "$gyp_rev" = %{gyp_rev} || :
195
196 v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog)
197
198 # Populate the LASTCHANGE file template as we no longer have the VCS files at this point
199 echo "%{svnver}" > src/build/LASTCHANGE.in
200
201 # add chromium and pld to useragent
202 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
203 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
204     -e 's/@BUILD_DIST_NAME@/PLD/g' \
205     -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
206     < %{PATCH8} | %{__patch} -p1
207
208 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
209 ln -s %{SOURCE7} src
210
211 %patch0 -p1
212 %patch1 -p1
213 %patch2 -p1
214 %patch3 -p1
215 %patch5 -p1
216 %patch6 -p1
217 %patch7 -p1
218 cd src
219 %patch9 -p1
220 cd ..
221
222 cd src
223 sh -x clean-source.sh %{?with_system_v8:v8=1} %{?with_nacl:nacl=1}
224
225 %build
226 cd src
227 test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
228 %ifarch %{ix86}
229         -Dtarget_arch=ia32 \
230 %endif
231 %ifarch %{x8664}
232         -Dtarget_arch=x64 \
233 %endif
234 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
235         -Dno_strict_aliasing=1 -Dgcc_version=44 \
236 %endif
237 %if %{with sandboxing}
238         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
239         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
240 %endif
241         %{!?debug:-Dwerror=} \
242         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
243         %{?with_shared_libs:-Dlibrary=shared_library} \
244         -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
245         -Dffmpeg_branding=Chrome \
246         -Dproprietary_codecs=1 \
247         %{!?with_nacl:-Ddisable_nacl=1} \
248         %{!?with_sse2:-Ddisable_sse2=1} \
249         %{?with_selinux:-Dselinux=1} \
250         %{gyp_with cups} \
251         %{gyp_with flac} \
252         %{gyp_with gconf} \
253         %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
254         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
255         %{gyp_with pulseaudio} \
256         %{gyp_with system_libwebp} \
257         %{gyp_with system_speex} \
258         %{gyp_with system_sqlite} \
259         %{gyp_with system_v8} \
260         %{gyp_with system_vpx} \
261         %{gyp_with system_yasm} \
262         %{gyp_with system_zlib} \
263         -Duse_system_bzip2=1 \
264         -Duse_system_icu=1 \
265         -Duse_system_libevent=1 \
266         -Duse_system_libjpeg=1 \
267         -Duse_system_libpng=1 \
268         -Duse_system_libxml=1 \
269         -Duse_system_libxslt=1 \
270         -Duse_system_xdg_utils=1 \
271
272 %{__make} chrome %{?with_sandboxing:chrome_sandbox} \
273         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
274         %{?with_verbose:V=1} \
275         CC="%{__cc}" \
276         CXX="%{__cxx}" \
277         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
278         CC.host="%{__cc}" \
279         CXX.host="%{__cxx}" \
280         LDFLAGS.host="%{rpmldflags}" \
281         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
282         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
283
284 %install
285 rm -rf $RPM_BUILD_ROOT
286 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
287         $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_pixmapsdir},%{_desktopdir},/etc/xdg/autostart}
288
289 cd src/out/%{!?debug:Release}%{?debug:Debug}
290 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
291 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
292 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
293 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
294 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
295 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
296 %if %{with ffmpegsumo}
297 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
298 %endif
299 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
300 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/xdg/autostart
301
302 %if %{with nacl}
303 # Install Native Client files on platforms that support it.
304 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
305 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
306 %ifarch %{x8664}
307 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
308 %endif
309 %ifarch %{ix86}
310 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
311 %endif
312 %endif
313
314 cd -
315
316 cp -p src/chrome/app/theme/chromium/product_logo_48.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
317
318 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
319 # http://code.google.com/p/chromium/issues/detail?id=24507
320 gecko-mediaplayer*.so
321 EOF
322
323 # find locales
324 %find_lang %{name}.lang
325 # always package en-US
326 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
327
328 %clean
329 rm -rf $RPM_BUILD_ROOT
330
331 %post
332 %update_desktop_database
333 %update_browser_plugins
334
335 %postun
336 if [ "$1" = 0 ]; then
337         %update_browser_plugins
338 fi
339
340 %files -f %{name}.lang
341 %defattr(644,root,root,755)
342 %{_browserpluginsconfdir}/browsers.d/%{name}.*
343 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
344 %attr(755,root,root) %{_bindir}/%{name}
345 %{_mandir}/man1/%{name}.1*
346 %{_pixmapsdir}/%{name}.png
347 %{_desktopdir}/*.desktop
348 /etc/xdg/autostart/*.desktop
349 %dir %{_libdir}/%{name}
350 %{_libdir}/%{name}/chrome.pak
351 %{_libdir}/%{name}/resources.pak
352 %dir %{_libdir}/%{name}/locales
353 %{_libdir}/%{name}/locales/en-US.pak
354 %dir %{_libdir}/%{name}/resources
355 %{_libdir}/%{name}/resources/inspector
356 %dir %{_libdir}/%{name}/themes
357 %dir %{_libdir}/%{name}/extensions
358 %dir %{_libdir}/%{name}/plugins
359 %attr(755,root,root) %{_libdir}/%{name}/%{name}
360 # These unique permissions are intentional and necessary for the sandboxing
361 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
362
363 # ffmpeg libs
364 %if %{with ffmpegsumo}
365 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
366 %endif
367
368 %if %{with nacl}
369 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
370 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
371 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
372 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
373 %endif
374
375 %files l10n -f %{name}.lang
376 %defattr(644,root,root,755)
This page took 0.068429 seconds and 3 git commands to generate.