]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
add system harfbuzz bcond
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_without  libjpegturbo    # use libjpeg-turbo features
9 %bcond_without  nacl                    # build Native Client support
10 %bcond_without  pulseaudio              # with pulseaudio
11 %bcond_without  sandboxing              # with sandboxing
12 %bcond_with             selinux                 # with SELinux (need policy first)
13 %bcond_with             shared_libs             # with shared libs
14 %bcond_with             sse2                    # use SSE2 instructions
15 %bcond_without  system_flac             # system flac
16 %bcond_with             system_ffmpeg   # system ffmpeg instead of ffmpegsumo
17 %bcond_with             system_harfbuzz # system harfbuzz
18 %bcond_without  system_jsoncpp  # system jsoncpp
19 %bcond_without  system_libexif  # system libexif
20 %bcond_without  system_libmtp   # system libmtp
21 %bcond_without  system_libusb   # system libusb-1
22 %bcond_without  system_libwebp  # system libwebp
23 %bcond_without  system_libxnvctrl       # system libxnvctrl
24 %bcond_without  system_minizip  # system minizip
25 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
26 %bcond_with             system_protobuf # system protobuf
27 %bcond_without  system_speex    # system speex
28 %bcond_with             system_sqlite   # system sqlite
29 %bcond_without  system_srtp             # system srtp (can be used if using bundled libjingle)
30 %bcond_with             system_v8               # system v8
31 %bcond_without  system_libvpx   # system libvpx
32 %bcond_without  system_yasm             # system yasm
33 %bcond_without  system_zlib             # system zlib
34 %bcond_with             tcmalloc                # use tcmalloc
35 %bcond_without  verbose                 # verbose build (V=1)
36
37 %if %{with nacl}
38 # temporary hack as seems this does not work: http://codereview.chromium.org/8890043
39 # nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
40 #14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
41 #14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
42 #14:51:06 @baggins> as-needed will take care of unneeded lib
43 #14:52:03 @baggins> -lssp comes with gcc
44 %define         _ssp_cflags     %{nil}
45 %endif
46
47 # TODO
48 # - check system sqlite linking problems
49 # - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
50 # - use_system_ssl (use_openssl: http://crbug.com/62803)
51 # - use_system_hunspell
52 # - use_system_stlport
53 # - other defaults: src/build/common.gypi
54
55 # NOTES:
56 # - mute BEEP mixer if you do not want to hear horrible system bell when
57 #   pressing home/end in url bar or more ^F search results on page.
58 # - space considerations:
59 #   - unpacked sources: ~649MiB
60 #   - built code: ~1.4GiB (x86_64/i686)
61 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
62 # - to look for new tarball, use update-source.sh script
63
64 # NOTE TO USERS:
65 # To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
66 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
67 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
68
69 %define         gyp_rev 1014
70 Summary:        A WebKit powered web browser
71 Name:           chromium-browser
72 Version:        24.0.1312.45
73 Release:        0.23
74 License:        BSD, LGPL v2+ (ffmpeg)
75 Group:          X11/Applications/Networking
76 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{version}.tar.gz
77 # Source0-md5:  2995d5aa3f1ecb470e60e0984229fcce
78 Source1:        %{name}.default
79 Source2:        %{name}.sh
80 Source3:        %{name}.desktop
81 Source5:        find-lang.sh
82 Source6:        update-source.sh
83 Source7:        clean-source.sh
84 Source8:        get-source.sh
85 Source9:        master_preferences.json
86 Patch1:         plugin-searchdirs.patch
87 #Patch2:                system-nspr.patch
88 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
89 Patch4:         path-libpdf.patch
90 Patch6:         get-webkit_revision.patch
91 Patch7:         dlopen_sonamed_gl.patch
92 Patch8:         chromium_useragent.patch.in
93 Patch9:         chromium-ppapi.patch
94 Patch10:        system-libxnvctrl.patch
95 # https://bugs.gentoo.org/show_bug.cgi?id=393471
96 # libjpeg-turbo >= 1.1.90 supports that feature
97 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
98 Patch15:        nacl-build-irt.patch
99 Patch16:        nacl-linkingfix.patch
100 Patch18:        nacl-no-untar.patch
101 Patch19:        system-jsoncpp.patch
102 Patch21:        system-srtp.patch
103 Patch22:        pulse_fix-157876.patch
104 Patch23:        no-pnacl.patch
105 Patch24:        nacl-verbose.patch
106 Patch25:        gnome3-volume-control.patch
107 Patch26:        master-prefs-path.patch
108 URL:            http://www.chromium.org/Home
109 %{?with_gconf:BuildRequires:    GConf2-devel}
110 BuildRequires:  OpenGL-GLU-devel
111 BuildRequires:  alsa-lib-devel
112 BuildRequires:  atk-devel
113 BuildRequires:  bison
114 BuildRequires:  bzip2-devel
115 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
116 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
117 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
118 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
119 %{?with_cups:BuildRequires:     cups-devel}
120 BuildRequires:  dbus-glib-devel
121 BuildRequires:  expat-devel
122 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
123 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
124 BuildRequires:  flex
125 BuildRequires:  fontconfig-devel
126 BuildRequires:  glib2-devel
127 BuildRequires:  gperf
128 BuildRequires:  gtk+2-devel
129 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
130 %{?with_kerberos:BuildRequires: heimdal-devel}
131 BuildRequires:  hicolor-icon-theme
132 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
133 %{?with_system_libxvnctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
134 BuildRequires:  libevent-devel
135 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
136 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
137 BuildRequires:  libicu-devel >= 4.6
138 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
139 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
140 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
141 BuildRequires:  libpng-devel
142 %{?with_selinux:BuildRequires:  libselinux-devel}
143 BuildRequires:  libstdc++-devel
144 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
145 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
146 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
147 BuildRequires:  libxml2-devel
148 BuildRequires:  libxslt-devel
149 BuildRequires:  lzma
150 %{?with_system_minizip:BuildRequires:   minizip-devel}
151 BuildRequires:  nspr-devel
152 BuildRequires:  nss-devel >= 1:3.12.3
153 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
154 BuildRequires:  pam-devel
155 BuildRequires:  pango-devel
156 BuildRequires:  perl-modules
157 BuildRequires:  pkgconfig
158 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
159 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
160 BuildRequires:  python
161 #BuildRequires: python-gyp >= 1-%{gyp_rev}
162 BuildRequires:  python-modules
163 BuildRequires:  rpm >= 4.4.9-56
164 BuildRequires:  rpmbuild(macros) >= 1.453
165 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
166 BuildRequires:  sqlite3-devel >= 3.6.1
167 %{?with_system_srtp:BuildRequires:      srtp-devel >= 1.4.4}
168 BuildRequires:  subversion
169 BuildRequires:  tar >= 1:1.22
170 BuildRequires:  udev-devel
171 BuildRequires:  util-linux
172 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
173 BuildRequires:  which
174 BuildRequires:  xorg-lib-libXScrnSaver-devel
175 BuildRequires:  xorg-lib-libXt-devel
176 BuildRequires:  xorg-lib-libXtst-devel
177 BuildRequires:  xz
178 %{?with_system_yasm:BuildRequires:      yasm}
179 %{?with_system_zlib:BuildRequires:      zlib-devel}
180 Requires:       browser-plugins >= 2.0
181 Requires:       desktop-file-utils
182 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
183 Requires:       hicolor-icon-theme
184 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
185 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
186 Requires:       xdg-utils >= 1.0.2-4
187 Provides:       wwwbrowser
188 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
189 Obsoletes:      chromium-browser-inspector < 15.0.863.0
190 ExclusiveArch:  %{ix86} %{x8664} arm
191 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
192
193 %define         find_lang       sh find-lang.sh %{buildroot}
194
195 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
196 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
197
198 %if %{without debuginfo}
199 %define         _enable_debug_packages  0
200 %endif
201
202 %description
203 Chromium is an open-source browser project that aims to build a safer,
204 faster, and more stable way for all Internet users to experience the
205 web.
206
207 Chromium serves as a base for Google Chrome, which is Chromium
208 rebranded (name and logo) with very few additions such as usage
209 tracking and an auto-updater system.
210
211 %package l10n
212 Summary:        chromium-browser language packages
213 Group:          I18n
214 Requires:       %{name} = %{version}-%{release}
215
216 %description l10n
217 Chromium is an open-source browser project that aims to build a safer,
218 faster, and more stable way for all Internet users to experience the
219 web.
220
221 This package contains language packages for 50 languages:
222
223 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
224 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
225 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
226 zh-TW
227
228 %prep
229 %setup -q
230
231 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
232 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
233 . ./src/chrome/VERSION
234 ver=$MAJOR.$MINOR.$BUILD.$PATCH
235 test "$ver" = %{version}
236
237 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
238 test "$gyp_rev" = %{gyp_rev} || :
239
240 v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
241
242 # add chromium and pld to useragent
243 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
244 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
245     -e 's/@BUILD_DIST_NAME@/PLD/g' \
246     -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
247     < %{PATCH8} | %{__patch} -p1
248
249 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
250 ln -s %{SOURCE7} src
251
252 %patch1 -p1
253 %patch3 -p1
254 %patch4 -p1
255 %patch6 -p1
256 %patch7 -p1
257 %patch15 -p1
258 cd src
259 %patch9 -p0
260 #%patch2 -p1
261 %{!?with_libjpegturbo:%patch11 -p0}
262 %patch16 -p1
263 %patch19 -p1
264 %patch21 -p1
265 %patch22 -p1
266 %patch25 -p1
267 cd ..
268 %patch18 -p1
269 %patch23 -p1
270 %patch24 -p1
271 %patch26 -p1
272
273 cd src
274
275 # Missing gyp files in tarball.
276 # https://code.google.com/p/chromium/issues/detail?id=144823
277 if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
278         echo "tarball fixed, please remove workaround"
279         exit 1
280 fi
281
282 install -d chrome/test/data/nacl
283 cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
284 {
285  'targets': [
286    {
287      'target_name': 'nacl_tests',
288      'type': 'none',
289    },
290  ],
291 }
292 EOF
293
294 sh -x clean-source.sh \
295         %{!?with_nacl:nacl=0} \
296         %{!?with_system_protobuf:protobuf=0} \
297         %{!?with_system_v8:v8=0} \
298         %{!?with_system_zlib:zlib=0} \
299         %{nil}
300
301 %build
302 cd src
303
304 %if %{with nacl}
305 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
306 # Make symlinks for NaCL
307 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,lib,lib32,nacl}
308
309 cd native_client/toolchain/linux_x86_newlib/x86_64-nacl/bin
310 __cc='%{__cc}'
311 if [ "${__cc}#ccache}" != "$__cc" ]; then
312         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
313         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
314         %{__sed} -i -e '1i#!/bin/sh' gcc g++
315         chmod +x gcc g++
316 else
317         ln -s %{_bindir}/x86_64-nacl-gcc gcc
318         ln -s %{_bindir}/x86_64-nacl-g++ g++
319 fi
320 ln -s %{_bindir}/x86_64-nacl-ar ar
321 ln -s %{_bindir}/x86_64-nacl-as as
322 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
323 ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
324 ln -s %{_bindir}/x86_64-nacl-strip strip
325 ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib
326 ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32
327 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
328 cd ../../../../..
329 fi
330 %endif
331
332 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
333 test -e Makefile || %{__python} build/gyp_chromium \
334         --format=make \
335         -Goutput_dir=../out \
336         build/all.gyp \
337 %ifarch %{ix86}
338         -Dtarget_arch=ia32 \
339 %endif
340 %ifarch %{x8664}
341         -Dtarget_arch=x64 \
342 %endif
343 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
344         -Dno_strict_aliasing=1 -Dgcc_version=44 \
345 %endif
346 %if %{with sandboxing}
347         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
348         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
349 %endif
350         %{!?debug:-Dwerror=} \
351         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
352         %{?with_shared_libs:-Dlibrary=shared_library} \
353         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
354         -Dinclude_tests=0 \
355 %if %{with nacl}
356         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
357         -Ddisable_glibc_untar=1 \
358         -Ddisable_newlib_untar=1 \
359         -Ddisable_glibc=1 \
360         -Ddisable_pnacl=1 \
361         -Dbuild_pnacl_newlib=0 \
362 %else
363         -Ddisable_pnacl_untar=1 \
364         -Ddisable_nacl=1 \
365 %endif
366         %{!?with_sse2:-Ddisable_sse2=1} \
367         %{?with_selinux:-Dselinux=1} \
368         %{gyp_with cups} \
369         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
370         %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
371         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
372         %{gyp_with pulseaudio} \
373         %{gyp_with system_ffmpeg} \
374         %{gyp_with system_flac} \
375         %{gyp_with system_harfbuzz} \
376         %{gyp_with system_libexif} \
377         %{gyp_with system_libmtp} \
378         %{gyp_with system_libusb} \
379         %{gyp_with system_libvpx} \
380         %{gyp_with system_libwebp} \
381         %{gyp_with system_libxnvctrl} \
382         %{gyp_with system_minizip} \
383         %{gyp_with system_opus} \
384         %{gyp_with system_protobuf} \
385         %{gyp_with system_speex} \
386         %{gyp_with system_sqlite} \
387         %{gyp_with system_v8} \
388         %{gyp_with system_yasm} \
389         %{gyp_with system_zlib} \
390         -Duse_system_bzip2=1 \
391         -Duse_system_expat=1 \
392         -Duse_system_icu=1 \
393         -Duse_system_libevent=1 \
394         -Duse_system_libjpeg=1 \
395         -Duse_system_libpng=1 \
396         -Duse_system_libxml=1 \
397         -Duse_system_libxslt=1 \
398         -Duse_system_xdg_utils=1 \
399         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
400         -Dlinux_use_gold_binary=0 \
401         -Dlinux_use_gold_flags=0
402
403 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
404         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
405         %{?with_verbose:V=1} \
406         CC="%{__cc}" \
407         CXX="%{__cxx}" \
408         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
409         CC.host="%{__cc}" \
410         CXX.host="%{__cxx}" \
411         LDFLAGS.host="%{rpmldflags}" \
412         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
413         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
414
415 %install
416 rm -rf $RPM_BUILD_ROOT
417 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
418         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
419
420 cd out/%{!?debug:Release}%{?debug:Debug}
421 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
422 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
423 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
424 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
425 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
426 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
427 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
428 %if %{without system_ffmpeg}
429 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
430 %endif
431 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
432 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
433
434 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
435
436 %if %{with nacl}
437 # Install Native Client files on platforms that support it.
438 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
439 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
440 %ifarch %{x8664}
441 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
442 %endif
443 %ifarch %{ix86}
444 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
445 %endif
446 %endif
447
448 cd -
449
450 for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
451         size=${icon##*/product_logo_}
452         size=${size%.png}
453
454         # this will skip non-numeric (22_mono_invert, 22_mono)
455         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
456         test -d "$dir" || continue
457
458         install -d $RPM_BUILD_ROOT$dir
459         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
460 done
461
462 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
463 # http://code.google.com/p/chromium/issues/detail?id=24507
464 gecko-mediaplayer*.so
465 EOF
466
467 # find locales
468 %find_lang %{name}.lang
469 # always package en-US
470 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
471
472 %clean
473 rm -rf $RPM_BUILD_ROOT
474
475 %post
476 %update_icon_cache hicolor
477 %update_desktop_database
478 %update_browser_plugins
479
480 %postun
481 if [ "$1" = 0 ]; then
482         %update_icon_cache hicolor
483         %update_browser_plugins
484 fi
485
486 %files
487 %defattr(644,root,root,755)
488 %doc src/{AUTHORS,LICENSE}
489 %{_browserpluginsconfdir}/browsers.d/%{name}.*
490 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
491 %dir %{_sysconfdir}/%{name}
492 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
493 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
494 %attr(755,root,root) %{_bindir}/%{name}
495 %{_mandir}/man1/%{name}.1*
496 %{_desktopdir}/*.desktop
497 %{_iconsdir}/hicolor/*/apps/%{name}.png
498 %dir %{_libdir}/%{name}
499 %{_libdir}/%{name}/chrome*.pak
500 %{_libdir}/%{name}/content_resources.pak
501 %{_libdir}/%{name}/resources.pak
502 %dir %{_libdir}/%{name}/locales
503 %{_libdir}/%{name}/locales/en-US.pak
504 %dir %{_libdir}/%{name}/resources
505 %{_libdir}/%{name}/resources/inspector
506 %dir %{_libdir}/%{name}/themes
507 %dir %{_libdir}/%{name}/extensions
508 %dir %{_libdir}/%{name}/plugins
509 %attr(755,root,root) %{_libdir}/%{name}/%{name}
510 # These unique permissions are intentional and necessary for the sandboxing
511 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
512
513 # ffmpeg libs
514 %if %{without system_ffmpeg}
515 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
516 %endif
517
518 %if %{with nacl}
519 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
520 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
521 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
522 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
523 %endif
524
525 %files l10n -f %{name}.lang
526 %defattr(644,root,root,755)
This page took 0.056833 seconds and 3 git commands to generate.