]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
clean third_party keeping only stuff really needed
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  ffmpegsumo              # build with ffmpegsumo
6 %bcond_without  gconf                   # with GConf
7 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
8 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
9 %bcond_without  libjpegturbo    # use libjpeg-turbo features
10 %bcond_without  nacl                    # build Native Client support
11 %bcond_without  pulseaudio              # with pulseaudio
12 %bcond_without  sandboxing              # with sandboxing
13 %bcond_with             selinux                 # with SELinux (need policy first)
14 %bcond_with             shared_libs             # with shared libs
15 %bcond_with             sse2                    # use SSE2 instructions
16 %bcond_without  system_flac             # system flac
17 %bcond_without  system_jsoncpp  # system jsoncpp
18 %bcond_without  system_libexif  # system libexif
19 %bcond_without  system_libmtp   # system libmtp
20 %bcond_without  system_libusb   # system libusb-1
21 %bcond_without  system_libwebp  # system libwebp
22 %bcond_without  system_minizip  # system minizip
23 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
24 %bcond_without  system_speex    # system speex
25 %bcond_with             system_sqlite   # system sqlite
26 %bcond_without  system_srtp             # system srtp (can be used if using bundled libjingle)
27 %bcond_with             system_v8               # system v8
28 %bcond_without  system_vpx              # system vpx
29 %bcond_without  system_yasm             # system yasm
30 # system zlib disabled because of mixed-source.patch
31 # https://code.google.com/p/chromium/issues/detail?id=143623
32 %bcond_with             system_zlib             # system zlib
33 %bcond_with             tcmalloc                # use tcmalloc
34 %bcond_without  verbose                 # verbose build (V=1)
35
36 %if %{with nacl}
37 # temporary hack as seems this does not work: http://codereview.chromium.org/8890043
38 # nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
39 #14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
40 #14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
41 #14:51:06 @baggins> as-needed will take care of unneeded lib
42 #14:52:03 @baggins> -lssp comes with gcc
43 %define         _ssp_cflags     %{nil}
44 %endif
45
46 # TODO
47 # - check system sqlite linking problems
48 # - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
49 # - use_system_ssl (use_openssl: http://crbug.com/62803)
50 # - use_system_ffmpeg && build_ffmpegsumo
51 # - use_system_hunspell
52 # - use_system_stlport
53 # - other defaults: src/build/common.gypi
54 # - use_system_libmtp
55 # - use_system_libexif
56 # - use_system_opus
57 # - use_system_libjpeg==1 use_libjpeg_turbo==0
58
59 # NOTES:
60 # - mute BEEP mixer if you do not want to hear horrible system bell when
61 #   pressing home/end in url bar or more ^F search results on page.
62 # - space considerations:
63 #   - unpacked sources: ~800MiB
64 #   - built code: ~1.4GiB (x86_64)
65 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
66 # - to look for new tarball, use update-source.sh script
67
68 # NOTE TO USERS:
69 # To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
70 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
71 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
72
73 %define         gyp_rev 1014
74 Summary:        A WebKit powered web browser
75 Name:           chromium-browser
76 Version:        24.0.1312.45
77 Release:        0.3
78 License:        BSD, LGPL v2+ (ffmpeg)
79 Group:          X11/Applications/Networking
80 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{version}.tar.xz
81 # Source0-md5:  2995d5aa3f1ecb470e60e0984229fcce
82 Source1:        %{name}.default
83 Source2:        %{name}.sh
84 Source3:        %{name}.desktop
85 Source5:        find-lang.sh
86 Source6:        update-source.sh
87 Source7:        clean-source.sh
88 Source8:        get-source.sh
89 Source9:        master_preferences.json
90 #Patch10:               system-libs.patch
91 Patch1:         plugin-searchdirs.patch
92 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
93 Patch4:         path-libpdf.patch
94 Patch5:         options-support.patch
95 Patch6:         get-webkit_revision.patch
96 Patch7:         dlopen_sonamed_gl.patch
97 Patch8:         chromium_useragent.patch.in
98 Patch9:         chromium-ppapi.patch
99 # https://bugs.gentoo.org/show_bug.cgi?id=393471
100 # libjpeg-turbo >= 1.1.90 supports that feature
101 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
102 Patch15:        nacl-build-irt.patch
103 Patch16:        nacl-linkingfix.patch
104 Patch18:        nacl-no-untar.patch
105 Patch19:        system-jsoncpp.patch
106 Patch21:        system-srtp.patch
107 Patch22:        pulse_fix-157876.patch
108 Patch23:        no-pnacl.patch
109 Patch24:        nacl-verbose.patch
110 Patch25:        gnome3-volume-control.patch
111 Patch26:        master-prefs-path.patch
112 URL:            http://www.chromium.org/Home
113 %{?with_gconf:BuildRequires:    GConf2-devel}
114 BuildRequires:  OpenGL-GLU-devel
115 BuildRequires:  alsa-lib-devel
116 BuildRequires:  atk-devel
117 BuildRequires:  bison
118 BuildRequires:  bzip2-devel
119 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
120 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
121 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
122 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
123 %{?with_cups:BuildRequires:     cups-devel}
124 BuildRequires:  dbus-glib-devel
125 BuildRequires:  expat-devel
126 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
127 BuildRequires:  flex
128 BuildRequires:  fontconfig-devel
129 BuildRequires:  glib2-devel
130 BuildRequires:  gperf
131 BuildRequires:  gtk+2-devel
132 %{?with_kerberos:BuildRequires: heimdal-devel}
133 BuildRequires:  hicolor-icon-theme
134 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
135 BuildRequires:  libevent-devel
136 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
137 BuildRequires:  libicu-devel >= 4.6
138 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
139 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
140 BuildRequires:  libpng-devel
141 %{?with_selinux:BuildRequires:  libselinux-devel}
142 BuildRequires:  libstdc++-devel
143 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
144 %{?with_system_vpx:BuildRequires:       libvpx-devel >= 0.9.5-2}
145 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
146 BuildRequires:  libxml2-devel
147 BuildRequires:  libxslt-devel
148 BuildRequires:  lzma
149 %{?with_system_minizip:BuildRequires:   minizip-devel}
150 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
151 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
152 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
153 BuildRequires:  nspr-devel
154 BuildRequires:  nss-devel >= 1:3.12.3
155 BuildRequires:  pam-devel
156 BuildRequires:  pango-devel
157 BuildRequires:  perl-modules
158 BuildRequires:  pkgconfig
159 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
160 BuildRequires:  python
161 #BuildRequires: python-gyp >= 1-%{gyp_rev}
162 BuildRequires:  python-modules
163 BuildRequires:  rpm >= 4.4.9-56
164 BuildRequires:  rpmbuild(macros) >= 1.453
165 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
166 BuildRequires:  sqlite3-devel >= 3.6.1
167 %{?with_system_srtp:BuildRequires:      srtp-devel >= 1.4.4}
168 BuildRequires:  subversion
169 BuildRequires:  tar >= 1:1.22
170 BuildRequires:  udev-devel
171 BuildRequires:  util-linux
172 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
173 BuildRequires:  which
174 BuildRequires:  xorg-lib-libXScrnSaver-devel
175 BuildRequires:  xorg-lib-libXt-devel
176 BuildRequires:  xorg-lib-libXtst-devel
177 BuildRequires:  xz
178 %{?with_system_yasm:BuildRequires:      yasm}
179 %{?with_system_zlib:BuildRequires:      zlib-devel}
180 Requires:       browser-plugins >= 2.0
181 Requires:       desktop-file-utils
182 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
183 Requires:       hicolor-icon-theme
184 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
185 %{?with_system_vpx:Requires:    libvpx >= 0.9.5-2}
186 Requires:       xdg-utils >= 1.0.2-4
187 Provides:       wwwbrowser
188 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
189 Obsoletes:      chromium-browser-inspector < 15.0.863.0
190 ExclusiveArch:  %{ix86} %{x8664} arm
191 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
192
193 %define         find_lang       sh find-lang.sh %{buildroot}
194
195 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
196 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
197
198 %if %{without debuginfo}
199 %define         _enable_debug_packages  0
200 %endif
201
202 %description
203 Chromium is an open-source browser project that aims to build a safer,
204 faster, and more stable way for all Internet users to experience the
205 web.
206
207 Chromium serves as a base for Google Chrome, which is Chromium
208 rebranded (name and logo) with very few additions such as usage
209 tracking and an auto-updater system.
210
211 %package l10n
212 Summary:        chromium-browser language packages
213 Group:          I18n
214 Requires:       %{name} = %{version}-%{release}
215
216 %description l10n
217 Chromium is an open-source browser project that aims to build a safer,
218 faster, and more stable way for all Internet users to experience the
219 web.
220
221 This package contains language packages for 50 languages:
222
223 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
224 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
225 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
226 zh-TW
227
228 %prep
229 %setup -q
230
231 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
232 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
233 . ./src/chrome/VERSION
234 ver=$MAJOR.$MINOR.$BUILD.$PATCH
235 test "$ver" = %{version}
236
237 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
238 test "$gyp_rev" = %{gyp_rev} || :
239
240 v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
241
242 # add chromium and pld to useragent
243 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
244 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
245     -e 's/@BUILD_DIST_NAME@/PLD/g' \
246     -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
247     < %{PATCH8} | %{__patch} -p1
248
249 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
250 ln -s %{SOURCE7} src
251
252 #%patch10 -p1
253 %patch1 -p1
254 %patch3 -p1
255 %patch4 -p1
256 %patch5 -p1
257 %patch6 -p1
258 %patch7 -p1
259 %patch15 -p1
260 cd src
261 %patch9 -p0
262 %{!?with_libjpegturbo:%patch11 -p0}
263 %patch16 -p1
264 %patch19 -p1
265 %patch21 -p1
266 %patch22 -p1
267 %patch25 -p1
268 cd ..
269 %patch18 -p1
270 %patch23 -p1
271 %patch24 -p1
272 %patch26 -p1
273
274 cd src
275
276 # Missing gyp files in tarball.
277 # https://code.google.com/p/chromium/issues/detail?id=144823
278 if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
279         echo "tarball fixed, please remove workaround"
280         exit 1
281 fi
282
283 install -d chrome/test/data/nacl
284 cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
285 {
286  'targets': [
287    {
288      'target_name': 'nacl_tests',
289      'type': 'none',
290    },
291  ],
292 }
293 EOF
294
295 sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0} libxml=0 %{!?with_system_zlib:zlib=0}
296
297 rm -rf native_client/toolchain/linux_x86_newlib
298
299 %build
300 cd src
301
302 %if %{with nacl}
303 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
304 # Make symlinks for nacl
305 cd native_client/toolchain
306 install -d linux_x86_newlib/x86_64-nacl/bin
307 install -d linux_x86_newlib/x86_64-nacl/lib
308 install -d linux_x86_newlib/x86_64-nacl/lib32
309 install -d linux_x86_newlib/x86_64-nacl/nacl/include/bits
310 install -d linux_x86_newlib/x86_64-nacl/nacl/include/machine
311 install -d linux_x86_newlib/x86_64-nacl/nacl/include/sys
312 # link newlib toolchain to glibc as well, see gentoo bug #417019
313 #ln -s linux_x86_newlib linux_x86
314 cd linux_x86_newlib/x86_64-nacl/bin
315
316 __cc='%{__cc}'
317 if [ "${__cc}#ccache}" != "$__cc" ]; then
318         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
319         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
320         %{__sed} -i -e '1i#!/bin/sh' gcc g++
321         chmod +x gcc g++
322 else
323         ln -s %{_bindir}/x86_64-nacl-gcc gcc
324         ln -s %{_bindir}/x86_64-nacl-g++ g++
325 fi
326
327 ln -s %{_bindir}/x86_64-nacl-ar ar
328 ln -s %{_bindir}/x86_64-nacl-as as
329 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
330 ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
331 ln -s %{_bindir}/x86_64-nacl-strip strip
332 ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib/
333 ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32/
334 cd ../nacl/include
335 for i in $(find %{_prefix}/x86_64-nacl/include -type f | grep -v "c++"); do
336         ln -s $i ${i#%{_prefix}/x86_64-nacl/include/}
337 done
338 cd ../../../../../..
339 fi
340 %endif
341
342 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
343 test -e Makefile || %{__python} build/gyp_chromium \
344         --format=make \
345         -Goutput_dir=../out \
346         build/all.gyp \
347 %ifarch %{ix86}
348         -Dtarget_arch=ia32 \
349 %endif
350 %ifarch %{x8664}
351         -Dtarget_arch=x64 \
352 %endif
353 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
354         -Dno_strict_aliasing=1 -Dgcc_version=44 \
355 %endif
356 %if %{with sandboxing}
357         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
358         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
359 %endif
360         %{!?debug:-Dwerror=} \
361         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
362         %{?with_shared_libs:-Dlibrary=shared_library} \
363         -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
364         -Dffmpeg_branding=Chrome \
365         -Dremove_webcore_debug_symbols=1 \
366         -Dproprietary_codecs=1 \
367 %if %{with nacl}
368         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
369         -Ddisable_glibc_untar=1 \
370         -Ddisable_newlib_untar=1 \
371         -Ddisable_glibc=1 \
372         -Ddisable_pnacl=1 \
373         -Dbuild_pnacl_newlib=0 \
374 %else
375         -Ddisable_pnacl_untar=1 \
376         -Ddisable_nacl=1 \
377 %endif
378         %{!?with_sse2:-Ddisable_sse2=1} \
379         %{?with_selinux:-Dselinux=1} \
380         %{gyp_with cups} \
381         %{gyp_with gconf} \
382         %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
383         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
384         %{gyp_with pulseaudio} \
385         %{gyp_with system_flac} \
386         %{gyp_with system_libexif} \
387         %{gyp_with system_libmtp} \
388         %{gyp_with system_libusb} \
389         %{gyp_with system_libwebp} \
390         %{gyp_with system_minizip} \
391         %{gyp_with system_opus} \
392         %{gyp_with system_speex} \
393         %{gyp_with system_sqlite} \
394         %{gyp_with system_v8} \
395         %{gyp_with system_vpx} \
396         %{gyp_with system_yasm} \
397         %{gyp_with system_zlib} \
398         -Duse_system_bzip2=1 \
399         -Duse_system_expat=1 \
400         -Duse_system_icu=1 \
401         -Duse_system_libevent=1 \
402         -Duse_system_libjpeg=1 \
403         -Duse_system_libpng=1 \
404         -Duse_system_libxml=1 \
405         -Duse_system_libxslt=1 \
406         -Duse_system_xdg_utils=1 \
407         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
408         -Dlinux_use_gold_binary=0 \
409         -Dlinux_use_gold_flags=0
410
411 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
412         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
413         %{?with_verbose:V=1} \
414         CC="%{__cc}" \
415         CXX="%{__cxx}" \
416         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
417         CC.host="%{__cc}" \
418         CXX.host="%{__cxx}" \
419         LDFLAGS.host="%{rpmldflags}" \
420         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
421         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
422
423 %install
424 rm -rf $RPM_BUILD_ROOT
425 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
426         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
427
428 cd out/%{!?debug:Release}%{?debug:Debug}
429 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
430 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
431 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
432 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
433 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
434 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
435 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
436 %if %{with ffmpegsumo}
437 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
438 %endif
439 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
440 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
441
442 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
443
444 %if %{with nacl}
445 # Install Native Client files on platforms that support it.
446 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
447 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
448 %ifarch %{x8664}
449 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
450 %endif
451 %ifarch %{ix86}
452 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
453 %endif
454 %endif
455
456 cd -
457
458 for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
459         size=${icon##*/product_logo_}
460         size=${size%.png}
461
462         # this will skip non-numeric (22_mono_invert, 22_mono)
463         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
464         test -d "$dir" || continue
465
466         install -d $RPM_BUILD_ROOT$dir
467         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
468 done
469
470 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
471 # http://code.google.com/p/chromium/issues/detail?id=24507
472 gecko-mediaplayer*.so
473 EOF
474
475 # find locales
476 %find_lang %{name}.lang
477 # always package en-US
478 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
479
480 %clean
481 rm -rf $RPM_BUILD_ROOT
482
483 %post
484 %update_icon_cache hicolor
485 %update_desktop_database
486 %update_browser_plugins
487
488 %postun
489 if [ "$1" = 0 ]; then
490         %update_icon_cache hicolor
491         %update_browser_plugins
492 fi
493
494 %files
495 %defattr(644,root,root,755)
496 %doc src/{AUTHORS,LICENSE}
497 %{_browserpluginsconfdir}/browsers.d/%{name}.*
498 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
499 %dir %{_sysconfdir}/%{name}
500 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
501 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
502 %attr(755,root,root) %{_bindir}/%{name}
503 %{_mandir}/man1/%{name}.1*
504 %{_desktopdir}/*.desktop
505 %{_iconsdir}/hicolor/*/apps/%{name}.png
506 %dir %{_libdir}/%{name}
507 %{_libdir}/%{name}/chrome*.pak
508 %{_libdir}/%{name}/content_resources.pak
509 %{_libdir}/%{name}/resources.pak
510 %dir %{_libdir}/%{name}/locales
511 %{_libdir}/%{name}/locales/en-US.pak
512 %dir %{_libdir}/%{name}/resources
513 %{_libdir}/%{name}/resources/inspector
514 %dir %{_libdir}/%{name}/themes
515 %dir %{_libdir}/%{name}/extensions
516 %dir %{_libdir}/%{name}/plugins
517 %attr(755,root,root) %{_libdir}/%{name}/%{name}
518 # These unique permissions are intentional and necessary for the sandboxing
519 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
520
521 # ffmpeg libs
522 %if %{with ffmpegsumo}
523 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
524 %endif
525
526 %if %{with nacl}
527 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
528 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
529 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
530 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
531 %endif
532
533 %files l10n -f %{name}.lang
534 %defattr(644,root,root,755)
This page took 0.067793 seconds and 3 git commands to generate.