]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
add system re2 bcond, disabled as symbol mismatches
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_without  libjpegturbo    # use libjpeg-turbo features
9 %bcond_without  nacl                    # build Native Client support
10 %bcond_without  pulseaudio              # with pulseaudio
11 %bcond_without  sandboxing              # with sandboxing
12 %bcond_with             selinux                 # with SELinux (need policy first)
13 %bcond_with             shared_libs             # with shared libs
14 %bcond_with             sse2                    # use SSE2 instructions
15 %bcond_without  system_flac             # system flac
16 %bcond_without  system_ffmpeg   # system ffmpeg instead of ffmpegsumo
17 %bcond_without  system_harfbuzz # system harfbuzz
18 %bcond_without  system_jsoncpp  # system jsoncpp
19 %bcond_without  system_libexif  # system libexif
20 %bcond_without  system_libmtp   # system libmtp
21 %bcond_without  system_libusb   # system libusb-1
22 %bcond_without  system_libwebp  # system libwebp
23 %bcond_without  system_libxnvctrl       # system libxnvctrl
24 %bcond_without  system_minizip  # system minizip
25 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
26 %bcond_without  system_protobuf # system protobuf
27 %bcond_with             system_re2              # system re2
28 %bcond_without  system_speex    # system speex
29 %bcond_with             system_sqlite   # system sqlite
30 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
31 %bcond_with             system_v8               # system v8
32 # system vpx broken currently due unreleased VP9 codec: https://code.google.com/p/chromium/issues/detail?id=174287
33 %bcond_without  system_libvpx   # system libvpx
34 %bcond_without  system_yasm             # system yasm
35 %bcond_without  system_zlib             # system zlib
36 %bcond_without  tcmalloc                # use tcmalloc
37 %bcond_without  verbose                 # verbose build (V=1)
38
39 # TODO
40 # - check system sqlite linking problems
41 # - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
42 # - use_system_ssl (use_openssl: http://crbug.com/62803)
43 # - use_system_hunspell
44 # - use_system_stlport
45 # - other defaults: src/build/common.gypi
46
47 # NOTES:
48 # - mute BEEP mixer if you do not want to hear horrible system bell when
49 #   pressing home/end in url bar or more ^F search results on page.
50 # - space considerations:
51 #   - unpacked sources: ~490MiB
52 #   - built code: ~1.4GiB (x86_64/i686)
53 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
54 # - to look for new tarball, use update-source.sh script
55
56 # NOTE TO USERS:
57 # To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
58 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
59 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
60
61 %define         branch          26.0.1410
62 %define         basever         12
63 #define         patchver        70
64 %define         gyp_rev 1014
65 Summary:        A WebKit powered web browser
66 Name:           chromium-browser
67 %if "%{?patchver}" != ""
68 Version:        %{branch}.%{patchver}
69 %else
70 Version:        %{branch}.%{basever}
71 %endif
72 Release:        0.26
73 License:        BSD, LGPL v2+ (ffmpeg)
74 Group:          X11/Applications/Networking
75 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/dev/%{name}-%{branch}.%{basever}.tar.gz
76 # Source0-md5:  d005fc9e50c28a2e3c71eee7310417f4
77 %if "%{?patchver}" != ""
78 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
79 # Patch0-md5:   37675cd75c578d26d6210259877f3947
80 %endif
81 Source1:        %{name}.default
82 Source2:        %{name}.sh
83 Source3:        %{name}.desktop
84 Source5:        find-lang.sh
85 Source6:        update-source.sh
86 Source7:        clean-source.sh
87 Source8:        get-source.sh
88 Source9:        master_preferences.json
89 Patch1:         plugin-searchdirs.patch
90 #Patch2:                system-nspr.patch
91 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
92 Patch4:         path-libpdf.patch
93 Patch6:         get-webkit_revision.patch
94 Patch7:         dlopen_sonamed_gl.patch
95 Patch8:         chromium_useragent.patch.in
96 Patch9:         chromium-ppapi.patch
97 Patch10:        system-libxnvctrl.patch
98 # https://bugs.gentoo.org/show_bug.cgi?id=393471
99 # libjpeg-turbo >= 1.1.90 supports that feature
100 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
101 Patch12:        system-ffmpeg.patch
102 Patch15:        nacl-build-irt.patch
103 Patch16:        nacl-linkingfix.patch
104 Patch18:        nacl-no-untar.patch
105 Patch19:        system-jsoncpp.patch
106 Patch24:        nacl-verbose.patch
107 Patch25:        gnome3-volume-control.patch
108 Patch26:        master-prefs-path.patch
109 Patch27:        tcmalloc-glibc2.16.patch
110 URL:            http://www.chromium.org/Home
111 %{?with_gconf:BuildRequires:    GConf2-devel}
112 BuildRequires:  alsa-lib-devel
113 BuildRequires:  atk-devel
114 BuildRequires:  bison
115 BuildRequires:  bzip2-devel
116 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
117 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
118 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
119 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
120 %{?with_cups:BuildRequires:     cups-devel}
121 BuildRequires:  elfutils-devel
122 BuildRequires:  expat-devel
123 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
124 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
125 BuildRequires:  fontconfig-devel
126 BuildRequires:  glib2-devel
127 BuildRequires:  gperf
128 BuildRequires:  gtest-devel
129 BuildRequires:  gtk+2-devel
130 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
131 %{?with_kerberos:BuildRequires: heimdal-devel}
132 BuildRequires:  hicolor-icon-theme
133 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
134 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
135 BuildRequires:  libevent-devel
136 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
137 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
138 BuildRequires:  libicu-devel >= 4.6
139 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
140 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
141 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
142 BuildRequires:  libpng-devel
143 %{?with_selinux:BuildRequires:  libselinux-devel}
144 BuildRequires:  libstdc++-devel
145 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
146 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
147 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
148 BuildRequires:  libxml2-devel
149 BuildRequires:  libxslt-devel
150 BuildRequires:  man-db
151 %{?with_system_minizip:BuildRequires:   minizip-devel}
152 BuildRequires:  nspr-devel
153 BuildRequires:  nss-devel >= 1:3.12.3
154 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
155 BuildRequires:  pam-devel
156 BuildRequires:  pango-devel
157 BuildRequires:  pciutils-devel
158 BuildRequires:  perl-modules
159 BuildRequires:  pkgconfig
160 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
161 %{?with_system_re2:BuildRequires:       re2-devel}
162 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
163 BuildRequires:  python
164 #BuildRequires: python-gyp >= 1-%{gyp_rev}
165 BuildRequires:  python-modules
166 BuildRequires:  python-ply
167 BuildRequires:  rpm >= 4.4.9-56
168 BuildRequires:  rpmbuild(macros) >= 1.453
169 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
170 BuildRequires:  sqlite3-devel >= 3.6.1
171 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
172 BuildRequires:  subversion
173 BuildRequires:  tar >= 1:1.22
174 BuildRequires:  udev-devel
175 BuildRequires:  usbutils
176 BuildRequires:  util-linux
177 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
178 BuildRequires:  which
179 BuildRequires:  xorg-lib-libXScrnSaver-devel
180 BuildRequires:  xz
181 %{?with_system_yasm:BuildRequires:      yasm}
182 %{?with_system_zlib:BuildRequires:      zlib-devel}
183 Requires:       browser-plugins >= 2.0
184 Requires:       desktop-file-utils
185 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
186 # crashes if no fontconfig font present
187 Requires:       fonts-Type1-urw
188 Requires:       hicolor-icon-theme
189 Requires:       libevent >= 2.0.21
190 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
191 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
192 Requires:       lsb-release
193 Requires:       shared-mime-info
194 Requires:       xdg-utils >= 1.0.2-4
195 Requires:       xorg-lib-libX11 >= 1.4.99.1
196 Provides:       wwwbrowser
197 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
198 Obsoletes:      chromium-browser-inspector < 15.0.863.0
199 ExclusiveArch:  %{ix86} %{x8664} arm
200 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
201
202 %define         find_lang       sh find-lang.sh %{buildroot}
203
204 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
205 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
206
207 %if %{without debuginfo}
208 %define         _enable_debug_packages  0
209 %endif
210
211 %description
212 Chromium is an open-source browser project that aims to build a safer,
213 faster, and more stable way for all Internet users to experience the
214 web.
215
216 Chromium serves as a base for Google Chrome, which is Chromium
217 rebranded (name and logo) with very few additions such as usage
218 tracking and an auto-updater system.
219
220 %package l10n
221 Summary:        chromium-browser language packages
222 Group:          I18n
223 Requires:       %{name} = %{version}-%{release}
224
225 %description l10n
226 Chromium is an open-source browser project that aims to build a safer,
227 faster, and more stable way for all Internet users to experience the
228 web.
229
230 This package contains language packages for 50 languages:
231
232 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
233 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
234 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
235 zh-TW
236
237 %prep
238 %setup -qc
239 %if "%{?patchver}" != ""
240 cd %{name}-%{branch}.%{basever}
241 %patch0 -p1
242 cd ..
243 %endif
244 mv %{name}-%{branch}.%{basever}/src .
245
246 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
247 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
248 . ./src/chrome/VERSION
249 ver=$MAJOR.$MINOR.$BUILD.$PATCH
250 test "$ver" = %{version}
251
252 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
253 test "$gyp_rev" = %{gyp_rev} || :
254
255 v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
256
257 # add chromium and pld to useragent
258 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
259 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
260     -e 's/@BUILD_DIST_NAME@/PLD/g' \
261     -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
262     < %{PATCH8} | %{__patch} -p1
263
264 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
265 ln -s %{SOURCE7} src
266
267 %patch1 -p1
268 %patch3 -p1
269 %patch4 -p1
270 %patch6 -p1
271 %patch7 -p1
272 %patch10 -p1
273 %patch15 -p1
274 cd src
275 %patch9 -p0
276 #%patch2 -p1
277 %{!?with_libjpegturbo:%patch11 -p0}
278 %patch12 -p1
279 %patch16 -p1
280 %patch19 -p1
281 %patch27 -p1
282 cd ..
283 %patch25 -p1
284 %patch18 -p1
285 %patch24 -p1
286 %patch26 -p1
287
288 cd src
289
290 sh -x clean-source.sh \
291         %{!?with_nacl:nacl=0} \
292         %{!?with_system_libvpx:libvpx=0} \
293         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
294         %{!?with_system_protobuf:protobuf=0} \
295         %{!?with_system_re2:re2=0} \
296         %{!?with_system_v8:v8=0} \
297         %{!?with_system_zlib:zlib=0} \
298         %{nil}
299
300 %build
301 cd src
302
303 %if %{with nacl}
304 rm -rf native_client/toolchain/linux_x86_newlib
305 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
306 # Make symlinks for NaCL
307 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
308
309 cd native_client/toolchain/linux_x86_newlib
310 ln -s x86_64-nacl/bin bin
311 cd x86_64-nacl/bin
312 __cc='%{__cc}'
313 if [ "${__cc#ccache}" != "$__cc" ]; then
314         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
315         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
316         %{__sed} -i -e '1i#!/bin/sh' gcc g++
317         chmod +x gcc g++
318 else
319         ln -s %{_bindir}/x86_64-nacl-gcc gcc
320         ln -s %{_bindir}/x86_64-nacl-g++ g++
321 fi
322 ln -s gcc x86_64-nacl-gcc
323 ln -s g++ x86_64-nacl-g++
324 ln -s %{_bindir}/x86_64-nacl-ar .
325 ln -s %{_bindir}/x86_64-nacl-ar ar
326 ln -s %{_bindir}/x86_64-nacl-as as
327 ln -s %{_bindir}/x86_64-nacl-ranlib .
328 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
329 ln -s %{_bindir}/x86_64-nacl-strip .
330 ln -s %{_bindir}/x86_64-nacl-strip strip
331 ln -s %{_prefix}/x86_64-nacl/lib ../lib
332 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
333 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
334 cd ../../../../..
335 fi
336 %endif
337
338 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
339 test -e Makefile || \
340         CC="%{__cc}" \
341         CXX="%{__cxx}" \
342         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
343         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
344         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
345 %{__python} build/gyp_chromium \
346         --format=make \
347         -Goutput_dir=../out \
348         build/all.gyp \
349 %ifarch %{ix86}
350         -Dtarget_arch=ia32 \
351 %endif
352 %ifarch %{x8664}
353         -Dtarget_arch=x64 \
354 %endif
355 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
356         -Dno_strict_aliasing=1 -Dgcc_version=44 \
357 %endif
358 %if %{with sandboxing}
359         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
360         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
361 %endif
362         %{!?debug:-Dwerror=} \
363         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
364         %{?with_shared_libs:-Dlibrary=shared_library} \
365         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
366         -Dinclude_tests=0 \
367 %if %{with nacl}
368         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
369         -Ddisable_glibc_untar=1 \
370         -Ddisable_newlib_untar=1 \
371         -Ddisable_glibc=1 \
372         -Ddisable_pnacl=1 \
373         -Dbuild_pnacl_newlib=0 \
374 %else
375         -Ddisable_pnacl_untar=1 \
376         -Ddisable_nacl=1 \
377 %endif
378         %{!?with_sse2:-Ddisable_sse2=1} \
379         %{?with_selinux:-Dselinux=1} \
380         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
381         -Dlinux_link_libpci=1 \
382         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
383         -Dlinux_use_gold_binary=0 \
384         -Dlinux_use_gold_flags=0 \
385         %{gyp_with cups} \
386         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
387         %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
388         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
389         %{gyp_with pulseaudio} \
390         %{gyp_with system_ffmpeg} \
391         %{gyp_with system_flac} \
392         %{gyp_with system_harfbuzz} \
393         %{gyp_with system_libexif} \
394         %{gyp_with system_libmtp} \
395         %{gyp_with system_libsrtp} \
396         %{gyp_with system_libusb} \
397         %{gyp_with system_libvpx} \
398         %{gyp_with system_libwebp} \
399         %{gyp_with system_libxnvctrl} \
400         %{gyp_with system_minizip} \
401         %{gyp_with system_opus} \
402         %{gyp_with system_protobuf} \
403         %{gyp_with system_re2} \
404         %{gyp_with system_speex} \
405         %{gyp_with system_sqlite} \
406         %{gyp_with system_v8} \
407         %{gyp_with system_yasm} \
408         %{gyp_with system_zlib} \
409         -Duse_system_bzip2=1 \
410         -Duse_system_expat=1 \
411         -Duse_system_icu=1 \
412         -Duse_system_libevent=1 \
413         -Duse_system_libjpeg=1 \
414         -Duse_system_libpng=1 \
415         -Duse_system_libxml=1 \
416         -Duse_system_libxslt=1 \
417         -Duse_system_xdg_utils=1 \
418
419 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
420 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
421         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
422         %{?with_verbose:V=1} \
423         CC.host="%{__cc}" \
424         CXX.host="%{__cxx}" \
425         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
426
427 cd ../out/%{!?debug:Release}%{?debug:Debug}
428 MANWIDTH=80 man ./chrome.1 > man.out
429 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
430
431 %install
432 rm -rf $RPM_BUILD_ROOT
433 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
434         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
435
436 cd out/%{!?debug:Release}%{?debug:Debug}
437 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
438 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
439 %{__sed} -i -e '
440         s,@libdir@,%{_libdir}/%{name},
441
442         /@OPTIONS@/ {
443                 r options.txt
444                 d
445         }
446 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
447 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
448 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
449 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
450 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
451 %if %{without system_ffmpeg}
452 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
453 %endif
454 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
455 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
456
457 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
458
459 %if %{with nacl}
460 # Install Native Client files on platforms that support it.
461 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
462 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
463 %ifarch %{x8664}
464 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
465 %endif
466 %ifarch %{ix86}
467 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
468 %endif
469 %endif
470
471 cd -
472
473 for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
474         size=${icon##*/product_logo_}
475         size=${size%.png}
476
477         # this will skip non-numeric (22_mono_invert, 22_mono)
478         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
479         test -d "$dir" || continue
480
481         install -d $RPM_BUILD_ROOT$dir
482         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
483 done
484
485 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
486 # http://code.google.com/p/chromium/issues/detail?id=24507
487 gecko-mediaplayer*.so
488 EOF
489
490 # find locales
491 %find_lang %{name}.lang
492 # always package en-US
493 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
494
495 %clean
496 rm -rf $RPM_BUILD_ROOT
497
498 %post
499 %update_icon_cache hicolor
500 %update_desktop_database
501 %update_browser_plugins
502
503 %postun
504 if [ "$1" = 0 ]; then
505         %update_icon_cache hicolor
506         %update_browser_plugins
507 fi
508
509 %files
510 %defattr(644,root,root,755)
511 %doc src/{AUTHORS,LICENSE}
512 %{_browserpluginsconfdir}/browsers.d/%{name}.*
513 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
514 %dir %{_sysconfdir}/%{name}
515 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
516 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
517 %attr(755,root,root) %{_bindir}/%{name}
518 %{_mandir}/man1/%{name}.1*
519 %{_desktopdir}/*.desktop
520 %{_iconsdir}/hicolor/*/apps/%{name}.png
521 %dir %{_libdir}/%{name}
522 %{_libdir}/%{name}/chrome*.pak
523 %{_libdir}/%{name}/content_resources.pak
524 %{_libdir}/%{name}/resources.pak
525 %dir %{_libdir}/%{name}/locales
526 %{_libdir}/%{name}/locales/en-US.pak
527 %dir %{_libdir}/%{name}/resources
528 %{_libdir}/%{name}/resources/inspector
529 %dir %{_libdir}/%{name}/themes
530 %dir %{_libdir}/%{name}/extensions
531 %dir %{_libdir}/%{name}/plugins
532 %attr(755,root,root) %{_libdir}/%{name}/%{name}
533 # These unique permissions are intentional and necessary for the sandboxing
534 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
535
536 # ffmpeg libs
537 %if %{without system_ffmpeg}
538 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
539 %endif
540
541 %if %{with nacl}
542 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
543 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
544 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
545 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
546 %endif
547
548 %files l10n -f %{name}.lang
549 %defattr(644,root,root,755)
This page took 0.060302 seconds and 3 git commands to generate.