]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
- don't make wget quiet, so we will know what is happening on slow links
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_with     verbose         # verbose build (V=1)
4 %bcond_with     selinux         # with SELinux (need policy first)
5 %bcond_with     system_v8       # with system v8
6 %bcond_without  system_zlib     # with system zlib
7 %bcond_with     system_sqlite   # with system sqlite
8 %bcond_without  ffmpegsumo      # build with ffmpegsumo
9 %bcond_without  sandboxing      # with sandboxing
10 %bcond_with     shared_libs     # with shared libs
11 %bcond_without  debuginfo       # disable debuginfo creation (it is huge)
12
13 # TODO
14 # - check system sqlite linking problems
15
16 # NOTES:
17 # - mute BEEP mixer if you do not want to hear horrible system bell when
18 #   pressing home/end in url bar or more ^F search results on page.
19 # - build i686: -bp: ~570MB; bc: ~928MB; -bb: ~1.0GB
20 # - build x86_64: -bp: ~570MB; bc: ~990MB; -bb: ~1.0GB
21 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
22 # - to look for new tarball, use update-source.sh script
23
24 %define         svndate 20100610
25 %define         svnver  49356
26 %define         rel             1
27
28 Summary:        A WebKit powered web browser
29 Name:           chromium-browser
30 Version:        6.0.431.0
31 Release:        %{svnver}.%{rel}
32 License:        BSD, LGPL v2+ (ffmpeg)
33 Group:          X11/Applications/Networking
34 Source0:        http://ppa.launchpad.net/chromium-daily/ppa/ubuntu/pool/main/c/chromium-browser/%{name}_%{version}~svn%{svndate}r%{svnver}.orig.tar.gz
35 # Source0-md5:  050c8db52b2e261a55fcca86ec56bebb
36 Source2:        %{name}.sh
37 Source3:        %{name}.desktop
38 Source4:        find-lang.sh
39 Source5:        update-source.sh
40 Patch0:         system-libs.patch
41 Patch1:         plugin-searchdirs.patch
42 Patch2:         gyp-system-minizip.patch
43 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch.diff
44 # http://aur.archlinux.org/packages/chromium-browser-svn/chromium-browser-svn/search-workaround.patch
45 Patch4:         search-workaround.patch
46 Patch5:         options-support.patch
47 Patch11:        memory_details-iceweasel.patch
48 URL:            http://code.google.com/chromium/
49 BuildRequires:  GConf2-devel
50 BuildRequires:  OpenGL-GLU-devel
51 BuildRequires:  alsa-lib-devel
52 BuildRequires:  atk-devel
53 BuildRequires:  bison
54 BuildRequires:  bzip2-devel
55 BuildRequires:  cups-devel
56 BuildRequires:  dbus-devel
57 BuildRequires:  flex
58 BuildRequires:  fontconfig-devel
59 BuildRequires:  glib2-devel
60 BuildRequires:  gperf
61 BuildRequires:  gtk+2-devel
62 BuildRequires:  libevent-devel
63 BuildRequires:  libjpeg-devel
64 BuildRequires:  libpng-devel
65 %{?with_selinux:BuildRequires:  libselinux-devel}
66 BuildRequires:  libstdc++-devel
67 BuildRequires:  libvpx-devel
68 BuildRequires:  libxml2-devel
69 BuildRequires:  libxslt-devel
70 BuildRequires:  lzma
71 BuildRequires:  minizip-devel
72 BuildRequires:  nspr-devel
73 BuildRequires:  nss-devel >= 1:3.12.3
74 BuildRequires:  pango-devel
75 BuildRequires:  perl-modules
76 BuildRequires:  pkgconfig
77 BuildRequires:  python
78 # grep gyp.googlecode.com src/DEPS | cut -d'"' -f2 | cut -d@ -f2
79 BuildRequires:  python-gyp >= 0.1-795
80 BuildRequires:  python-modules
81 BuildRequires:  rpmbuild(macros) >= 1.453
82 BuildRequires:  sqlite3-devel >= 3.6.1
83 %{?with_system_v8:BuildRequires:        v8-devel}
84 BuildRequires:  which
85 BuildRequires:  xorg-lib-libXScrnSaver-devel
86 BuildRequires:  yasm
87 %{?with_system_zlib:BuildRequires:      zlib-devel}
88 Requires:       browser-plugins >= 2.0
89 Requires:       xdg-utils
90 Provides:       wwwbrowser
91 Obsoletes:      chromium-browser-bookmark_manager
92 ExclusiveArch:  %{ix86} %{x8664} arm
93 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
95 %define         find_lang       sh find-lang.sh %{buildroot}
96
97 %if %{without debuginfo}
98 %define         _enable_debug_packages  0
99 %endif
100
101 %description
102 Chromium is an open-source browser project that aims to build a safer,
103 faster, and more stable way for all Internet users to experience the
104 web.
105
106 Chromium serves as a base for Google Chrome, which is Chromium
107 rebranded (name and logo) with very few additions such as usage
108 tracking and an auto-updater system.
109
110 This package contains the Chromium browser.
111
112 %package inspector
113 Summary:        Page inspector for the chromium-browser
114 Group:          Development/Tools
115 Requires:       %{name} = %{version}-%{release}
116
117 %description inspector
118 Chromium is an open-source browser project that aims to build a safer,
119 faster, and more stable way for all Internet users to experience the
120 web.
121
122 This package contains 'inspector', allowing web developpers to inspect
123 any element of a web page at runtime (html, javascript, css, ..)
124
125 %package l10n
126 Summary:        chromium-browser language packages
127 Group:          I18n
128 Requires:       %{name} = %{version}-%{release}
129
130 %description l10n
131 Chromium is an open-source browser project that aims to build a safer,
132 faster, and more stable way for all Internet users to experience the
133 web.
134
135 This package contains language packages for 50 languages:
136
137 ar, bg, bn, ca, cs, da, de, el, en-GB, es-419, es, et, fi, fil, fr,
138 gu, he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or,
139 pl, pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi,
140 zh-CN, zh-TW
141
142 %prep
143 %setup -q -n %{name}-%{version}~svn%{svndate}r%{svnver}
144 lzma -dc %{name}-%{version}~svn%{svndate}r%{svnver}-source.tar.lzma | tar x
145 rm -f %{name}-%{version}~svn%{svndate}r%{svnver}-source.tar.lzma
146
147 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
148 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
149 . ./src/chrome/VERSION
150 ver=$MAJOR.$MINOR.$BUILD.$PATCH
151 if [ "$ver" != %{version} ]; then
152         exit 1
153 fi
154
155 # Populate the LASTCHANGE file template as we no longer have the VCS files at this point
156 echo "%{svnver}" > src/build/LASTCHANGE.in
157
158 sed -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE4} > find-lang.sh
159
160 %patch0 -p1
161 %patch1 -p1
162 %patch2 -p1
163 %patch3 -p0
164 %patch4 -p0
165 %patch5 -p1
166 %patch11 -p1
167
168 %build
169 cd src
170 %{__python} build/gyp_chromium --format=make build/all.gyp \
171 %ifarch %{ix86}
172         -Dtarget_arch=ia32 \
173 %endif
174 %ifarch %{x8664}
175         -Dtarget_arch=x64 \
176 %endif
177 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
178         -Dno_strict_aliasing=1 -Dgcc_version=44 \
179 %endif
180 %if %{with sandboxing}
181         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
182         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
183 %endif
184         %{!?debug:-Dwerror=} \
185         %{?with_shared_libs:-Dlibrary=shared_library} \
186         -Djavascript_engine=%{?with_system_v8:system-v8}%{!?with_system_v8:v8} \
187         -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
188         -Duse_system_bzip2=1 \
189         -Duse_system_libevent=1 \
190         -Duse_system_libjpeg=1 \
191         -Duse_system_libpng=1 \
192         -Duse_system_libxml=1 \
193         -Duse_system_libxslt=1 \
194         -Duse_system_sqlite=%{?with_system_sqlite:1}%{!?with_system_sqlite:0} \
195         -Duse_system_zlib=%{?with_system_zlib:1}%{!?with_system_zlib:0} \
196         -Duse_system_vpx=1 \
197         -Duse_system_yasm=1 \
198         -Dffmpeg_branding=Chrome \
199         -Dproprietary_codecs=1 \
200 %if %{with selinux}
201         -Dselinux=1 \
202 %endif
203
204 %{__make} chrome %{?with_sandboxing:chrome_sandbox} \
205         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
206         %{?with_verbose:V=1} \
207         CC="%{__cc}" \
208         CXX="%{__cxx}" \
209         CC.host="%{__cc}" \
210         CXX.host="%{__cxx}" \
211         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
212         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
213
214 %install
215 rm -rf $RPM_BUILD_ROOT
216 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}/{themes,locales,plugins,extensions,resources},%{_mandir}/man1,%{_pixmapsdir},%{_desktopdir}}
217
218 cd src/out/%{!?debug:Release}%{?debug:Debug}
219
220 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
221 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
222 cp -a chrome.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
223 cp -a locales/*.pak $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
224 cp -a resources/* $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
225 cp -a chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
226 cp -a product_logo_48.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
227 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
228 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
229 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
230 install -p xdg-settings $RPM_BUILD_ROOT%{_libdir}/%{name}
231 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
232 cd -
233
234 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
235 # http://code.google.com/p/chromium/issues/detail?id=24507
236 gecko-mediaplayer*.so
237 EOF
238
239 # find locales
240 %find_lang %{name}.lang
241 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
242
243 %clean
244 rm -rf $RPM_BUILD_ROOT
245
246 %post
247 %update_browser_plugins
248
249 %postun
250 if [ "$1" = 0 ]; then
251         %update_browser_plugins
252 fi
253
254 %files -f %{name}.lang
255 %defattr(644,root,root,755)
256 %{_browserpluginsconfdir}/browsers.d/%{name}.*
257 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
258 %attr(755,root,root) %{_bindir}/%{name}
259 %{_mandir}/man1/%{name}.1*
260 %{_pixmapsdir}/%{name}.png
261 %{_desktopdir}/*.desktop
262 %dir %{_libdir}/%{name}
263 %{_libdir}/%{name}/chrome.pak
264 %dir %{_libdir}/%{name}/locales
265 %{_libdir}/%{name}/locales/en-US.pak
266 %dir %{_libdir}/%{name}/resources
267 %dir %{_libdir}/%{name}/themes
268 %dir %{_libdir}/%{name}/extensions
269 %dir %{_libdir}/%{name}/plugins
270 %attr(755,root,root) %{_libdir}/%{name}/%{name}
271 # These unique permissions are intentional and necessary for the sandboxing
272 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
273
274 # ffmpeg libs
275 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
276
277 # bundle this copy until xdg-utils will have this itself
278 %attr(755,root,root) %{_libdir}/%{name}/xdg-settings
279
280 %{_libdir}/%{name}/resources/bookmark_manager
281 %{_libdir}/%{name}/resources/calendar_app
282 %{_libdir}/%{name}/resources/docs_app
283 %{_libdir}/%{name}/resources/gmail_app
284 %{_libdir}/%{name}/resources/net_internals
285 %{_libdir}/%{name}/resources/shared
286
287 %files inspector
288 %defattr(644,root,root,755)
289 %{_libdir}/%{name}/resources/inspector
290
291 %files l10n -f %{name}.lang
292 %defattr(644,root,root,755)
This page took 0.310057 seconds and 3 git commands to generate.