]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
adapter
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  ffmpegsumo              # build with ffmpegsumo
6 %bcond_without  gconf                   # with GConf
7 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
8 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
9 %bcond_without  libjpegturbo    # use libjpeg-turbo features
10 %bcond_without  nacl                    # build Native Client support
11 %bcond_without  pulseaudio              # with pulseaudio
12 %bcond_without  sandboxing              # with sandboxing
13 %bcond_with             selinux                 # with SELinux (need policy first)
14 %bcond_with             shared_libs             # with shared libs
15 %bcond_with             sse2                    # use SSE2 instructions
16 %bcond_without  system_flac             # system flac
17 %bcond_without  system_jsoncpp  # system jsoncpp
18 %bcond_without  system_libexif  # system libexif
19 %bcond_without  system_libmtp   # system libmtp
20 %bcond_without  system_libusb   # system libusb-1
21 %bcond_without  system_libwebp  # system libwebp
22 %bcond_without  system_libxnvctrl       # system libxnvctrl
23 %bcond_without  system_minizip  # system minizip
24 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
25 %bcond_without  system_speex    # system speex
26 %bcond_with             system_sqlite   # system sqlite
27 %bcond_without  system_srtp             # system srtp (can be used if using bundled libjingle)
28 %bcond_with             system_v8               # system v8
29 %bcond_without  system_libvpx   # system libvpx
30 %bcond_without  system_yasm             # system yasm
31 %bcond_without  system_zlib             # system zlib
32 %bcond_with             tcmalloc                # use tcmalloc
33 %bcond_without  verbose                 # verbose build (V=1)
34
35 %if %{with nacl}
36 # temporary hack as seems this does not work: http://codereview.chromium.org/8890043
37 # nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
38 #14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
39 #14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
40 #14:51:06 @baggins> as-needed will take care of unneeded lib
41 #14:52:03 @baggins> -lssp comes with gcc
42 %define         _ssp_cflags     %{nil}
43 %endif
44
45 # TODO
46 # - check system sqlite linking problems
47 # - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
48 # - use_system_ssl (use_openssl: http://crbug.com/62803)
49 # - use_system_ffmpeg && build_ffmpegsumo
50 # - use_system_hunspell
51 # - use_system_stlport
52 # - other defaults: src/build/common.gypi
53
54 # NOTES:
55 # - mute BEEP mixer if you do not want to hear horrible system bell when
56 #   pressing home/end in url bar or more ^F search results on page.
57 # - space considerations:
58 #   - unpacked sources: ~649MiB
59 #   - built code: ~1.4GiB (x86_64/i686)
60 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
61 # - to look for new tarball, use update-source.sh script
62
63 # NOTE TO USERS:
64 # To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
65 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
66 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
67
68 %define         gyp_rev 1014
69 Summary:        A WebKit powered web browser
70 Name:           chromium-browser
71 Version:        24.0.1312.45
72 Release:        0.20
73 License:        BSD, LGPL v2+ (ffmpeg)
74 Group:          X11/Applications/Networking
75 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{version}.tar.gz
76 # Source0-md5:  2995d5aa3f1ecb470e60e0984229fcce
77 Source1:        %{name}.default
78 Source2:        %{name}.sh
79 Source3:        %{name}.desktop
80 Source5:        find-lang.sh
81 Source6:        update-source.sh
82 Source7:        clean-source.sh
83 Source8:        get-source.sh
84 Source9:        master_preferences.json
85 Patch1:         plugin-searchdirs.patch
86 #Patch2:                system-nspr.patch
87 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
88 Patch4:         path-libpdf.patch
89 Patch5:         options-support.patch
90 Patch6:         get-webkit_revision.patch
91 Patch7:         dlopen_sonamed_gl.patch
92 Patch8:         chromium_useragent.patch.in
93 Patch9:         chromium-ppapi.patch
94 Patch10:        system-libxnvctrl.patch
95 # https://bugs.gentoo.org/show_bug.cgi?id=393471
96 # libjpeg-turbo >= 1.1.90 supports that feature
97 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
98 Patch15:        nacl-build-irt.patch
99 Patch16:        nacl-linkingfix.patch
100 Patch18:        nacl-no-untar.patch
101 Patch19:        system-jsoncpp.patch
102 Patch21:        system-srtp.patch
103 Patch22:        pulse_fix-157876.patch
104 Patch23:        no-pnacl.patch
105 Patch24:        nacl-verbose.patch
106 Patch25:        gnome3-volume-control.patch
107 Patch26:        master-prefs-path.patch
108 URL:            http://www.chromium.org/Home
109 %{?with_gconf:BuildRequires:    GConf2-devel}
110 BuildRequires:  OpenGL-GLU-devel
111 BuildRequires:  alsa-lib-devel
112 BuildRequires:  atk-devel
113 BuildRequires:  bison
114 BuildRequires:  bzip2-devel
115 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
116 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
117 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
118 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
119 %{?with_cups:BuildRequires:     cups-devel}
120 BuildRequires:  dbus-glib-devel
121 BuildRequires:  expat-devel
122 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
123 BuildRequires:  flex
124 BuildRequires:  fontconfig-devel
125 BuildRequires:  glib2-devel
126 BuildRequires:  gperf
127 BuildRequires:  gtk+2-devel
128 %{?with_kerberos:BuildRequires: heimdal-devel}
129 BuildRequires:  hicolor-icon-theme
130 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
131 %{?with_system_libxvnctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
132 BuildRequires:  libevent-devel
133 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
134 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
135 BuildRequires:  libicu-devel >= 4.6
136 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
137 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
138 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
139 BuildRequires:  libpng-devel
140 %{?with_selinux:BuildRequires:  libselinux-devel}
141 BuildRequires:  libstdc++-devel
142 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
143 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
144 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
145 BuildRequires:  libxml2-devel
146 BuildRequires:  libxslt-devel
147 BuildRequires:  lzma
148 %{?with_system_minizip:BuildRequires:   minizip-devel}
149 BuildRequires:  nspr-devel
150 BuildRequires:  nss-devel >= 1:3.12.3
151 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
152 BuildRequires:  pam-devel
153 BuildRequires:  pango-devel
154 BuildRequires:  perl-modules
155 BuildRequires:  pkgconfig
156 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
157 BuildRequires:  python
158 #BuildRequires: python-gyp >= 1-%{gyp_rev}
159 BuildRequires:  python-modules
160 BuildRequires:  rpm >= 4.4.9-56
161 BuildRequires:  rpmbuild(macros) >= 1.453
162 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
163 BuildRequires:  sqlite3-devel >= 3.6.1
164 %{?with_system_srtp:BuildRequires:      srtp-devel >= 1.4.4}
165 BuildRequires:  subversion
166 BuildRequires:  tar >= 1:1.22
167 BuildRequires:  udev-devel
168 BuildRequires:  util-linux
169 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
170 BuildRequires:  which
171 BuildRequires:  xorg-lib-libXScrnSaver-devel
172 BuildRequires:  xorg-lib-libXt-devel
173 BuildRequires:  xorg-lib-libXtst-devel
174 BuildRequires:  xz
175 %{?with_system_yasm:BuildRequires:      yasm}
176 %{?with_system_zlib:BuildRequires:      zlib-devel}
177 Requires:       browser-plugins >= 2.0
178 Requires:       desktop-file-utils
179 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
180 Requires:       hicolor-icon-theme
181 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
182 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
183 Requires:       xdg-utils >= 1.0.2-4
184 Provides:       wwwbrowser
185 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
186 Obsoletes:      chromium-browser-inspector < 15.0.863.0
187 ExclusiveArch:  %{ix86} %{x8664} arm
188 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
189
190 %define         find_lang       sh find-lang.sh %{buildroot}
191
192 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
193 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
194
195 %if %{without debuginfo}
196 %define         _enable_debug_packages  0
197 %endif
198
199 %description
200 Chromium is an open-source browser project that aims to build a safer,
201 faster, and more stable way for all Internet users to experience the
202 web.
203
204 Chromium serves as a base for Google Chrome, which is Chromium
205 rebranded (name and logo) with very few additions such as usage
206 tracking and an auto-updater system.
207
208 %package l10n
209 Summary:        chromium-browser language packages
210 Group:          I18n
211 Requires:       %{name} = %{version}-%{release}
212
213 %description l10n
214 Chromium is an open-source browser project that aims to build a safer,
215 faster, and more stable way for all Internet users to experience the
216 web.
217
218 This package contains language packages for 50 languages:
219
220 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
221 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
222 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
223 zh-TW
224
225 %prep
226 %setup -q
227
228 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
229 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
230 . ./src/chrome/VERSION
231 ver=$MAJOR.$MINOR.$BUILD.$PATCH
232 test "$ver" = %{version}
233
234 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
235 test "$gyp_rev" = %{gyp_rev} || :
236
237 v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
238
239 # add chromium and pld to useragent
240 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
241 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
242     -e 's/@BUILD_DIST_NAME@/PLD/g' \
243     -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
244     < %{PATCH8} | %{__patch} -p1
245
246 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
247 ln -s %{SOURCE7} src
248
249 %patch1 -p1
250 %patch3 -p1
251 %patch4 -p1
252 %patch5 -p1
253 %patch6 -p1
254 %patch7 -p1
255 %patch15 -p1
256 cd src
257 %patch9 -p0
258 #%patch2 -p1
259 %{!?with_libjpegturbo:%patch11 -p0}
260 %patch16 -p1
261 %patch19 -p1
262 %patch21 -p1
263 %patch22 -p1
264 %patch25 -p1
265 cd ..
266 %patch18 -p1
267 %patch23 -p1
268 %patch24 -p1
269 %patch26 -p1
270
271 cd src
272
273 # Missing gyp files in tarball.
274 # https://code.google.com/p/chromium/issues/detail?id=144823
275 if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
276         echo "tarball fixed, please remove workaround"
277         exit 1
278 fi
279
280 install -d chrome/test/data/nacl
281 cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
282 {
283  'targets': [
284    {
285      'target_name': 'nacl_tests',
286      'type': 'none',
287    },
288  ],
289 }
290 EOF
291
292 sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0} %{!?with_system_zlib:zlib=0}
293
294 %build
295 cd src
296
297 %if %{with nacl}
298 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
299 # Make symlinks for NaCL
300 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,lib,lib32,nacl}
301
302 cd native_client/toolchain/linux_x86_newlib/x86_64-nacl/bin
303 __cc='%{__cc}'
304 if [ "${__cc}#ccache}" != "$__cc" ]; then
305         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
306         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
307         %{__sed} -i -e '1i#!/bin/sh' gcc g++
308         chmod +x gcc g++
309 else
310         ln -s %{_bindir}/x86_64-nacl-gcc gcc
311         ln -s %{_bindir}/x86_64-nacl-g++ g++
312 fi
313 ln -s %{_bindir}/x86_64-nacl-ar ar
314 ln -s %{_bindir}/x86_64-nacl-as as
315 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
316 ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
317 ln -s %{_bindir}/x86_64-nacl-strip strip
318 ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib
319 ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32
320 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
321 cd ../../../../..
322 fi
323 %endif
324
325 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
326 test -e Makefile || %{__python} build/gyp_chromium \
327         --format=make \
328         -Goutput_dir=../out \
329         build/all.gyp \
330 %ifarch %{ix86}
331         -Dtarget_arch=ia32 \
332 %endif
333 %ifarch %{x8664}
334         -Dtarget_arch=x64 \
335 %endif
336 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
337         -Dno_strict_aliasing=1 -Dgcc_version=44 \
338 %endif
339 %if %{with sandboxing}
340         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
341         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
342 %endif
343         %{!?debug:-Dwerror=} \
344         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
345         %{?with_shared_libs:-Dlibrary=shared_library} \
346         -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
347         -Dffmpeg_branding=Chrome \
348         -Dremove_webcore_debug_symbols=1 \
349         -Dproprietary_codecs=1 \
350         -Dinclude_tests=0 \
351 %if %{with nacl}
352         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
353         -Ddisable_glibc_untar=1 \
354         -Ddisable_newlib_untar=1 \
355         -Ddisable_glibc=1 \
356         -Ddisable_pnacl=1 \
357         -Dbuild_pnacl_newlib=0 \
358 %else
359         -Ddisable_pnacl_untar=1 \
360         -Ddisable_nacl=1 \
361 %endif
362         %{!?with_sse2:-Ddisable_sse2=1} \
363         %{?with_selinux:-Dselinux=1} \
364         %{gyp_with cups} \
365         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
366         %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
367         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
368         %{gyp_with pulseaudio} \
369         %{gyp_with system_flac} \
370         %{gyp_with system_libexif} \
371         %{gyp_with system_libmtp} \
372         %{gyp_with system_libusb} \
373         %{gyp_with system_libvpx} \
374         %{gyp_with system_libwebp} \
375         %{gyp_with system_libxnvctrl} \
376         %{gyp_with system_minizip} \
377         %{gyp_with system_opus} \
378         %{gyp_with system_speex} \
379         %{gyp_with system_sqlite} \
380         %{gyp_with system_v8} \
381         %{gyp_with system_yasm} \
382         %{gyp_with system_zlib} \
383         -Duse_system_bzip2=1 \
384         -Duse_system_expat=1 \
385         -Duse_system_icu=1 \
386         -Duse_system_libevent=1 \
387         -Duse_system_libjpeg=1 \
388         -Duse_system_libpng=1 \
389         -Duse_system_libxml=1 \
390         -Duse_system_libxslt=1 \
391         -Duse_system_xdg_utils=1 \
392         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
393         -Dlinux_use_gold_binary=0 \
394         -Dlinux_use_gold_flags=0
395
396 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
397         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
398         %{?with_verbose:V=1} \
399         CC="%{__cc}" \
400         CXX="%{__cxx}" \
401         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
402         CC.host="%{__cc}" \
403         CXX.host="%{__cxx}" \
404         LDFLAGS.host="%{rpmldflags}" \
405         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
406         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
407
408 %install
409 rm -rf $RPM_BUILD_ROOT
410 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
411         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
412
413 cd out/%{!?debug:Release}%{?debug:Debug}
414 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
415 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
416 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
417 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
418 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
419 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
420 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
421 %if %{with ffmpegsumo}
422 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
423 %endif
424 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
425 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
426
427 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
428
429 %if %{with nacl}
430 # Install Native Client files on platforms that support it.
431 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
432 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
433 %ifarch %{x8664}
434 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
435 %endif
436 %ifarch %{ix86}
437 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
438 %endif
439 %endif
440
441 cd -
442
443 for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
444         size=${icon##*/product_logo_}
445         size=${size%.png}
446
447         # this will skip non-numeric (22_mono_invert, 22_mono)
448         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
449         test -d "$dir" || continue
450
451         install -d $RPM_BUILD_ROOT$dir
452         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
453 done
454
455 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
456 # http://code.google.com/p/chromium/issues/detail?id=24507
457 gecko-mediaplayer*.so
458 EOF
459
460 # find locales
461 %find_lang %{name}.lang
462 # always package en-US
463 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
464
465 %clean
466 rm -rf $RPM_BUILD_ROOT
467
468 %post
469 %update_icon_cache hicolor
470 %update_desktop_database
471 %update_browser_plugins
472
473 %postun
474 if [ "$1" = 0 ]; then
475         %update_icon_cache hicolor
476         %update_browser_plugins
477 fi
478
479 %files
480 %defattr(644,root,root,755)
481 %doc src/{AUTHORS,LICENSE}
482 %{_browserpluginsconfdir}/browsers.d/%{name}.*
483 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
484 %dir %{_sysconfdir}/%{name}
485 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
486 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
487 %attr(755,root,root) %{_bindir}/%{name}
488 %{_mandir}/man1/%{name}.1*
489 %{_desktopdir}/*.desktop
490 %{_iconsdir}/hicolor/*/apps/%{name}.png
491 %dir %{_libdir}/%{name}
492 %{_libdir}/%{name}/chrome*.pak
493 %{_libdir}/%{name}/content_resources.pak
494 %{_libdir}/%{name}/resources.pak
495 %dir %{_libdir}/%{name}/locales
496 %{_libdir}/%{name}/locales/en-US.pak
497 %dir %{_libdir}/%{name}/resources
498 %{_libdir}/%{name}/resources/inspector
499 %dir %{_libdir}/%{name}/themes
500 %dir %{_libdir}/%{name}/extensions
501 %dir %{_libdir}/%{name}/plugins
502 %attr(755,root,root) %{_libdir}/%{name}/%{name}
503 # These unique permissions are intentional and necessary for the sandboxing
504 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
505
506 # ffmpeg libs
507 %if %{with ffmpegsumo}
508 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
509 %endif
510
511 %if %{with nacl}
512 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
513 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
514 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
515 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
516 %endif
517
518 %files l10n -f %{name}.lang
519 %defattr(644,root,root,755)
This page took 0.088758 seconds and 3 git commands to generate.