]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
fix ffmpeg packaging
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  gconf                   # with GConf
6 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
7 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
8 %bcond_without  libjpegturbo    # use libjpeg-turbo features
9 %bcond_without  nacl                    # build Native Client support
10 %bcond_without  pulseaudio              # with pulseaudio
11 %bcond_without  sandboxing              # with sandboxing
12 %bcond_with             selinux                 # with SELinux (need policy first)
13 %bcond_with             shared_libs             # with shared libs
14 %bcond_with             sse2                    # use SSE2 instructions
15 %bcond_without  system_flac             # system flac
16 %bcond_with             system_ffmpeg   # system ffmpeg instead of ffmpegsumo
17 %bcond_without  system_jsoncpp  # system jsoncpp
18 %bcond_without  system_libexif  # system libexif
19 %bcond_without  system_libmtp   # system libmtp
20 %bcond_without  system_libusb   # system libusb-1
21 %bcond_without  system_libwebp  # system libwebp
22 %bcond_without  system_libxnvctrl       # system libxnvctrl
23 %bcond_without  system_minizip  # system minizip
24 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
25 %bcond_with             system_protobuf # system protobuf
26 %bcond_without  system_speex    # system speex
27 %bcond_with             system_sqlite   # system sqlite
28 %bcond_without  system_srtp             # system srtp (can be used if using bundled libjingle)
29 %bcond_with             system_v8               # system v8
30 %bcond_without  system_libvpx   # system libvpx
31 %bcond_without  system_yasm             # system yasm
32 %bcond_without  system_zlib             # system zlib
33 %bcond_with             tcmalloc                # use tcmalloc
34 %bcond_without  verbose                 # verbose build (V=1)
35
36 %if %{with nacl}
37 # temporary hack as seems this does not work: http://codereview.chromium.org/8890043
38 # nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
39 #14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
40 #14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
41 #14:51:06 @baggins> as-needed will take care of unneeded lib
42 #14:52:03 @baggins> -lssp comes with gcc
43 %define         _ssp_cflags     %{nil}
44 %endif
45
46 # TODO
47 # - check system sqlite linking problems
48 # - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
49 # - use_system_ssl (use_openssl: http://crbug.com/62803)
50 # - use_system_hunspell
51 # - use_system_stlport
52 # - other defaults: src/build/common.gypi
53
54 # NOTES:
55 # - mute BEEP mixer if you do not want to hear horrible system bell when
56 #   pressing home/end in url bar or more ^F search results on page.
57 # - space considerations:
58 #   - unpacked sources: ~649MiB
59 #   - built code: ~1.4GiB (x86_64/i686)
60 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
61 # - to look for new tarball, use update-source.sh script
62
63 # NOTE TO USERS:
64 # To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
65 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
66 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
67
68 %define         gyp_rev 1014
69 Summary:        A WebKit powered web browser
70 Name:           chromium-browser
71 Version:        24.0.1312.45
72 Release:        0.22
73 License:        BSD, LGPL v2+ (ffmpeg)
74 Group:          X11/Applications/Networking
75 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}-%{version}.tar.gz
76 # Source0-md5:  2995d5aa3f1ecb470e60e0984229fcce
77 Source1:        %{name}.default
78 Source2:        %{name}.sh
79 Source3:        %{name}.desktop
80 Source5:        find-lang.sh
81 Source6:        update-source.sh
82 Source7:        clean-source.sh
83 Source8:        get-source.sh
84 Source9:        master_preferences.json
85 Patch1:         plugin-searchdirs.patch
86 #Patch2:                system-nspr.patch
87 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
88 Patch4:         path-libpdf.patch
89 Patch6:         get-webkit_revision.patch
90 Patch7:         dlopen_sonamed_gl.patch
91 Patch8:         chromium_useragent.patch.in
92 Patch9:         chromium-ppapi.patch
93 Patch10:        system-libxnvctrl.patch
94 # https://bugs.gentoo.org/show_bug.cgi?id=393471
95 # libjpeg-turbo >= 1.1.90 supports that feature
96 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
97 Patch15:        nacl-build-irt.patch
98 Patch16:        nacl-linkingfix.patch
99 Patch18:        nacl-no-untar.patch
100 Patch19:        system-jsoncpp.patch
101 Patch21:        system-srtp.patch
102 Patch22:        pulse_fix-157876.patch
103 Patch23:        no-pnacl.patch
104 Patch24:        nacl-verbose.patch
105 Patch25:        gnome3-volume-control.patch
106 Patch26:        master-prefs-path.patch
107 URL:            http://www.chromium.org/Home
108 %{?with_gconf:BuildRequires:    GConf2-devel}
109 BuildRequires:  OpenGL-GLU-devel
110 BuildRequires:  alsa-lib-devel
111 BuildRequires:  atk-devel
112 BuildRequires:  bison
113 BuildRequires:  bzip2-devel
114 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
115 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
116 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
117 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
118 %{?with_cups:BuildRequires:     cups-devel}
119 BuildRequires:  dbus-glib-devel
120 BuildRequires:  expat-devel
121 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
122 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
123 BuildRequires:  flex
124 BuildRequires:  fontconfig-devel
125 BuildRequires:  glib2-devel
126 BuildRequires:  gperf
127 BuildRequires:  gtk+2-devel
128 %{?with_kerberos:BuildRequires: heimdal-devel}
129 BuildRequires:  hicolor-icon-theme
130 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
131 %{?with_system_libxvnctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
132 BuildRequires:  libevent-devel
133 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
134 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
135 BuildRequires:  libicu-devel >= 4.6
136 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
137 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
138 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
139 BuildRequires:  libpng-devel
140 %{?with_selinux:BuildRequires:  libselinux-devel}
141 BuildRequires:  libstdc++-devel
142 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
143 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 0.9.5-2}
144 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
145 BuildRequires:  libxml2-devel
146 BuildRequires:  libxslt-devel
147 BuildRequires:  lzma
148 %{?with_system_minizip:BuildRequires:   minizip-devel}
149 BuildRequires:  nspr-devel
150 BuildRequires:  nss-devel >= 1:3.12.3
151 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
152 BuildRequires:  pam-devel
153 BuildRequires:  pango-devel
154 BuildRequires:  perl-modules
155 BuildRequires:  pkgconfig
156 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
157 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
158 BuildRequires:  python
159 #BuildRequires: python-gyp >= 1-%{gyp_rev}
160 BuildRequires:  python-modules
161 BuildRequires:  rpm >= 4.4.9-56
162 BuildRequires:  rpmbuild(macros) >= 1.453
163 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
164 BuildRequires:  sqlite3-devel >= 3.6.1
165 %{?with_system_srtp:BuildRequires:      srtp-devel >= 1.4.4}
166 BuildRequires:  subversion
167 BuildRequires:  tar >= 1:1.22
168 BuildRequires:  udev-devel
169 BuildRequires:  util-linux
170 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
171 BuildRequires:  which
172 BuildRequires:  xorg-lib-libXScrnSaver-devel
173 BuildRequires:  xorg-lib-libXt-devel
174 BuildRequires:  xorg-lib-libXtst-devel
175 BuildRequires:  xz
176 %{?with_system_yasm:BuildRequires:      yasm}
177 %{?with_system_zlib:BuildRequires:      zlib-devel}
178 Requires:       browser-plugins >= 2.0
179 Requires:       desktop-file-utils
180 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
181 Requires:       hicolor-icon-theme
182 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
183 %{?with_system_libvpx:Requires: libvpx >= 0.9.5-2}
184 Requires:       xdg-utils >= 1.0.2-4
185 Provides:       wwwbrowser
186 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
187 Obsoletes:      chromium-browser-inspector < 15.0.863.0
188 ExclusiveArch:  %{ix86} %{x8664} arm
189 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
190
191 %define         find_lang       sh find-lang.sh %{buildroot}
192
193 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
194 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
195
196 %if %{without debuginfo}
197 %define         _enable_debug_packages  0
198 %endif
199
200 %description
201 Chromium is an open-source browser project that aims to build a safer,
202 faster, and more stable way for all Internet users to experience the
203 web.
204
205 Chromium serves as a base for Google Chrome, which is Chromium
206 rebranded (name and logo) with very few additions such as usage
207 tracking and an auto-updater system.
208
209 %package l10n
210 Summary:        chromium-browser language packages
211 Group:          I18n
212 Requires:       %{name} = %{version}-%{release}
213
214 %description l10n
215 Chromium is an open-source browser project that aims to build a safer,
216 faster, and more stable way for all Internet users to experience the
217 web.
218
219 This package contains language packages for 50 languages:
220
221 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
222 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
223 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
224 zh-TW
225
226 %prep
227 %setup -q
228
229 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
230 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
231 . ./src/chrome/VERSION
232 ver=$MAJOR.$MINOR.$BUILD.$PATCH
233 test "$ver" = %{version}
234
235 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
236 test "$gyp_rev" = %{gyp_rev} || :
237
238 v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
239
240 # add chromium and pld to useragent
241 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
242 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
243     -e 's/@BUILD_DIST_NAME@/PLD/g' \
244     -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
245     < %{PATCH8} | %{__patch} -p1
246
247 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
248 ln -s %{SOURCE7} src
249
250 %patch1 -p1
251 %patch3 -p1
252 %patch4 -p1
253 %patch6 -p1
254 %patch7 -p1
255 %patch15 -p1
256 cd src
257 %patch9 -p0
258 #%patch2 -p1
259 %{!?with_libjpegturbo:%patch11 -p0}
260 %patch16 -p1
261 %patch19 -p1
262 %patch21 -p1
263 %patch22 -p1
264 %patch25 -p1
265 cd ..
266 %patch18 -p1
267 %patch23 -p1
268 %patch24 -p1
269 %patch26 -p1
270
271 cd src
272
273 # Missing gyp files in tarball.
274 # https://code.google.com/p/chromium/issues/detail?id=144823
275 if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
276         echo "tarball fixed, please remove workaround"
277         exit 1
278 fi
279
280 install -d chrome/test/data/nacl
281 cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
282 {
283  'targets': [
284    {
285      'target_name': 'nacl_tests',
286      'type': 'none',
287    },
288  ],
289 }
290 EOF
291
292 sh -x clean-source.sh \
293         %{!?with_nacl:nacl=0} \
294         %{!?with_system_protobuf:protobuf=0} \
295         %{!?with_system_v8:v8=0} \
296         %{!?with_system_zlib:zlib=0} \
297         %{nil}
298
299 %build
300 cd src
301
302 %if %{with nacl}
303 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
304 # Make symlinks for NaCL
305 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,lib,lib32,nacl}
306
307 cd native_client/toolchain/linux_x86_newlib/x86_64-nacl/bin
308 __cc='%{__cc}'
309 if [ "${__cc}#ccache}" != "$__cc" ]; then
310         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
311         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
312         %{__sed} -i -e '1i#!/bin/sh' gcc g++
313         chmod +x gcc g++
314 else
315         ln -s %{_bindir}/x86_64-nacl-gcc gcc
316         ln -s %{_bindir}/x86_64-nacl-g++ g++
317 fi
318 ln -s %{_bindir}/x86_64-nacl-ar ar
319 ln -s %{_bindir}/x86_64-nacl-as as
320 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
321 ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
322 ln -s %{_bindir}/x86_64-nacl-strip strip
323 ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib
324 ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32
325 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
326 cd ../../../../..
327 fi
328 %endif
329
330 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} -f Makefile
331 test -e Makefile || %{__python} build/gyp_chromium \
332         --format=make \
333         -Goutput_dir=../out \
334         build/all.gyp \
335 %ifarch %{ix86}
336         -Dtarget_arch=ia32 \
337 %endif
338 %ifarch %{x8664}
339         -Dtarget_arch=x64 \
340 %endif
341 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
342         -Dno_strict_aliasing=1 -Dgcc_version=44 \
343 %endif
344 %if %{with sandboxing}
345         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
346         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
347 %endif
348         %{!?debug:-Dwerror=} \
349         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
350         %{?with_shared_libs:-Dlibrary=shared_library} \
351         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1 -Dproprietary_codecs=1} \
352         -Dinclude_tests=0 \
353 %if %{with nacl}
354         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
355         -Ddisable_glibc_untar=1 \
356         -Ddisable_newlib_untar=1 \
357         -Ddisable_glibc=1 \
358         -Ddisable_pnacl=1 \
359         -Dbuild_pnacl_newlib=0 \
360 %else
361         -Ddisable_pnacl_untar=1 \
362         -Ddisable_nacl=1 \
363 %endif
364         %{!?with_sse2:-Ddisable_sse2=1} \
365         %{?with_selinux:-Dselinux=1} \
366         %{gyp_with cups} \
367         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
368         %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
369         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
370         %{gyp_with pulseaudio} \
371         %{gyp_with system_ffmpeg} \
372         %{gyp_with system_flac} \
373         %{gyp_with system_libexif} \
374         %{gyp_with system_libmtp} \
375         %{gyp_with system_libusb} \
376         %{gyp_with system_libvpx} \
377         %{gyp_with system_libwebp} \
378         %{gyp_with system_libxnvctrl} \
379         %{gyp_with system_minizip} \
380         %{gyp_with system_opus} \
381         %{gyp_with system_protobuf} \
382         %{gyp_with system_speex} \
383         %{gyp_with system_sqlite} \
384         %{gyp_with system_v8} \
385         %{gyp_with system_yasm} \
386         %{gyp_with system_zlib} \
387         -Duse_system_bzip2=1 \
388         -Duse_system_expat=1 \
389         -Duse_system_icu=1 \
390         -Duse_system_libevent=1 \
391         -Duse_system_libjpeg=1 \
392         -Duse_system_libpng=1 \
393         -Duse_system_libxml=1 \
394         -Duse_system_libxslt=1 \
395         -Duse_system_xdg_utils=1 \
396         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
397         -Dlinux_use_gold_binary=0 \
398         -Dlinux_use_gold_flags=0
399
400 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
401         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
402         %{?with_verbose:V=1} \
403         CC="%{__cc}" \
404         CXX="%{__cxx}" \
405         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
406         CC.host="%{__cc}" \
407         CXX.host="%{__cxx}" \
408         LDFLAGS.host="%{rpmldflags}" \
409         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
410         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
411
412 %install
413 rm -rf $RPM_BUILD_ROOT
414 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
415         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
416
417 cd out/%{!?debug:Release}%{?debug:Debug}
418 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
419 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
420 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
421 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
422 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
423 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
424 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
425 %if %{without system_ffmpeg}
426 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
427 %endif
428 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
429 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
430
431 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
432
433 %if %{with nacl}
434 # Install Native Client files on platforms that support it.
435 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
436 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
437 %ifarch %{x8664}
438 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
439 %endif
440 %ifarch %{ix86}
441 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
442 %endif
443 %endif
444
445 cd -
446
447 for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
448         size=${icon##*/product_logo_}
449         size=${size%.png}
450
451         # this will skip non-numeric (22_mono_invert, 22_mono)
452         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
453         test -d "$dir" || continue
454
455         install -d $RPM_BUILD_ROOT$dir
456         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
457 done
458
459 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
460 # http://code.google.com/p/chromium/issues/detail?id=24507
461 gecko-mediaplayer*.so
462 EOF
463
464 # find locales
465 %find_lang %{name}.lang
466 # always package en-US
467 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
468
469 %clean
470 rm -rf $RPM_BUILD_ROOT
471
472 %post
473 %update_icon_cache hicolor
474 %update_desktop_database
475 %update_browser_plugins
476
477 %postun
478 if [ "$1" = 0 ]; then
479         %update_icon_cache hicolor
480         %update_browser_plugins
481 fi
482
483 %files
484 %defattr(644,root,root,755)
485 %doc src/{AUTHORS,LICENSE}
486 %{_browserpluginsconfdir}/browsers.d/%{name}.*
487 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
488 %dir %{_sysconfdir}/%{name}
489 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
490 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
491 %attr(755,root,root) %{_bindir}/%{name}
492 %{_mandir}/man1/%{name}.1*
493 %{_desktopdir}/*.desktop
494 %{_iconsdir}/hicolor/*/apps/%{name}.png
495 %dir %{_libdir}/%{name}
496 %{_libdir}/%{name}/chrome*.pak
497 %{_libdir}/%{name}/content_resources.pak
498 %{_libdir}/%{name}/resources.pak
499 %dir %{_libdir}/%{name}/locales
500 %{_libdir}/%{name}/locales/en-US.pak
501 %dir %{_libdir}/%{name}/resources
502 %{_libdir}/%{name}/resources/inspector
503 %dir %{_libdir}/%{name}/themes
504 %dir %{_libdir}/%{name}/extensions
505 %dir %{_libdir}/%{name}/plugins
506 %attr(755,root,root) %{_libdir}/%{name}/%{name}
507 # These unique permissions are intentional and necessary for the sandboxing
508 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
509
510 # ffmpeg libs
511 %if %{without system_ffmpeg}
512 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
513 %endif
514
515 %if %{with nacl}
516 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
517 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
518 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
519 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
520 %endif
521
522 %files l10n -f %{name}.lang
523 %defattr(644,root,root,755)
This page took 0.080771 seconds and 3 git commands to generate.