]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
- use system expat
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
4 %bcond_without  ffmpegsumo              # build with ffmpegsumo
5 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
6 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
7 %bcond_without  cups                    # with cups
8 %bcond_without  gconf                   # with GConf
9 %bcond_without  pulseaudio              # with pulseaudio
10 %bcond_with             nacl                    # build Native Client support
11 %bcond_without  sandboxing              # with sandboxing
12 %bcond_with             selinux                 # with SELinux (need policy first)
13 %bcond_with             shared_libs             # with shared libs
14 %bcond_with             sse2                    # use SSE2 instructions
15 %bcond_with             system_sqlite   # with system sqlite
16 %bcond_without  system_flac             # with system flac
17 %bcond_without  system_libwebp  # with system libwebp
18 %bcond_without  system_speex    # with system speex
19 %bcond_without  system_v8               # with system v8
20 %bcond_without  system_vpx              # with system vpx
21 %bcond_without  system_yasm             # with system yasm
22 %bcond_without  system_zlib             # with system zlib
23 %bcond_with             verbose                 # verbose build (V=1)
24
25 # TODO
26 # - check system sqlite linking problems
27 # - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
28 # - use_system_ssl (use_openssl: http://crbug.com/62803)
29 # - use_system_ffmpeg && build_ffmpegsumo
30 # - use_system_hunspell
31 # - use_system_stlport
32 # - other defaults: src/build/common.gypi
33
34 # NOTES:
35 # - mute BEEP mixer if you do not want to hear horrible system bell when
36 #   pressing home/end in url bar or more ^F search results on page.
37 # - build -bp: 1.2G
38 # - build i686: -bc: 2.7G; -bb: ~1.0GB
39 # - build x86_64: ~1.9G
40 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
41 # - to look for new tarball, use update-source.sh script
42
43 # NOTE TO USERS:
44 # To use chromium nightly builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
45 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
46 # or:
47 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
48
49 %define         svndate %{nil}
50 %define         svnver  112386
51 %define         rel             1
52
53 %define         gyp_rev 1014
54 Summary:        A WebKit powered web browser
55 Name:           chromium-browser
56 Version:        16.0.912.59
57 Release:        0.%{svnver}.%{rel}
58 License:        BSD, LGPL v2+ (ffmpeg)
59 Group:          X11/Applications/Networking
60 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/beta/%{name}_%{version}~r%{svnver}.orig.tar.gz
61 # Source0-md5:  79d7767698b1522ddf5f7cf725e0594f
62 #SourceX:       http://ppa.launchpad.net/chromium-daily/ppa/ubuntu/pool/main/c/chromium-browser/%{name}_%{version}~svn%{svndate}r%{svnver}.orig.tar.gz
63 Source2:        %{name}.sh
64 Source3:        %{name}.desktop
65 Source4:        find-lang.sh
66 Source5:        update-source.sh
67 Patch0:         system-libs.patch
68 Patch1:         plugin-searchdirs.patch
69 Patch2:         gyp-system-minizip.patch
70 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
71 Patch5:         options-support.patch
72 Patch6:         get-webkit_revision.patch
73 Patch7:         dlopen_sonamed_gl.patch
74 Patch8:         chromium_useragent.patch.in
75 Patch9:         system-expat.patch
76 URL:            http://www.chromium.org/Home
77 %{?with_gconf:BuildRequires:    GConf2-devel}
78 BuildRequires:  OpenGL-GLU-devel
79 BuildRequires:  alsa-lib-devel
80 BuildRequires:  atk-devel
81 BuildRequires:  bison
82 BuildRequires:  bzip2-devel
83 %{?with_cups:BuildRequires:     cups-devel}
84 BuildRequires:  dbus-glib-devel
85 BuildRequires:  expat-devel
86 %{?with_system_flac:BuildRequires:      flac-devel}
87 BuildRequires:  flex
88 BuildRequires:  fontconfig-devel
89 BuildRequires:  glib2-devel
90 BuildRequires:  gperf
91 BuildRequires:  gtk+2-devel
92 %{?with_kerberos:BuildRequires: heimdal-devel}
93 BuildRequires:  libevent-devel
94 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
95 BuildRequires:  libicu-devel >= 4.6
96 BuildRequires:  libjpeg-devel
97 BuildRequires:  libpng-devel
98 %{?with_selinux:BuildRequires:  libselinux-devel}
99 BuildRequires:  libstdc++-devel
100 %{?with_system_vpx:BuildRequires:       libvpx-devel >= 0.9.5-2}
101 %{?with_system_libwebp:BuildRequires:   libwebp-devel}
102 BuildRequires:  libxml2-devel
103 BuildRequires:  libxslt-devel
104 BuildRequires:  lzma
105 BuildRequires:  minizip-devel
106 %{?with_nacl:BuildRequires:     nacl-toolchain-newlib >= 0.6941}
107 BuildRequires:  nspr-devel
108 BuildRequires:  nss-devel >= 1:3.12.3
109 BuildRequires:  pam-devel
110 BuildRequires:  pango-devel
111 BuildRequires:  perl-modules
112 BuildRequires:  pkgconfig
113 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
114 BuildRequires:  python
115 #BuildRequires: python-gyp >= 1-%{gyp_rev}
116 BuildRequires:  python-modules
117 BuildRequires:  rpm >= 4.4.9-56
118 BuildRequires:  rpmbuild(macros) >= 1.453
119 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
120 BuildRequires:  sqlite3-devel >= 3.6.1
121 BuildRequires:  tar >= 1:1.22
122 BuildRequires:  util-linux
123 %{?with_system_v8:BuildRequires:        v8-devel >= 3.6}
124 BuildRequires:  which
125 BuildRequires:  xorg-lib-libXScrnSaver-devel
126 BuildRequires:  xorg-lib-libXt-devel
127 BuildRequires:  xorg-lib-libXtst-devel
128 %{?with_system_yasm:BuildRequires:      yasm}
129 %{?with_system_zlib:BuildRequires:      zlib-devel}
130 Requires:       browser-plugins >= 2.0
131 Requires:       desktop-file-utils
132 %{?with_system_vpx:Requires:    libvpx >= 0.9.5-2}
133 Requires:       xdg-utils >= 1.0.2-4
134 Provides:       wwwbrowser
135 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
136 Obsoletes:      chromium-browser-inspector < 15.0.863.0
137 ExclusiveArch:  %{ix86} %{x8664} arm
138 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
139
140 %define         find_lang       sh find-lang.sh %{buildroot}
141 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
142 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
143
144 %if %{without debuginfo}
145 %define         _enable_debug_packages  0
146 %endif
147
148 # undefine if empty, makes prep simplier
149 %if "%{svndate}" == "%{nil}"
150 %undefine       svndate
151 %endif
152
153 %description
154 Chromium is an open-source browser project that aims to build a safer,
155 faster, and more stable way for all Internet users to experience the
156 web.
157
158 Chromium serves as a base for Google Chrome, which is Chromium
159 rebranded (name and logo) with very few additions such as usage
160 tracking and an auto-updater system.
161
162 %package l10n
163 Summary:        chromium-browser language packages
164 Group:          I18n
165 Requires:       %{name} = %{version}-%{release}
166
167 %description l10n
168 Chromium is an open-source browser project that aims to build a safer,
169 faster, and more stable way for all Internet users to experience the
170 web.
171
172 This package contains language packages for 50 languages:
173
174 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
175 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
176 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
177 zh-TW
178
179 %prep
180 %setup -q -n %{name}-%{version}~%{?svndate:svn%{svndate}}r%{svnver}
181 SRC=%{name}-%{version}~%{?svndate:svn%{svndate}}r%{svnver}-source.tar.*
182 tar xf $SRC
183 %{__rm} $SRC
184
185 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
186 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
187 . ./src/chrome/VERSION
188 ver=$MAJOR.$MINOR.$BUILD.$PATCH
189 test "$ver" = %{version}
190
191 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
192 test "$gyp_rev" = %{gyp_rev} || :
193
194 # Populate the LASTCHANGE file template as we no longer have the VCS files at this point
195 echo "%{svnver}" > src/build/LASTCHANGE.in
196
197 # add chromium and pld to useragent
198 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
199 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
200     -e 's/@BUILD_DIST_NAME@/PLD/g' \
201     -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
202     < %{PATCH8} | %{__patch} -p1
203
204 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE4} > find-lang.sh
205
206 %patch0 -p1
207 %patch1 -p1
208 %patch2 -p1
209 %patch3 -p1
210 %patch5 -p1
211 %patch6 -p1
212 %patch7 -p1
213 cd src
214 %patch9 -p1
215 cd ..
216
217 # drop bundled libs, from gentoo
218 remove_bundled_lib() {
219         echo "Removing bundled library $1 ..."
220         local out
221         out=$(find $1 -mindepth 1 ! -iname '*.gyp' -print -delete)
222         if [ -z "$out" ]; then
223                 echo >&2 "No files matched when removing bundled library $1"
224                 exit 1
225         fi
226 }
227
228 cd src
229 rm -v third_party/expat/files/lib/expat.h
230 remove_bundled_lib "third_party/bzip2"
231 remove_bundled_lib "third_party/icu"
232 remove_bundled_lib "third_party/libevent"
233 remove_bundled_lib "third_party/libjpeg"
234 remove_bundled_lib "third_party/libpng"
235 # third_party/libvpx/libvpx.h should be kept
236 #remove_bundled_lib "third_party/libvpx"
237 remove_bundled_lib "third_party/libxml"
238 remove_bundled_lib "third_party/libxslt"
239 remove_bundled_lib "third_party/zlib"
240 # third_party/yasm/source/patched-yasm/modules/arch/x86/gen_x86_insn.py', needed by `out/Release/obj/gen/third_party/yasm/x86insns.c'.  Stop.
241 #remove_bundled_lib "third_party/yasm"
242
243 %if %{with system_v8}
244 # Remove bundled v8.
245 find v8 -type f \! -iname '*.gyp*' -delete
246
247 # The implementation files include v8 headers with full path,
248 # like #include "v8/include/v8.h". Make sure the system headers
249 # will be used.
250 rmdir v8/include
251 ln -s %{_includedir} v8/include
252 %endif
253
254 %if %{with nacl}
255 # NOTE: here is always x86_64
256 rm -rf native_client/toolchain/linux_x86_newlib
257 ln -s %{_prefix}/x86_64-nacl-newlib native_client/toolchain/linux_x86_newlib
258 %endif
259
260 %build
261 cd src
262 test -e Makefile || %{__python} build/gyp_chromium --format=make build/all.gyp \
263 %ifarch %{ix86}
264         -Dtarget_arch=ia32 \
265 %endif
266 %ifarch %{x8664}
267         -Dtarget_arch=x64 \
268 %endif
269 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
270         -Dno_strict_aliasing=1 -Dgcc_version=44 \
271 %endif
272 %if %{with sandboxing}
273         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
274         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
275 %endif
276         %{!?debug:-Dwerror=} \
277         %{!?debuginfo:-Dfastbuild=1} \
278         %{?with_shared_libs:-Dlibrary=shared_library} \
279         -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
280         -Dffmpeg_branding=Chrome \
281         -Dproprietary_codecs=1 \
282         %{!?with_nacl:-Ddisable_nacl=1} \
283         %{!?with_sse2:-Ddisable_sse2=1} \
284         %{?with_selinux:-Dselinux=1} \
285         %{gyp_with cups} \
286         %{gyp_with flac} \
287         %{gyp_with gconf} \
288         %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
289         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
290         %{gyp_with pulseaudio} \
291         %{gyp_with system_libwebp} \
292         %{gyp_with system_speex} \
293         %{gyp_with system_sqlite} \
294         %{gyp_with system_v8} \
295         %{gyp_with system_vpx} \
296         %{gyp_with system_yasm} \
297         %{gyp_with system_zlib} \
298         -Duse_system_bzip2=1 \
299         -Duse_system_icu=1 \
300         -Duse_system_libevent=1 \
301         -Duse_system_libjpeg=1 \
302         -Duse_system_libpng=1 \
303         -Duse_system_libxml=1 \
304         -Duse_system_libxslt=1 \
305         -Duse_system_xdg_utils=1 \
306
307 %{__make} chrome %{?with_sandboxing:chrome_sandbox} \
308         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
309         %{?with_verbose:V=1} \
310         CC="%{__cc}" \
311         CXX="%{__cxx}" \
312         CC.host="%{__cc}" \
313         CXX.host="%{__cxx}" \
314         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
315         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
316
317 %install
318 rm -rf $RPM_BUILD_ROOT
319 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}/{themes,locales,plugins,extensions,resources},%{_mandir}/man1,%{_pixmapsdir},%{_desktopdir}}
320
321 cd src/out/%{!?debug:Release}%{?debug:Debug}
322 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
323 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
324 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
325 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
326 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
327 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
328 %if %{with ffmpegsumo}
329 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
330 %endif
331 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
332
333 %if %{with nacl}
334 # Install Native Client files on platforms that support it.
335 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
336 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
337 %ifarch %{x8664}
338 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
339 %endif
340 %ifarch %{ix86}
341 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
342 %endif
343 %endif
344
345 cd -
346
347 cp -p src/chrome/app/theme/chromium/product_logo_48.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
348
349 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
350 # http://code.google.com/p/chromium/issues/detail?id=24507
351 gecko-mediaplayer*.so
352 EOF
353
354 # find locales
355 %find_lang %{name}.lang
356 # always package en-US
357 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
358
359 %clean
360 rm -rf $RPM_BUILD_ROOT
361
362 %post
363 %update_desktop_database
364 %update_browser_plugins
365
366 %postun
367 if [ "$1" = 0 ]; then
368         %update_browser_plugins
369 fi
370
371 %files -f %{name}.lang
372 %defattr(644,root,root,755)
373 %{_browserpluginsconfdir}/browsers.d/%{name}.*
374 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
375 %attr(755,root,root) %{_bindir}/%{name}
376 %{_mandir}/man1/%{name}.1*
377 %{_pixmapsdir}/%{name}.png
378 %{_desktopdir}/*.desktop
379 %dir %{_libdir}/%{name}
380 %{_libdir}/%{name}/chrome.pak
381 %{_libdir}/%{name}/resources.pak
382 %dir %{_libdir}/%{name}/locales
383 %{_libdir}/%{name}/locales/en-US.pak
384 %dir %{_libdir}/%{name}/resources
385 %{_libdir}/%{name}/resources/inspector
386 %dir %{_libdir}/%{name}/themes
387 %dir %{_libdir}/%{name}/extensions
388 %dir %{_libdir}/%{name}/plugins
389 %attr(755,root,root) %{_libdir}/%{name}/%{name}
390 # These unique permissions are intentional and necessary for the sandboxing
391 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
392
393 # ffmpeg libs
394 %if %{with ffmpegsumo}
395 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
396 %endif
397
398 %if %{with nacl}
399 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
400 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
401 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
402 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
403 %endif
404
405 %files l10n -f %{name}.lang
406 %defattr(644,root,root,755)
This page took 0.05664 seconds and 3 git commands to generate.