]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
clean more sources to make alt tarball match official
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_with     dev                     # with dev optimizations (skip clean source)
6 %bcond_without  gconf                   # with GConf
7 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in net/http/http_auth_gssapi_posix.cc)
8 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
9 %bcond_with             gps                     # with gps support (linked), if enabled must use exactly same gpsd as shm structures may change leading to unexpected results (crash)
10 %bcond_without  libjpegturbo    # use libjpeg-turbo features
11 %bcond_with     nacl                    # build Native Client support, disabled: http://crbug.com/269560
12 %bcond_without  ninja                   # use Ninja instead of make to build
13 %bcond_without  pulseaudio              # with pulseaudio
14 %bcond_without  sandboxing              # with sandboxing
15 %bcond_with             selinux                 # with SELinux (need policy first)
16 %bcond_with             shared_libs             # with shared libs
17 %bcond_with             sse2                    # use SSE2 instructions
18 %bcond_without  system_flac             # system flac
19 %bcond_with     system_ffmpeg   # system ffmpeg instead of ffmpegsumo
20 %bcond_without  system_harfbuzz # system harfbuzz
21 %bcond_without  system_icu      # system icu
22 %bcond_without  system_jsoncpp  # system jsoncpp
23 %bcond_without  system_libexif  # system libexif
24 %bcond_without  system_libmtp   # system libmtp
25 %bcond_with     system_libusb   # system libusb-1, disabled: http://crbug.com/266149
26 %bcond_without  system_libwebp  # system libwebp
27 %bcond_without  system_libxnvctrl       # system libxnvctrl
28 %bcond_with     system_mesa             # system Mesa
29 %bcond_without  system_minizip  # system minizip
30 %bcond_without  system_opus             # system opus codec support, http://www.opus-codec.org/examples/
31 %bcond_without  system_protobuf # system protobuf
32 %bcond_without  system_re2              # system re2
33 %bcond_without  system_snappy   # system snappy
34 %bcond_without  system_speex    # system speex
35 %bcond_with     system_sqlite   # system sqlite WebSQL (http://www.w3.org/TR/webdatabase/) will not work
36 %bcond_without  system_libsrtp  # system srtp (can be used if using bundled libjingle)
37 %bcond_with             system_v8               # system v8
38 %bcond_with     system_libvpx   # system libvpx
39 %bcond_without  system_yasm             # system yasm
40 %bcond_without  system_zlib             # system zlib
41 %bcond_with     tcmalloc                # use tcmalloc
42 %bcond_without  verbose                 # verbose build (V=1)
43
44 %ifarch %{ix86}
45 # GLsizeiptr different size, track: http://bugs.gentoo.org/457130
46 %undefine       with_system_mesa
47
48 # unable build with debuginfo on 32bit build systems
49 # /usr/bin/ld.gold: fatal error: chrome: mmap: failed to allocate 2994044872 bytes for output file: Cannot allocate memory
50 %undefine       with_debuginfo
51 %endif
52
53 %ifarch %{x8664}
54 # x86_64 systems fail with debugedit crashing
55 # /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
56 %undefine       with_debuginfo
57 %endif
58
59 # TODO
60 # - find system deps: find -type f -name '*.gyp*' | xargs grep -oh 'use_system_.*%' | sort -u
61 # - use_system_skia
62 # - use_system_ssl (use_openssl: http://crbug.com/62803)
63 # - use_system_stlport (android specific)
64 # - vpx: invert (remove) media_use_libvpx when libvpx with vp9 support is released
65
66 # NOTES:
67 # - mute BEEP mixer if you do not want to hear horrible system bell when
68 #   pressing home/end in url bar or more ^F search results on page.
69 # - space considerations:
70 #   - unpacked sources: ~490MiB
71 #   - built code: ~1.4GiB (x86_64/i686)
72 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
73 # - to look for new tarball, use update-source.sh script
74
75 %define         branch          39.0.2171
76 %define         basever         71
77 %define         patchver        95
78 %define         gyp_rev 1014
79 Summary:        A WebKit powered web browser
80 Name:           chromium-browser
81 %if "%{?patchver}" != ""
82 Version:        %{branch}.%{patchver}
83 %else
84 Version:        %{branch}.%{basever}
85 %endif
86 Release:        1
87 License:        BSD%{!?with_system_ffmpeg:, LGPL v2+ (ffmpeg)}
88 Group:          X11/Applications/Networking
89 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
90 # Source0-md5:  238cbf816f3d3c01a58894a32eb9995d
91 %if "%{?patchver}" != ""
92 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
93 # Patch0-md5:   1e03edf9545804bbc54ab3a77b1f4603
94 %endif
95 Source1:        %{name}.default
96 Source2:        %{name}.sh
97 Source3:        %{name}.desktop
98 Source5:        find-lang.sh
99 Source6:        update-source.sh
100 Source7:        clean-source.sh
101 Source8:        get-source.sh
102 Source9:        master_preferences.json
103 Patch2:         enable-video-decode-accel.patch
104 Patch4:         path-libpdf.patch
105 Patch7:         dlopen_sonamed_gl.patch
106 Patch8:         chromium_useragent.patch.in
107 # https://bugs.gentoo.org/show_bug.cgi?id=393471
108 # libjpeg-turbo >= 1.1.90 supports that feature
109 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
110 Patch15:        nacl-build-irt.patch
111 Patch16:        nacl-linkingfix.patch
112 Patch18:        nacl-no-untar.patch
113 Patch24:        nacl-verbose.patch
114 Patch25:        gnome3-volume-control.patch
115 Patch26:        master-prefs-path.patch
116 Patch28:        system-mesa.patch
117 Patch31:        system-jinja.patch
118 Patch32:        remove_bundled_libraries-stale.patch
119 Patch35:        etc-dir.patch
120 Patch36:        angle.patch
121 Patch37:        %{name}-build.patch
122 URL:            http://www.chromium.org/Home
123 %{?with_gconf:BuildRequires:    GConf2-devel}
124 %{?with_system_mesa:BuildRequires:      Mesa-libGL-devel >= 9.1}
125 BuildRequires:  Mesa-libGLES-devel >= 9.1
126 %{?with_system_mesa:BuildRequires:      Mesa-libGLU-devel}
127 %{?with_system_mesa:BuildRequires:      Mesa-libOSMesa-devel >= 9.1}
128 BuildRequires:  alsa-lib-devel
129 BuildRequires:  atk-devel
130 BuildRequires:  bison
131 BuildRequires:  bzip2-devel
132 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
133 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
134 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
135 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
136 %{?with_cups:BuildRequires:     cups-devel}
137 BuildRequires:  elfutils-devel
138 BuildRequires:  expat-devel
139 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 1.0}
140 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
141 BuildRequires:  fontconfig-devel
142 BuildRequires:  glib2-devel
143 BuildRequires:  gperf
144 %{?with_gps:BuildRequires:      gpsd-devel}
145 BuildRequires:  gtest-devel
146 BuildRequires:  gtk+2-devel
147 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-devel}
148 %{?with_system_harfbuzz:BuildRequires:  harfbuzz-icu-devel}
149 %{?with_kerberos:BuildRequires: heimdal-devel}
150 BuildRequires:  hicolor-icon-theme
151 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
152 %{?with_system_libxnvctrl:BuildRequires:        libXNVCtrl-devel >= 310.19}
153 BuildRequires:  libevent-devel
154 %{?with_system_libexif:BuildRequires:   libexif-devel >= 1:0.6.21}
155 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
156 %{?with_system_icu:BuildRequires:       libicu-devel >= 4.6}
157 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
158 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
159 %{?with_system_libmtp:BuildRequires:    libmtp-devel >= 1.1.3}
160 BuildRequires:  libpng-devel
161 %{?with_selinux:BuildRequires:  libselinux-devel}
162 BuildRequires:  libstdc++-devel
163 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
164 %{?with_system_libvpx:BuildRequires:    libvpx-devel >= 1.3.0}
165 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.4.0}
166 BuildRequires:  libxml2-devel
167 BuildRequires:  libxslt-devel
168 BuildRequires:  man-db
169 %{?with_system_minizip:BuildRequires:   minizip-devel}
170 %{?with_ninja:BuildRequires:    ninja >= 1.3.0}
171 BuildRequires:  nspr-devel
172 BuildRequires:  nss-devel >= 1:3.12.3
173 %{?with_system_opus:BuildRequires:      opus-devel >= 1.0.2}
174 BuildRequires:  pam-devel
175 BuildRequires:  pango-devel
176 BuildRequires:  pciutils-devel
177 BuildRequires:  perl-JSON
178 BuildRequires:  perl-modules
179 BuildRequires:  pkgconfig
180 %{?with_system_protobuf:BuildRequires:  protobuf-devel}
181 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
182 BuildRequires:  python
183 BuildRequires:  python-BeautifulSoup
184 #BuildRequires: python-gyp >= 1-%{gyp_rev}
185 BuildRequires:  python-jinja2 >= 2.7
186 BuildRequires:  python-modules
187 BuildRequires:  python-ply >= 3.4
188 %{?with_system_re2:BuildRequires:       re2-devel >= 20130115-2}
189 BuildRequires:  rpm >= 4.4.9-56
190 BuildRequires:  rpmbuild(macros) >= 1.453
191 %{?with_system_snappy:BuildRequires:    snappy-devel}
192 BuildRequires:  speech-dispatcher-devel >= 0.8
193 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
194 %{?with_system_sqlite:BuildRequires:    sqlite3-devel >= 3.7}
195 %{?with_system_libsrtp:BuildRequires:   srtp-devel >= 1.4.4}
196 BuildRequires:  tar >= 1:1.22
197 BuildRequires:  udev-devel
198 BuildRequires:  usbutils
199 BuildRequires:  util-linux
200 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
201 BuildRequires:  which
202 BuildRequires:  xorg-lib-libXScrnSaver-devel
203 BuildRequires:  xorg-lib-libXtst-devel
204 BuildRequires:  xz
205 %{?with_system_yasm:BuildRequires:      yasm}
206 %{?with_system_zlib:BuildRequires:      zlib-devel}
207 Requires:       browser-plugins >= 2.0
208 Requires:       desktop-file-utils
209 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
210 # crashes if no fontconfig font present
211 Requires:       fonts-Type1-urw
212 Requires:       hicolor-icon-theme
213 Requires:       libevent >= 2.0.21
214 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
215 %{?with_system_libvpx:Requires: libvpx >= 1.3.0}
216 Requires:       lsb-release
217 %{?with_system_re2:Requires:    re2 >= 20130115-2}
218 %{?with_system_protobuf:Requires:       protobuf-libs >= 2.5.0-2}
219 Requires:       shared-mime-info
220 %{?with_system_sqlite:Requires: sqlite3(icu)}
221 Requires:       xdg-utils >= 1.0.2-4
222 Requires:       xorg-lib-libX11 >= 1.4.99.1
223 Provides:       wwwbrowser
224 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
225 Obsoletes:      chromium-browser-inspector < 15.0.863.0
226 ExclusiveArch:  %{ix86} %{x8664} arm
227 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
228
229 # Set up Google API keys, see http://www.chromium.org/developers/how-tos/api-keys
230 # Note: these are for PLD Linux use ONLY.
231 # For your own distribution, please get your own set of keys.
232 %define         google_api_key AIzaSyD1tTgDbP-N6BGXKZ7VqSos_IU1QflGbyg
233 %define         google_default_client_id 724288223830.apps.googleusercontent.com
234 %define         google_default_client_secret rHmKOPygcI6G-clFHb-RfuHb
235
236 %define         find_lang       sh find-lang.sh %{buildroot}
237
238 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
239 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
240
241 %ifarch %{ix86}
242 %define         target_arch ia32
243 %endif
244 %ifarch %{x8664}
245 %define         target_arch x64
246 %endif
247
248 %define         buildtype       %{?debug:Debug}%{!?debug:Release}
249 %define         builddir        out/%{buildtype}
250
251 %if %{without debuginfo}
252 %define         _enable_debug_packages  0
253 %endif
254
255 %description
256 Chromium is an open-source browser project that aims to build a safer,
257 faster, and more stable way for all Internet users to experience the
258 web.
259
260 Chromium serves as a base for Google Chrome, which is Chromium
261 rebranded (name and logo) with very few additions such as usage
262 tracking and an auto-updater system.
263
264 %package l10n
265 Summary:        chromium-browser language packages
266 Group:          I18n
267 Requires:       %{name} = %{version}-%{release}
268 %if "%{_rpmversion}" >= "5"
269 BuildArch:      noarch
270 %endif
271
272 %description l10n
273 Chromium is an open-source browser project that aims to build a safer,
274 faster, and more stable way for all Internet users to experience the
275 web.
276
277 This package contains language packages for 50 languages:
278
279 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
280 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
281 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
282 zh-TW
283
284 %prep
285 %setup -qc
286 %if "%{?patchver}" != ""
287 cd chromium*-%{branch}.%{basever}
288 %patch0 -p1
289 cd ..
290 %endif
291 mv chromium*-%{branch}.%{basever}/* .
292
293 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
294 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
295 . ./chrome/VERSION
296 chrome=$MAJOR.$MINOR.$BUILD.$PATCH
297 test "$chrome" = %{version}
298
299 gyp_rev=$(grep googlecode_url.*gyp DEPS | cut -d'"' -f6 | cut -d@ -f2)
300 test "$gyp_rev" = %{gyp_rev} || :
301
302 # add chromium and pld to useragent
303 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
304 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
305         -e 's/@BUILD_DIST_NAME@/PLD/g' \
306         -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
307         < %{PATCH8} | %{__patch} -p1
308
309 %{__sed} -e 's,@localedir@,%{_datadir}/%{name},' %{SOURCE5} > find-lang.sh
310 ln -s %{SOURCE7} .
311
312 #%patch2 -p1 NOT COMPILING
313 %patch4 -p3
314 %patch7 -p1
315 %patch15 -p2
316 %{!?with_libjpegturbo:%patch11 -p0}
317 %patch16 -p1
318 %patch28 -p1
319 %patch25 -p1
320 %{?with_nacl:%patch18 -p1}
321 %patch24 -p1
322 %patch26 -p2
323 %patch31 -p0
324 %patch32 -p1
325 %patch35 -p1
326 %patch36 -p1
327 %patch37 -p1
328
329 %{?with_dev:exit 0}
330
331 sh -x clean-source.sh \
332         %{!?with_nacl:nacl=0} \
333         %{!?with_system_libvpx:libvpx=0} \
334         %{!?with_system_libxnvctrl:libXNVCtrl=0} \
335         %{!?with_system_mesa:mesa=0} \
336         %{!?with_system_protobuf:protobuf=0} \
337         %{!?with_system_re2:re2=0} \
338         %{!?with_system_snappy:snappy=0} \
339         %{!?with_system_sqlite:sqlite=0} \
340         %{!?with_system_v8:v8=0} \
341         %{!?with_system_libwebp:libwebp=0} \
342         %{!?with_system_zlib:zlib=0} \
343         %{!?with_system_ffmpeg:ffmpeg=0} \
344         %{nil}
345
346 %build
347 %if %{with nacl}
348 rm -rf native_client/toolchain/linux_x86_newlib
349 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
350 # Make symlinks for NaCL
351 install -d native_client/toolchain/linux_x86_newlib/x86_64-nacl/{bin,nacl}
352
353 cd native_client/toolchain/linux_x86_newlib
354 ln -s x86_64-nacl/bin bin
355 cd x86_64-nacl/bin
356 __cc='%{__cc}'
357 if [ "${__cc#ccache}" != "$__cc" ]; then
358         echo 'exec ccache %{_bindir}/x86_64-nacl-gcc "$@"' > gcc
359         echo 'exec ccache %{_bindir}/x86_64-nacl-g++ "$@"' > g++
360         %{__sed} -i -e '1i#!/bin/sh' gcc g++
361         chmod +x gcc g++
362 else
363         ln -s %{_bindir}/x86_64-nacl-gcc gcc
364         ln -s %{_bindir}/x86_64-nacl-g++ g++
365 fi
366 ln -s gcc x86_64-nacl-gcc
367 ln -s g++ x86_64-nacl-g++
368 ln -s %{_bindir}/x86_64-nacl-ar .
369 ln -s %{_bindir}/x86_64-nacl-ar ar
370 ln -s %{_bindir}/x86_64-nacl-as as
371 ln -s %{_bindir}/x86_64-nacl-ranlib .
372 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
373 ln -s %{_bindir}/x86_64-nacl-strip .
374 ln -s %{_bindir}/x86_64-nacl-strip strip
375 ln -s %{_bindir}/x86_64-nacl-objcopy .
376 ln -s %{_prefix}/x86_64-nacl/lib ../lib
377 ln -s %{_prefix}/x86_64-nacl/lib32 ../lib32
378 ln -s %{_prefix}/x86_64-nacl/include ../nacl/include
379 cd ../../../../..
380 fi
381 %endif
382
383 %if %{without system_ffmpeg}
384 if [ ! -d third_party/ffmpeg/build.%{target_arch}.linux ]; then
385         # Re-configure bundled ffmpeg
386         cd third_party/ffmpeg
387         chromium/scripts/build_ffmpeg.py linux %{target_arch} \
388                 --branding Chromium
389         chromium/scripts/copy_config.sh
390         chromium/scripts/generate_gyp.py
391         cd -
392 fi
393 %endif
394
395 third_party/libaddressinput/chromium/tools/update-strings.py
396
397 flags="
398         -Dtarget_arch=%{target_arch} \
399         -Dpython_arch=%{target_arch} \
400         -Dffmpeg_branding=Chromium \
401         -Dsystem_libdir=%{_lib} \
402         -Dpython_ver=%{py_ver} \
403 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
404         -Dno_strict_aliasing=1 -Dgcc_version=44 \
405 %endif
406         %{!?debug:-Dwerror= -Ddisable_fatal_linker_warnings=} \
407         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
408         %{?with_shared_libs:-Dlibrary=shared_library} \
409         %{!?with_system_ffmpeg:-Dbuild_ffmpegsumo=1} \
410         -Dinclude_tests__=0 \
411 %if %{with nacl}
412         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
413         -Ddisable_glibc_untar=1 \
414         -Ddisable_newlib_untar=1 \
415         -Ddisable_glibc=1 \
416         -Ddisable_pnacl=1 \
417         -Dbuild_pnacl_newlib=0 \
418 %else
419         -Ddisable_pnacl_untar=1 \
420         -Ddisable_nacl=1 \
421 %endif
422         %{!?with_sse2:-Ddisable_sse2=1} \
423         %{?with_selinux:-Dselinux=1} \
424         -Dusb_ids_path=$(pkg-config --variable usbids usbutils) \
425         -Dlinux_link_libpci=1 \
426         -Dlinux_link_libspeechd=1 -Dlibspeechd_h_prefix=speech-dispatcher/ \
427         -Duse_allocator=%{!?with_tcmalloc:none}%{?with_tcmalloc:tcmalloc} \
428         %{?with_gps:-Dlinux_use_libgps=1 -Dlinux_link_libgps=1} \
429         -Dclang=0 \
430         -Dhost_clang=0 \
431         -Dlinux_use_bundled_binutils=0 \
432         -Dlinux_use_bundled_gold=0 \
433         -Dlinux_use_gold_flags=0 \
434         -Dlogging_like_official_build=1 \
435         -Dgoogle_api_key=%{google_api_key} \
436         -Dgoogle_default_client_id=%{google_default_client_id} \
437         -Dgoogle_default_client_secret=%{google_default_client_secret} \
438         %{gyp_with cups} \
439         %{gyp_with gconf} -Dlinux_link_gsettings=0 \
440         %{gyp_with kerberos} -Dlinux_link_kerberos=1 \
441         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
442         %{gyp_with pulseaudio} \
443         %{gyp_with system_ffmpeg} -Dmedia_use_ffmpeg=1 \
444         %{gyp_with system_flac} \
445         %{gyp_with system_harfbuzz} \
446         %{gyp_with system_icu} %{?with_system_icu:-Dicu_use_data_file_flag=0} \
447         %{gyp_with system_jsoncpp} \
448         %{gyp_with system_libexif} \
449         %{gyp_with system_libmtp} \
450         %{gyp_with system_libsrtp} \
451         %{gyp_with system_libusb} \
452         %{gyp_with system_libvpx} -Dmedia_use_libvpx=1 \
453         %{gyp_with system_libwebp} \
454         %{gyp_with system_libxnvctrl} \
455         %{gyp_with system_mesa} \
456         %{gyp_with system_minizip} \
457         %{gyp_with system_opus} \
458         %{gyp_with system_protobuf} \
459         %{gyp_with system_re2} \
460         %{gyp_with system_snappy} \
461         %{gyp_with system_speex} \
462         %{gyp_with system_sqlite} %{?with_system_sqlite:-Denable_sql_database=0} \
463         %{gyp_with system_v8} \
464         %{gyp_with system_yasm} \
465         %{gyp_with system_zlib} \
466         -Duse_system_bzip2=1 \
467         -Duse_system_expat=1 \
468         -Duse_system_libevent=1 \
469         -Duse_system_libjpeg=1 \
470         -Duse_system_libpng=1 \
471         -Duse_system_libxml=1 \
472         -Duse_system_libxslt=1 \
473         -Duse_system_nspr=1 \
474         -Duse_system_xdg_utils=1 \
475 "
476
477 build/linux/unbundle/replace_gyp_files.py $flags
478
479 %if %{with ninja}
480 chkfile=%{builddir}/build.ninja
481 %else
482 chkfile=Makefile
483 %endif
484 test %{_specdir}/%{name}.spec -nt $chkfile && %{__rm} -f $chkfile
485 test -e $chkfile || \
486         CC="%{__cc}" \
487         CXX="%{__cxx}" \
488         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
489         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
490         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
491         CC_host="%{__cc}" \
492         CXX_host="%{__cxx}" \
493         LD_host="%{__cxx}" \
494 %{__python} build/gyp_chromium \
495         --format=%{?with_ninja:ninja}%{!?with_ninja:make} \
496         --depth=. \
497         build/all.gyp \
498         $flags
499
500 %if %{with ninja}
501 ninja %{?_smp_mflags} %{?with_verbose:-v} -C %{builddir} \
502 %else
503 # need {CC/CXX/LDFLAGS}.host overrides for v8 build
504 %{__make} -r \
505         BUILDTYPE=%{buildtype} \
506         %{?with_verbose:V=1} \
507         CC.host="%{__cc}" \
508         CXX.host="%{__cxx}" \
509         LDFLAGS.host="%{rpmldflags} -fuse-ld=gold" \
510 %endif
511         chrome %{?with_sandboxing:chrome_sandbox} \
512         %{nil}
513
514 cd %{builddir}
515 MANWIDTH=80 man ./chrome.1 > man.out
516 %{__sed} -e '1,/OPTIONS/d; /ENVIRONMENT/,$d' man.out > options.txt
517
518 %install
519 rm -rf $RPM_BUILD_ROOT
520 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins \
521         $RPM_BUILD_ROOT%{_datadir}/%{name}/{locales,resources} \
522         $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir}} \
523         $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{native-messaging-hosts,policies/managed}
524
525 cd %{builddir}
526 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
527 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
528 %{__sed} -i -e '
529         s,@libdir@,%{_libdir}/%{name},
530
531         /@OPTIONS@/ {
532                 r options.txt
533                 d
534         }
535 ' $RPM_BUILD_ROOT%{_bindir}/%{name}
536 cp -a locales resources $RPM_BUILD_ROOT%{_datadir}/%{name}
537 cp -p *.pak $RPM_BUILD_ROOT%{_libdir}/%{name}
538 ln -s %{_datadir}/%{name}/locales $RPM_BUILD_ROOT%{_libdir}/%{name}/locales
539 ln -s %{_datadir}/%{name}/resources $RPM_BUILD_ROOT%{_libdir}/%{name}/resources
540 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
541 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
542 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome-sandbox
543 %if %{without system_ffmpeg}
544 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
545 %endif
546 install -p libpdf.so $RPM_BUILD_ROOT%{_libdir}/%{name}
547 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
548 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
549
550 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/%{name}/resources/extension/demo
551
552 %if %{with nacl}
553 # Install Native Client files on platforms that support it.
554 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
555 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
556 %ifarch %{x8664}
557 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
558 %endif
559 %ifarch %{ix86}
560 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
561 %endif
562 %endif
563
564 cd -
565
566 for icon in chrome/app/theme/chromium/product_logo_[0-9]*.png; do
567         size=${icon##*/product_logo_}
568         size=${size%.png}
569
570         # this will skip non-numeric (22_mono_invert, 22_mono)
571         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
572         test -d "$dir" || continue
573
574         install -d $RPM_BUILD_ROOT$dir
575         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
576 done
577
578 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
579 # http://code.google.com/p/chromium/issues/detail?id=24507
580 gecko-mediaplayer*.so
581 EOF
582
583 # find locales
584 %find_lang %{name}.lang
585 # always package en-US
586 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
587
588 %clean
589 rm -rf $RPM_BUILD_ROOT
590
591 %pretrans
592 for d in locales resources; do
593         if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
594                 install -d %{_datadir}/%{name}
595                 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
596         fi
597 done
598 exit 0
599
600 %post
601 %update_icon_cache hicolor
602 %update_desktop_database
603 %update_browser_plugins
604
605 %postun
606 if [ "$1" = 0 ]; then
607         %update_icon_cache hicolor
608         %update_browser_plugins
609 fi
610
611 %files
612 %defattr(644,root,root,755)
613 %doc AUTHORS LICENSE
614 %{_browserpluginsconfdir}/browsers.d/%{name}.*
615 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
616 %dir %{_sysconfdir}/%{name}
617 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
618 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
619 %dir %{_sysconfdir}/%{name}/native-messaging-hosts
620 %dir %{_sysconfdir}/%{name}/policies
621 %dir %{_sysconfdir}/%{name}/policies/managed
622 %attr(755,root,root) %{_bindir}/%{name}
623 %{_mandir}/man1/%{name}.1*
624 %{_desktopdir}/*.desktop
625 %{_iconsdir}/hicolor/*/apps/%{name}.png
626 %dir %{_libdir}/%{name}
627 %{_libdir}/%{name}/chrome*.pak
628 %{_libdir}/%{name}/content_resources.pak
629 %{_libdir}/%{name}/keyboard_resources.pak
630 %{_libdir}/%{name}/resources.pak
631 %{_libdir}/%{name}/locales
632 %{_libdir}/%{name}/resources
633
634 # conflicts with browser-plugin-chrome-pdf?
635 %attr(755,root,root) %{_libdir}/%{name}/libpdf.so
636
637 %dir %{_datadir}/%{name}
638 %dir %{_datadir}/%{name}/locales
639 %{_datadir}/%{name}/locales/en-US.pak
640 %dir %{_datadir}/%{name}/resources
641 %{_datadir}/%{name}/resources/inspector
642
643 %dir %{_libdir}/%{name}/plugins
644 %attr(755,root,root) %{_libdir}/%{name}/%{name}
645 # These unique permissions are intentional and necessary for the sandboxing
646 %attr(4555,root,root) %{_libdir}/%{name}/chrome-sandbox
647
648 # ffmpeg libs
649 %if %{without system_ffmpeg}
650 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
651 %endif
652
653 %if %{with nacl}
654 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
655 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
656 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
657 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
658 %endif
659
660 %files l10n -f %{name}.lang
661 %defattr(644,root,root,755)
This page took 0.126894 seconds and 3 git commands to generate.