]> git.pld-linux.org Git - packages/chromium-browser.git/blob - chromium-browser.spec
use make -r
[packages/chromium-browser.git] / chromium-browser.spec
1 #
2 # Conditional build:
3 %bcond_without  cups                    # with cups
4 %bcond_without  debuginfo               # disable debuginfo creation (it is huge)
5 %bcond_without  ffmpegsumo              # build with ffmpegsumo
6 %bcond_without  gconf                   # with GConf
7 %bcond_without  kerberos                # build with kerberos support (dlopened if support compiled, library names in src/net/http/http_auth_gssapi_posix.cc)
8 %bcond_without  keyring                 # with keyring support (gnome-keyring dlopened, kwalletd via dbus)
9 %bcond_without  libjpegturbo    # use libjpeg-turbo features
10 %bcond_without  nacl                    # build Native Client support
11 %bcond_without  pulseaudio              # with pulseaudio
12 %bcond_without  sandboxing              # with sandboxing
13 %bcond_with             selinux                 # with SELinux (need policy first)
14 %bcond_with             shared_libs             # with shared libs
15 %bcond_with             sse2                    # use SSE2 instructions
16 %bcond_without  system_flac             # system flac
17 %bcond_without  system_jsoncpp  # system jsoncpp
18 %bcond_without  system_libusb   # system libusb-1
19 %bcond_without  system_libwebp  # system libwebp
20 %bcond_without  system_speex    # system speex
21 %bcond_with             system_sqlite   # system sqlite
22 %bcond_without  system_srtp             # system srtp (can be used if using bundled libjingle)
23 %bcond_with             system_v8               # system v8
24 %bcond_without  system_vpx              # system vpx
25 %bcond_without  system_yasm             # system yasm
26 # system zlib disabled because of mixed-source.patch
27 # https://code.google.com/p/chromium/issues/detail?id=143623
28 %bcond_with             system_zlib             # system zlib
29 %bcond_with             tcmalloc                # use tcmalloc
30 %bcond_without  verbose                 # verbose build (V=1)
31
32 %if %{with nacl}
33 # temporary hack as seems this does not work: http://codereview.chromium.org/8890043
34 # nacl_bootstrap.c:(.text.load_elf_file+0x707): undefined reference to `__stack_chk_fail'
35 #14:08:04 @baggins> glen: yes, I added SSP in rpm5, add -lssp to link flags to fix it
36 #14:19:42 @baggins> it doesn't hurt to add -lssp here and there, and we'll be a bit more secure
37 #14:51:06 @baggins> as-needed will take care of unneeded lib
38 #14:52:03 @baggins> -lssp comes with gcc
39 %define         _ssp_cflags     %{nil}
40 %endif
41
42 # TODO
43 # - check system sqlite linking problems
44 # - find system deps: find -name '*.gyp*' | xargs grep 'use_system.*=='
45 # - use_system_ssl (use_openssl: http://crbug.com/62803)
46 # - use_system_ffmpeg && build_ffmpegsumo
47 # - use_system_hunspell
48 # - use_system_stlport
49 # - other defaults: src/build/common.gypi
50
51 # NOTES:
52 # - mute BEEP mixer if you do not want to hear horrible system bell when
53 #   pressing home/end in url bar or more ^F search results on page.
54 # - space considerations:
55 #   - unpacked sources: ~800MiB
56 #   - built code: ~1.4GiB (x86_64)
57 # - http://code.google.com/p/chromium/wiki/LinuxBuildInstructionsPrerequisites
58 # - to look for new tarball, use update-source.sh script
59
60 # NOTE TO USERS:
61 # To use chromium nightly beta builds for pld-th save to /etc/poldek/repos.d (as chromium-nightly.conf):
62 # http://carme.pld-linux.org/~glen/chromium-browser/th/x86_64/chromium-nightly.conf
63 # http://carme.pld-linux.org/~glen/chromium-browser/th/i686/chromium-nightly.conf
64
65 %define         branch          23.0.1271
66 %define         basever         64
67 %define         patchver        97
68 %define         gyp_rev 1014
69 Summary:        A WebKit powered web browser
70 Name:           chromium-browser
71 Version:        %{branch}.%{patchver}
72 Release:        2
73 License:        BSD, LGPL v2+ (ffmpeg)
74 Group:          X11/Applications/Networking
75 Source0:        http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{branch}.%{basever}.tar.xz
76 # Source0-md5:  6c467affd292ee9a9020ac91147969c8
77 %if "%{?patchver}" != ""
78 Patch0:         http://carme.pld-linux.org/~glen/chromium-browser/src/stable/%{name}-%{version}.patch.xz
79 # Patch0-md5:   2f4e98e37053705fd86ffcb49f1f2247
80 %endif
81 Source1:        %{name}.default
82 Source2:        %{name}.sh
83 Source3:        %{name}.desktop
84 Source5:        find-lang.sh
85 Source6:        update-source.sh
86 Source7:        clean-source.sh
87 Source8:        get-source.sh
88 Source9:        master_preferences.json
89 #Patch10:               system-libs.patch
90 Patch1:         plugin-searchdirs.patch
91 Patch2:         gyp-system-minizip.patch
92 Patch3:         disable_dlog_and_dcheck_in_release_builds.patch
93 Patch4:         path-libpdf.patch
94 Patch5:         options-support.patch
95 Patch6:         get-webkit_revision.patch
96 Patch7:         dlopen_sonamed_gl.patch
97 Patch8:         chromium_useragent.patch.in
98 Patch9:         chromium-ppapi.patch
99 # https://bugs.gentoo.org/show_bug.cgi?id=393471
100 # libjpeg-turbo >= 1.1.90 supports that feature
101 Patch11:        chromium-revert-jpeg-swizzle-r2.patch
102 Patch15:        nacl-build-irt.patch
103 Patch16:        nacl-linkingfix.patch
104 Patch17:        system-icu.patch
105 Patch18:        nacl-no-untar.patch
106 Patch19:        system-jsoncpp.patch
107 Patch20:        system-speex.patch
108 Patch21:        system-srtp.patch
109 Patch22:        gnome3-volume-control.patch
110 Patch23:        master-prefs-path.patch
111 URL:            http://www.chromium.org/Home
112 %{?with_gconf:BuildRequires:    GConf2-devel}
113 BuildRequires:  OpenGL-GLU-devel
114 BuildRequires:  alsa-lib-devel
115 BuildRequires:  atk-devel
116 BuildRequires:  bison
117 BuildRequires:  bzip2-devel
118 %{?with_nacl:BuildRequires:     crossnacl-binutils >= 2.20.1}
119 %{?with_nacl:BuildRequires:     crossnacl-gcc >= 4.4.3}
120 %{?with_nacl:BuildRequires:     crossnacl-gcc-c++ >= 4.4.3}
121 %{?with_nacl:BuildRequires:     crossnacl-newlib >= 1.20.0-3}
122 %{?with_cups:BuildRequires:     cups-devel}
123 BuildRequires:  dbus-glib-devel
124 BuildRequires:  expat-devel
125 %{?with_system_flac:BuildRequires:      flac-devel >= 1.2.1-7}
126 BuildRequires:  flex
127 BuildRequires:  fontconfig-devel
128 BuildRequires:  glib2-devel
129 BuildRequires:  gperf
130 BuildRequires:  gtk+2-devel
131 %{?with_kerberos:BuildRequires: heimdal-devel}
132 BuildRequires:  hicolor-icon-theme
133 %{?with_system_jsoncpp:BuildRequires:   jsoncpp-devel}
134 BuildRequires:  libevent-devel
135 %{?with_keyring:BuildRequires:  libgnome-keyring-devel}
136 BuildRequires:  libicu-devel >= 4.6
137 %{!?with_libjpegturbo:BuildRequires:    libjpeg-devel}
138 %{?with_libjpegturbo:BuildRequires:     libjpeg-turbo-devel >= 1.2.0}
139 BuildRequires:  libpng-devel
140 %{?with_selinux:BuildRequires:  libselinux-devel}
141 BuildRequires:  libstdc++-devel
142 %{?with_system_libusb:BuildRequires:    libusb-devel >= 1.0}
143 %{?with_system_vpx:BuildRequires:       libvpx-devel >= 0.9.5-2}
144 %{?with_system_libwebp:BuildRequires:   libwebp-devel >= 0.1.99}
145 BuildRequires:  libxml2-devel
146 BuildRequires:  libxslt-devel
147 BuildRequires:  lzma
148 BuildRequires:  minizip-devel
149 BuildRequires:  nspr-devel
150 BuildRequires:  nss-devel >= 1:3.12.3
151 BuildRequires:  pam-devel
152 BuildRequires:  pango-devel
153 BuildRequires:  perl-modules
154 BuildRequires:  pkgconfig
155 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
156 BuildRequires:  python
157 #BuildRequires: python-gyp >= 1-%{gyp_rev}
158 BuildRequires:  python-modules
159 BuildRequires:  rpm >= 4.4.9-56
160 BuildRequires:  rpmbuild(macros) >= 1.453
161 %{?with_system_speex:BuildRequires:     speex-devel >= 1:1.2-rc1}
162 BuildRequires:  sqlite3-devel >= 3.6.1
163 %{?with_system_srtp:BuildRequires:      srtp-devel >= 1.4.4}
164 BuildRequires:  subversion
165 BuildRequires:  tar >= 1:1.22
166 BuildRequires:  udev-devel
167 BuildRequires:  util-linux
168 %{?with_system_v8:BuildRequires:        v8-devel >= 3.7}
169 BuildRequires:  which
170 BuildRequires:  xorg-lib-libXScrnSaver-devel
171 BuildRequires:  xorg-lib-libXt-devel
172 BuildRequires:  xorg-lib-libXtst-devel
173 BuildRequires:  xz
174 %{?with_system_yasm:BuildRequires:      yasm}
175 %{?with_system_zlib:BuildRequires:      zlib-devel}
176 Requires:       browser-plugins >= 2.0
177 Requires:       desktop-file-utils
178 %{?with_system_flac:Requires:   flac >= 1.2.1-7}
179 Requires:       hicolor-icon-theme
180 %{?with_libjpegturbo:Requires:  libjpeg-turbo >= 1.2.0}
181 %{?with_system_vpx:Requires:    libvpx >= 0.9.5-2}
182 Requires:       xdg-utils >= 1.0.2-4
183 Provides:       wwwbrowser
184 Obsoletes:      chromium-browser-bookmark_manager < 5.0.388.0
185 Obsoletes:      chromium-browser-inspector < 15.0.863.0
186 ExclusiveArch:  %{ix86} %{x8664} arm
187 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
188
189 %define         find_lang       sh find-lang.sh %{buildroot}
190
191 # Usage: gyp_with BCOND_NAME [OPTION_NAME]
192 %define         gyp_with() %{expand:%%{?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=1}%%{!?with_%{1}:-D%{?2:use_%{2}}%{!?2:use_%{1}}=0}}
193
194 %if %{without debuginfo}
195 %define         _enable_debug_packages  0
196 %endif
197
198 %description
199 Chromium is an open-source browser project that aims to build a safer,
200 faster, and more stable way for all Internet users to experience the
201 web.
202
203 Chromium serves as a base for Google Chrome, which is Chromium
204 rebranded (name and logo) with very few additions such as usage
205 tracking and an auto-updater system.
206
207 %package l10n
208 Summary:        chromium-browser language packages
209 Group:          I18n
210 Requires:       %{name} = %{version}-%{release}
211
212 %description l10n
213 Chromium is an open-source browser project that aims to build a safer,
214 faster, and more stable way for all Internet users to experience the
215 web.
216
217 This package contains language packages for 50 languages:
218
219 ar, bg, bn, ca, cs, da, de, el, en-GB, es-LA, es, et, fi, fil, fr, gu,
220 he, hi, hr, hu, id, it, ja, kn, ko, lt, lv, ml, mr, nb, nl, or, pl,
221 pt-BR, pt-PT, ro, ru, sk, sl, sr, sv, ta, te, th, tr, uk, vi, zh-CN,
222 zh-TW
223
224 %prep
225 %setup -qc
226 %if "%{?patchver}" != ""
227 cd %{name}-%{branch}.%{basever}
228 %patch0 -p1
229 cd ..
230 %endif
231 mv %{name}-%{branch}.%{basever}/src .
232
233 # Google's versioning is interesting. They never reset "BUILD", which is how we jumped
234 # from 3.0.201.0 to 4.0.202.0 as they moved to a new major branch
235 . ./src/chrome/VERSION
236 ver=$MAJOR.$MINOR.$BUILD.$PATCH
237 test "$ver" = %{version}
238
239 gyp_rev=$(grep googlecode_url.*gyp src/DEPS | cut -d'"' -f6 | cut -d@ -f2)
240 test "$gyp_rev" = %{gyp_rev} || :
241
242 v8_ver=$(awk 'NR=1 {print $NF; exit}' src/v8/ChangeLog || :)
243
244 # add chromium and pld to useragent
245 %define pld_version %(echo %{pld_release} | sed -e 'y/[at]/[AT]/')
246 sed -e 's/@BUILD_DIST@/PLD %{pld_version}/g' \
247     -e 's/@BUILD_DIST_NAME@/PLD/g' \
248     -e 's/@BUILD_DIST_VERSION@/%{pld_version}/g' \
249     < %{PATCH8} | %{__patch} -p1
250
251 %{__sed} -e 's,@localedir@,%{_libdir}/%{name},' %{SOURCE5} > find-lang.sh
252 ln -s %{SOURCE7} src
253
254 #%patch10 -p1
255 %patch1 -p1
256 %patch2 -p1
257 %patch3 -p1
258 %patch4 -p1
259 %patch5 -p1
260 %patch6 -p1
261 %patch7 -p1
262 %patch15 -p1
263 cd src
264 %patch9 -p0
265 %{!?with_libjpegturbo:%patch11 -p0}
266 %patch16 -p1
267 %patch17 -p0
268 %patch19 -p1
269 %patch21 -p1
270 %patch22 -p1
271 cd ..
272 %patch18 -p1
273 %patch20 -p1
274 %patch23 -p1
275
276 cd src
277
278 # Missing gyp files in tarball.
279 # https://code.google.com/p/chromium/issues/detail?id=144823
280 if [ -e chrome/test/data/nacl/nacl_test_data.gyp ]; then
281         echo "tarball fixed, please remove workaround"
282         exit 1
283 fi
284
285 install -d chrome/test/data/nacl
286 cat > chrome/test/data/nacl/nacl_test_data.gyp <<-EOF
287 {
288  'targets': [
289    {
290      'target_name': 'nacl_tests',
291      'type': 'none',
292    },
293  ],
294 }
295 EOF
296
297 sh -x clean-source.sh %{!?with_system_v8:v8=0} %{!?with_nacl:nacl=0} libxml=0 %{!?with_system_zlib:zlib=0}
298
299 rm -rf native_client/toolchain/linux_x86_newlib
300
301 %build
302 cd src
303
304 %if %{with nacl}
305 if [ ! -d native_client/toolchain/linux_x86_newlib ]; then
306 # Make symlinks for nacl
307 cd native_client/toolchain
308 install -d linux_x86_newlib/x86_64-nacl/bin
309 install -d linux_x86_newlib/x86_64-nacl/lib
310 install -d linux_x86_newlib/x86_64-nacl/lib32
311 install -d linux_x86_newlib/x86_64-nacl/nacl/include/bits
312 install -d linux_x86_newlib/x86_64-nacl/nacl/include/machine
313 install -d linux_x86_newlib/x86_64-nacl/nacl/include/sys
314 # link newlib toolchain to glibc as well, see gentoo bug #417019
315 #ln -s linux_x86_newlib linux_x86
316 cd linux_x86_newlib/x86_64-nacl/bin
317 ln -s %{_bindir}/x86_64-nacl-gcc gcc
318 ln -s %{_bindir}/x86_64-nacl-g++ g++
319 ln -s %{_bindir}/x86_64-nacl-ar ar
320 ln -s %{_bindir}/x86_64-nacl-as as
321 ln -s %{_bindir}/x86_64-nacl-ranlib ranlib
322 ln -s %{_bindir}/x86_64-nacl-strip x86-64-nacl-strip
323 ln -s %{_bindir}/x86_64-nacl-strip strip
324 ln -s %{_prefix}/x86_64-nacl/lib/*.a ../lib/
325 ln -s %{_prefix}/x86_64-nacl/lib/32/*.a ../lib32/
326 cd ../nacl/include
327 for i in $(find %{_prefix}/x86_64-nacl/include -type f | grep -v "c++"); do
328         ln -s $i ${i#%{_prefix}/x86_64-nacl/include/}
329 done
330 cd ../../../../../..
331 fi
332 %endif
333
334 test %{_specdir}/%{name}.spec -nt Makefile && %{__rm} Makefile
335 test -e Makefile || %{__python} build/gyp_chromium \
336         --format=make \
337         -Goutput_dir=../out \
338         build/all.gyp \
339 %ifarch %{ix86}
340         -Dtarget_arch=ia32 \
341 %endif
342 %ifarch %{x8664}
343         -Dtarget_arch=x64 \
344 %endif
345 %if "%{cc_version}" >= "4.4.0" && "%{cc_version}" < "4.5.0"
346         -Dno_strict_aliasing=1 -Dgcc_version=44 \
347 %endif
348 %if %{with sandboxing}
349         -Dlinux_sandbox_path=%{_libdir}/%{name}/chromium-sandbox \
350         -Dlinux_sandbox_chrome_path=%{_libdir}/%{name}/%{name} \
351 %endif
352         %{!?debug:-Dwerror=} \
353         %{!?debuginfo:-Dfastbuild=1 -Dremove_webcore_debug_symbols=1} \
354         %{?with_shared_libs:-Dlibrary=shared_library} \
355         -Dbuild_ffmpegsumo=%{?with_ffmpegsumo:1}%{!?with_ffmpegsumo:0} \
356         -Dffmpeg_branding=Chrome \
357         -Dremove_webcore_debug_symbols=1 \
358         -Dproprietary_codecs=1 \
359 %if %{with nacl}
360         -Ddisable_glibc=1 \
361         -Dnaclsdk_mode=custom:/usr/x86_64-nacl \
362         -Ddisable_glibc_untar=1 \
363         -Ddisable_newlib_untar=1 \
364         -Ddisable_pnacl_untar=1 \
365 %else
366         -Ddisable_nacl=1 \
367 %endif
368         -Ddisable_pnacl=1 \
369         %{!?with_sse2:-Ddisable_sse2=1} \
370         %{?with_selinux:-Dselinux=1} \
371         %{gyp_with cups} \
372         %{gyp_with gconf} \
373         %{gyp_with kerberos} -Dlinux_link_kerberos=0 \
374         %{gyp_with keyring gnome_keyring} -Dlinux_link_gnome_keyring=0 \
375         %{gyp_with pulseaudio} \
376         %{gyp_with system_flac} \
377         %{gyp_with system_libusb} \
378         %{gyp_with system_libwebp} \
379         %{gyp_with system_speex} \
380         %{gyp_with system_sqlite} \
381         %{gyp_with system_v8} \
382         %{gyp_with system_vpx} \
383         %{gyp_with system_yasm} \
384         %{gyp_with system_zlib} \
385         -Duse_system_bzip2=1 \
386         -Duse_system_icu=1 \
387         -Duse_system_libevent=1 \
388         -Duse_system_libjpeg=1 \
389         -Duse_system_libpng=1 \
390         -Duse_system_libxml=1 \
391         -Duse_system_libxslt=1 \
392         -Duse_system_xdg_utils=1 \
393         %{!?with_tcmalloc:-Dlinux_use_tcmalloc=0} \
394         -Dlinux_use_gold_binary=0 \
395         -Dlinux_use_gold_flags=0
396
397 %{__make} -r chrome %{?with_sandboxing:chrome_sandbox} \
398         BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
399         %{?with_verbose:V=1} \
400         CC="%{__cc}" \
401         CXX="%{__cxx}" \
402         LDFLAGS="%{rpmldflags} -fuse-ld=gold" \
403         CC.host="%{__cc}" \
404         CXX.host="%{__cxx}" \
405         LDFLAGS.host="%{rpmldflags}" \
406         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
407         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}"
408
409 %install
410 rm -rf $RPM_BUILD_ROOT
411 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/{themes,plugins,extensions} \
412         $RPM_BUILD_ROOT{%{_bindir},%{_sysconfdir}/%{name},%{_mandir}/man1,%{_desktopdir}}
413
414 cd out/%{!?debug:Release}%{?debug:Debug}
415 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/default
416 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
417 %{__sed} -i -e 's,@libdir@,%{_libdir}/%{name},' $RPM_BUILD_ROOT%{_bindir}/%{name}
418 cp -a *.pak locales resources $RPM_BUILD_ROOT%{_libdir}/%{name}
419 cp -p chrome.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
420 install -p chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/%{name}
421 install -p chrome_sandbox $RPM_BUILD_ROOT%{_libdir}/%{name}/chromium-sandbox
422 %if %{with ffmpegsumo}
423 install -p libffmpegsumo.so $RPM_BUILD_ROOT%{_libdir}/%{name}
424 %endif
425 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_desktopdir}
426 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/master_preferences
427
428 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/resources/extension/demo
429
430 %if %{with nacl}
431 # Install Native Client files on platforms that support it.
432 install -p nacl_helper{,_bootstrap} $RPM_BUILD_ROOT%{_libdir}/%{name}
433 install -p libppGoogleNaClPluginChrome.so $RPM_BUILD_ROOT%{_libdir}/%{name}
434 %ifarch %{x8664}
435 install -p nacl_irt_x86_64.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
436 %endif
437 %ifarch %{ix86}
438 install -p nacl_irt_x86_32.nexe $RPM_BUILD_ROOT%{_libdir}/%{name}
439 %endif
440 %endif
441
442 cd -
443
444 for icon in src/chrome/app/theme/chromium/product_logo_[0-9]*.png; do
445         size=${icon##*/product_logo_}
446         size=${size%.png}
447
448         # this will skip non-numeric (22_mono_invert, 22_mono)
449         dir=%{_iconsdir}/hicolor/${size}x${size}/apps
450         test -d "$dir" || continue
451
452         install -d $RPM_BUILD_ROOT$dir
453         cp -p $icon $RPM_BUILD_ROOT$dir/%{name}.png
454 done
455
456 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins -b <<'EOF'
457 # http://code.google.com/p/chromium/issues/detail?id=24507
458 gecko-mediaplayer*.so
459 EOF
460
461 # find locales
462 %find_lang %{name}.lang
463 # always package en-US
464 %{__sed} -i -e '/en-US.pak/d' %{name}.lang
465
466 %clean
467 rm -rf $RPM_BUILD_ROOT
468
469 %post
470 %update_icon_cache hicolor
471 %update_desktop_database
472 %update_browser_plugins
473
474 %postun
475 if [ "$1" = 0 ]; then
476         %update_icon_cache hicolor
477         %update_browser_plugins
478 fi
479
480 %files
481 %defattr(644,root,root,755)
482 %doc src/{AUTHORS,LICENSE}
483 %{_browserpluginsconfdir}/browsers.d/%{name}.*
484 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
485 %dir %{_sysconfdir}/%{name}
486 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/default
487 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/master_preferences
488 %attr(755,root,root) %{_bindir}/%{name}
489 %{_mandir}/man1/%{name}.1*
490 %{_desktopdir}/*.desktop
491 %{_iconsdir}/hicolor/*/apps/%{name}.png
492 %dir %{_libdir}/%{name}
493 %{_libdir}/%{name}/chrome*.pak
494 %{_libdir}/%{name}/content_resources.pak
495 %{_libdir}/%{name}/resources.pak
496 %dir %{_libdir}/%{name}/locales
497 %{_libdir}/%{name}/locales/en-US.pak
498 %dir %{_libdir}/%{name}/resources
499 %{_libdir}/%{name}/resources/inspector
500 %dir %{_libdir}/%{name}/themes
501 %dir %{_libdir}/%{name}/extensions
502 %dir %{_libdir}/%{name}/plugins
503 %attr(755,root,root) %{_libdir}/%{name}/%{name}
504 # These unique permissions are intentional and necessary for the sandboxing
505 %attr(4555,root,root) %{_libdir}/%{name}/chromium-sandbox
506
507 # ffmpeg libs
508 %if %{with ffmpegsumo}
509 %attr(755,root,root) %{_libdir}/%{name}/libffmpegsumo.so
510 %endif
511
512 %if %{with nacl}
513 %attr(755,root,root) %{_libdir}/%{name}/libppGoogleNaClPluginChrome.so
514 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper
515 %attr(755,root,root) %{_libdir}/%{name}/nacl_helper_bootstrap
516 %attr(755,root,root) %{_libdir}/%{name}/nacl_irt_x86_*.nexe
517 %endif
518
519 %files l10n -f %{name}.lang
520 %defattr(644,root,root,755)
This page took 0.058586 seconds and 3 git commands to generate.