]> git.pld-linux.org Git - packages/chef.git/blob - chef.spec
fill direct require errors from chec-solo invocation
[packages/chef.git] / chef.spec
1 # TODO
2 # - try not to use /var/chef
3 Summary:        A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
4 Name:           chef
5 Version:        0.10.6
6 Release:        0.3
7 License:        Apache v2.0
8 Group:          Development/Languages
9 URL:            http://wiki.opscode.com/display/chef
10 Source0:        http://rubygems.org/downloads/%{name}-%{version}.gem
11 # Source0-md5:  ea8746476a2ec37e1f8265a9febba6b9
12 BuildRequires:  rubygems
13 Requires:       ruby >= 1:1.8.7
14 Requires:       ruby-bunny >= 0.6.0
15 Requires:       ruby-erubis
16 Requires:       ruby-mixlib-authentication >= 1.1.0
17 Requires:       ruby-mixlib-config >= 1.1.2
18 Requires:       ruby-mixlib-log >= 1.3.0
19 Requires:       ruby-moneta
20 Requires:       ruby-ohai >= 0.6
21 Requires:       ruby-rubygems
22 Requires:       ruby-uuidtools
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 A systems integration framework, built to bring the benefits of
28 configuration management to your entire infrastructure.
29
30 %prep
31 %setup -qc
32 %{__tar} xf %{SOURCE0} -O data.tar.gz | %{__tar} xz
33 find -newer README.rdoc -o -print | xargs touch --reference %{SOURCE0}
34
35 %build
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{_bindir}}
40
41 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
42 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc README.rdoc
50 %attr(755,root,root) %{_bindir}/chef-client
51 %attr(755,root,root) %{_bindir}/chef-solo
52 %attr(755,root,root) %{_bindir}/knife
53 %attr(755,root,root) %{_bindir}/shef
54 %{ruby_rubylibdir}/chef.rb
55 %{ruby_rubylibdir}/chef
This page took 0.116524 seconds and 4 git commands to generate.