]> git.pld-linux.org Git - packages/chef.git/blob - chef.spec
use FHS paths: /var/lib/chef, /var/cache/chef
[packages/chef.git] / chef.spec
1 Summary:        A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
2 Name:           chef
3 Version:        11.4.4
4 Release:        0.12
5 License:        Apache v2.0
6 Group:          Development/Languages
7 Source0:        http://rubygems.org/downloads/%{name}-%{version}.gem
8 # Source0-md5:  dc50aa6a4a7d4785a4c82fcaab3f9436
9 Patch0:         platform-pld.patch
10 Patch1:         FHS.patch
11 URL:            http://wiki.opscode.com/display/chef
12 BuildRequires:  rpm-rubyprov
13 BuildRequires:  rpmbuild(macros) >= 1.656
14 BuildRequires:  sed >= 4.0
15 %if %{with tests}
16 BuildRequires:  ruby-rack
17 BuildRequires:  ruby-rake
18 BuildRequires:  ruby-rdoc
19 BuildRequires:  ruby-rspec-core >= 2.12.0
20 BuildRequires:  ruby-rspec-expectations >= 2.12.0
21 BuildRequires:  ruby-rspec-mocks >= 2.12.0
22 BuildRequires:  ruby-rspec_junit_formatter
23 BuildRequires:  ruby-sdoc
24 %endif
25 Requires:       lsb-release
26 Requires:       ruby-erubis
27 Requires:       ruby-highline >= 1.6.9
28 Requires:       ruby-json >= 1.4.4
29 Requires:       ruby-mixlib-authentication >= 1.3.0
30 Requires:       ruby-mixlib-cli >= 1.3.0
31 Requires:       ruby-mixlib-config >= 1.1.2
32 Requires:       ruby-mixlib-log >= 1.3.0
33 Requires:       ruby-mixlib-shellout
34 Requires:       ruby-net-ssh >= 2.6
35 Requires:       ruby-net-ssh-multi >= 1.1.0
36 Requires:       ruby-ohai >= 0.6.0
37 Requires:       ruby-rest-client >= 1.0.4
38 Requires:       ruby-rubygems
39 Requires:       ruby-yajl >= 1.1
40 Requires:       yum >= 3.4.3-7
41 BuildArch:      noarch
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 A systems integration framework, built to bring the benefits of
46 configuration management to your entire infrastructure.
47
48 %prep
49 %setup -q
50 %patch0 -p1
51 %patch1 -p1
52
53 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}} \
58         $RPM_BUILD_ROOT{%{_sysconfdir},/var/{cache,lib}}/%{name}
59 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
60 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
61
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc README.md CONTRIBUTING.md
69 %dir %{_sysconfdir}/%{name}
70 %attr(755,root,root) %{_bindir}/chef-apply
71 %attr(755,root,root) %{_bindir}/chef-client
72 %attr(755,root,root) %{_bindir}/chef-shell
73 %attr(755,root,root) %{_bindir}/chef-solo
74 %attr(755,root,root) %{_bindir}/knife
75 %attr(755,root,root) %{_bindir}/shef
76 %{ruby_vendorlibdir}/chef.rb
77 %{ruby_vendorlibdir}/chef
78
79 %dir /var/lib/%{name}
80 %dir /var/cache/%{name}
This page took 0.079081 seconds and 4 git commands to generate.