]> git.pld-linux.org Git - packages/chef.git/blob - chef.spec
require ruby with rubygems not fatal
[packages/chef.git] / chef.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 Summary:        A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
6 Name:           chef
7 Version:        11.4.4
8 Release:        5
9 License:        Apache v2.0
10 Group:          Development/Languages
11 Source0:        http://rubygems.org/downloads/%{name}-%{version}.gem
12 # Source0-md5:  dc50aa6a4a7d4785a4c82fcaab3f9436
13 Source1:        %{name}.rb
14 Patch0:         platform-pld.patch
15 Patch1:         FHS.patch
16 Patch2:         https://github.com/glensc/chef/compare/poldek.patch
17 # Patch2-md5:   de55627051f1e0486d29814eb305c7f4
18 Patch3:         https://github.com/glensc/chef/compare/pld-knife-boostrap.patch
19 # Patch3-md5:   bfc884469fad7b5aa46341402be5fccd
20 URL:            http://wiki.opscode.com/display/chef
21 BuildRequires:  rpm-rubyprov
22 BuildRequires:  rpmbuild(macros) >= 1.656
23 BuildRequires:  sed >= 4.0
24 %if %{with tests}
25 BuildRequires:  ruby-abstract
26 BuildRequires:  ruby-mixlib-authentication >= 1.3.0
27 BuildRequires:  ruby-net-ssh-multi >= 1.1.0
28 BuildRequires:  ruby-rack
29 BuildRequires:  ruby-rake
30 #BuildRequires: ruby-rdoc
31 BuildRequires:  ruby-rest-client >= 1.0.4
32 BuildRequires:  ruby-rspec-core >= 2.12.0
33 BuildRequires:  ruby-rspec-expectations >= 2.12.0
34 BuildRequires:  ruby-rspec-mocks >= 2.12.0
35 #BuildRequires: ruby-rspec_junit_formatter
36 #BuildRequires: ruby-sdoc
37 %endif
38 Requires:       lsb-release
39 Requires:       poldek >= 0.30
40 Requires:       ruby-erubis
41 Requires:       ruby-highline >= 1.6.9
42 Requires:       ruby-json >= 1.4.4
43 Requires:       ruby-mixlib-authentication >= 1.3.0
44 Requires:       ruby-mixlib-cli >= 1.3.0
45 Requires:       ruby-mixlib-config >= 1.1.2
46 Requires:       ruby-mixlib-log >= 1.3.0
47 Requires:       ruby-mixlib-shellout
48 Requires:       ruby-net-ssh >= 2.6
49 Requires:       ruby-net-ssh-multi >= 1.1.0
50 Requires:       ruby-ohai >= 0.6.0
51 Requires:       ruby-rest-client >= 1.0.4
52 Requires:       ruby-rubygems
53 Requires:       ruby-yajl >= 1.1
54 Requires:       ruby >= 1:1.9.3.429-4
55 BuildArch:      noarch
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 A systems integration framework, built to bring the benefits of
60 configuration management to your entire infrastructure.
61
62 %prep
63 %setup -q
64 %patch0 -p1
65 %patch1 -p1
66 %patch2 -p1
67 %patch3 -p1
68
69 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
70
71 %build
72 %if %{with tests}
73 rspec spec
74 %endif
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir},%{_mandir}/man1} \
79         $RPM_BUILD_ROOT{%{_sysconfdir},/var/{cache,lib}}/%{name}
80 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
81 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
82 cp -a distro/common/man/* $RPM_BUILD_ROOT%{_mandir}
83
84 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/chef.rb
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(644,root,root,755)
91 %doc README.md CONTRIBUTING.md
92 %dir %{_sysconfdir}/%{name}
93 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/chef.rb
94 %attr(755,root,root) %{_bindir}/chef-apply
95 %attr(755,root,root) %{_bindir}/chef-client
96 %attr(755,root,root) %{_bindir}/chef-shell
97 %attr(755,root,root) %{_bindir}/chef-solo
98 %attr(755,root,root) %{_bindir}/knife
99 %attr(755,root,root) %{_bindir}/shef
100 %{_mandir}/man1/chef-shell.1*
101 %{_mandir}/man1/knife-bootstrap.1*
102 %{_mandir}/man1/knife-client.1*
103 %{_mandir}/man1/knife-configure.1*
104 %{_mandir}/man1/knife-cookbook-site.1*
105 %{_mandir}/man1/knife-cookbook.1*
106 %{_mandir}/man1/knife-data-bag.1*
107 %{_mandir}/man1/knife-environment.1*
108 %{_mandir}/man1/knife-exec.1*
109 %{_mandir}/man1/knife-index.1*
110 %{_mandir}/man1/knife-node.1*
111 %{_mandir}/man1/knife-role.1*
112 %{_mandir}/man1/knife-search.1*
113 %{_mandir}/man1/knife-ssh.1*
114 %{_mandir}/man1/knife-status.1*
115 %{_mandir}/man1/knife-tag.1*
116 %{_mandir}/man1/knife.1*
117 %{_mandir}/man8/chef-client.8*
118 %{_mandir}/man8/chef-expander.8*
119 %{_mandir}/man8/chef-expanderctl.8*
120 %{_mandir}/man8/chef-server-webui.8*
121 %{_mandir}/man8/chef-server.8*
122 %{_mandir}/man8/chef-solo.8*
123 %{_mandir}/man8/chef-solr.8*
124 %{ruby_vendorlibdir}/chef.rb
125 %{ruby_vendorlibdir}/chef
126
127 %dir /var/lib/%{name}
128 %dir /var/cache/%{name}
This page took 0.071367 seconds and 4 git commands to generate.