]> git.pld-linux.org Git - packages/cgicc.git/blob - cgicc.spec
- pl, BR: libtool 1.5 for C++
[packages/cgicc.git] / cgicc.spec
1 Summary:        A C++ library for CGI programming
2 Summary(pl):    Biblioteka C++ do programowania CGI
3 Name:           cgicc
4 Version:        3.2.3
5 Release:        0.1
6 License:        GPL v2
7 Group:          Libraries
8 Source0:        ftp://ftp.cgicc.org/%{name}-%{version}.tar.bz2
9 # Source0-md5:  cd7a7a5a1fd186bd8f481c4e17354a0b
10 URL:            http://www.cgicc.org/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  doxygen
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  libtool >= 2:1.5
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 GNU cgicc is a C++ class library that greatly simplifies the creation
20 of CGI applications for the World Wide Web. cgicc performs the
21 following functions:
22 - Parses both GET and POST form data transparently.
23 - Provides string, integer, floating-point and single- and
24   multiple-choice retrieval methods for form data.
25 - Provides methods for saving and restoring CGI environments to aid in
26   application debugging.
27 - Provides full on-the-fly HTML generation capabilities, with support
28   for cookies.
29 - Supports HTTP file upload.
30 - Compatible with FastCGI.
31
32 %description -l pl
33 GNU cgicc to biblioteka klas C++ znacznie upraszczaj±ca tworzenie
34 aplikacji CGI dla WWW. cgicc wykonuje nastêpuj±ce funkcje:
35 - w sposób przezroczysty analizuje dane z formularzy GET i POST
36 - udostêpnia metody uzyskiwania ³añcuchów znaków, liczb ca³kowitych i
37   zmiennoprzecinkowych oraz opcji jednokrotnego i wielokrotnego wyboru
38   z danych formularzy
39 - udostêpnia metody do zapisu i odtwarzania ¶rodowiska CGI
40   pomagaj±ce przy ¶ledzeniu aplikacji
41 - udostêpnia pe³ne mo¿liwo¶ci generowania HTML-a w locie, z obs³ug±
42   ciasteczek
43 - obs³uguje wysy³anie plików po HTTP
44 - jest kompatybilna z FastCGI.
45
46 %package devel
47 Summary:        A C++ library for CGI programming - header files
48 Summary(pl):    Biblioteka C++ do programowania CGI - pliki nag³ówkowe
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 Header files for cgicc library.
54
55 %description devel -l pl
56 Pliki nag³ówkowe biblioteki cgicc.
57
58 %package static
59 Summary:        A C++ library for CGI programming - static version
60 Summary(pl):    Biblioteka C++ do programowania CGI - wersja statyczna
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static version of cgicc library.
66
67 %description static -l pl
68 Statyczna wersja biblioteki cgicc.
69
70 %prep
71 %setup -q
72
73 %build
74 %{__libtoolize}
75 %{__aclocal}
76 %{__autoconf}
77 %{__autoheader}
78 %{__automake}
79 %configure
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc doc/html/*
97 %attr(755,root,root) %{_libdir}/*.so.*
98
99 %files devel
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_libdir}/*.so
102 %{_includedir}/cgicc
103
104 %files static
105 %defattr(644,root,root,755)
106 %{_libdir}/*.a
This page took 0.041787 seconds and 3 git commands to generate.