]> git.pld-linux.org Git - packages/ccrtp.git/blob - ccrtp.spec
- tabs in preamble
[packages/ccrtp.git] / ccrtp.spec
1 Summary:        Common C++ class framework for RTP/RTCP
2 Summary(pl.UTF-8):      Szkielet klas C++ dla RTP/RTCP
3 Name:           ccrtp
4 Version:        1.5.1
5 Release:        1
6 License:        GPL
7 Group:          Libraries
8 Source0:        ftp://ftp.gnu.org/pub/gnu/ccrtp/%{name}-%{version}.tar.gz
9 # Source0-md5:  728c41edd62be2871eac50be287f97ee
10 Patch0:         %{name}-gcc4.patch
11 URL:            http://www.gnu.org/software/ccrtp/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  commoncpp2-devel >= 1.5.0
15 BuildRequires:  doxygen
16 BuildRequires:  libtool
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 ccRTP is a generic, extensible and efficient C++ framework for
21 developing applications based on the Real-Time Transport Protocol
22 (RTP) from the IETF. It is based on Common C++ and provides a full
23 RTP/RTCP stack for sending and receiving of realtime data by the use
24 of send and receive packet queues. ccRTP supports unicast,
25 multi-unicast and multicast, manages multiple sources, handles RTCP
26 automatically, supports different threading models and is generic as
27 for underlying network and transport protocols.
28
29 %description -l pl.UTF-8
30 ccRTP jest ogólnym, rozszerzalnym i efektywnym szkieletem C++ do
31 rozwijania aplikacji bazujących na transporcie czasu rzeczywistego
32 (RTP) z IETF. Bazuje na Common C++ i udostępnia pełen stos RTP/RTCP do
33 wysyłania i odbierania danych w czasie rzeczywistym z użyciem kolejek
34 wysyłania i odbierania pakietów. ccRTP obsługuje unicasty,
35 multi-unicasty i multicasty, zarządza wieloma źródłami, obsługuje
36 automatycznie RTCP, wspiera różne modele wątkowania i jest ogólny dla
37 podstawowych sieci i protokołów transportowych.
38
39 %package devel
40 Summary:        Header files for ccrtp library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ccrtp
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       commoncpp2-devel
45
46 %description devel
47 Header files for ccrtp library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki ccrtp.
51
52 %package static
53 Summary:        Static ccrtp library
54 Summary(pl.UTF-8):      Statyczna biblioteka ccrtp
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static ccrtp library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka ccrtp.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67
68 %build
69 %{__libtoolize}
70 %{__aclocal} -I m4
71 %{__autoconf}
72 %{__autoheader}
73 %{__automake}
74 %configure
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc AUTHORS COPYING COPYING.addendum README
92 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
93
94 %files devel
95 %defattr(644,root,root,755)
96 %doc doc/html/*.html doc/html/*.*g*
97 %attr(755,root,root) %{_libdir}/lib*.so
98 %{_libdir}/lib*.la
99 %{_includedir}/ccrtp
100 %{_pkgconfigdir}/*.pc
101 %{_infodir}/*.info*
102
103 %files static
104 %defattr(644,root,root,755)
105 %{_libdir}/lib*.a
This page took 0.090156 seconds and 4 git commands to generate.