]> git.pld-linux.org Git - packages/calibre.git/blob - calibre.spec
- don't try to install init_calibre.py (avoid warnings)
[packages/calibre.git] / calibre.spec
1 #
2 # NOTE:
3 # Upstream packages some unfree fonts which we cannot redistribute,
4 # so when upgrading calibre we should download upstream tarball by hand from
5 # http://downloads.sourceforge.net/calibre and run generate-tarball.sh script
6 # included as SourceX.
7 #
8 Summary:        E-book converter and library management
9 Name:           calibre
10 Version:        0.6.53
11 Release:        0.1
12 License:        GPL v3+
13 Group:          Applications/Multimedia
14 Source0:        %{name}-%{version}-nofonts.tar.bz2
15 # Source0-md5:  7ed89159bbd97db0d2dcf850bb1dd867
16 Source1:        generate-tarball.sh
17 Patch0:         %{name}-prefix.patch
18 Patch1:         %{name}-manpages.patch
19 Patch2:         %{name}-no-update.patch
20 Patch3:         %{name}-env_module.patch
21 URL:            http://www.calibre-ebook.com/
22 BuildRequires:  ImageMagick-devel
23 BuildRequires:  chmlib-devel
24 BuildRequires:  podofo-devel
25 BuildRequires:  poppler-Qt-devel
26 BuildRequires:  python-BeautifulSoup
27 BuildRequires:  python-PIL
28 BuildRequires:  python-PyQt4-devel
29 BuildRequires:  python-cssutils
30 BuildRequires:  python-dateutil
31 BuildRequires:  python-lxml
32 BuildRequires:  python-mechanize
33 BuildRequires:  python-modules-sqlite
34 BuildRequires:  python-sip-devel
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  xdg-utils
37 Requires:       python-PIL
38 Requires:       python-cssutils
39 Requires:       python-dateutil
40 Requires:       python-lxml
41 Requires:       python-mechanize
42 Requires:       python-modules-sqlite
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Calibre is meant to be a complete e-library solution. It includes
47 library management, format conversion, news feeds to ebook conversion
48 as well as e-book reader sync features.
49
50 Calibre is primarily a ebook cataloging program. It manages your ebook
51 collection for you. It is designed around the concept of the logical
52 book, i.e. a single entry in the database that may correspond to
53 ebooks in several formats. It also supports conversion to and from a
54 dozen different ebook formats.
55
56 Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML,
57 CBR, CBZ, RTF, TXT, PDF and LRS.
58
59 %prep
60 %setup -q -n %{name}
61 %patch0 -p1
62 %patch1 -p1
63 %patch2 -p1
64 %patch3 -p1
65
66 %build
67 %{__python} setup.py build
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__python} setup.py install \
73         --root=$RPM_BUILD_ROOT \
74         --libdir="%{_libdir}"
75
76 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/man $RPM_BUILD_ROOT%{_mandir}
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc COPYRIGHT README
84 %attr(755,root,root) %{_bindir}/*
85 %{_datadir}/%{name}
86 %{_libdir}/%{name}
87 %{_mandir}/man1/*.1*
This page took 0.06436 seconds and 3 git commands to generate.