]> git.pld-linux.org Git - packages/calibre.git/blob - calibre.spec
- reverse, CFLAGS already passed by python macro
[packages/calibre.git] / calibre.spec
1 #
2 # NOTE:
3 # Upstream packages some unfree fonts which we cannot redistribute,
4 # so when upgrading calibre we should download upstream tarball by hand from
5 # http://downloads.sourceforge.net/calibre and run below script in order
6 # to remove them:
7 #
8 # #!/bin/sh
9 #
10 # VERSION=$1
11 #
12 # rm -rf calibre
13 # tar -xvzf calibre-$VERSION.tar.gz
14 # rm -f calibre/resources/fonts/liberation/*
15 # rm -f calibre/resources/fonts/prs500/*
16 #
17 # tar -cvjf calibre-$VERSION-nofonts.tar.bz2 calibre
18 #
19 Summary:        E-book converter and library management
20 Name:           calibre
21 Version:        0.6.53
22 Release:        0.1
23 License:        GPL v3+
24 Group:          Applications/Multimedia
25 Source0:        %{name}-%{version}-nofonts.tar.bz2
26 # Source0-md5:  7ed89159bbd97db0d2dcf850bb1dd867
27 Patch0:         %{name}-prefix.patch
28 Patch1:         %{name}-manpages.patch
29 Patch2:         %{name}-no-update.patch
30 URL:            http://www.calibre-ebook.com/
31 BuildRequires:  ImageMagick-devel
32 BuildRequires:  chmlib-devel
33 BuildRequires:  podofo-devel
34 BuildRequires:  poppler-Qt-devel
35 BuildRequires:  python-BeautifulSoup
36 BuildRequires:  python-PIL
37 BuildRequires:  python-PyQt4-devel
38 BuildRequires:  python-cssutils
39 BuildRequires:  python-dateutil
40 BuildRequires:  python-lxml
41 BuildRequires:  python-mechanize
42 BuildRequires:  python-modules-sqlite
43 BuildRequires:  python-sip-devel
44 BuildRequires:  rpm-pythonprov
45 Requires:       python-PIL
46 Requires:       python-cssutils
47 Requires:       python-dateutil
48 Requires:       python-lxml
49 Requires:       python-mechanize
50 Requires:       python-modules-sqlite
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 Calibre is meant to be a complete e-library solution. It includes
55 library management, format conversion, news feeds to ebook conversion
56 as well as e-book reader sync features.
57
58 Calibre is primarily a ebook cataloging program. It manages your ebook
59 collection for you. It is designed around the concept of the logical
60 book, i.e. a single entry in the database that may correspond to
61 ebooks in several formats. It also supports conversion to and from a
62 dozen different ebook formats.
63
64 Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML,
65 CBR, CBZ, RTF, TXT, PDF and LRS.
66
67 %prep
68 %setup -q -n %{name}
69 %patch0 -p1
70 %patch1 -p1
71 %patch2 -p1
72
73 %build
74 %{__python} setup.py build
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__python} setup.py install \
80         --root=$RPM_BUILD_ROOT \
81         --libdir="%{_libdir}"
82
83 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/man $RPM_BUILD_ROOT%{_mandir}
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc COPYRIGHT README
91 %attr(755,root,root) %{_bindir}/*
92 %{_datadir}/%{name}
93 %{_libdir}/%{name}
94 %{_mandir}/man1/*.1*
This page took 0.065409 seconds and 3 git commands to generate.