]> git.pld-linux.org Git - packages/cairo.git/blob - cairo.spec
- removed obsolete Xc information
[packages/cairo.git] / cairo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     glitz           # build with glitz backend
5 %bcond_with     xcb             # enable XCB backend
6 %bcond_with     tests           # perform tests (can fail due to out of memory)
7 %bcond_without  lcd             # use own LCD filtering instead of freetype's
8 #
9 Summary:        Cairo - multi-platform 2D graphics library
10 Summary(pl.UTF-8):      Cairo - wieloplatformowa biblioteka graficzna 2D
11 Name:           cairo
12 Version:        1.2.6
13 Release:        3
14 License:        LGPL v2.1 or MPL v1.1
15 Group:          Libraries
16 Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
17 # Source0-md5:  487b3d7515752fe57f780d0fd707b01a
18 Patch0:         %{name}-link.patch
19 Patch1:         http://david.freetype.org/lcd/cairo-1.2.4-lcd-filter-1.patch
20 URL:            http://cairographics.org/
21 BuildRequires:  autoconf >= 2.54
22 BuildRequires:  automake >= 1:1.7
23 BuildRequires:  fontconfig-devel
24 %{?with_lcd:BuildRequires:      freetype-devel >= 1:2.3.0}
25 %{!?with_lcd:BuildRequires:     freetype-devel >= 1:2.1.10}
26 %{?with_glitz:BuildRequires:    glitz-devel >= 0.5.1}
27 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.3}
28 BuildRequires:  libpng-devel
29 BuildRequires:  libtool
30 BuildRequires:  pkgconfig
31 %{?with_xcb:BuildRequires:      libxcb-devel}
32 BuildRequires:  xorg-lib-libXrender-devel >= 0.6
33 BuildRequires:  zlib-devel
34 %{!?with_lcd:Requires:  freetype >= 1:2.1.10}
35 %{?with_lcd:Requires:   freetype >= 1:2.3.0}
36 %{?with_glitz:Requires: glitz >= 0.5.1}
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Cairo provides anti-aliased vector-based rendering for X. Paths
41 consist of line segments and cubic splines and can be rendered at any
42 width with various join and cap styles. All colors may be specified
43 with optional translucence (opacity/alpha) and combined using the
44 extended Porter/Duff compositing algebra as found in the X Render
45 Extension.
46
47 Cairo exports a stateful rendering API similar in spirit to the path
48 construction, text, and painting operators of PostScript, (with the
49 significant addition of translucence in the imaging model). When
50 complete, the API is intended to support the complete imaging model of
51 PDF 1.4.
52
53 %description -l pl.UTF-8
54 Cairo obsługuje oparty na wektorach rendering z antyaliasingiem dla X.
55 Ścieżki składają się z odcinków i splajnów kubicznych, a renderowane
56 mogą być z dowolną grubością i różnymi stylami połączeń i zakończeń.
57 Wszystkie kolory mogą być podane z opcjonalną półprzezroczystością
58 (podaną przez współczynnik nieprzezroczystości lub alpha) i łączone
59 przy użyciu rozszerzonego algorytmu mieszania Portera-Duffa, który
60 można znaleźć w rozszerzeniu X Render.
61
62 Cairo eksportuje stanowe API renderujące w duchu podobne do operatorów
63 konstruowania ścieżek, tekstu i rysowania z PostScriptu (ze znacznym
64 dodatkiem półprzezroczystości w modelu obrazu). Kiedy API zostanie
65 ukończone, ma obsługiwać pełny model obrazu z PDF w wersji 1.4.
66
67 %package devel
68 Summary:        Development files for Cairo library
69 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Cairo
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       fontconfig-devel
73 Requires:       freetype-devel >= 1:2.1.10
74 %{?with_glitz:Requires: glitz-devel >= 0.5.1}
75 Requires:       libpng-devel
76 %{?with_xcb:Requires:   libxcb-devel}
77 Requires:       xorg-lib-libXrender-devel >= 0.6
78
79 %description devel
80 Development files for Cairo library.
81
82 %description devel -l pl.UTF-8
83 Pliki programistyczne biblioteki Cairo.
84
85 %package static
86 Summary:        Static Cairo library
87 Summary(pl.UTF-8):      Statyczna biblioteka Cairo
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 Static Cairo library.
93
94 %description static -l pl.UTF-8
95 Statyczna biblioteka Cairo.
96
97 %package apidocs
98 Summary:        Cairo API documentation
99 Summary(pl.UTF-8):      Dokumentacja API Cairo
100 Group:          Documentation
101 Requires:       gtk-doc-common
102
103 %description apidocs
104 Cairo API documentation.
105
106 %description apidocs -l pl.UTF-8
107 Dokumentacja API Cairo. 
108
109 %prep
110 %setup -q
111 %patch0 -p1
112 %{?with_lcd:%patch1 -p1}
113
114 %build
115 %{?with_apidocs:%{__gtkdocize}}
116 %{__libtoolize}
117 %{__aclocal}
118 %{__autoheader}
119 %{__autoconf}
120 %{__automake}
121 %configure \
122         %{?with_apidocs:--enable-gtk-doc} \
123         %{?with_xcb:--enable-xcb} \
124         %{?with_glitz:--enable-glitz} \
125         --enable-ps \
126         --enable-pdf \
127         --with-html-dir=%{_gtkdocdir}
128 %{__make}
129 %{?with_tests:%{__make} check}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %files
144 %defattr(644,root,root,755)
145 # COPYING contains only notes, not LGPL/MPL texts
146 %doc AUTHORS COPYING ChangeLog NEWS README TODO
147 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
148
149 %files devel
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/lib*.so
152 %{_libdir}/lib*.la
153 %{_includedir}/*
154 %{_pkgconfigdir}/*.pc
155
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/lib*.a
159
160 %files apidocs
161 %defattr(644,root,root,755)
162 %{_gtkdocdir}/cairo
This page took 0.034871 seconds and 4 git commands to generate.