]> git.pld-linux.org Git - packages/cacti.git/blob - cacti.spec
- up to 0.8.6j
[packages/cacti.git] / cacti.spec
1 # TODO
2 # - patch source to use adodb system path instead of symlinking
3 %include        /usr/lib/rpm/macros.perl
4 Summary:        Cacti is a PHP frontend for rrdtool
5 Summary(pl):    Cacti - frontend w PHP do rrdtoola
6 Name:           cacti
7 Version:        0.8.6j
8 Release:        1
9 License:        GPL
10 Group:          Applications/WWW
11 Source0:        http://www.cacti.net/downloads/%{name}-%{version}.tar.gz
12 # Source0-md5:  29436be46b289d13dfce48e7618129e2
13 Patch10:        %{name}-plugin-%{version}.diff
14 Patch11:        %{name}-config.patch
15 URL:            http://www.cacti.net/
16 BuildRequires:  rpm-perlprov
17 Requires:       adodb >= 4.67-1.17
18 Requires:       crondaemon
19 Requires:       net-snmp-utils
20 Requires:       php(gd)
21 Requires:       php(mysql)
22 Requires:       php(pcre)
23 Requires:       php(snmp)
24 Requires:       php(xml)
25 Requires:       php-cli
26 Requires:       rrdtool
27 Requires:       webserver
28 Requires:       webserver(php)
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         webadminroot /usr/share/%{name}
33
34 %description
35 Cacti is a complete frondend to rrdtool, it stores all of the
36 nessesary information to create graphs and populate them with data in
37 a MySQL database.
38
39 The frontend is completely PHP driven. Along with being able to
40 maintain Graphs, Data Sources, and Round Robin Archives in a database,
41 cacti handles the data gathering also. There is also SNMP support for
42 those used to creating traffic graphs with MRTG.
43
44 %description -l pl
45 Cacti to pe³ny frontend do rrdtoola, zapamiêtuj±cy wszystkie
46 informacje potrzebne do tworzenia wykresów i wype³niaj±ce je danymi w
47 bazie MySQL.
48
49 Frontend jest w pe³ni oparty na PHP. Oprócz zarz±dzania wykresami,
50 ¼ród³ami danych, archiwami Round Robin w bazie danych, cacti obs³uguje
51 tak¿e gromadzenie danych. Ma tak¿e obs³ugê SNMP przydatn± przy
52 tworzeniu wykresów ruchu przy u¿yciu MRTG.
53
54 %prep
55 %setup -q
56 %patch10 -p1
57 %patch11 -p1
58
59 rm -rf lib/adodb
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT%{webadminroot}
64 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{%{name},cron.d}
65 install -d $RPM_BUILD_ROOT/var/{log,lib/%{name}}
66 cp -aRf * $RPM_BUILD_ROOT%{webadminroot}
67 ln -s . $RPM_BUILD_ROOT%{webadminroot}/%{name}
68
69 # TODO: move this to SOURCES. it's a lot better to backtrack changes
70 # if it's a separate file.
71 cat << 'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/%{name}.cfg
72 <?php
73 $database_type = 'mysql';
74 $database_default = 'cacti';
75 $database_hostname = 'localhost';
76 $database_username = 'cactiuser';
77 $database_password = 'cactiuser';
78
79 $plugins = array();
80 // $plugins[] = 'thold';
81 // $plugins[] = 'monitor';
82 // $plugins[] = 'discovery';
83
84 /* Do not edit this line */
85 $config = array();
86
87 /* This is full URL Path to the Cacti installation
88    For example, if your cacti was accessible by http://server/cacti/ you would user '/cacti/'
89    as the url path.  For just http://server/ use '/'
90 */
91 $config['url_path'] = '/cacti/';
92
93 ?>
94 EOF
95
96 mv $RPM_BUILD_ROOT%{webadminroot}/log $RPM_BUILD_ROOT/var/log/%{name}
97 ln -sf /var/log/cacti $RPM_BUILD_ROOT%{webadminroot}/log
98
99 mv $RPM_BUILD_ROOT%{webadminroot}/rra $RPM_BUILD_ROOT/var/lib/%{name}
100 ln -sf /var/lib/%{name}/rra $RPM_BUILD_ROOT%{webadminroot}/rra
101 ln -sf /usr/share/php/adodb $RPM_BUILD_ROOT%{webadminroot}/lib/adodb
102
103 cat  << 'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/cron.d/%{name}
104 */5 * * * * http umask 022; %{_bindir}/php %{webadminroot}/poller.php > /dev/null 2>&1
105 EOF
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %files
111 %defattr(644,root,root,755)
112 %doc docs/CHANGELOG docs/CONTRIB docs/README
113 %attr(750,root,http) %dir %{_sysconfdir}/%{name}
114 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}.cfg
115 %attr(770,root,http) %dir /var/log/%{name}
116 %attr(660,root,http) %ghost /var/log/%{name}/*.log
117 %attr(750,root,http) %dir /var/lib/%{name}
118 %attr(770,root,http) %dir /var/lib/%{name}/rra
119 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
120 %{webadminroot}
This page took 0.141868 seconds and 4 git commands to generate.