packages/cacti.git
7 days ago- one more module: ctype master
Arkadiusz Miśkiewicz [Tue, 5 Dec 2017 10:19:59 +0000 (11:19 +0100)]
- one more module: ctype

7 days ago- uses php filter json mbstring modules
Arkadiusz Miśkiewicz [Tue, 5 Dec 2017 10:17:58 +0000 (11:17 +0100)]
- uses php filter json mbstring modules

7 days ago- install locales, too
Arkadiusz Miśkiewicz [Tue, 5 Dec 2017 10:12:54 +0000 (11:12 +0100)]
- install locales, too

7 days ago- install cache, formats dirs, too.
Arkadiusz Miśkiewicz [Tue, 5 Dec 2017 10:08:46 +0000 (11:08 +0100)]
- install cache, formats dirs, too.

7 days ago- install cacti mibs (used by internal mibs parser)
Arkadiusz Miśkiewicz [Tue, 5 Dec 2017 09:59:42 +0000 (10:59 +0100)]
- install cacti mibs (used by internal mibs parser)

7 days agoUses pdo now. Switch requires.
Arkadiusz Miśkiewicz [Tue, 5 Dec 2017 09:55:51 +0000 (10:55 +0100)]
Uses pdo now. Switch requires.

7 days ago- up to 1.1.28
Arkadiusz Miśkiewicz [Tue, 5 Dec 2017 09:15:13 +0000 (10:15 +0100)]
- up to 1.1.28

3 months ago- mostly updated; one patch left + testing; new config variable path_cactilog
Arkadiusz Miśkiewicz [Thu, 31 Aug 2017 07:15:50 +0000 (09:15 +0200)]
- mostly updated; one patch left + testing; new config variable path_cactilog

12 months ago0.8.8h auto/th/cacti-0.8.8h-1
Elan Ruusamäe [Sun, 4 Dec 2016 13:51:24 +0000 (15:51 +0200)]
0.8.8h

-bug:0002656: Authentication using web authentication as a user not in the cacti database allows complete access (regression)
-bug:0002667: Cacti SQL Injection Vulnerability
-bug:0002666: When click the [Clear] button after clicking the [Refresh] button in Preview Mode , fails to CSRFcheck
-bug:0002673: CVE-2016-3659 - Cacti graph_view.php SQL Injection Vulnerability
-bug:0002676: Outdated MIBs for non-unicast packets
-bug:0002677: Index is a MySQL 5.6 reserved word
-bug:0002681: generate_graph_def_name() generates reserved word "cf"

21 months agovim modeline to top
Elan Ruusamäe [Sat, 5 Mar 2016 23:15:42 +0000 (01:15 +0200)]
vim modeline to top

21 months agoup to 0.8.8g; fixes CVE-2015-8604, CVE-2015-8377 auto/th/cacti-0.8.8g-1
Elan Ruusamäe [Thu, 25 Feb 2016 21:03:41 +0000 (23:03 +0200)]
up to 0.8.8g; fixes CVE-2015-8604, CVE-2015-8377

- bug:0002652: CVE-2015-8604: SQL injection in graphs_new.php
- bug:0002655: CVE-2015-8377: SQL injection vulnerability in the host_new_graphs_save function in graphs_new.php

2 years agovirtual php deps AC-branch auto/ac/cacti-0.8.8f-1
Elan Ruusamäe [Wed, 2 Sep 2015 11:52:57 +0000 (14:52 +0300)]
virtual php deps

2 years agomake logrotate compatible with ac
Elan Ruusamäe [Wed, 2 Sep 2015 11:52:45 +0000 (14:52 +0300)]
make logrotate compatible with ac

2 years agoup to 0.8.8f auto/th/cacti-0.8.8f-1
Elan Ruusamäe [Mon, 27 Jul 2015 10:00:00 +0000 (13:00 +0300)]
up to 0.8.8f

-bug:0002599: 0.8.8e Poller Script Parser is Broken
-bug:0002600: cli/upgrade_database.php is missing releases
-bug:0002603: Graph managment graphs.php save button does not work
-bug:0002599: Poller Script Parser is Broken

2 years agoup to 0.8.8e; fixes CVE-2015-4634 auto/th/cacti-0.8.8e-1
Elan Ruusamäe [Thu, 16 Jul 2015 10:47:39 +0000 (13:47 +0300)]
up to 0.8.8e; fixes CVE-2015-4634

-bug: Fixed issue with graph zooming failing to work
-bug: Fixed various SQL Injection vectors
-bug#0002569: Impossible to have a URL pointing directly to a graph
-bug#0002574: SQL Injection Vulnerabilities in graph items and graph template items
-bug#0002577: CVE-2015-4634 - SQL injection in graphs.php
-bug#0002579: SQL Injection Vulnerabilities in data sources
-bug#0002580: SQL Injection in cdef.php
-bug#0002582: SQL Injection in data_templates.php
-bug#0002583: SQL Injection in graph_templates.php
-bug#0002584: SQL Injection in host_templates.php
-bug#0002586: Cannot delete data sources from the GUI
-bug#0002592: graph_view.php - viewing host in new tab - Undefined index: nodeid
-bug#0002594: status_fail_date and status_rec_date are set incorrectly after host is marked down
-bug#0002597: Incorrect value in Hosts column on Host Templates page
-bug#0002598: Incorrect row number in Devices -> (Edit) page

2 years agoup to 0.8.8d; security fixes (JVN#78187936, TN:JPCERT#98968540, CVE-2015-4342) auto/th/cacti-0.8.8d-1
Elan Ruusamäe [Fri, 12 Jun 2015 12:45:33 +0000 (15:45 +0300)]
up to 0.8.8d; security fixes (JVN#78187936, TN:JPCERT#98968540, CVE-2015-4342)

- bug: Fixed SQL injection VN: JVN#78187936 / TN:JPCERT#98968540
- bug#0002542: [FG-VD-15-017] Cacti Cross-Site Scripting Vulnerability Notification
- bug#0002571: SQL Injection and Location header injection from cdef id CVE-2015-4342

3 years agoutilities_view_logfile: global $refresh auto/th/cacti-0.8.8c-1
Elan Ruusamäe [Sun, 30 Nov 2014 09:28:05 +0000 (11:28 +0200)]
utilities_view_logfile: global $refresh

3 years agoDatabase upgrade needs setup files
Arkadiusz Miśkiewicz [Sat, 29 Nov 2014 23:37:09 +0000 (00:37 +0100)]
Database upgrade needs setup files

3 years ago- up to 0.8.8c
Arkadiusz Miśkiewicz [Sat, 29 Nov 2014 23:22:27 +0000 (00:22 +0100)]
- up to 0.8.8c

3 years agoofficial security.patch. fixes CVE-2014-2326, CVE-2014-2328, CVE-2014-2708, CVE-2014... auto/th/cacti-0.8.8b-5
Elan Ruusamäe [Thu, 3 Jul 2014 12:04:08 +0000 (15:04 +0300)]
official security.patch. fixes CVE-2014-2326, CVE-2014-2328, CVE-2014-2708, CVE-2014-2709

CVE-2014-2326 Unspecified HTML Injection Vulnerability
CVE-2014-2328 Unspecified Remote Command Execution Vulnerability
CVE-2014-2708 Unspecified SQL Injection Vulnerability
CVE-2014-2709 Unspecified Remote Command Execution Vulnerability

3 years agodateext is global setting now
Elan Ruusamäe [Fri, 11 Apr 2014 10:20:43 +0000 (13:20 +0300)]
dateext is global setting now

3 years agofix logrotate su lines, them must match permissions of olddir, not rotated file
Elan Ruusamäe [Fri, 11 Apr 2014 10:19:57 +0000 (13:19 +0300)]
fix logrotate su lines, them must match permissions of olddir, not rotated file

3 years agofix empty COMMENT errors (upstream fix) auto/th/cacti-0.8.8b-4
Elan Ruusamäe [Sat, 8 Feb 2014 19:07:54 +0000 (21:07 +0200)]
fix empty COMMENT errors (upstream fix)

http://bugs.cacti.net/view.php?id=2379
fix COMMENT handling, even in case COMMENT is empty, with or without HR
and with variable substitution

3 years agoadd (disabled) modsecurity rules from ubuntu
Elan Ruusamäe [Tue, 4 Feb 2014 08:00:54 +0000 (10:00 +0200)]
add (disabled) modsecurity rules from ubuntu

3 years agoftp and bcmath are optional
Elan Ruusamäe [Mon, 3 Feb 2014 14:54:59 +0000 (16:54 +0200)]
ftp and bcmath are optional

4 years ago- rel 2; su directive for poller.log logrotate auto/th/cacti-0.8.8b-2
Arkadiusz Miśkiewicz [Sat, 30 Nov 2013 10:30:08 +0000 (11:30 +0100)]
- rel 2; su directive for poller.log logrotate

4 years agoadd url
Elan Ruusamäe [Sun, 1 Sep 2013 11:04:12 +0000 (14:04 +0300)]
add url

4 years agophp autodeps auto/th/cacti-0.8.8b-1
Elan Ruusamäe [Sun, 18 Aug 2013 21:51:06 +0000 (00:51 +0300)]
php autodeps

4 years agoup to 0.8.8b
Elan Ruusamäe [Sun, 18 Aug 2013 21:43:10 +0000 (00:43 +0300)]
up to 0.8.8b

- bug: Fixed issue with custom data source information being lost when saved from edit
- bug: Repopulate the poller cache on new installations
- bug: Fix issue with poller not escaping the script query path correctly
- bug: Allow snmpv3 priv proto none
- bug: Fix issue where host activate may flush the entire poller item cache
- security: SQL injection and shell escaping issues

4 years agosend noisy poller output to a logfile
Elan Ruusamäe [Sat, 6 Jul 2013 16:16:55 +0000 (19:16 +0300)]
send noisy poller output to a logfile

4 years agoapache 2.2/2.4 compatinle config
Elan Ruusamäe [Wed, 26 Jun 2013 10:10:13 +0000 (13:10 +0300)]
apache 2.2/2.4 compatinle config

4 years agoRevert "- migrate to apache 2.4"
Elan Ruusamäe [Wed, 26 Jun 2013 10:09:30 +0000 (13:09 +0300)]
Revert "- migrate to apache 2.4"

This reverts commit 2bbf124c70cb118cc69c7733c9f7b74fff851b84.

4 years ago- migrate to apache 2.4 auto/th/cacti-0.8.8a-4
Jan Rękorajski [Wed, 15 May 2013 16:16:29 +0000 (18:16 +0200)]
- migrate to apache 2.4
- rel 4

4 years agoshorten commandline auto/ti/cacti-0.8.8a-3
Elan Ruusamäe [Tue, 12 Mar 2013 15:47:39 +0000 (17:47 +0200)]
shorten commandline

4 years agopoller_graphs_reapply_names.php uses -id instead of --id
Arkadiusz Miśkiewicz [Mon, 11 Mar 2013 20:53:56 +0000 (21:53 +0100)]
poller_graphs_reapply_names.php uses -id instead of --id

4 years ago- run all commands
Arkadiusz Miśkiewicz [Sun, 10 Mar 2013 15:11:35 +0000 (16:11 +0100)]
- run all commands

4 years ago- reindexation/names applying example
Arkadiusz Miśkiewicz [Fri, 8 Mar 2013 21:29:13 +0000 (22:29 +0100)]
- reindexation/names applying example

5 years agoLog file permissions fixed in cacti.logrotate auto/th/cacti-0.8.8a-3
Jacek Konieczny [Thu, 22 Nov 2012 17:44:33 +0000 (18:44 +0100)]
Log file permissions fixed in cacti.logrotate

Log writting would fail after rotation under lighttpd,
as the file would not be writtable by http group.

Permissions changed to match those in the package.

Release: 3

5 years ago- drop obsolete files auto/ti/cacti-0.8.8a-2
Elan Ruusamäe [Tue, 30 Oct 2012 17:40:31 +0000 (19:40 +0200)]
- drop obsolete files

5 years agoupdate official patches
Elan Ruusamäe [Tue, 30 Oct 2012 17:38:17 +0000 (19:38 +0200)]
update official patches

- Fix SNMPv3 privilege protocol to allow NONE

5 years agoup to 0.8.8a auto/th/cacti-0.8.8a-1
Elan Ruusamäe [Mon, 29 Oct 2012 20:29:31 +0000 (22:29 +0200)]
up to 0.8.8a

http://www.cacti.net/release_notes_0_8_8a.php

5 years agoup to 0.8.8
Elan Ruusamäe [Mon, 29 Oct 2012 20:26:39 +0000 (22:26 +0200)]
up to 0.8.8

Plugin Architecture is now part of Cacti

5 years ago- use php(core) as dependency to require php version auto/th/cacti-0.8.7i-9
Elan Ruusamäe [Thu, 23 Aug 2012 22:18:11 +0000 (01:18 +0300)]
- use php(core) as dependency to require php version
- release 8 (by relup.sh)

5 years ago- use virtual php extension deps (to be independant of php version) auto/th/cacti-0.8.7i-8
Elan Ruusamäe [Tue, 7 Aug 2012 14:22:19 +0000 (17:22 +0300)]
- use virtual php extension deps (to be independant of php version)
- release 8 (by relup.sh)

5 years agono package should directly depend on php-cli package auto/th/cacti-0.8.7i-4
Elan Ruusamäe [Wed, 1 Aug 2012 22:20:46 +0000 (01:20 +0300)]
no package should directly depend on php-cli package

5 years ago- rel 3 auto/th/cacti-0_8_7i-3
Jan Rękorajski [Sun, 5 Feb 2012 10:46:29 +0000 (10:46 +0000)]
- rel 3
- logrotate 3.8.0 requires "su" option for non-root writable dirs

Changed files:
    cacti.logrotate -> 1.2
    cacti.spec -> 1.150

5 years ago- patch comments auto/ac/cacti-0_8_7i-2
Elan Ruusamäe [Tue, 24 Jan 2012 09:45:10 +0000 (09:45 +0000)]
- patch comments

Changed files:
    mysql-socket.patch -> 1.3

5 years ago- allow adodb mysql driver in the future support socket too auto/th/cacti-0_8_7i-2
Elan Ruusamäe [Tue, 24 Jan 2012 09:25:34 +0000 (09:25 +0000)]
- allow adodb mysql driver in the future support socket too

Changed files:
    mysql-socket.patch -> 1.2

5 years ago- allow using mysql sockets when connecting to db
Elan Ruusamäe [Tue, 24 Jan 2012 09:24:53 +0000 (09:24 +0000)]
- allow using mysql sockets when connecting to db

Changed files:
    cacti.spec -> 1.149
    mysql-socket.patch -> 1.1

5 years ago- up to 0.8.7i; use consolidated PIA tarball; requires boost 5.x according to changelog auto/th/cacti-0_8_7i-1
Elan Ruusamäe [Mon, 23 Jan 2012 16:39:02 +0000 (16:39 +0000)]
- up to 0.8.7i; use consolidated PIA tarball; requires boost 5.x according to changelog

Changed files:
    cacti-PA.patch -> 1.8
    cacti-pa.sql -> 1.3
    cacti.spec -> 1.148

5 years ago- release 3 auto/th/cacti-0_8_7h-3
Arkadiusz Miśkiewicz [Sat, 12 Nov 2011 17:56:59 +0000 (17:56 +0000)]
- release 3

Changed files:
    cacti.spec -> 1.147

5 years ago- upgrade_database.php in %post
Elan Ruusamäe [Thu, 3 Nov 2011 05:15:05 +0000 (05:15 +0000)]
- upgrade_database.php in %post

Changed files:
    cacti.spec -> 1.146

5 years ago- libraries require_once auto/th/cacti-0_8_7h-2
Elan Ruusamäe [Tue, 1 Nov 2011 21:55:40 +0000 (21:55 +0000)]
- libraries require_once

Changed files:
    cacti-adodb.patch -> 1.4

5 years ago- rel 2. fixed adodb patch auto/ac/cacti-0_8_7h-2
Elan Ruusamäe [Tue, 1 Nov 2011 21:54:11 +0000 (21:54 +0000)]
- rel 2. fixed adodb patch

Changed files:
    cacti.spec -> 1.145

5 years ago- fix crappy patching
Elan Ruusamäe [Tue, 1 Nov 2011 21:53:55 +0000 (21:53 +0000)]
- fix crappy patching

Changed files:
    cacti-adodb.patch -> 1.3

5 years ago- obsolete cacti-add_template package, use %cacti_import_template macro to register...
Elan Ruusamäe [Sat, 29 Oct 2011 10:49:09 +0000 (10:49 +0000)]
- obsolete cacti-add_template package, use %cacti_import_template macro to register templates

Changed files:
    cacti.spec -> 1.144

5 years ago- plugin "update" no longer required with PIA 2.x
Elan Ruusamäe [Sat, 29 Oct 2011 10:34:15 +0000 (10:34 +0000)]
- plugin "update" no longer required with PIA 2.x

Changed files:
    cacti.spec -> 1.143

5 years ago- up to 0.8.7h auto/ac/cacti-0_8_7h-1 auto/th/cacti-0_8_7h-1 auto/ti/cacti-0_8_7h-1
Arkadiusz Miśkiewicz [Wed, 12 Oct 2011 18:43:49 +0000 (18:43 +0000)]
- up to 0.8.7h

Changed files:
    cacti-PA.patch -> 1.7
    cacti-adodb.patch -> 1.2
    cacti-config.patch -> 1.11
    cacti.spec -> 1.142
    cli-relpath.patch -> 1.3
    host_name-url.patch -> 1.4

5 years ago- added temporary patch for 0.8.7g fixing some XSS and SQLI vulnerabilities auto/ac/cacti-0_8_7g-11 auto/th/cacti-0_8_7g-11
marti [Thu, 14 Apr 2011 18:30:34 +0000 (18:30 +0000)]
- added temporary patch for 0.8.7g fixing some XSS and SQLI vulnerabilities

Changed files:
    cacti.spec -> 1.141

5 years ago- patch for 0.8.7g fixing some Cross-site scripting and SQL InjectionS potientials
marti [Thu, 14 Apr 2011 18:28:09 +0000 (18:28 +0000)]
- patch for 0.8.7g fixing some Cross-site scripting and SQL InjectionS potientials

Changed files:
    cacti-0.8.7g-sqli-xss.patch -> 1.1

5 years ago- package log archive dir; rel 10 auto/ac/cacti-0_8_7g-10 auto/th/cacti-0_8_7g-10
Elan Ruusamäe [Tue, 21 Dec 2010 10:34:52 +0000 (10:34 +0000)]
- package log archive dir; rel 10

Changed files:
    cacti.spec -> 1.140

5 years ago- updated Plugin Archidecture to 2.9 auto/ac/cacti-0_8_7g-9 auto/th/cacti-0_8_7g-9
Elan Ruusamäe [Wed, 15 Dec 2010 18:41:38 +0000 (18:41 +0000)]
- updated Plugin Archidecture to 2.9

Changed files:
    cacti.spec -> 1.139

5 years agoupdated from cacti-plugin-0.8.7g-PA-v2.9.tar.gz :
Elan Ruusamäe [Wed, 15 Dec 2010 18:40:05 +0000 (18:40 +0000)]
updated from cacti-plugin-0.8.7g-PA-v2.9.tar.gz :
filterdiff -p 1 -x 'images/*' cacti-plugin-arch/cacti-plugin-0.8.7g-PA-v2.9.diff > cacti-PA.patch

Changed files:
    cacti-PA.patch -> 1.6

5 years ago- md5 for PA auto/ac/cacti-0_8_7g-8 auto/th/cacti-0_8_7g-8
Elan Ruusamäe [Tue, 14 Dec 2010 06:25:22 +0000 (06:25 +0000)]
- md5 for PA

Changed files:
    cacti.spec -> 1.138

5 years ago- install PA icons
Elan Ruusamäe [Tue, 14 Dec 2010 06:24:48 +0000 (06:24 +0000)]
- install PA icons

Changed files:
    cacti.spec -> 1.137

5 years ago- cacti(pia) provide for Cacti Plugin Architecture version dep auto/ac/cacti-0_8_7g-7 auto/th/cacti-0_8_7g-7
Elan Ruusamäe [Tue, 14 Dec 2010 05:51:39 +0000 (05:51 +0000)]
- cacti(pia) provide for Cacti Plugin Architecture version dep

Changed files:
    cacti.spec -> 1.136

5 years ago- add /var/cache/cacti for scripts like ss_get_mysql_stats.php, so they don't trash... auto/ac/cacti-0_8_7g-6 auto/th/cacti-0_8_7g-6
Elan Ruusamäe [Mon, 13 Dec 2010 23:24:09 +0000 (23:24 +0000)]
- add /var/cache/cacti for scripts like ss_get_mysql_stats.php, so they don't trash /tmp; rel 6

Changed files:
    cacti.spec -> 1.135

5 years ago- fix config syntax error, actually use just one config file from webapps dir; rel 5 auto/ac/cacti-0_8_7g-5 auto/th/cacti-0_8_7g-5
Elan Ruusamäe [Mon, 13 Dec 2010 10:19:48 +0000 (10:19 +0000)]
- fix config syntax error, actually use just one config file from webapps dir; rel 5

Changed files:
    cacti-config.patch -> 1.10
    cacti.cfg.php -> 1.5
    cacti.spec -> 1.134

5 years ago- adjust PA patch for current patchset
Elan Ruusamäe [Mon, 13 Dec 2010 10:06:01 +0000 (10:06 +0000)]
- adjust PA patch for current patchset

Changed files:
    cacti-PA.patch -> 1.5
    cacti.spec -> 1.133

5 years ago- original patches came first, pa patch needs update
Elan Ruusamäe [Mon, 13 Dec 2010 09:51:27 +0000 (09:51 +0000)]
- original patches came first, pa patch needs update

Changed files:
    cacti.spec -> 1.132
    html_output.patch -> 1.3
    poller_interval.patch -> 1.3

5 years ago- add logrotate, adapter
Elan Ruusamäe [Mon, 13 Dec 2010 09:47:56 +0000 (09:47 +0000)]
- add logrotate, adapter

Changed files:
    cacti.logrotate -> 1.1
    cacti.spec -> 1.131

5 years ago- release 4 auto/th/cacti-0_8_7g-4
Sławomir Paszkiewicz [Wed, 17 Nov 2010 12:31:46 +0000 (12:31 +0000)]
- release 4

Changed files:
    cacti.spec -> 1.130

5 years ago- added plugins array to default config
Sławomir Paszkiewicz [Mon, 15 Nov 2010 10:00:49 +0000 (10:00 +0000)]
- added plugins array to default config

Changed files:
    cacti.cfg.php -> 1.4

5 years ago- REAL use of /etc/webapps/cacti/config.php instead of default one
Sławomir Paszkiewicz [Mon, 15 Nov 2010 09:17:34 +0000 (09:17 +0000)]
- REAL use of /etc/webapps/cacti/config.php instead of default one

Changed files:
    cacti-config.patch -> 1.9

5 years ago- Rel 3 auto/th/cacti-0_8_7g-3
Jarosław Skibiński [Sat, 9 Oct 2010 23:54:44 +0000 (23:54 +0000)]
- Rel 3

Changed files:
    cacti.spec -> 1.129

5 years ago- Add patch from date 2010/07/27 more info http://www.cacti.net/download_patches.php
Jarosław Skibiński [Sat, 9 Oct 2010 23:53:15 +0000 (23:53 +0000)]
- Add patch from date 2010/07/27 more info cacti.net/download_patches.php

Changed files:
    cacti.spec -> 1.128
    html_output.patch -> 1.2
    poller_interval.patch -> 1.2

5 years ago- The following patch was released on 2010/08/31 and 2010/07/27 mor info: http:...
Jarosław Skibiński [Sat, 9 Oct 2010 23:16:59 +0000 (23:16 +0000)]
- The following patch was released on 2010/08/31 and 2010/07/27 mor info:  cacti.net/download_patches.php http://www.cacti.net/spine_download_patches.php

Changed files:
    data_source_deactivate.patch -> 1.1
    graph_list_view.patch -> 1.1
    html_output.patch -> 1.1
    ldap_group_authenication.patch -> 1.1
    ping.patch -> 1.1
    poller_interval.patch -> 1.1
    script_server_command_line_parse.patch -> 1.1
    unified_issues.patch -> 1.1

5 years ago- release 2 auto/ac/cacti-0_8_7g-2 auto/th/cacti-0_8_7g-2 auto/ti/cacti-0_8_7g-2
Elan Ruusamäe [Wed, 14 Jul 2010 10:07:51 +0000 (10:07 +0000)]
- release 2

Changed files:
    cacti.spec -> 1.127

5 years ago- removed png patching crap, thx glen
Sławomir Paszkiewicz [Tue, 13 Jul 2010 16:25:36 +0000 (16:25 +0000)]
- removed png patching crap, thx glen

Changed files:
    cacti-PA.patch -> 1.4

5 years ago- updated PA patch to 2.8; rel 1 auto/ac/cacti-0_8_7g-1 auto/th/cacti-0_8_7g-1
Sławomir Paszkiewicz [Tue, 13 Jul 2010 12:20:26 +0000 (12:20 +0000)]
- updated PA patch to 2.8; rel 1

Changed files:
    cacti.spec -> 1.126

5 years ago- updated to 2.8
Sławomir Paszkiewicz [Tue, 13 Jul 2010 12:20:18 +0000 (12:20 +0000)]
- updated to 2.8

Changed files:
    cacti-PA.patch -> 1.3

5 years ago- up to 0.8.7g, pa patch needs updating (not available on website)
Elan Ruusamäe [Mon, 12 Jul 2010 09:36:58 +0000 (09:36 +0000)]
- up to 0.8.7g, pa patch needs updating (not available on website)

Changed files:
    cacti.spec -> 1.125

5 years ago- obsolete
Andrzej Zawadzki [Fri, 28 May 2010 08:07:28 +0000 (08:07 +0000)]
- obsolete

Changed files:
    cacti-rrdresourcecheck.patch -> 1.2

5 years ago- up to 0.8.7f auto/ac/cacti-0_8_7f-1 auto/th/cacti-0_8_7f-1 auto/ti/cacti-0_8_7f-1
Andrzej Zawadzki [Fri, 28 May 2010 08:05:35 +0000 (08:05 +0000)]
- up to 0.8.7f
- works for me

Changed files:
    cacti-PA.patch -> 1.2
    cacti-log-verbosity.patch -> 1.3
    cacti.spec -> 1.124
    host_name-url.patch -> 1.3

5 years ago- added sql_injection_template_export.patch. Resolves: CVE-2010-1431 auto/th/cacti-0_8_7e-11
pawelz [Fri, 7 May 2010 11:38:15 +0000 (11:38 +0000)]
- added sql_injection_template_export.patch. Resolves: CVE-2010-1431
- rel 11

Changed files:
    cacti.spec -> 1.123
    sql_injection_template_export.patch -> 1.1

5 years ago- worked fine for years without gd ext; rel 10 auto/ac/cacti-0_8_7e-10 auto/th/cacti-0_8_7e-10
Elan Ruusamäe [Wed, 14 Apr 2010 21:49:06 +0000 (21:49 +0000)]
- worked fine for years without gd ext; rel 10

Changed files:
    cacti.spec -> 1.122

5 years ago- require php with not broken xml, php5 is now minimum dep; rel 9 auto/ac/cacti-0_8_7e-9
Elan Ruusamäe [Wed, 14 Apr 2010 15:38:01 +0000 (15:38 +0000)]
- require php with not broken xml, php5 is now minimum dep; rel 9

Changed files:
    cacti.spec -> 1.121

5 years ago- include -> require in cli auto/ac/cacti-0_8_7e-8 auto/th/cacti-0_8_7e-8
Elan Ruusamäe [Wed, 14 Apr 2010 15:23:29 +0000 (15:23 +0000)]
- include -> require in cli

Changed files:
    cacti.spec -> 1.120

5 years ago- be like other scripts
Elan Ruusamäe [Wed, 14 Apr 2010 15:23:08 +0000 (15:23 +0000)]
- be like other scripts

Changed files:
    cli-relpath.patch -> 1.2

5 years ago- do not add duplicate shebangs
Elan Ruusamäe [Wed, 14 Apr 2010 15:17:05 +0000 (15:17 +0000)]
- do not add duplicate shebangs

Changed files:
    cacti.spec -> 1.119

5 years ago- make sure cli programs work from any current dir; rel 8
Elan Ruusamäe [Wed, 14 Apr 2010 15:13:18 +0000 (15:13 +0000)]
- make sure cli programs work from any current dir; rel 8

Changed files:
    cacti.spec -> 1.118
    cli-relpath.patch -> 1.1

5 years ago- release 7 auto/ac/cacti-0_8_7e-7 auto/th/cacti-0_8_7e-7
Elan Ruusamäe [Tue, 13 Apr 2010 20:25:25 +0000 (20:25 +0000)]
- release 7

Changed files:
    cacti.spec -> 1.117

5 years ago- our anal cvsnt
Elan Ruusamäe [Tue, 13 Apr 2010 20:25:13 +0000 (20:25 +0000)]
- our anal cvsnt

Changed files:
    template_duplication.patch -> 1.2

5 years ago- upgrade PluginArchidecture patch to 0.8.7e-PA-v2.6 (replaced by cacti-PA.patch)
Elan Ruusamäe [Tue, 13 Apr 2010 19:40:26 +0000 (19:40 +0000)]
- upgrade PluginArchidecture patch to 0.8.7e-PA-v2.6 (replaced by cacti-PA.patch)

Changed files:
    cacti-plugin-0.8.7e-PA-v2.5.diff -> 1.2

5 years ago- add 5 official patches, upgrade PluginArchidecture patch to 0.8.7e-PA-v2.6 auto/ac/cacti-0_8_7e-6 auto/th/cacti-0_8_7e-6
Elan Ruusamäe [Tue, 13 Apr 2010 19:39:57 +0000 (19:39 +0000)]
- add 5 official patches, upgrade PluginArchidecture patch to 0.8.7e-PA-v2.6
- rel 6

Changed files:
    cacti.spec -> 1.116
    cli_add_graph.patch -> 1.1
    cross_site_fix.patch -> 1.1
    fix_icmp_on_windows_iis_servers.patch -> 1.1
    snmp_invalid_response.patch -> 1.1
    template_duplication.patch -> 1.1

5 years ago- PluginArchitecture patch - http://cactiusers.org/wiki/PluginArchitectureInstall
Elan Ruusamäe [Tue, 13 Apr 2010 19:38:07 +0000 (19:38 +0000)]
- PluginArchitecture patch - cactiusers.org/wiki/PluginArchitectureInstall
  extracted from this archive: http://mirror.cactiusers.org/downloads/plugins/cacti-plugin-0.8.7e-PA-v2.6.zip

Changed files:
    cacti-PA.patch -> 1.1

5 years ago- use require instead of include to make permission problems fatal
Elan Ruusamäe [Tue, 13 Apr 2010 10:48:51 +0000 (10:48 +0000)]
- use require instead of include to make permission problems fatal

Changed files:
    cacti-config.patch -> 1.8

5 years ago- R: session; http://lists.pld-linux.org/mailman/pipermail/pld-devel-en/2009-December... auto/ac/cacti-0_8_7e-5 auto/th/cacti-0_8_7e-5
Elan Ruusamäe [Wed, 2 Dec 2009 10:04:30 +0000 (10:04 +0000)]
- R: session; lists.pld-linux.org/mailman/pipermail/pld-devel-en/2009-December/021307.html; rel 5

Changed files:
    cacti.spec -> 1.115

5 years ago- match host_name also for action=preview; rel 4 auto/ac/cacti-0_8_7e-4
Elan Ruusamäe [Wed, 7 Oct 2009 09:44:41 +0000 (09:44 +0000)]
- match host_name also for action=preview; rel 4

Changed files:
    cacti.spec -> 1.114
    host_name-url.patch -> 1.2

5 years ago- understand $host_name in graph_view (map to $host_id) auto/ac/cacti-0_8_7e-3
Elan Ruusamäe [Fri, 2 Oct 2009 07:32:51 +0000 (07:32 +0000)]
- understand $host_name in graph_view (map to $host_id)

Changed files:
    host_name-url.patch -> 1.1

This page took 0.498014 seconds and 4 git commands to generate.