]> git.pld-linux.org Git - packages/cacti.git/blob - cacti.spec
- Requires: webserver(access)
[packages/cacti.git] / cacti.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Cacti is a PHP frontend for rrdtool
3 Summary(pl.UTF-8):      Cacti - frontend w PHP do rrdtoola
4 Name:           cacti
5 Version:        0.8.7b
6 Release:        15
7 License:        GPL
8 Group:          Applications/WWW
9 Source0:        http://www.cacti.net/downloads/%{name}-%{version}.tar.gz
10 # Source0-md5:  63ffca5735b60bc33c68bc880f0e8042
11 Source1:        %{name}.cfg.php
12 Source2:        %{name}.crontab
13 Source3:        http://cactiusers.org/downloads/%{name}-plugin-arch.tar.gz
14 # Source3-md5:  7079c1f366e8ea1b26c7e251e6373226
15 Source4:        %{name}-apache.conf
16 Source5:        %{name}-lighttpd.conf
17 Source6:        %{name}-rrdpath.sql
18 Patch100:       http://www.cacti.net/downloads/patches/0.8.7b/upgrade_from_086k_fix.patch
19 Patch101:       http://www.cacti.net/downloads/patches/0.8.7b/snmp_auth_none_notice.patch
20 Patch102:       http://www.cacti.net/downloads/patches/0.8.7b/reset_each_patch.patch
21 Patch0:         %{name}-config.patch
22 Patch1:         %{name}-adodb.patch
23 Patch2:         %{name}-ioerror.patch
24 Patch3:         %{name}-webroot.patch
25 Patch4:         %{name}-linux_memory.patch
26 Patch5:         %{name}-log-verbosity.patch
27 Patch6:         %{name}-ss_disk-array-indices.patch
28 Patch7:         %{name}-rrdtool-1.3.patch
29 Patch8:         %{name}-rrdresourcecheck.patch
30 URL:            http://www.cacti.net/
31 BuildRequires:  rpm-perlprov
32 BuildRequires:  sed >= 4.0
33 Requires(postun):       /usr/sbin/userdel
34 Requires(pre):  /bin/id
35 Requires(pre):  /usr/sbin/useradd
36 Requires:       adodb >= 4.67-1.17
37 Requires:       crondaemon
38 Requires:       group(http)
39 Requires:       net-snmp-utils
40 Requires:       php(gd)
41 Requires:       php(mysql)
42 Requires:       php(pcre)
43 Requires:       php(snmp)
44 Requires:       php(xml)
45 Requires:       php-cli
46 Requires:       rrdtool
47 Requires:       webapps
48 Requires:       webserver
49 Requires:       webserver(access)
50 Requires:       webserver(alias)
51 Requires:       webserver(php)
52 Suggests:       cacti-spine
53 Provides:       user(cacti)
54 BuildArch:      noarch
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %define         _webapps        /etc/webapps
58 %define         _webapp         %{name}
59 %define         _sysconfdir     %{_webapps}/%{_webapp}
60 %define         _appdir         /usr/share/%{name}
61
62 %description
63 Cacti is a complete frondend to rrdtool, it stores all of the
64 nessesary information to create graphs and populate them with data in
65 a MySQL database.
66
67 The frontend is completely PHP driven. Along with being able to
68 maintain Graphs, Data Sources, and Round Robin Archives in a database,
69 cacti handles the data gathering also. There is also SNMP support for
70 those used to creating traffic graphs with MRTG.
71
72 %description -l pl.UTF-8
73 Cacti to pełny frontend do rrdtoola, zapamiętujący wszystkie
74 informacje potrzebne do tworzenia wykresów i wypełniające je danymi w
75 bazie MySQL.
76
77 Frontend jest w pełni oparty na PHP. Oprócz zarządzania wykresami,
78 źródłami danych, archiwami Round Robin w bazie danych, cacti obsługuje
79 także gromadzenie danych. Ma także obsługę SNMP przydatną przy
80 tworzeniu wykresów ruchu przy użyciu MRTG.
81
82 %package setup
83 Summary:        Cacti setup package
84 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Cacti
85 Group:          Applications/WWW
86 Requires:       %{name} = %{version}-%{release}
87 Suggests:       %{name}-doc = %{version}-%{release}
88
89 %description setup
90 Install this package to configure initial Cacti installation. You
91 should uninstall this package when you're done, as it considered
92 insecure to keep the setup files in place.
93
94 %description setup -l pl.UTF-8
95 Ten pakiet należy zainstalować, aby wstępnie skonfigurować instalację
96 Cacti. Po tym pakiet powinien zostać odinstalowany, jako że jego
97 obecność może być niebezpieczna.
98
99 %package doc
100 Summary:        HTML Documentation for Cacti
101 Summary(pl.UTF-8):      Dokumentacja do Cacti w formacie HTML
102 Group:          Documentation
103 Requires:       %{name} = %{version}-%{release}
104
105 %description doc
106 HTML Documentation for Cacti.
107
108 %description doc -l pl.UTF-8
109 Dokumentacja do Cacti w formacie HTML.
110
111 %prep
112 %setup -q -a 3
113 %patch100 -p1
114 %patch101 -p1
115 %patch102 -p1
116 %{__patch} -p1 -s < cacti-plugin-arch/cacti-plugin-0.8.7b-PA-v2.1.diff
117 %patch0 -p1
118 %patch1 -p1
119 %patch2 -p1
120 %patch3 -p1
121 %patch4 -p1
122 %patch5 -p1
123 %patch6 -p1
124 %patch7 -p0
125 %patch8 -p1
126
127 mkdir -p sql
128 mv *.sql sql
129 # you should run this sql if your database contains path to %{_datadir}...
130 cp %{SOURCE6} sql
131
132 mv cacti-plugin-arch/pa.sql sql
133 rm -rf cacti-plugin-arch
134 rm -rf lib/adodb
135 rm -f log/.htaccess
136 rm -f cli/.htaccess
137 rm -f rra/.placeholder
138 rm -f plugins/index.php
139
140 %{__sed} -i -e '1i#!%{_bindir}/php' scripts/*.php
141 chmod a+rx scripts/*
142
143 %{__sed} -i -e '1i#!%{_bindir}/php' cli/*.php
144 chmod a+rx cli/*
145
146 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_appdir}/docs,/etc/cron.d,%{_sbindir}}
151 install -d $RPM_BUILD_ROOT/var/{log,lib/%{name}}
152
153 cp -a *.php $RPM_BUILD_ROOT%{_appdir}
154 cp -a cli images include install lib plugins resource scripts sql $RPM_BUILD_ROOT%{_appdir}
155 cp -a docs/html $RPM_BUILD_ROOT%{_appdir}/docs/html
156 mv $RPM_BUILD_ROOT{%{_appdir}/poller.php,%{_sbindir}/cacti-poller}
157
158 cp -a log $RPM_BUILD_ROOT/var/log/%{name}
159 cp -a rra $RPM_BUILD_ROOT/var/lib/%{name}
160
161 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/config.php
162 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}
163
164 cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
165 cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
166 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %pre
172 %useradd -u 184 -d /var/lib/%{name} -g http -c "Cacti User" cacti
173
174 %post
175 if [ ! -f /var/log/%{name}/cacti.log ]; then
176         install -m660 -oroot -ghttp /dev/null /var/log/%{name}/cacti.log
177 fi
178
179 %postun
180 if [ "$1" = "0" ]; then
181         %userremove cacti
182 fi
183
184 %triggerin -- apache1 < 1.3.37-3, apache1-base
185 %webapp_register apache %{_webapp}
186
187 %triggerun -- apache1 < 1.3.37-3, apache1-base
188 %webapp_unregister apache %{_webapp}
189
190 %triggerin -- apache < 2.2.0, apache-base
191 %webapp_register httpd %{_webapp}
192
193 %triggerun -- apache < 2.2.0, apache-base
194 %webapp_unregister httpd %{_webapp}
195
196 %triggerin -- lighttpd
197 %webapp_register lighttpd %{_webapp}
198
199 %triggerun -- lighttpd
200 %webapp_unregister lighttpd %{_webapp}
201
202 %triggerpostun -- %{name} < 0.8.7b-9.5
203 if [ -f /etc/cacti/cacti.cfg.rpmsave ]; then
204         cp -f %{_sysconfdir}/config.php{,.rpmnew}
205         mv /etc/cacti/cacti.cfg.rpmsave %{_sysconfdir}/config.php
206 fi
207
208 %files
209 %defattr(644,root,root,755)
210 %doc docs/CHANGELOG docs/CONTRIB docs/README docs/text/manual.txt
211 %dir %attr(750,root,http) %{_sysconfdir}
212 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
213 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
214 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
215 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
216 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
217 %attr(755,root,root) %{_sbindir}/cacti-poller
218 %dir %{_appdir}
219 %exclude %{_appdir}/install
220 %exclude %{_appdir}/docs
221 %{_appdir}/resource
222 %{_appdir}/sql
223 %{_appdir}/lib
224 %{_appdir}/include
225 %{_appdir}/images
226 %{_appdir}/plugins
227 %{_appdir}/*.php
228
229 %dir %{_appdir}/cli
230 %attr(755,root,root) %{_appdir}/cli/*
231
232 %dir %{_appdir}/scripts
233 %attr(755,root,root) %{_appdir}/scripts/*
234
235 %attr(750,root,http) %dir /var/lib/%{name}
236 %attr(770,root,http) %dir /var/lib/%{name}/rra
237 %attr(730,root,http) %dir /var/log/%{name}
238 %attr(660,root,http) %ghost /var/log/%{name}/cacti.log
239
240 %files setup
241 %defattr(644,root,root,755)
242 %{_appdir}/install
243
244 %files doc
245 %defattr(644,root,root,755)
246 %{_appdir}/docs
This page took 0.076969 seconds and 3 git commands to generate.