]> git.pld-linux.org Git - packages/cacti-spine.git/blob - cacti-spine.spec
up to 0.8.8g; still fails to link with -lcap
[packages/cacti-spine.git] / cacti-spine.spec
1 # TODO
2 # - -lcap link fail:
3 #spine.o: In function `drop_root':
4 #/home/users/glen/rpm/packages/BUILD.x86_64-linux/cacti-spine-0.8.8f/spine.c:133: undefined reference to `cap_from_text'
5 # - http://bugs.cacti.net/view.php?id=2650
6 #
7 # Conditional build:
8 %bcond_without  cap             # Enable support for the Linux Capabilities (default: disabled)
9
10 Summary:        A backend data gatherer for Cacti
11 Summary(pl.UTF-8):      Backend gromadzący dane dla Cacti
12 Name:           cacti-spine
13 Version:        0.8.8g
14 Release:        0.1
15 License:        GPL
16 Group:          Daemons
17 Source0:        http://www.cacti.net/downloads/spine/%{name}-%{version}.tar.gz
18 # Source0-md5:  9e90936b950a7a353b31bf16ff7798f4
19 Patch0:         %{name}-paths.patch
20 Patch1:         x32.patch
21 # Official patches http://www.cacti.net/spine_download_patches.php
22 URL:            http://www.cacti.net/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 %{?with_cap:BuildRequires:      libcap-devel}
26 BuildRequires:  libtool
27 BuildRequires:  mysql-devel
28 BuildRequires:  net-snmp-devel
29 BuildRequires:  openssl-devel
30 BuildRequires:  rpmbuild(macros) >= 1.502
31 BuildRequires:  zlib-devel
32 %requires_eq    net-snmp-libs
33 Requires:       cacti
34 Obsoletes:      cacti-cactid
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _webapps        /etc/webapps
38 %define         _webapp         cacti
39 %define         _sysconfdir     %{_webapps}/%{_webapp}
40 %define         _bindir         %{_sbindir}
41
42 %description
43 A backend data gatherer for Cacti. This package represents the future
44 replacement for Cacti's cmd.php. It is almost 100% compatible with the
45 legacy cmd.php processor.
46
47 %description -l pl.UTF-8
48 Backend gromadzący dane dla Cacti. Ten pakiet reprezentuje przyszły
49 zamiennik cmd.php z Cacti. Jest prawie w 100% kompatybilny ze starym
50 procesorem cmd.php.
51
52 %prep
53 %setup -q
54 %patch0 -p1
55 %ifarch x32
56 %patch1 -p1
57 %endif
58
59 %build
60 %{__libtoolize}
61 %{__aclocal} -I m4
62 %{__automake}
63 %{__autoconf}
64 chmod +x ./configure
65 %configure \
66         --with-results-buffer=4096 \
67         --with-mysql \
68         %{__enable_disable cap lcap} \
69         --with-snmp=%{_prefix}
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 mv $RPM_BUILD_ROOT%{_sbindir}/{spine,cacti-poller-spine}
78 mv $RPM_BUILD_ROOT%{_sysconfdir}/spine.conf{.dist,}
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc README
86 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/spine.conf
87 %attr(755,root,root) %{_sbindir}/cacti-poller-spine
This page took 0.036051 seconds and 4 git commands to generate.